Subscribe: RSS
  • I’ve a problem uploading files using FCKEditor.

    I’m creating a link from some text.

    1. I highlight the text
    2. I click the create link button
    3. I click browse server. The window opens with the frames, but no directories are listed and no files shown. I get a Javascript line 159 Object Required error in IE for frmfolders.html
    4. When I try to upload a file, I get an Invalid XML Response from Connector error in a popup window.

    Help!

    Running on Windows 2000 Server, Apache 2, PHP 5.1.2.

    Many thanks.
    D.
    • Please check you Resource Path and Resource Url under

      Administration > System Configuration > Interface & Editor Settings

      You will find the 2 fields there, and more information about IIS is displayed right next to them.

      Hope it helps.

      regards.
        Zaigham R - MODX Professional | Skype | Email | Twitter

        Digging the interwebs for #MODX gems and bringing it to you. modx.link
      • Bizzarely, the contents of the

        \manager\media\browser\mcpuk\connectors

        folder seem to be being deleted. Replace them and all works well.

        A security issue? I’ve tightened the permissions on the folder in any case.


        (Just to add, this is happening on a private site, so I don’t think 3rd party hacking is likely)
        • OK - more information. I’ve been able to reproduce the problem myself.

          I open the FCKEditor Resource Browser and create a new directory.

          I go to the new directory and upload a file - cardiff.pdf.

          The pdf directory in the connectors directory disappears all together.

          The new directory created to contain the file actually contains a new folder called cardiff.pdf with a number of new folders inside including:
          Auth
          Commands
          Commands/Helpers
          Docs
          dtd
          images


          (Sorry to keep adding to this - just realised it’s moving the contents of the connectors/php folder to the new folder named the same as the file it has uploaded)

          I wonder if it’s not able to change to a temporary file directory and hence the error - where are temporary files uploaded to? The upload_tmp_dir in php.ini is set correctly.
          • I’ve solved the problem.

            The maximum upload file size in PHP was set to 2Mb. The file being uploaded was 2.2Mb!

            Obviously the file wasn’t successfully uploaded by php, and therefore the script acted strangely.

            I’ve increased the maximum upload filesize for now which gets over the immediate problem.


            • i sort of have the same problem.
              Website was moved to a new server. Image browser led to an empty folder and i could not upload img / create folder.
              I cheked the Resource path-- it was the old one.

              Using phpinfp.php i found this:
              _SERVER["DOCUMENT_ROOT"] /home/faktv/myDomainName

              * Changed the Resource path to
              1) /home/faktv/myDomainName/assets/
              2) home/faktv/myDomainName/assests/
              .. and it did still did not work.


              * Uploaded install/ upgrade from 0.9.1 to 0.9.2.1 ran the install to update my modx.
              Still did not help.

              UPD:
              Seems it was File Manager Path in the Miscellaneous Settings. Once i changed that, everything worked again. =]
              • I’m having the problem too . . . I’ve tried resolving using the solutions here but still the same problem...

                Uploading a file (even small ones of about 500-700k) I nearly always get the same error "Invalid XML Response".

                Anyone have any ideas?

                Thanks!
                • OK. Found a solution in the FCK Editor forums at sourceforge. See this thread for details:

                  http://sourceforge.net/forum/message.php?msg_id=3433951

                  By adding in the following to GetUploadProgress.php right after "//Progresshandler not specified, return generic response" solves the problem . . . at least for me it did!

                  header ("content-type: text/xml"); 
                  echo "<?xml version=\"1.0\" encoding=\"utf-8\" ?>\n";
                  • I am now experiencing the same problem having moved from a development server (uniform server on WinXP) to a live server (Linux shared hosting with FastHosts).

                    The problem also occurs with the file manager - but returns "64 - host not found". The error only occurs when uploading image files - other files (e.g. css) upload without problems.

                    I assume the problem is caused by the PHP configuration, but do not know where to begin to resolve the issue. Any help would be appreciated - the site is due to go live at the end of month.
                    • Problem solved!

                      Should have guessed it - the problem is being caused by proxy/firewall restrictions on our internal network.