On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hello,

    I use ManagerManager in one of my sites. It worked perfectly, but then today a problem has appeared. Whenever I attempt to edit a document, I get this message:

    "ManagerManager: An error has occurred: undefined - undefined"

    To the best of my knowledge I’ve not made any changes to the site which would have affected ManagerManager.

    Can anyone advise me as to possible causes and solutions?

    Thanks in advance for all your help.

    Cheers
    • "ManagerManager: An error has occurred: undefined - undefined"
      Yes I can confirm this. I worked yesterday evening on a site and everything worked fine. Now all of a sudden I get the same Javascript alert. I tested it in Safari 3 and Firefox 3, both show the same alert. The version of ManagerManager I use is 0.3.2 and the MODx version is 0.9.6.3.

      I investigated a little bit further: activating the ManagerManager plugin without any rules works, using just the mm_hideTabs function works also, but as soon as I call a mm_hideFields of any kind the error occurs.

      Thanks for taking a look at this,
      Bogdan
        Medianotions – Studio für Webdesign
        http://www.medianotions.de
      • I also got the error "ManagerManager: An error has occurred: undefined - undefined" just couple minutes ago.

        I suspect this has something to do about the ManagerManager Plugin configuration variable $js_url. If variable $js_url was empty I got the error but when I linked the variable to my local jQuery library everything works fine (e.g. $js_url = ’http://www.example.com/assets/js/jquery.js’;).
          Mikko Lammi, Owner at Maagit
        • Ah ... that’s the point:
          // The URL to the Jquery library. Leave blank and it will use the one available from jquery.com ...


          I guess the location on jquery.com has changed or is temporarily unavailable. Tricky!
            Medianotions – Studio für Webdesign
            http://www.medianotions.de
          • Looks like Google has change their JSAPI loader - it no longer supports jQuery. A peril of relying on third party hosted scripts.

            We can still use their hosted AJAX libraries (presumably their preferred method now).

            To fix, just replace the "includeJquery" function in /assets/plugins/managermanager/functions/utilities.inc.php with the following:

            // Return the HTML necessary to link to the jQuery library
            function includeJquery($js_url) {	
            	// If no JS url has been supplied, use the Google hosted version
            	if (!$js_url || empty($js_url)) {
            		$html .= '<script src="http://ajax.googleapis.com/ajax/libs/jquery/1.2/jquery.min.js" type="text/javascript" charset="utf-8"></script>';
            		$html .= "\n";
            	} else {
            		$html .= '<script src="'.$js_url.'" type="text/javascript" charset="utf-8"></script>';
            		$html .= "\n";
            	}
            	
            	return $html;	
            }


            I’ve updated the version in the repository accordingly to version 0.3.2.1.
              Author: ManagerManager plugin - customise your ModX manager interface

              Rckt - web development, Sheffield, UK
            • Hey Nick,

              Out of curiosity would it make sense to use Google’s loader API which doesn’t reference a direct link and would have in theory prevented this bug from happening? In this instance I think the appropriate call would be:

                  <script src="http://www.google.com/jsapi"></script>
                  <script type="text/javascript">
                    google.load("jquery", "1.2.6");
                  </script>
              


              Taken from: http://code.google.com/apis/ajaxlibs/ (and other code examples that my copy-paste skills worked on tongue )
                Ryan Thrash, MODX Co-Founder
                Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
              • I’m confused. Does this error negatively affect anything else on my site or in the manager? Why is it showing up and how do I make it not show up anymore. (I’m sorry, my web designer is not available and I’m trying to take care of things on my own).

                Thanks for your help!

                - Ruben
                • One fix is to use your own file, inside the Manager go to :
                  Resources => Manage Resources => Plugins => ManagerManager =>General
                  Around line 18 replace :
                  $js_url = ''; 

                  With :
                  $site = $modx->config['site_url'];
                  $js_url = $site.'assets/js/jquery-1.2.6.min.js'; 

                  Then upload a copy of jQuery to the assets/js/ folder.
                  EDIT : Sorry, changed to previous jQuery version, if that doesn’t work try the unpacked version
                  • Bunk58

                    I tried your approach, didn’t have any affect. Still getting error. Is there anything different if on WAMP?
                      www.terrybarthdesign.com
                    • jquery1.3 doesnt work with it. Need to use 1.2.6 or 1.2.3
                        Chuck the Trukk
                        ProWebscape.com :: Nashville-WebDesign.com
                        - - - - - - - -
                        What are TV's? Here's some info below.
                        http://modxcms.com/forums/index.php/topic,21081.msg159009.html#msg1590091
                        http://modxcms.com/forums/index.php/topic,14957.msg97008.html#msg97008