On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hi,

    I have uploaded a clean install of modx and get the following error when i go to the manager page:

    Warning: fopen(mysite/public_html/manager/media/style//login.html) [function.fopen]: failed to open stream: No such file or directory in mysite/public_html/manager/includes/accesscontrol.inc.php on line 129

    ...i get this error for lines 129 - 131.

    I can’t think waht it could be. When the install finishes it just goes to a page listing the install results and i’m sure previously it gives me an option to sign into the Manager...but nothing.

    Anyone have any ideas what this could be?
    I did find a previous post regarding this error but it went unresolved.

    Thanks

    J
      www.9thwave.co.uk
         WEB | DESIGN | PRINT
    • What version of MODx are you using? Looks like the theme isn’t being set correctly, which I think was an issue in some older MODx releases but has been fixed in the more recent MODx releases.

      Other than that, have you tried reuploading the files, it may be a case that some files got skipped or corrupted during the upload.
        Garry Nutting
        Senior Developer
        MODX, LLC

        Email: support@modx.com
        Twitter: @garryn
        Web: modx.com
      • Hi,

        It was the latest version that i uploaded.
        I’ll just try a fresh install again and see if i have any luck.
          www.9thwave.co.uk
             WEB | DESIGN | PRINT
        • i’ve reinstalled an i get exactly the same error...could it be something to do with teh server setup?

          any help much appreciated.

          Thanks

            www.9thwave.co.uk
               WEB | DESIGN | PRINT
          • i wonder if anyone could take a look at the phpinfo that i have just uploaded to see if there is some kind of server configuration problem??
            I’m clutching at straws here and this may not solve the problem but i can’t think of anything else and i’ve never had an install problem with Modx before.
            I don’t want to add a link to the phpinfo if it contains sensitive info so if anyone knows about this stuff could you pm me?
            Otherwise perhaps there is some info that i could check myself?

            Thanks for any help.

            J

            BTW - I’m using the latest Modx install 0.9.6.2, PHP5.2.5, MySQL5.0.51a
              www.9thwave.co.uk
                 WEB | DESIGN | PRINT
            • Ok janice171, this is the code line that’s starting the errors :-
              $tplFile = $base_path.'manager/media/style/'.$manager_theme.'/login.html';
              


              From your first post it would appear that the variable $manager_theme is not being set as was said above.

              This is set from the php extract() function, this may be failing but I can’t find any info on what php settings control this function.
              It may also be that the setting manager_theme in the table system_settings is not set, this should contain the name of one of the subdirs in the manager/media/style path, I think it defaults to MODxLight.
                Use MODx, or the cat gets it!
              • here’s the first part of the phpinfo sheet in case it means anything to anybody?


                Server API 	CGI
                Virtual Directory Support 	disabled
                Configuration File (php.ini) Path 	/usr/lib
                Loaded Configuration File 	/usr/local/lib/php.ini
                PHP API 	20041225
                PHP Extension 	20060613
                Zend Extension 	220060519
                Debug Build 	no
                Thread Safety 	disabled
                Zend Memory Manager 	enabled
                IPv6 Support 	enabled
                Registered PHP Streams 	php, file, data, http, ftp, compress.zlib
                Registered Stream Socket Transports 	tcp, udp, unix, udg
                Registered Stream Filters 	string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, convert.iconv.*, zlib.*
                
                  www.9thwave.co.uk
                     WEB | DESIGN | PRINT
                • I’m getting exactly the same problem and I had MODX all working, I have re-installed and get the same error. I think the problem is that the SQL database still has old data in it.. I am about to clean out the SQL and see if that fixes the problem.. will let you know soon..
                  • When you say you’ve uploaded a clean install, does that mean you’re running the installer on a server after uploading modx and the installer. Also, please state the explicit version you’re using; if from the subversion repository please include the revision you checked out. "The latest" means a lot of things ranging from Revolution to the Evolution branch to 0963 RC2 to ... you get the idea.

                    Do you have other installs working succesfully? Are you using a custom manager theme? Do you have access to phpmyadmin?
                      Ryan Thrash, MODX Co-Founder
                      Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
                    • I’m having the same trouble: FRESH install on Bluehost.com servers.
                      "
                      Warning: fopen(/home2/planetc5/public_html/site/manager/media/style/MODxCarbon/login.html) [function.fopen]: failed to open stream: No such file or directory in /home2/planetc5/public_html/site/manager/includes/accesscontrol.inc.php on line 129

                      Warning: filesize() [function.filesize]: stat failed for /home2/planetc5/public_html/site/manager/media/style/MODxCarbon/login.html in /home2/planetc5/public_html/site/manager/includes/accesscontrol.inc.php on line 130

                      Warning: fread(): supplied argument is not a valid stream resource in /home2/planetc5/public_html/site/manager/includes/accesscontrol.inc.php on line 130

                      Warning: fclose(): supplied argument is not a valid stream resource in /home2/planetc5/public_html/site/manager/includes/accesscontrol.inc.php on line 131
                      "

                      Please someone help me out!