On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Checking PHP version: OK!
    Checking if sessions are properly configured: OK!
    Checking if assets/cache directory exists: OK!
    Checking if assets/cache directory is writable: OK!
    Checking if assets/cache/siteCache.idx.php file is writable: OK!
    Checking if assets/cache/sitePublishing.idx.php file is writable: OK!
    Checking if assets/images directory exists: OK!
    Checking if assets/images directory is writable: OK!
    Checking if assets/export directory exists: OK!
    Checking if assets/export directory is writable: OK!
    Checking if manager/includes/config.inc.php exists and is writable: OK!
    Creating connection to the database: OK!

    Checking table prefix `modx_`: Failed! - Table prefix is already in use in this database!

    It’s a fresh install on mt ss hosting.
    Tried 0.9.5 a while ago and worked. Wanted to start clean but keep getting that message. The db is clean. No tables or data whatsoever.

    Does somebody knows how to solve this?

    thanks...
    • Probably not without more information about what steps you took and what your environment is... especially with regards to PHP and MySQL versions and configuration
      • Hello,

        I have the same problem as above. The environment is:

        PHP 4.4.1
        mySQL 3.23.58

        The reason could be, that the server doesn’t have mySQL 4.1.x or higher.
        I update the server and post the result in this thread ...
        • @Jonas

          ok, I’ve found the reason for the error: In the file "install/action.summary.php" is a bug:

          Line 152

          if (@ $rs == mysql_query("SELECT COUNT(*) FROM $dbase.`" . $table_prefix . "site_content`")) {

          should be

          if (@ $rs = mysql_query("SELECT COUNT(*) FROM $dbase.`" . $table_prefix . "site_content`")) {

          PS: The CMS runs with mySQL 3.23.58, too.
          • Nice catch ublix -- this is being committed for 0.9.6.1 release... http://modxcms.com/bugs/task/894
            • I made the changes ... still not working. I’m upgrading because I do not have the Captcha snippet for some reason. So right now I’m in the middle of something and can’t get anything done. (yes I have a backup)

              PHP 5.2.2-1
              Apache 2.0.58-r2
              MySQL 5.0.44
              • Quote from: fruitwerks at Aug 14, 2007, 04:39 PM

                still not working.
                More information required. This post was discussing 0.9.6 new install issues on MySQL 3.23.58, so I don’t see anything relevant in this thread that would help diagnose or even provide an intimation of what your issue might be with upgrading on MySQL 5.0.44.
                • gotcha.. well I am experiencing the same exact issue.

                  trying to upgrade from

                  MODx version 0.9.5
                  Version codename rev 2106

                  started out with etomite long ago, but never have hit a snag on an upgrade before.

                  what else do you need to know? smiley

                  btw - I just need the vericode / capcha snippet.. know where I can find it?

                  Thanks
                  • Still confused. How can you be having the exact same problem, as again, this problem was with new installations, not upgrades. The table_prefix will always already be in use on upgrades, but should never exist on new installs. Are you sure you are running an upgrade and not trying to run a new install with an existing database?
                    • ... Tried it again. unzipped the source to an empty dir - worked great.
                      ...copied my goodies back over.

                      All is good... that was a bit odd.

                      Thanks!