On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Wondered if anyone had came accros the same issue but I just discovered that PHx messes up Ditto’s pagination : after installing PHx, noticed my pagination was just... gone ! Every placeholder used in the pagination template ([+total+] , [+previous+] [+pages+] and [+next+]) is just not displayed huh

    Anyone has experienced the same issue and if so, what is the solution (I need both Ditto and PHx) ?
      .: COO - Commerce Guys - Community Driven Innovation :.


      MODx est l'outil id
    • I just tried to add &phx=`0` in my Ditto call to make sure the Ditto PHx extender does not conflict with the plugin, but no changes undecided

      Edit : Hmmm, never mind, this has already been brought up and Heliotrope mentionned that you have to make your Ditto call cached for this to work...
        .: COO - Commerce Guys - Community Driven Innovation :.


        MODx est l'outil id
      • OK there is something which is not working for me : though pagination shows up with PHx activated when the Ditto call is cached, the next and previous links, as well as page number links do NOT work undecided

        Am I the only one ?
          .: COO - Commerce Guys - Community Driven Innovation :.


          MODx est l'outil id
        • Okay I found the solution : you have to call Ditto cached yes but you can’t cache the page, that was it !
            .: COO - Commerce Guys - Community Driven Innovation :.


            MODx est l'outil id
          • Thanks David, drove me nuts for hours before I tried the magic search feature laugh
            • Indeed it can drive you crazy but when unexplainable problem occurs (i.e you know you did things right), it’s often cache related tongue
                .: COO - Commerce Guys - Community Driven Innovation :.


                MODx est l'outil id
              • So what was the solution? I don’t see any Ditto code in this thread about the cache. Please enlighten me.
                  MySQL: 5.0.45
                  PHP: 5.2.6
                  Linux 2.6.9-023stab048.6-enterprise #1
                  cURL enabled
                  PDO enabled
                  FFox Apple 3.6.8
                  Firebug DIS-abled
                • MARKSVIRTUALDESK Reply #8, 12 years ago
                  Quote from: davidm at May 12, 2007, 10:24 AM

                  Okay I found the solution : you have to call Ditto cached yes but you can’t cache the page, that was it !
                    [html]<div><div style="float:left;"><a href="http://modxcms.com/Ditto-487.html" target="_blank"><img src="http://modxcms.com/assets/images/ditto.gif" alt="" border="0"></a></div><div style="float:left; padding: 0 5px 0 5px; border-left: 2px solid #ddd; margin-left: 5px;"><a style="display:block;"href="http://modxcms.com/ditto_docs.html">Documentation</a><a style="display:block;" href="http://modxcms.com/ditto_trac.html">TRAC (Bugtracker)</a><a style="display:block;"href="http://modxcms.com/forums/index.php/board,180.0.html">Forum</a><a style="display:block;"href="http://modxcms.com/forums/index.php/topic,13348.0.html">How to get help</a></div><div style="float:left; padding: 0 5px 0 5px; border-left: 2px solid #ddd;"><a style="display:block;"href="http://modxcms.com/ditto_wiki.html">User Wiki</a><a style="display:block;" href="http://modxcms.com/ditto_credits.html">Credits</a><a style="display:block;"href="http://modxcms.com/ditto_svn.html">SVN Server</a><a style="display:block;"href="http://modxcms.com/ditto">Ditto HQ</a></div><div style="float:left; padding: 0 5px 0 5px; border-left: 2px solid #ddd;"><a style="display:block;"href="http://modxcms.com/ditto_stable_download.html"><strong><span style="color:#CC0000;">Stable Download</span></strong></a><a style="display:block;"href="http://modxcms.com/ditto_download.html"><strong><span style="color:#CC0000;">Development Download</span></strong></a></div><div style="clear: both;"></div></div>[/html]
                  • Thanks Mark. I missed that while scrolling.
                      MySQL: 5.0.45
                      PHP: 5.2.6
                      Linux 2.6.9-023stab048.6-enterprise #1
                      cURL enabled
                      PDO enabled
                      FFox Apple 3.6.8
                      Firebug DIS-abled
                    • didn’t work for me. sad EDIT: Got mine to work thanks to the members here. I had a space after paginate. grin