MCPuck File Browser - MODX Community Forums https://forums.modx.com/board/?board=89 <![CDATA[Again to Resource Browser :(]]> https://forums.modx.com/thread/46381/again-to-resource-browser?page=2#dis-post-554176
After moving to a new host I got the same problem with Resource Browser as Hypercubed:

- It sees no file nor folder
- FF console shows "this.DOMDocument has no properties"
- IE6 shows "Object Required" error

However, none of the solutions presented here works for me.
Trying in vain for a half of a day to get the Browser to work I found the folllowing:

- the resource browser CREATES folders, still it doesnt show them
- having the above fact in mind, it doesnt upload files
- making a clean MODx install in a different folder (sitepath/test/) and pointing the resource path to the problem resource folder (changing sitepath/test/assets/ to sitepath/assets/) I get a WORKING resource browser. That means that the browser from the newly installed system on the same host SEES the resource folder of the actual previously installed sytem (so its not the problem of the host security settings, nor it is the problem of permissions)

Now I am desperate in getting this to work, as I have tried everything I am qualified in. I seem to have two ways: try to connect a freshly downloaded FCKeditor to my current MODx install or... make a clean install of MODx in hope that it will work with all my tweaks and hacks and resources. Both tasks seem too tough for now Sad

Maybe there is still a way to force the trouble Browser to see the files/folders?
]]>
https://forums.modx.com/thread/46381/again-to-resource-browser?page=2#dis-post-554176 Thu, 28 Sep 2017 07:02:28 +0000 https://forums.modx.com/thread/46381/again-to-resource-browser?page=2#dis-post-554176
<![CDATA[Image thumbnails are not displaying in FCKeditor]]> https://forums.modx.com/thread/46348/image-thumbnails-are-not-displaying-in-fckeditor?page=3#dis-post-527086 insert image in FCKeditor there are broken image thumbnails in "BrowseServer" window. Pasting image works correct. I wonder why? Could somebody clear the topic?

]]>
https://forums.modx.com/thread/46348/image-thumbnails-are-not-displaying-in-fckeditor?page=3#dis-post-527086 Wed, 17 Jun 2015 12:50:17 +0000 https://forums.modx.com/thread/46348/image-thumbnails-are-not-displaying-in-fckeditor?page=3#dis-post-527086
<![CDATA[TinyMCE & FCKeditor File Browser Problem]]> https://forums.modx.com/thread/46359/tinymce-fckeditor-file-browser-problem#dis-post-520141
What I’ve done is placed a symbolic link in the ’files’ directory that links to the images directory like so

files/
images/ -> ../images

Yet the file browser will not display any images.]]>
https://forums.modx.com/thread/46359/tinymce-fckeditor-file-browser-problem#dis-post-520141 Fri, 06 Feb 2015 04:12:10 +0000 https://forums.modx.com/thread/46359/tinymce-fckeditor-file-browser-problem#dis-post-520141
<![CDATA[ [SOLVED] Major TinyMCE / FCKeditor file browser problem]]> https://forums.modx.com/thread/46351/solved-major-tinymce-fckeditor-file-browser-problem?page=4#dis-post-507444
A client of ours rang up today to tell us they could no longer see any files/folders or upload any files to their website. So I had a look and indeed none of their pdf’s, word docs etc that are in the assets/files folder were showing up in the FCKeditor filebrowser. I did notice a "Object Required" script error was being generated - URL: "..../manager/media/browser/mcpuk/frmfolders.html". Also getting an "invalid XML response from connector" when trying to upload a image or file. I can however create folders in the files folder but they dont appear - you can see them in the Resourses - Manage Files section of modx.

I’m using MODx version 0.9.5 and tinyMCE version 2.0.8

We’ve had issues with them uploading bad filenames before - like files starting with ’ or a ! or even a bullet point! these files broke the file browser in firefox. But it dosn’t look like they’ve uploaded anything funny, that would break it.

What’s my best course of action? Can I reinstall TinyMCE? Will a re-installation include the FCKeditor file browser? Or is there some other way to reset this?

Thanks for your help,
Cliff.

]]>
https://forums.modx.com/thread/46351/solved-major-tinymce-fckeditor-file-browser-problem?page=4#dis-post-507444 Wed, 27 Aug 2014 07:12:10 +0000 https://forums.modx.com/thread/46351/solved-major-tinymce-fckeditor-file-browser-problem?page=4#dis-post-507444
<![CDATA[MCPUK alternative? KCFinder]]> https://forums.modx.com/thread/46431/mcpuk-alternative-kcfinder?page=5#dis-post-484155
found this: http://kcfinder.sunhater.com/

... there has been a discussion to replace the old MCPUK, maybe KCFinder is an alternative?]]>
https://forums.modx.com/thread/46431/mcpuk-alternative-kcfinder?page=5#dis-post-484155 Wed, 27 Nov 2013 05:08:04 +0000 https://forums.modx.com/thread/46431/mcpuk-alternative-kcfinder?page=5#dis-post-484155
<![CDATA[window.top.opener.SetUrl is not a function]]> https://forums.modx.com/thread/46398/window-top-opener-seturl-is-not-a-function#dis-post-459672
Error: window.top.opener.SetUrl is not a function
Source File: http://www.1qct.org/manager/media/browser/mcpuk/frmresourceslist.html
Line: 189

I installed FCKeditor in addition to TinyMCE and it works fine, I just told my client to work with it until I figure this out.]]>
https://forums.modx.com/thread/46398/window-top-opener-seturl-is-not-a-function#dis-post-459672 Thu, 21 Mar 2013 09:39:43 +0000 https://forums.modx.com/thread/46398/window-top-opener-seturl-is-not-a-function#dis-post-459672
<![CDATA[MCPUK + TinyMCE won't insert images]]> https://forums.modx.com/thread/46414/mcpuk-tinymce-won-t-insert-images#dis-post-426756 When I use TinyMCE as the editor for my site, it isn’t possible to insert pictures in the MCPUK file browser.
I can upload, but when I click the picture, nothing happens...

If I use FCKEditor, there is no problems...

It is probably something with permissions, but I can’t figure it out...

edit:
MODx 0.9.6.3
Linux
Apache
MySQL]]>
https://forums.modx.com/thread/46414/mcpuk-tinymce-won-t-insert-images#dis-post-426756 Fri, 15 Jun 2012 04:40:32 +0000 https://forums.modx.com/thread/46414/mcpuk-tinymce-won-t-insert-images#dis-post-426756
<![CDATA[Missing thumbnails after migration]]> https://forums.modx.com/thread/46433/missing-thumbnails-after-migration#dis-post-412585
I have a recurring problem with missing image thumbnails in the file browser. I can see from the forums that other people report similar problems, but my circumstances don’t seem to fit with other solutions. Here is what happens.

I develop a new website on domain www.test-server.com/client - everything works perfectly, I can upload images and see their thumbnails. All good.

The problem presents itself when I move the site onto its live domain, eg www.client.com

So I copy down all the files via FTP and the database, and upload them to the new domain. Everything works perfectly apart from the thumbnails which are all broken. I can see the thumbnails via FTP (in assets/images/dir) but they simply won’t show in the file browser.

Both domains are on the same server, so this is not a PHP component issue. I also take care to adjust the path to the file browser when it goes live.

Also, uploading NEW images to the new site is no problem, the thumbnails show. It’s the ones that I migrated that are not showing.

My best guess is that this is some kind of file ownership issue, and the migrated thumbnails somehow have the wrong ownership as a result of being FTPd rather than uploaded via the site itself.

I hope this is clear ...

Has anyone experienced this and have a fix?

Many thanks!

James.]]>
https://forums.modx.com/thread/46433/missing-thumbnails-after-migration#dis-post-412585 Sun, 19 Feb 2012 08:49:58 +0000 https://forums.modx.com/thread/46433/missing-thumbnails-after-migration#dis-post-412585
<![CDATA[Can't click and insert files/images through MCPuk]]> https://forums.modx.com/thread/72927/can-t-click-and-insert-files-images-through-mcpuk#dis-post-405469
I still can't find out why i am not able to click and insert files and images through MCPuk, whenever i click a file and try to insert it there's no respons. Nothing happens and the file is not being inserted into the page. I'm using TinyMCE aswel, but that seems to work properly. Does anyone know what this problem might cause?

Thanks in advance,
Peace,

Nick]]>
https://forums.modx.com/thread/72927/can-t-click-and-insert-files-images-through-mcpuk#dis-post-405469 Tue, 03 Jan 2012 08:31:39 +0000 https://forums.modx.com/thread/72927/can-t-click-and-insert-files-images-through-mcpuk#dis-post-405469
<![CDATA[MCPUK - Sort files by last modification]]> https://forums.modx.com/thread/46410/mcpuk---sort-files-by-last-modification#dis-post-268329
I had a little problem lately, I have a lot of files in different directories, and I wanted that the last file I upload was in first position in MCPUK to make the choice easier.

I added code to GetForldersAndFiles.php at line 118 just after
<?php
/**
 * The filenames are in the array $files
 * SORT IT!
 */
 natcasesort($files);
 $files = array_values($files);
?>


My code
<?php
/*************************************
* Modification by G. EYDIEUX
* This code allow you to sort files by last modification when you a lot of file
* in the same folder, the last one you added will be in first position
* /!\ Set $debug to true if you want to see a debug file in manager\media\browser\mcpuk\connectors\php
* /!\ because echo won't work
*/
$debug = false;

if($debug)/* DEBUG */
{
	$fp=fopen("debug_log.txt","a");
	fwrite($fp,"Before modification :\n");
	foreach($files as $key => $value)
		fwrite($fp,"[$key] => $value\n");
	fwrite($fp,"\n\nDuring modification :\n");
}

$temp_array = array();
for ($i=0;$i<sizeof($files);$i++)
{
	$modif_time = filemtime($this->real_cwd."/".$files[$i]);
	$temp_array[$modif_time] = $files[$i];
	if($debug)/* DEBUG */
		fwrite($fp,"modif_time = $modif_time - file = $files[$i]\n");
}
krsort($temp_array);
$files = array_values($temp_array);

if($debug)/* DEBUG */
{
	fwrite($fp,"\n\nAfter modification :\n");
	foreach($files as $key => $value)
		fwrite($fp,"[$key] => $value\n");
	fwrite($fp,"------------------------\n\n");
	fclose($fp);
}
/*************************************/
?>

(The <?php and ?> are just here to have colors in code wink )]]>
https://forums.modx.com/thread/46410/mcpuk---sort-files-by-last-modification#dis-post-268329 Wed, 20 Apr 2011 10:03:29 +0000 https://forums.modx.com/thread/46410/mcpuk---sort-files-by-last-modification#dis-post-268329
<![CDATA[FCKeditor -Resources Browser stopped showing contents. "oNode has no properties"]]> https://forums.modx.com/thread/46373/fckeditor--resources-browser-stopped-showing-contents-onode-has-no-properties#dis-post-268184 I’m not able to upload picture via the FCKeditor / Resource Browser. No contents is showing up and I can’t upload any more pictures/files. I run it with FireBug and here is the error I get in the console:
get http: //localhost/testProject/manager/media/browser/mcpuk/connectors/php/connecor.php?Command=GetFolders&Type=images&ExtraParams=&CurrentFolder=/ (fckxml.js line 73)

The error is:
oNode has no properties
     GetFoldersAndFilesCallBack(Object DOMDocument=document)
     onreadystatechange()
.....


I’m totally stuck! Has anyone encountered this error before?
Thanks for helping.....

Eric]]>
https://forums.modx.com/thread/46373/fckeditor--resources-browser-stopped-showing-contents-onode-has-no-properties#dis-post-268184 Mon, 07 Mar 2011 01:56:56 +0000 https://forums.modx.com/thread/46373/fckeditor--resources-browser-stopped-showing-contents-onode-has-no-properties#dis-post-268184
<![CDATA[How to make the ImageEditor (MCPUK) Window resizeable?]]> https://forums.modx.com/thread/46376/how-to-make-the-imageeditor-mcpuk-window-resizeable#dis-post-268194
Thanks]]>
https://forums.modx.com/thread/46376/how-to-make-the-imageeditor-mcpuk-window-resizeable#dis-post-268194 Tue, 01 Feb 2011 08:47:35 +0000 https://forums.modx.com/thread/46376/how-to-make-the-imageeditor-mcpuk-window-resizeable#dis-post-268194
<![CDATA[images are no more previewed in "insert/edit images" dialog of TinyMCE]]> https://forums.modx.com/thread/46403/images-are-no-more-previewed-in-insert-edit-images-dialog-of-tinymce#dis-post-268305
Since my last update of MODX, images are no more previewed in "insert/edit images" dialog of TinyMCE.
Does someone already meet this problem?

Thanks in advance]]>
https://forums.modx.com/thread/46403/images-are-no-more-previewed-in-insert-edit-images-dialog-of-tinymce#dis-post-268305 Sun, 30 Jan 2011 07:04:44 +0000 https://forums.modx.com/thread/46403/images-are-no-more-previewed-in-insert-edit-images-dialog-of-tinymce#dis-post-268305
<![CDATA[MCPUK Browers and 404 error]]> https://forums.modx.com/thread/46434/mcpuk-browers-and-404-error#dis-post-268485
The following appears in the browser path but nothing more than a 404 error page in the window.

http://www.mywebsite.co.uk/manager/media/browser/mcpuk/browser.php?Connector=/manager/media/browser/mcpuk/connectors/php/connector.php&ServerPath=/&editor=tinymce&editorpath=/assets/plugins/tinymce/&type=images

I have tried changing file permissions but to avail, can anyone else suggest a solution? huh

The other alternative would be to move the 3 smaller sites into Revolution, but there is a much bigger site which I would prefer not to have to change over at the moment.

I am checking to see whether the hosting company has made any security changes, but it seems very odd that I can access my images in my Revo sites all of which are hosted with the same company but not in the Evo sites.

I would be grateful for anyone’s help. smiley]]>
https://forums.modx.com/thread/46434/mcpuk-browers-and-404-error#dis-post-268485 Thu, 20 Jan 2011 05:19:22 +0000 https://forums.modx.com/thread/46434/mcpuk-browers-and-404-error#dis-post-268485
<![CDATA[TinyMCE+mpuck - can't upload to subdirectory]]> https://forums.modx.com/thread/46419/tinymce-mpuck---can-t-upload-to-subdirectory#dis-post-268378
Using MODx 0.9.6.2 (an older install) and the TinyMCE + mpuck versions that came wit it, i can use QuickEdit to upload and manage images in the assets/images directory and files in the assets/files directory.

PROBLEM: if I create any sub-directories, like assets/images/events or assets/files/pdf from the file manager, and then try to upload anything in them, i get the "failed to upload file. internal error..."

I checked the permissions they’re all 0777, and I’ve checked the resource browser paths, they’re all set as in the DOCUMENT_ROOT setting in php.ini.

How come I can upload in the main resource directories but not in any of their sub-directories?
I’ve searched around but can’t find anything relevant.
Can anybody please help me solve this?

]]>
https://forums.modx.com/thread/46419/tinymce-mpuck---can-t-upload-to-subdirectory#dis-post-268378 Fri, 19 Nov 2010 01:44:37 +0000 https://forums.modx.com/thread/46419/tinymce-mpuck---can-t-upload-to-subdirectory#dis-post-268378
<![CDATA[Problem with thumbnails, for some images only! (bigger than 2 mb)]]> https://forums.modx.com/thread/46427/problem-with-thumbnails-for-some-images-only-bigger-than-2-mb#dis-post-268400
Nobody have a solution for this?

The problem is that no thumbnail is created when the image is greater than 2 MB. I did changes the settings in php.ini, and the limitation seems to be in the resources explorer itself.

Please help! Thanks]]>
https://forums.modx.com/thread/46427/problem-with-thumbnails-for-some-images-only-bigger-than-2-mb#dis-post-268400 Fri, 22 Oct 2010 01:30:06 +0000 https://forums.modx.com/thread/46427/problem-with-thumbnails-for-some-images-only-bigger-than-2-mb#dis-post-268400
<![CDATA[Admin users can see Resource Browser files but web users cannot]]> https://forums.modx.com/thread/46432/admin-users-can-see-resource-browser-files-but-web-users-cannot?page=3#dis-post-268477
I’m running MODx using the parameters listed below, and I’m having a problem after fixing a different problem. Web users can no longer see the MCPuck Resource Browser or upload files etc. unless they are also logged into the MODx manager at the same time.

This only became a problem after I changed the session.save_path in php.ini to a local folder, as I’m on a shared server and the web users were getting logged out too quickly. It looks like I’ve fixed that problem, but now I have this new one.

Has anyone else experiecned this?

Web Server:
* PHP version 5.2.13
* Apache version 2.2.15
* Operating System Linux (no idea of the version)

Database:
* MySQL version 5.1.46-log
* no tables over a meg

MODx:
* Version 1.0.3
* Plugins: PHx

Browser/Client:
* Firefox 3.6.3 and Safari 4.0.5
* Mac OS X]]>
https://forums.modx.com/thread/46432/admin-users-can-see-resource-browser-files-but-web-users-cannot?page=3#dis-post-268477 Wed, 18 Aug 2010 05:42:39 +0000 https://forums.modx.com/thread/46432/admin-users-can-see-resource-browser-files-but-web-users-cannot?page=3#dis-post-268477
<![CDATA[TincyMCE MCPUK Browser open_basedir restriction Warning]]> https://forums.modx.com/thread/46430/tincymce-mcpuk-browser-open-basedir-restriction-warning#dis-post-268406 I regularly run into this issue, that was introduced in evo 1.0.3, see description and I also files an issue in jira and 2 possible fixes.
http://modxcms.com/forums/index.php/topic,48343.msg287060.html#msg287060

basically just remove
define('MODX_BASE_PATH', realpath('../../../../'));


Is nobody else having this an error on the mcpuk browser?]]>
https://forums.modx.com/thread/46430/tincymce-mcpuk-browser-open-basedir-restriction-warning#dis-post-268406 Thu, 17 Jun 2010 05:35:18 +0000 https://forums.modx.com/thread/46430/tincymce-mcpuk-browser-open-basedir-restriction-warning#dis-post-268406
<![CDATA[Ajax File Manager, insert image thru TV]]> https://forums.modx.com/thread/46429/ajax-file-manager-insert-image-thru-tv#dis-post-268404
Could some one help me with ajax file manager what i am using to replace the painfull mcpuk. I have managed to get the afm working with rich text editors file/image browser but it won’t work with insert image via tv’s. Instead it will open the annoying mcpuk.

Should i make some type of changes to the tmplvars.inc.php]]>
https://forums.modx.com/thread/46429/ajax-file-manager-insert-image-thru-tv#dis-post-268404 Tue, 01 Jun 2010 01:50:09 +0000 https://forums.modx.com/thread/46429/ajax-file-manager-insert-image-thru-tv#dis-post-268404
<![CDATA[Friendly URL alias path / relative image path problem]]> https://forums.modx.com/thread/46428/friendly-url-alias-path-relative-image-path-problem#dis-post-268402
www.domain.com/Clients/

The problem is that when I have a page under this section with TVs referencing images as added by the file browser, the image paths are appended to the ’friendly alias’ path as follows:

www.domain.com/Clients/assets/images/...

...when the /assets/ folder containing the images is actually located in the root:

www.domain.com/assets/images/


Obviously this means that the images do not load with Friendly Alias paths enabled.
Does anyone know how to change the file browser paths to absolute instead of relative in order to solve this issue?


tianheng2012@gmail.com
]]>
https://forums.modx.com/thread/46428/friendly-url-alias-path-relative-image-path-problem#dis-post-268402 Fri, 28 May 2010 05:33:40 +0000 https://forums.modx.com/thread/46428/friendly-url-alias-path-relative-image-path-problem#dis-post-268402