TinyMCE - MODX Community Forums https://forums.modx.com/board/?board=87 <![CDATA[ [TIP] Enabling HTML5 elements in TinyMCE]]> https://forums.modx.com/thread/70203/tip-enabling-html5-elements-in-tinymce?page=2#dis-post-558810 Note: this is only possible if you use HTML mode, this is not an automatically added tag.


Locate the config file for TinyMCE, and update the mce_extended_valid_elements variable to include the elements you need.
The config file is located:
In Evo: 'assets/plugins/tinymce/js/xconfig.js'
In Revo: 'assets/components/tinymce/xconfig.js'

You add the name of the element, plus any attributes that should be allowed. Multiple elements are added separated by a comma. Details on how to add elements are here.
http://www.tinymce.com/wiki.php/Configuration:extended_valid_elements

var mce_extended_valid_elements = "figure[class],figcaption";


It can be also helpful to refer to the docs for the standard valid_elements, as this describes how the rules are applied in more detail:
http://www.tinymce.com/wiki.php/Configuration:valid_elements

Also, if you are having trouble getting this to work, check you have emptied your browser cache since making the change.]]>
https://forums.modx.com/thread/70203/tip-enabling-html5-elements-in-tinymce?page=2#dis-post-558810 Tue, 29 May 2018 03:50:08 +0000 https://forums.modx.com/thread/70203/tip-enabling-html5-elements-in-tinymce?page=2#dis-post-558810
<![CDATA[How to STOP TinyMCE from adding and removing code?]]> https://forums.modx.com/thread/102357/how-to-stop-tinymce-from-adding-and-removing-code#dis-post-551638
Please help. Thanks.]]>
https://forums.modx.com/thread/102357/how-to-stop-tinymce-from-adding-and-removing-code#dis-post-551638 Sat, 10 Jun 2017 10:36:39 +0000 https://forums.modx.com/thread/102357/how-to-stop-tinymce-from-adding-and-removing-code#dis-post-551638
<![CDATA[TinyMCE4 image problem with evo 1.2]]> https://forums.modx.com/thread/102185/tinymce4-image-problem-with-evo-1-2#dis-post-550566 https://forums.modx.com/thread/102185/tinymce4-image-problem-with-evo-1-2#dis-post-550566 Mon, 08 May 2017 01:40:38 +0000 https://forums.modx.com/thread/102185/tinymce4-image-problem-with-evo-1-2#dis-post-550566 <![CDATA[TinyMCE4 theme in a module]]> https://forums.modx.com/thread/101636/tinymce4-theme-in-a-module#dis-post-548248
$event_output = $modx->invokeEvent("OnRichTextEditorInit", array('editor'=>$modx->config['which_editor'], 'elements'=>array('tvmailMessage')));


Specifically I would like to use the Simple theme.]]>
https://forums.modx.com/thread/101636/tinymce4-theme-in-a-module#dis-post-548248 Mon, 23 Jan 2017 07:36:46 +0000 https://forums.modx.com/thread/101636/tinymce4-theme-in-a-module#dis-post-548248
<![CDATA[Tiny MCE not working after update.]]> https://forums.modx.com/thread/101371/tiny-mce-not-working-after-update#dis-post-546971
As a NOOB to MODX i today updated the TinyMCE editor.
After this it doesnt seem to work anymore, i completly deinstalled, removed package files, downloaded again and newly installed.
Still not working.

Can anybody give me a clear instructions on how to proceed?

thanks !!!]]>
https://forums.modx.com/thread/101371/tiny-mce-not-working-after-update#dis-post-546971 Tue, 06 Dec 2016 01:01:16 +0000 https://forums.modx.com/thread/101371/tiny-mce-not-working-after-update#dis-post-546971
<![CDATA[Add Table button for TinyMCE in Revo]]> https://forums.modx.com/thread/46252/add-table-button-for-tinymce-in-revo#dis-post-544700 https://forums.modx.com/thread/46252/add-table-button-for-tinymce-in-revo#dis-post-544700 Fri, 02 Sep 2016 05:30:10 +0000 https://forums.modx.com/thread/46252/add-table-button-for-tinymce-in-revo#dis-post-544700 <![CDATA[tinymce plugin spellchecker won't work]]> https://forums.modx.com/thread/46168/tinymce-plugin-spellchecker-won-t-work#dis-post-543876
template,spellchecker,style,advimage,advlink,modxlink,searchreplace,print,contextmenu,paste,fullscreen,noneditable,nonbreaking,xhtmlxtras,visualchars,media


and add the buttons in Custom Buttons Row 3
template,spellchecker

The buttom Template shows up but spellchecker button is empty


Has anyone experience the same issue?

greetings

Viktor]]>
https://forums.modx.com/thread/46168/tinymce-plugin-spellchecker-won-t-work#dis-post-543876 Fri, 05 Aug 2016 05:08:04 +0000 https://forums.modx.com/thread/46168/tinymce-plugin-spellchecker-won-t-work#dis-post-543876
<![CDATA[Tiny MCE RTE usage not enabling greyed out resource SAVE button]]> https://forums.modx.com/thread/100667/tiny-mce-rte-usage-not-enabling-greyed-out-resource-save-button#dis-post-543874
cheers

dubbs]]>
https://forums.modx.com/thread/100667/tiny-mce-rte-usage-not-enabling-greyed-out-resource-save-button#dis-post-543874 Fri, 05 Aug 2016 01:48:07 +0000 https://forums.modx.com/thread/100667/tiny-mce-rte-usage-not-enabling-greyed-out-resource-save-button#dis-post-543874
<![CDATA[Tinymce for Bootstrap]]> https://forums.modx.com/thread/100629/tinymce-for-bootstrap#dis-post-543722
i'm searching for an modx editor (tinymce etc. ) or plugin which works with bootstrap.

Sorry for my english!]]>
https://forums.modx.com/thread/100629/tinymce-for-bootstrap#dis-post-543722 Mon, 01 Aug 2016 03:09:41 +0000 https://forums.modx.com/thread/100629/tinymce-for-bootstrap#dis-post-543722
<![CDATA[TinyMCE template plugin]]> https://forums.modx.com/thread/76466/tinymce-template-plugin?page=2#dis-post-543064
Did someone succeed in implementing templates functionality for Tiny (4.3.2 Revo).
The plugin is present in the component/tinymce folder.
Adding it to the plugin list + adding'template' to button list did the job to activate a popup where you're supposed to pick up a template (html chunks).
Unfortunately this list is empty and I did not find where I have to store html files for those templates, neither if/how to setup this.

However in tiny documentation they talk about ' template_external_list_url' : JavaScript file containing an array of template files. This can be a backend page such as a PHP page.

Well... how this could be achieved in Revo ?

There's a template.list.php file in the component/tinymce folder :
<?php
/**
 * @package tinymce
 */
require dirname(__FILE__).'/connector.php';

$templates = $modx->tinymce->getTemplateList();

echo 'var tinyMCETemplateList = '.$modx->toJSON($templates).';';
die();


Any clues ?

thank you

EDIT:
I forgot to precise:
in system parameter there's too a tiny.template_list parameter where you have to enter the list of templates (Nameof TPL:path:description, other one, etc...
This make a list og file to be selectable in the Template popup.
This seams to work BUT the resulting code is NOT the one in the html file.
(for instance a 2 columns chunk like this :
<div>
<div class="col col50">
col1
</div>
<div class="col col50">
col2
</div>
</div>

wich is ok in the popup preview, is immediatly corrupted when inserted and becomes :
<div></div>
]]>
https://forums.modx.com/thread/76466/tinymce-template-plugin?page=2#dis-post-543064 Wed, 06 Jul 2016 01:32:41 +0000 https://forums.modx.com/thread/76466/tinymce-template-plugin?page=2#dis-post-543064
<![CDATA[Adding second Insert/edit image button with custom output/formatting]]> https://forums.modx.com/thread/99183/adding-second-insert-edit-image-button-with-custom-output-formatting#dis-post-536477
Normally, I try not to post help topics without trying something first, but I frankly can't figure out where to start. I've found how to add a custom button to TinyMCE editor (http://community.tinymce.com/tryit/3_x/custom_toolbar_button.php), but that's about it.

I also found some code related to the Insert/edit image button under assets/components/tinymce/jscripts/tiny_mce/plugins/advimage, but nothing that seems to change the HTML output. My hope was to just copy/paste all the files under a new name and change the output, then add the button with the new name under System Settings. A method that would probably break upon updating TinyMCE, but it would get me by.

I appreciate any help or direction!

]]>
https://forums.modx.com/thread/99183/adding-second-insert-edit-image-button-with-custom-output-formatting#dis-post-536477 Sat, 02 Jan 2016 09:23:59 +0000 https://forums.modx.com/thread/99183/adding-second-insert-edit-image-button-with-custom-output-formatting#dis-post-536477
<![CDATA[TinyMCE File Browser and Media Sources]]> https://forums.modx.com/thread/98174/tinymce-file-browser-and-media-sources#dis-post-530861
I have 2 contexts (not counting mgr):

web
jc

Content editors that only have access to jc cannot use TinyMCE file browser as the path always defaults to something like this:

http://whatever.com/manager/index.php?a=browser&ctx=web&wctx=web&source=10&referringAction=index&v=231pl


I've set the default_media_source in system settings, context settings, and user settings and source=10 is correct. However, I cannot figure out how to make it use the correct context. Any help would be appreciated.

The users belong to the correct user group and can only see the jc context as expected. Template Variables have been set to use the proper media source. It's only attempting to insert an image or create a link to file in Tiny where it insists on using the web context, which they don't have access to.]]>
https://forums.modx.com/thread/98174/tinymce-file-browser-and-media-sources#dis-post-530861 Tue, 01 Sep 2015 12:05:18 +0000 https://forums.modx.com/thread/98174/tinymce-file-browser-and-media-sources#dis-post-530861
<![CDATA[ [SOLVED] TinyMCE 3.3.2 CSS selectors generating span tags]]> https://forums.modx.com/thread/46099/solved-tinymce-3-3-2-css-selectors-generating-span-tags#dis-post-530011
After installing MODx 1.0.3 with the upgraded TinyMCE plugin (3.3.2), I have noticed that the CSS selectors are not behaving as they used to.

Using styles defined in "manager->tools->configuration->interface & features->TinyMCE settings->CSS selectors" now seems to generate a nested span tag with the class assigned, even if you had selected the whole element.

Apparently, this is due to a change in the TinyMCE CSS engine.
(see: http://tinymce.moxiecode.com/punbb/viewtopic.php?id=20905)

My solution:

1. Remove all selectors from manager->tools->configuration->interface & features->TinyMCE settings->CSS selectors

2. Go to Elements->Manage Elements->Plugins->TinyMCE and add your styles to the custom parameters field, using the style_formats option (http://wiki.moxiecode.com/index.php/TinyMCE:Configuration/style_formats)

eg:
style_formats : [
        {title : 'List with arrows', selector  : 'ul', classes: 'linked'},
        {title : 'Paragraph with border', selector  : 'p', classes : 'bordered'},
        {title : 'Red background', selector  : 'p', classes : 'redbg'}
    ]


This would appear to be a better way of controlling the styles that the editor has available to them, as it allows you to specify which elements can have a specific class.

Cheers

Gerard

]]>
https://forums.modx.com/thread/46099/solved-tinymce-3-3-2-css-selectors-generating-span-tags#dis-post-530011 Thu, 13 Aug 2015 03:21:35 +0000 https://forums.modx.com/thread/46099/solved-tinymce-3-3-2-css-selectors-generating-span-tags#dis-post-530011
<![CDATA[TinyMCE: some images not showing in image browser popup]]> https://forums.modx.com/thread/73396/tinymce-some-images-not-showing-in-image-browser-popup#dis-post-528133 TinyMCE Version: 3.3.9.2

No image thumbnails are displayed in the Browse popup when editing a page. Except if I create a new folder, and then upload an image inside of it (using the browse area upload/create folder buttons). If I upload an image into the base assets/images folder, the upload works fine. The image shows up in FTP/Cpanel (and even if I got to Elements > Manage Files), just not in the browse window, so I'm unable to select it to add to the page.

I've double checked all of the paths, and they appear to be correct. Folder permissions are 755 and file permissions are 644, which I believe are also correct.

I also cleared the Modx cache and my browser caches, but that didn't help. I've also deleted all of the .thumb files in the assets/images folder, but they were not regenerated and that didn't solve the issue.

I have done a couple repair installs as well (mostly to fix other issues), but the problem with the editor browser still persists.

Finally, I tried updating to the most recent version of TinyMCE, but that made it so I could not create a new folder, and made the image uploads not go through at all. So for now I'm sticking with the version the repair install seems to have put in.

I'm open to any suggestions to get this fixed. If any clarification is needed, please let me know.]]>
https://forums.modx.com/thread/73396/tinymce-some-images-not-showing-in-image-browser-popup#dis-post-528133 Thu, 09 Jul 2015 06:41:31 +0000 https://forums.modx.com/thread/73396/tinymce-some-images-not-showing-in-image-browser-popup#dis-post-528133
<![CDATA[MODx Revolution 2.0.0-rc-2; TinyMCE does not appear in chunks]]> https://forums.modx.com/thread/46127/modx-revolution-2-0-0-rc-2-tinymce-does-not-appear-in-chunks?page=3#dis-post-527213 MODx Revolution 2.0.0-rc-2 rev6923
TinyMCE 4.0.0 rc3

new to MODx and tinyMCE. When editing Chunks in Revolution RC2 there is no TinyMCE editor only box for plain HTML; TinyMCE is installed in packages and does show up and work in other sections e.g. Document. From tutorials for Evolution it looks as though there is box to choose Rich Text editor at bottom of Chunk. Am I missing something (configuration) in Revolution or is it just not there?

thanks

Paul]]>
https://forums.modx.com/thread/46127/modx-revolution-2-0-0-rc-2-tinymce-does-not-appear-in-chunks?page=3#dis-post-527213 Sat, 20 Jun 2015 06:32:12 +0000 https://forums.modx.com/thread/46127/modx-revolution-2-0-0-rc-2-tinymce-does-not-appear-in-chunks?page=3#dis-post-527213
<![CDATA[Adding span classes]]> https://forums.modx.com/thread/92785/adding-span-classes#dis-post-525651
It should be
<h1 class="blogNewsSubhead"> … </h1>


but instead I'm getting
<h1><span class="blogNewsSubhead"> … </span></h1>


Me as the developer can manually correct this but a standard user won't.

Does anyone know how I stop it adding this span class?
]]>
https://forums.modx.com/thread/92785/adding-span-classes#dis-post-525651 Sun, 17 May 2015 11:57:42 +0000 https://forums.modx.com/thread/92785/adding-span-classes#dis-post-525651
<![CDATA[How to stop tinyMCE adding spaces in empty cells?]]> https://forums.modx.com/thread/96948/how-to-stop-tinymce-adding-spaces-in-empty-cells#dis-post-524533 https://forums.modx.com/thread/96948/how-to-stop-tinymce-adding-spaces-in-empty-cells#dis-post-524533 Fri, 17 Apr 2015 10:04:37 +0000 https://forums.modx.com/thread/96948/how-to-stop-tinymce-adding-spaces-in-empty-cells#dis-post-524533 <![CDATA[file system in tinymce 4 code base]]> https://forums.modx.com/thread/96701/file-system-in-tinymce-4-code-base#dis-post-523336 addon: http://modx.com/extras/package/tinymcerichtexteditor

settings of file system doesn't work,
how to fix?

its just need add parametre id to iframe
src="/manager/index.php?a=browser&source=5&id=1"]]>
https://forums.modx.com/thread/96701/file-system-in-tinymce-4-code-base#dis-post-523336 Wed, 25 Mar 2015 07:33:17 +0000 https://forums.modx.com/thread/96701/file-system-in-tinymce-4-code-base#dis-post-523336
<![CDATA[TinyMCE - adding a link to an image not working]]> https://forums.modx.com/thread/85328/tinymce---adding-a-link-to-an-image-not-working?page=2#dis-post-522996 MODX Revolution 2.2.8-pl (traditional)
PHP Version 5.3.24
Running on an apache server

Problem:
When using TinyMCE, I've inserted an image, selected that image, and clicked the insert/edit hyperlink button. The window pops up and I add the URL of where I want the image to link to. Then I click update. Instead of closing the popup window and adding the hyperlink - the popup window shows up again, without the URL I've just added, and the link isn't added to the image. Any suggestions/ideas?
]]>
https://forums.modx.com/thread/85328/tinymce---adding-a-link-to-an-image-not-working?page=2#dis-post-522996 Thu, 19 Mar 2015 06:03:48 +0000 https://forums.modx.com/thread/85328/tinymce---adding-a-link-to-an-image-not-working?page=2#dis-post-522996
<![CDATA[tinyMCE.init doesn't run]]> https://forums.modx.com/thread/96108/tinymce-init-doesn-t-run#dis-post-522931 Evo 1.04
TinyMCE 3.3.5

My code in the head section of a chunk which lives in the (modx-)template:
<script type="text/javascript" src="[(base_url)]/assets/plugins/tinymce/jscripts/tiny_mce/tiny_mce.js"></script >
<script type="text/javascript">
    tinyMCE.init({
      templates : [
	{
		title : "Bilderkasten",
		url : "[(base_url)]/assets/plugins/tinymce/custom/highslide.htm",
		description : "Bild vergrößern  mit Bildunterschrift"
	}
     ]
   });
   </script>

Already tried to put the call somewhere in the body...
also, to clear browser as well as modX cache

Thank you]]>
https://forums.modx.com/thread/96108/tinymce-init-doesn-t-run#dis-post-522931 Wed, 18 Mar 2015 10:39:47 +0000 https://forums.modx.com/thread/96108/tinymce-init-doesn-t-run#dis-post-522931