0.9.6 - MODX Community Forums https://forums.modx.com/board/?board=63 <![CDATA[Topic Archived (no new posts/replies)]]> https://forums.modx.com/thread/36402/topic-archived-no-new-posts-replies#dis-post-205322 https://forums.modx.com/thread/36402/topic-archived-no-new-posts-replies#dis-post-205322 Tue, 20 Oct 2009 07:45:20 +0000 https://forums.modx.com/thread/36402/topic-archived-no-new-posts-replies#dis-post-205322 <![CDATA[Blank manager page]]> https://forums.modx.com/thread/36401/blank-manager-page#dis-post-205321
When I try to login my CMS via /manager I get a blank page. If I look in the source code there’s nothing?!
What’s happening???

I hope you can give me a quick answer, because my client needs to login his CMS.

Regards,
Michael]]>
https://forums.modx.com/thread/36401/blank-manager-page#dis-post-205321 Wed, 02 Sep 2009 07:48:57 +0000 https://forums.modx.com/thread/36401/blank-manager-page#dis-post-205321
<![CDATA[Problem with TinyMCE and settings not being applied]]> https://forums.modx.com/thread/36400/problem-with-tinymce-and-settings-not-being-applied#dis-post-205313
I have successfully upgraded from 0.6.5 to 0.6.3 (or, have i?). When trying to add a plugin to TinyMCE I discovered it wasnt applying the settings I set.

After some digging I looked into tinymce.functions.php. It seems if (!function_exists(’getTinyMCEScript’)) is getting triggered. So, when I added a plugin manually in the source, it was included. Did the upgrade fail? Am I missing some files?

TinyMCE version 3.2.01, I guess.
]]>
https://forums.modx.com/thread/36400/problem-with-tinymce-and-settings-not-being-applied#dis-post-205313 Tue, 20 Jan 2009 04:00:03 +0000 https://forums.modx.com/thread/36400/problem-with-tinymce-and-settings-not-being-applied#dis-post-205313
<![CDATA[Font page suddenly complaining about missing /includes/defines.php]]> https://forums.modx.com/thread/36399/font-page-suddenly-complaining-about-missing-includes-defines-php#dis-post-205312 http://www.vicphysics.org/ :

Warning: require_once() [function.require-once]: Unable to access /mounted-storage/home43a/sub006/sc32167-DHIS/www/includes/defines.php in /mounted-storage/home43a/sub006/sc32167-DHIS/www/index.php(1) : eval()'d code(3) : eval()'d code on line 21

Warning: require_once(/mounted-storage/home43a/sub006/sc32167-DHIS/www/includes/defines.php) [function.require-once]: failed to open stream: No such file or directory in /mounted-storage/home43a/sub006/sc32167-DHIS/www/index.php(1) : eval()'d code(3) : eval()'d code on line 21

Fatal error: require_once() [function.require]: Failed opening required '/mounted-storage/home43a/sub006/sc32167-DHIS/www/includes/defines.php' (include_path='.:/usr/share/php5/') in /mounted-storage/home43a/sub006/sc32167-DHIS/www/index.php(1) : eval()'d code(3) : eval()'d code on line 21


No changes have been made to the site that could account for this error. Subpages on the site are working fine, eg: http://www.vicphysics.org/manager http://www.vicphysics.org/forums

I have contacted the host and they say I need to restore the /includes dorectory (which does not appear on the server currently) from backup. However looking at the backup and the original install, there doesn’t ever seem to have been an /includes directory under /www

Does anyone have any suggestions as to what’s going on here?

Thanks in advance!]]>
https://forums.modx.com/thread/36399/font-page-suddenly-complaining-about-missing-includes-defines-php#dis-post-205312 Wed, 10 Dec 2008 11:55:33 +0000 https://forums.modx.com/thread/36399/font-page-suddenly-complaining-about-missing-includes-defines-php#dis-post-205312
<![CDATA[MODx Manager Login Error]]> https://forums.modx.com/thread/36398/modx-manager-login-error#dis-post-205310
First time post here, fairly used to modx, but as a last resort I need to pick your brains...

Since uploading to a new server I am unable to log into the manager.

When I do, I get a warning box come up that has the html for the website’s homepage in it, that goes off the bottom of the screen:


I have reinstalled the manager folder to no avail, but have become really stuck.
There are no errors to go on... the database seems fine and the website front-end is all working...

Any ideas?]]>
https://forums.modx.com/thread/36398/modx-manager-login-error#dis-post-205310 Fri, 28 Nov 2008 12:10:18 +0000 https://forums.modx.com/thread/36398/modx-manager-login-error#dis-post-205310
<![CDATA[Site suddenly went down - cache files problem /manager/media/style//login.html]]> https://forums.modx.com/thread/36397/site-suddenly-went-down---cache-files-problem-manager-media-style-login-html#dis-post-205307
I had Modx 0.9.6 running perfectly for a year or so on a LAMP server.

Today, while I was browsing the manager, I suddenly started getting this errors:

Warning: fopen() [function.fopen]: Unable to access /home/supropia/public_html/manager/media/style//login.html in /home/supropia/public_html/manager/includes/accesscontrol.inc.php on line 128

Warning: fopen(/home/supropia/public_html/manager/media/style//login.html) [function.fopen]: failed to open stream: No such file or directory in /home/supropia/public_html/manager/includes/accesscontrol.inc.php on line 128


Now everytime I try to access the manager I get the above message. The frontend is also down (totally blank).

I read in other posts that this might be a assets/cache problem? (http://modxcms.com/bugs/task/622)

But... why did it happen all of a sudden?

Regards.

Mc]]>
https://forums.modx.com/thread/36397/site-suddenly-went-down---cache-files-problem-manager-media-style-login-html#dis-post-205307 Tue, 28 Oct 2008 09:50:32 +0000 https://forums.modx.com/thread/36397/site-suddenly-went-down---cache-files-problem-manager-media-style-login-html#dis-post-205307
<![CDATA[All pages but front suddenly blank.]]> https://forums.modx.com/thread/36396/all-pages-but-front-suddenly-blank#dis-post-205300
<div style="display:none">3054fa38dbdc58de23337c03e086c1e3</div>

I’ve checked everything under the hood, and it all seems fine. The templates all look correct, the documents in the editor all load fine, the database (while excruciatingly slow to view via phpmyadmin on the hosts erver) appear intact.

I am unaware of any changes the client has made that could cause such a problem, and I doubt they would have the knowledge to make any such change anyway. I’ve told them to stick to editing documents and to stay out of the rest of the manager. The site is hosted on a shared server.

The site in question is: http://vicphysics.org
An example problem page is: http://www.vicphysics.org/photocontest.html

Some details:

MODx version: 0.9.6
MySQL version: 5.0.51a
PHP version: 5.2.3
Phoinfo: http://vicphysics.org/phpinfo.php
Apache version: 2.2.4

Please let me know if there is any other information that would be helpful. Thank you in advance for any help you can offer!
]]>
https://forums.modx.com/thread/36396/all-pages-but-front-suddenly-blank#dis-post-205300 Fri, 17 Oct 2008 03:22:06 +0000 https://forums.modx.com/thread/36396/all-pages-but-front-suddenly-blank#dis-post-205300
<![CDATA[ [Solved] Where can I find a SQL file of the 0.9.6 install? (needed to fix db!)]]> https://forums.modx.com/thread/36395/solved-where-can-i-find-a-sql-file-of-the-0-9-6-install-needed-to-fix-db#dis-post-205290
I need this because I have a database which is ed up by the plesk backup tool. I thought I had a clean install of 0.9.6, but I can’t find it sad So I would be very happy if anyone can provide me with a sql file with the structure of the database from MODx 0.9.6. With that file I can recreate the database with the right settings (auto_increment and stuff) and import the data from the site into it.]]>
https://forums.modx.com/thread/36395/solved-where-can-i-find-a-sql-file-of-the-0-9-6-install-needed-to-fix-db#dis-post-205290 Fri, 03 Oct 2008 08:13:03 +0000 https://forums.modx.com/thread/36395/solved-where-can-i-find-a-sql-file-of-the-0-9-6-install-needed-to-fix-db#dis-post-205290
<![CDATA[document.parser.class.inc or .htaccess problem]]> https://forums.modx.com/thread/36394/document-parser-class-inc-or-htaccess-problem#dis-post-205287
I have been using tracking cookies on my site so that when a user logs in he or she is taken back to the last visited allowed page. This cookie is user specific so that several logins mat use the same machine.

My doc-not-found page also et this cookie by accident.

I was astonished to discover that the doc-not found cookie was being set even when that page had clearly not been visited. I altered the cookies so the name was apge specific and found I almost always got the doc-not found cookie.

I then added a modx log event to the document parser:

if ($this->documentMethod == "alias") {
// Check use_alias_path and check if $this->virtualDir is set to anything, then parse the path
if ($this->config[’use_alias_path’] == 1) {
$alias= (strlen($this->virtualDir) > 0 ? $this->virtualDir . ’/’ : ’’) . $this->documentIdentifier;
if (array_key_exists($alias, $this->documentListing)) {
$this->documentIdentifier= $this->documentListing[$alias];
} else {
$errorString= ’error doc: ’.$alias.’ ’;
foreach ($this->documentListing as $key => $value) {
$errorString .= $key.’=’.$value.’ | ’;
}

$this->logEvent(0, 3,$errorString, $source= ’Parser’);
$this->sendErrorPage();

I was astonished to discover that the offending document was favicon.ico which I have not specified anywhere (the browser does). There was also the odd missing image entry depending on page.

It turns out that the alias system goes out and looks for anything that it cant find on the server whether or not it ends in the alias suffix (in my case .html) as well as .html. Of course this fails and throws this bizarre (if slighly useful) error. Can be fixed in .htaccess or document.parser.class. Your choice.

Julian]]>
https://forums.modx.com/thread/36394/document-parser-class-inc-or-htaccess-problem#dis-post-205287 Mon, 15 Sep 2008 11:32:38 +0000 https://forums.modx.com/thread/36394/document-parser-class-inc-or-htaccess-problem#dis-post-205287
<![CDATA[0.9.6.1p2 Manager: Menu Tree scrollbar bug - SOLVED]]> https://forums.modx.com/thread/36393/0-9-6-1p2-manager-menu-tree-scrollbar-bug---solved#dis-post-205286 http://modxcms.com/forums/index.php/topic,15170.msg99904.html#msg99904), where only the left half of the scrollbar can be clicked & dragged up or down. I can use the mouse scroll wheel to scroll up and down, but my client hates using their scrollwheel and doesn’t view this as a solution. Any idea why only the left half of the frameset scrollbar works?

So far, I’ve confirmed the bug in OS X 10.5.4 using both FF 3.0 and Safari 3.1.2.

]]>
https://forums.modx.com/thread/36393/0-9-6-1p2-manager-menu-tree-scrollbar-bug---solved#dis-post-205286 Sun, 10 Aug 2008 02:16:54 +0000 https://forums.modx.com/thread/36393/0-9-6-1p2-manager-menu-tree-scrollbar-bug---solved#dis-post-205286
<![CDATA[API mapPath function removed? AAARGH!]]> https://forums.modx.com/thread/36392/api-mappath-function-removed-aaargh#dis-post-205283
Fatal error: Call to undefined method DocumentParser::mapPath() in /srv/www/htdocs/sanctree/manager/includes/document.parser.class.inc.php(769) : eval()’d code on line 20

Has mapPath() disappeared from the API? I’ve used it in practically every snippet, module and plugin I’ve ever written.
It worked in 0.9.6.2-rc1. IMHO you shouldn’t remove such a vital function in an API within -rc releases - it’s going to be a major task for me to change this particular bit of code, having spent the last 3 months building on 0.9.6.2-rc1.

Is there an alternative way of finding the MODx path without hard-coding, or reading the config file in every snippet etc?]]>
https://forums.modx.com/thread/36392/api-mappath-function-removed-aaargh#dis-post-205283 Fri, 08 Aug 2008 01:40:07 +0000 https://forums.modx.com/thread/36392/api-mappath-function-removed-aaargh#dis-post-205283
<![CDATA[0.9.6.2 rc 1(beta 2008-05-23) - doc group problem]]> https://forums.modx.com/thread/36391/0-9-6-2-rc-1-beta-2008-05-23---doc-group-problem#dis-post-205276 2. set group to "Site admon pages"
3. save
4. edit doc
5. change doc group to "all"
6. save

so - group not changed!!]]>
https://forums.modx.com/thread/36391/0-9-6-2-rc-1-beta-2008-05-23---doc-group-problem#dis-post-205276 Wed, 02 Jul 2008 12:56:39 +0000 https://forums.modx.com/thread/36391/0-9-6-2-rc-1-beta-2008-05-23---doc-group-problem#dis-post-205276
<![CDATA[Suddenly can't log into MODx 0.9.6.1b manager]]> https://forums.modx.com/thread/36390/suddenly-can-t-log-into-modx-0-9-6-1b-manager#dis-post-205274
In the morning, I was able to log into the MODx manager. I made a change to a snippet, saved it, and the site looks fine.

Later in the afternoon, I attempted to log in (with the same login info that I used earlier in the day), but now I get a solid error dialog entitled "The page at http://www.pacificbiosciences.com says:"


Figure 1. Error while inserting event log into database.

The dialog apparently is telling me that it failed to add an event to the event log, but I don’t know why that would be. The database login username mentioned in the dialog is correct, and I’m able to view the site, which suggests that the login password is also correct, right? What are the possible root causes of this error? Can you suggest any specific things I can look at?

Thanks a lot for any help you can offer.

ken


]]>
https://forums.modx.com/thread/36390/suddenly-can-t-log-into-modx-0-9-6-1b-manager#dis-post-205274 Fri, 23 May 2008 05:31:35 +0000 https://forums.modx.com/thread/36390/suddenly-can-t-log-into-modx-0-9-6-1b-manager#dis-post-205274
<![CDATA[blank index.php after upgrade to 0.9.6]]> https://forums.modx.com/thread/36389/blank-index-php-after-upgrade-to-0-9-6?page=2#dis-post-205268
conf:

PHP Version 5.2.3
Zend Engine v2.2.0,
Apache/1.3.37 (Unix)]]>
https://forums.modx.com/thread/36389/blank-index-php-after-upgrade-to-0-9-6?page=2#dis-post-205268 Fri, 07 Mar 2008 02:18:19 +0000 https://forums.modx.com/thread/36389/blank-index-php-after-upgrade-to-0-9-6?page=2#dis-post-205268
<![CDATA["captcha" image generation problems and veriword.php]]> https://forums.modx.com/thread/36387/captcha-image-generation-problems-and-veriword-php#dis-post-205248
My first step would be login to the manager and disable captcha. However, I can’t even login to the manager (http://avinator.com/manager). I attempted to change USE_CAPTCHA = 0 (from 1) in the modx_system_settings table, but that didn’t disable captcha.

1. how would I disable captcha if I can’t login to the manager screen?


Additionally, veriword.php fails to generate anything... It was working before, and I haven’t changed anything in the code, so I’m not sure what exactly made it stop working. The url is http://avinator.com/manager/includes/veriword.php?rand=1428236831

I have a feeling it has something to do with the gd image generation... but I’m not sure where to look, or how to fix it. Any help would be much appreciated.

ps - ModX rocks. I love it much more than Joomla. I just wish I could disable captcha until I find out what the problem is.]]>
https://forums.modx.com/thread/36387/captcha-image-generation-problems-and-veriword-php#dis-post-205248 Fri, 18 Jan 2008 12:22:06 +0000 https://forums.modx.com/thread/36387/captcha-image-generation-problems-and-veriword-php#dis-post-205248
<![CDATA[release notes]]> https://forums.modx.com/thread/36388/release-notes#dis-post-205249
Thanks.]]>
https://forums.modx.com/thread/36388/release-notes#dis-post-205249 Thu, 17 Jan 2008 12:29:28 +0000 https://forums.modx.com/thread/36388/release-notes#dis-post-205249
<![CDATA[Children documents not show in document tree in MODX management interface]]> https://forums.modx.com/thread/36386/children-documents-not-show-in-document-tree-in-modx-management-interface#dis-post-205242
Installed: MODX version 0.9.6
Version codename: rev 2767
Database: MySQL
Environment: Linux/Apache

I have just installed MODX in a clean environment.
When we create children documents of the site start document,
they are created but not shown in the document tree on the left hand
side of the screen.
When I click on "View Children", I see all the documents.
They are in the database (also checked via MySQL/phpmyadmin)

When a new child is created, the Site STart document shortly flashes
and it looks like I see a ’+’ sign in front, but then is goed back to only
mentioning the Site Start document.

New documents are created by right-clicking on Site Start and click
on "New Document Here".

This might be a bug, or something wrong in our config.

I checked all the site configs with one of the many other sites
we created with MODX, but no difference there.

Hope somebody can help us there.

Thanks,

Bert Catsburg

]]>
https://forums.modx.com/thread/36386/children-documents-not-show-in-document-tree-in-modx-management-interface#dis-post-205242 Tue, 27 Nov 2007 08:56:24 +0000 https://forums.modx.com/thread/36386/children-documents-not-show-in-document-tree-in-modx-management-interface#dis-post-205242
<![CDATA[CSS and XML as documents in 9.6 -- issue]]> https://forums.modx.com/thread/36383/css-and-xml-as-documents-in-9-6----issue?page=2#dis-post-205227
When creating XML or CSS documents in MODX 9.6 the resulting files refuse to be parsed by the server. It makes no difference whether the alias is used or the actual ID. It’s as if the documents are ’blank’.

Document settings:
-- no container
-- template (blank) - also tried using templates...
-- no cache - also tried cache enabled
-- type set to text/XML or text/CSS

When the exact same settings and options are tried on MODX 9.5... Everything works great! CSS is processed and XML files parse!

I’ve been able to repeat this on multiple installations of both.

Ideas would be GREATLY appreciated. I’m working on a project for someone now with 9.6 already integrated... I’m not looking forward to downgrading.

Greg
-------------------------
Linux server
MySQL client version: 4.0.16
Apache webserver
PHP 4]]>
https://forums.modx.com/thread/36383/css-and-xml-as-documents-in-9-6----issue?page=2#dis-post-205227 Thu, 15 Nov 2007 05:01:54 +0000 https://forums.modx.com/thread/36383/css-and-xml-as-documents-in-9-6----issue?page=2#dis-post-205227
<![CDATA[File-Manager don't allow to upload '.htc' files]]> https://forums.modx.com/thread/36385/file-manager-don-t-allow-to-upload-htc-files#dis-post-205238 ’.htc’ file with the file-manager but don’t allow it. I can select the file but when click the ’Upload’ button the page are reloaded as usual but the file is not uploaded.

I’am using the MODx 0.9.6 version and the directory in question is writable, I can upload any ’css’, ’txt’,...

Is this a bug?

Finally I uploaded the file by FTP and it’s displayed but the ’Edit’ and the ’View’ icons are grayed.]]>
https://forums.modx.com/thread/36385/file-manager-don-t-allow-to-upload-htc-files#dis-post-205238 Wed, 14 Nov 2007 09:22:02 +0000 https://forums.modx.com/thread/36385/file-manager-don-t-allow-to-upload-htc-files#dis-post-205238
<![CDATA[Aliases not saved in 0.9.6 when MODx charset not set as UTF-8]]> https://forums.modx.com/thread/36381/aliases-not-saved-in-0-9-6-when-modx-charset-not-set-as-utf-8#dis-post-205175

MODx 0.9.6 has been released in May 2007 and nobody seems to have noticed that there was a problem with documents aliases.

In "manager/processors/save_content.processor.php", in the function "stripAlias()" on line 859 :
$alias = strtr($alias, $replace_array);

The problem is that the array "$replace_array" is only declared if the configuration charset is set as UTF-8 :
if (strtoupper($modx->config['modx_charset']) == 'UTF-8'){

So, an error occured while saving the alias because the function "strtr()" don’t find any array as second parameter.

To make the thing work even if the configuration charset is not UTF-8, this should be placed within the "if" statement :
$alias = strtr($alias, $replace_array);


I hope this would be helpful (and quickly corrected).


Thank you,


Benjamin
]]>
https://forums.modx.com/thread/36381/aliases-not-saved-in-0-9-6-when-modx-charset-not-set-as-utf-8#dis-post-205175 Wed, 17 Oct 2007 11:48:41 +0000 https://forums.modx.com/thread/36381/aliases-not-saved-in-0-9-6-when-modx-charset-not-set-as-utf-8#dis-post-205175