0.9.6.3 - MODX Community Forums https://forums.modx.com/board/?board=60 <![CDATA[Fatal Error with 30 seconds execution time]]> https://forums.modx.com/thread/36091/fatal-error-with-30-seconds-execution-time#dis-post-551857
Fatal error: Maximum execution time of 30 seconds exceeded in C:\...\www\mysite\manager\includes\config.inc.php on line 61

Can anyone help with advice on what I can do?

Davis]]>
https://forums.modx.com/thread/36091/fatal-error-with-30-seconds-execution-time#dis-post-551857 Fri, 16 Jun 2017 08:24:55 +0000 https://forums.modx.com/thread/36091/fatal-error-with-30-seconds-execution-time#dis-post-551857
<![CDATA[Copy a site : File Manager is missing from Tools->Configuration in copied site]]> https://forums.modx.com/thread/36156/copy-a-site-file-manager-is-missing-from-tools--configuration-in-copied-site#dis-post-522002
I have a strange problem in a MODX 0.9.6.3 site.
The site is created on domain "aaa.com" and works fine.
The customers asked me to copy the complete site to
"bbb.com" and he would change the content himself.

This is what I did to copy the site:
- Copy over all file from aaa.com to bbb.com
- Change /manager/includes/config.inc.php to reflect the
new database login codes.
- Export the database of aaa.com
- Change in the database script the two references in
system-settings: rb_base_dir and filemanager_path
from aaa.com document_root to bbb.com document_root.
- Import the changed database script into the database
of bbb.com.

Of course I also changed things like names of the template
to reflect bbb.com, but this has nothing to do with the problem.

The problem is that certain functions are missing from the
manager interface:
- tool->configuration
The complete tab "File Manager" is missing !!
- tool->configuration
At the bottom of tab "Site" the section about TinyMCE
is missing.
- I cannot change the editor for a user to TinyMCE.
(This is probably the same as the second problem-item)


I checked all files in both sites and compared them.
Apart from the obvious files (config.inc.php) no other files
show any differences.
I reloaded the database from aaa.com again and got the same
problem.

Basically the question comes down to:
- What in MDOX decides to show the "File Manager" and the
"TinyMCE" in the Manager section.
- What do these two functionality items need which must be missing
in my site.

Thanks for your help.

Regards,

Bert Catsburg

PS: Please do not respons with "Upgrade first and then we talk" smiley

]]>
https://forums.modx.com/thread/36156/copy-a-site-file-manager-is-missing-from-tools--configuration-in-copied-site#dis-post-522002 Thu, 05 Mar 2015 03:50:40 +0000 https://forums.modx.com/thread/36156/copy-a-site-file-manager-is-missing-from-tools--configuration-in-copied-site#dis-post-522002
<![CDATA[Can't log into Manager directly after installing]]> https://forums.modx.com/thread/36098/can-t-log-into-manager-directly-after-installing?page=2#dis-post-520622
I’ve just installed Modx into the directory public_html/contents on a site that already has quite a bit of data on it. The install runs cleanly, but once it’s finished I am unable to log into the manager. I keep getting an "Incorrect user name or password entered" error.

I have double-checked and even reset the admin password through MySql, re-uploaded the files and reinstalled several times, and even even deleted the Modx subdirectory and installed version 0.9.6.2, but I keep getting the same bug.

Suggestions?]]>
https://forums.modx.com/thread/36098/can-t-log-into-manager-directly-after-installing?page=2#dis-post-520622 Sat, 14 Feb 2015 09:36:41 +0000 https://forums.modx.com/thread/36098/can-t-log-into-manager-directly-after-installing?page=2#dis-post-520622
<![CDATA[Suddenly unable to log into manager]]> https://forums.modx.com/thread/36132/suddenly-unable-to-log-into-manager?page=3#dis-post-478222
The manager login screen looks normal. If I enter an incorrect username or password, it tells me so (as expected). But when I enter the correct username/password it just shows the login screen again with no error message. No JS errors reported by firefox.

I checked the database, and the manager_log table indicates that I’ve logged in successfully.
I’ve tried multiple browsers and machines (PC/Mac) with the same result.
I’ve cleared my browser cache and MODx cache directory.
Checked server error logs - no problem there.

I’m at a complete loss - can anyone suggest what might be happening, or what else I can check?
]]>
https://forums.modx.com/thread/36132/suddenly-unable-to-log-into-manager?page=3#dis-post-478222 Thu, 19 Sep 2013 01:19:02 +0000 https://forums.modx.com/thread/36132/suddenly-unable-to-log-into-manager?page=3#dis-post-478222
<![CDATA[Fatal error: modules / mod_yt_meganews line 318]]> https://forums.modx.com/thread/36163/fatal-error-modules-mod-yt-meganews-line-318#dis-post-203371 /home/elsoca0/public_html/modules/mod_yt_meganews/assets/yt_mega
news.php on line 318

Greetings from Nicaragua]]>
https://forums.modx.com/thread/36163/fatal-error-modules-mod-yt-meganews-line-318#dis-post-203371 Sat, 13 Aug 2011 01:02:52 +0000 https://forums.modx.com/thread/36163/fatal-error-modules-mod-yt-meganews-line-318#dis-post-203371
<![CDATA[Step-by-step instructions for installing 0.9.6.3 with Fatcow.com as the host]]> https://forums.modx.com/thread/36031/step-by-step-instructions-for-installing-0-9-6-3-with-fatcow-com-as-the-host#dis-post-202703 fatcow.com and have been happy with them. There are apparently some steps unique to their site to get MODx installed. Please point any places where I screwed up or could have done better.

* Sign into fatcow.com
* Go to the Control Panel
* Click on "CGI and Scripted Language Support"
* Click on "PHP Scripting"
* Set the default PHP version to "PHP 5"
* Edit the php.ini file
* On the fatcow page, find the path to your Web document root
* Add to the php.ini file a line session.save_path = "xxxx/cgi-bin/tmp" where "xxxx" is the path to your Web document root
* Save the php.ini file
* Download the latest version of MODx to your PC
* Using filezilla or some other ftp program, ftp the zip file to your home directory
* Go to the fatcow control panel
* Click on "Archive Gateway"
* Select the modx zip file and click "Extract/Uncompress"
* Go back to Filezilla
* Drag the files and directory created in the "modx-x.x.x.x" directory to your root directory
* Set the permissions as covered in the MODx install page
* Go to the fatcow control panel
* Click on "Manage MySQL"
* Add a new database. Example values in the "Add New Database" box are "mydb" for Database Name, "mememe" for "Database Login", "mypass" for Password
* Go to http://yourwebsite.com/install/index.php
* Click "Next" to select English as the language
* Click "Begin"
* Check the "I agree to the terms set out in this license" box and click "Next"
* Check "New Installation" and click "Next"
* Go back to the fatcow control panel and click on "Manage MySQL"
* You will see on the page "Database is on xxxxxx.fatcowmysql.com "
* For the database host, put the "xxxxxx.fatcowmysql.com" from above
* For the database login name, put your equivalent of "mememe"
* For the database password, put your equivalent of "mypass"
* Click on the "Click here to test your server connection and get the available collations" link’
* You should get a message saying "passed"
* For the database name, put your equivalent of "mydb"
* You can use as the Connection Method "SET NAMES" or use "SET CHARACTER SET" and select "latin1_swedish_ci"
* Click on the "Click here to create your database or to test the selection of your database"
* You should get a message saying "passed"
* For Administrator username, enter your user name. Then enter your email, your password and your password again
* Click "Next"
* I checked the Sample Web Site box, left all the other boxes checked and clicked "Install"
* The Pre-install validation screen should come up with all OK’s. Click "Install"
* The Install results web page should come up all green. Click "Close"
* You will be taken to the manager web page. Enter your user name and password, then click "Login"
* You now have a MODx website
]]>
https://forums.modx.com/thread/36031/step-by-step-instructions-for-installing-0-9-6-3-with-fatcow-com-as-the-host#dis-post-202703 Sun, 12 Jun 2011 04:39:26 +0000 https://forums.modx.com/thread/36031/step-by-step-instructions-for-installing-0-9-6-3-with-fatcow-com-as-the-host#dis-post-202703
<![CDATA[Unable to preview not-published pages (MODx Parse Error / error in SQL syntax)]]> https://forums.modx.com/thread/36141/unable-to-preview-not-published-pages-modx-parse-error-error-in-sql-syntax#dis-post-203293 Page Settings -> Published? is unticked) that they are editing, by using the "Preview" tab.

This is not a feature that I normally use myself (publish, view in a new browser window, and then re-edit until done, is my way), but having tested this, the problem also occurs to me as well.

When trying to preview the not-published page, instead of the preview, the MODx preview tab displays the following error message:

« MODx Parse Error »
MODx encountered the following error while attempting to parse the requested resource:
« Execution of a query to the database failed - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 »
      SQL: SELECT fullname FROM `modx`.`modx_user_attributes` WHERE `modx`.`modx_user_attributes`.id = 


It looks as though one of the MODx SQL calls is getting truncated part-way through.

Does anybody have any ideas what may be causing the problem, and how I could resolve it?

Thanks for any advice.
]]>
https://forums.modx.com/thread/36141/unable-to-preview-not-published-pages-modx-parse-error-error-in-sql-syntax#dis-post-203293 Wed, 08 Jun 2011 09:47:13 +0000 https://forums.modx.com/thread/36141/unable-to-preview-not-published-pages-modx-parse-error-error-in-sql-syntax#dis-post-203293
<![CDATA[I want show my document root and also document alias in the url , how ?]]> https://forums.modx.com/thread/36162/i-want-show-my-document-root-and-also-document-alias-in-the-url-how#dis-post-203370 I am in a big problem regarding the Friendly url issue for my site. Just look at the link (i want it in the given way)

http://syd-srv06.ezyreg.com/~haha7316/lumina-diem/contact/

here the last part ’contact’ is the document alias, and ’lumina-diem’ is the document root, some other documents are also belong to the same document root ’lumina-diem’ like ’about us’, but the above url is not working, it says 404 page not found error.

So How can i show the www.MyDomain.com/document-Root/document/
___________________________________________________________________________
Modx version : 0.9.6.3
My situation in Friendly url is :
Use friendly URLs: Yes
Prefix for friendly URLs: (Blank/empty)
Suffix for friendly URLs: (Blank/empty)
Allow duplicate aliases: Yes
Use friendly alias path: Yes
Use friendly aliases: Yes
Automatically generate alias: Yes
_________________________________________________
My .htaccess is as follows:

# For full documentation and other suggested options, please see
# http://svn.modxcms.com/docs/display/MODx096/Friendly+URL+Solutions
# including for unexpected logouts in multi-server/cloud environments

Options +FollowSymlinks
RewriteEngine On
RewriteBase /

# Fix Apache internal dummy connections from breaking [(site_url)] cache
RewriteCond %{HTTP_USER_AGENT} ^.*internal\ dummy\ connection.*$ [NC]
RewriteRule .* - [F,L]

# Rewrite domain.com -> www.domain.com -- used with SEO Strict URLs plugin
#RewriteCond %{HTTP_HOST} .
#RewriteCond %{HTTP_HOST} !^www\.example\.com [NC]
#RewriteRule (.*) http://www.example.com/$1 [R=301,L]

# Exclude /assets and /manager directories from rewrite rules
RewriteRule ^(manager|assets) - [L]

# For Friendly URLs
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA,NC]

# Reduce server overhead by enabling output compression if supported.
#php_flag zlib.output_compression On
#php_value zlib.output_compression_level 5
_________________________________________________

Any help is appreciated. smiley

Note: If i add some spam text(Like : akjdak;adfjadj) in the .htacess then it give me 500 error, it means the .htacess works, but not sure the htdd.conf concept or if it is working or not)

Thanks

]]>
https://forums.modx.com/thread/36162/i-want-show-my-document-root-and-also-document-alias-in-the-url-how#dis-post-203370 Sun, 22 May 2011 07:15:41 +0000 https://forums.modx.com/thread/36162/i-want-show-my-document-root-and-also-document-alias-in-the-url-how#dis-post-203370
<![CDATA[ [Solved] manager login nolonger works page just reloads after restore]]> https://forums.modx.com/thread/36161/solved-manager-login-nolonger-works-page-just-reloads-after-restore?page=2#dis-post-203369
Some stats:

Domain: cktheatreschool.co.uk
Modx: 0.9.6.3
PHP: 5.3.6
MySQL: 5.1.56
Browser: Chrome, FF4/FF3, IE8 etc.
Server: VPS hosting, Cpanel v. 11.28.87, 2.6.18-194.8.1.el5.028stab070.5 kernel

Scenario: Started upgrading ModX to a new version - things went wrong. Restored the hosting to pre-upgrade using the image I took before I started work. Things worked okay for a bit but now no users can login correctly. The restore might be co-incidental but I figured it was worth mentioning.

At first I thought the passwords were bad so I used myPHPadmin to change them in the database, I even created a new user for testing purposes this way. The results are always the same.

FIRST INSTANCE:
Step 1. I enter my username
Step 2: I enter my RIGHT password, and
Step 3: I click on Login button, and nothing happens.
A) The user interface gets reloaded, and
B) The system pretends steps 1 through 3 have never happened.

SECOND INSTANCE:
Step 1. I enter my username
Step 2: I enter a WRONG password, and
Step 3: I click on Login button,
something happens.
A) The user interface gets reloaded, and
B) The system tells me, "The username or password you entered is incorrect. Please check the username, re-type the password, and try again."

This bug has been reported in Revolution (see here: http://bugs.modx.com/issues/4242) so that information might be relevant.

Any ideas what might be going on here...?

Any thoughts much appreciated
Cheers
D

]]>
https://forums.modx.com/thread/36161/solved-manager-login-nolonger-works-page-just-reloads-after-restore?page=2#dis-post-203369 Sun, 08 May 2011 05:58:08 +0000 https://forums.modx.com/thread/36161/solved-manager-login-nolonger-works-page-just-reloads-after-restore?page=2#dis-post-203369
<![CDATA[Cannot edit any thing]]> https://forums.modx.com/thread/36160/cannot-edit-any-thing#dis-post-203357
I am facing a big problem and want a solution, I struggle a lot but couldn’t find a solution.
I am using version 0.9.6.3, the site is running fine, but when ever I want to edit any thing, I get different error messages.

When editing a template I am getting this error

"Bad Request

Your browser sent a request that this server could not understand."
----------------------------------------------------------------------------

and when editing a document I am getting this error

"Method Not Implemented

POST to /manager/index.php not supported."

I am into deep problem, please help.

Thanks in advance

Pronab]]>
https://forums.modx.com/thread/36160/cannot-edit-any-thing#dis-post-203357 Mon, 28 Mar 2011 01:59:03 +0000 https://forums.modx.com/thread/36160/cannot-edit-any-thing#dis-post-203357
<![CDATA[Can't login into manager anymore (memory limit)]]> https://forums.modx.com/thread/36159/can-t-login-into-manager-anymore-memory-limit#dis-post-203349
i have an older Version of modx installed and wanted to login into the manager. But now there is always the same error in an alert box:

<br />
<b>Fatal error</b>:  Out of memory (allocated 27262976) (tried to allocate 7659547 bytes) in <b>/homepages/44/d200752930/htdocs/manager/includes/document.parser.class.inc.php</b> on line <b>1287</b><br />



Anyone has an idea, how i can fix this? Thanks!!]]>
https://forums.modx.com/thread/36159/can-t-login-into-manager-anymore-memory-limit#dis-post-203349 Thu, 24 Feb 2011 09:14:41 +0000 https://forums.modx.com/thread/36159/can-t-login-into-manager-anymore-memory-limit#dis-post-203349
<![CDATA[Trash can missing above Manager Tree?]]> https://forums.modx.com/thread/36055/trash-can-missing-above-manager-tree#dis-post-202834
It is not a totally clean install. Meaning, I did a fresh install without any plugins or snippets, and then imported a database from a site that was running 0.9.6.1p2. I say this because when I did a fresh intall with a clean database, I *do* have the trash can.


Anyway I can get it back?]]>
https://forums.modx.com/thread/36055/trash-can-missing-above-manager-tree#dis-post-202834 Tue, 04 Jan 2011 08:56:35 +0000 https://forums.modx.com/thread/36055/trash-can-missing-above-manager-tree#dis-post-202834
<![CDATA[File manager automatically deletes css file when just viewing folder]]> https://forums.modx.com/thread/36158/file-manager-automatically-deletes-css-file-when-just-viewing-folder#dis-post-203345
Saw these old unresolved posts when searching for help.
Bug 1871 in JIRA
old post- http://modxcms.com/forums/index.php/topic,17674.0.html

They had no solutions....

Can anyone help??

Thanks- Teri]]>
https://forums.modx.com/thread/36158/file-manager-automatically-deletes-css-file-when-just-viewing-folder#dis-post-203345 Sun, 19 Dec 2010 02:23:54 +0000 https://forums.modx.com/thread/36158/file-manager-automatically-deletes-css-file-when-just-viewing-folder#dis-post-203345
<![CDATA[Problem with tinyMCE]]> https://forums.modx.com/thread/36157/problem-with-tinymce#dis-post-203342
A friend of mine has a site that is built with modx evo 0.9.6.3 and his old developer is no longer around,

I have been trying to work out what the problem is and whether on not I should update, as well as how to update it, if that proves to be the solution.

The thing that is currently causing trouble is that TinyMCE has stopped appearing in the editor window and this is how my friend updates his site (he doesn’t know anything about code or html).

Currently TinyMCE (3.2.0.1) is installed, as I recently discovered some of the older JavaScript editors can stop working (or appearing) in newer browsers. I don’t know if/how this plug-in can be upgraded by itself without upgrading the rest of the cms, as I want to create a local version of the site first to ensure that nothing inside the templates break when upgraded.

Any help you can offer or if you can point me in the right direction, will be much appreciated.

Thanks in Advance,


Michael
]]>
https://forums.modx.com/thread/36157/problem-with-tinymce#dis-post-203342 Fri, 03 Dec 2010 09:58:15 +0000 https://forums.modx.com/thread/36157/problem-with-tinymce#dis-post-203342
<![CDATA[Can't select or delete page or open context menu]]> https://forums.modx.com/thread/36155/can-t-select-or-delete-page-or-open-context-menu#dis-post-203334
Even as admin, I can’t access the page either: clicking on its icon to try to bring up the context menu results in absolutely nothing happening; clicking on the page title to try to bring up the "Page data" page also results in nothing happening.

Does anybody know if there is any other way that I can try to delete the page, short of manually hacking around the database?

(And if it turns out that I do need to hack around the database, what data would I need to delete in order to delete this corrupt page (and without causing the rest of the site to topple over!)?)

Thanks for any help!


Site info: MODx 0.9.6.3, RHEL 5.5, PHP 5.1.6, MySQL 5.0.77, pdo_mysql: Don’t know, php-pdo RPM (v 5.1.6) is installed, is this the same thing?, browser: have tried various (Firefox, IE, Safari, Opera) on various computers/OS with no luck.]]>
https://forums.modx.com/thread/36155/can-t-select-or-delete-page-or-open-context-menu#dis-post-203334 Thu, 11 Nov 2010 06:48:26 +0000 https://forums.modx.com/thread/36155/can-t-select-or-delete-page-or-open-context-menu#dis-post-203334
<![CDATA[PHP error debug Error:Function split() is deprecated]]> https://forums.modx.com/thread/36154/php-error-debug-error-function-split-is-deprecated#dis-post-203332
PHP error debug
Error: Function split() is deprecated

PHP Deprecated: Function ereg_replace() is

The server was recently, without me knowing it, updated to a new version of php.

Is there a solution for this problem without having to upgrade to a new version of modx?

Thanx in advance!]]>
https://forums.modx.com/thread/36154/php-error-debug-error-function-split-is-deprecated#dis-post-203332 Tue, 21 Sep 2010 03:41:08 +0000 https://forums.modx.com/thread/36154/php-error-debug-error-function-split-is-deprecated#dis-post-203332
<![CDATA[Error when updating page]]> https://forums.modx.com/thread/36153/error-when-updating-page#dis-post-203331
When editing a page;

MODx encountered the following error while attempting to parse the requested resource:
« Execution of a query to the database failed - Incorrect key file for table ’./web175@002dkppsmodx/modx_site_content.MYI’; try to repair it »
SQL: UPDATE `web175-kppsmodx`.`modx_site_content` SET introtext=’’, content=’

(and then shown the content of the page, but changes not saved), and after this I can’t access the admin panel and get the following;

MODx encountered the following error while attempting to parse the requested resource:
« Execution of a query to the database failed - Table ’./web175@002dkppsmodx/modx_site_content’ is marked as crashed and should be repaired »
SQL: SELECT published FROM `web175-kppsmodx`.`modx_site_content` WHERE id=1
[Copy SQL to ClipBoard]

Parser timing
MySQL: 0.0004 s (0 Requests)
PHP: 1284017225.1801 s
Total: 1284017225.1805 s


can anyone shed any light to help me out please?

David.]]>
https://forums.modx.com/thread/36153/error-when-updating-page#dis-post-203331 Thu, 09 Sep 2010 06:51:34 +0000 https://forums.modx.com/thread/36153/error-when-updating-page#dis-post-203331
<![CDATA[Headers for home page being sent as 404 when page displays correctly]]> https://forums.modx.com/thread/36152/headers-for-home-page-being-sent-as-404-when-page-displays-correctly#dis-post-203325
I’m working on an existing site and went to add the Google verification META tag to link the site to Webmaster Tools.

It came up with the message: Verification failed. Your site’s home page returns a status of 404 (Not found) instead of 200 (OK).

I then went to an independant site to check the headers to make sure it wasn’t Google (http://www.seoconsultants.com/tools/headers) and it also said 404. Other pages come up as 200, but the URL itself comes up 404.

I removed the .htaccess file to see if that would help, but still nothing. I also disabled ’friendly URLs’ to see if that would help, but also nothing.

Can anyone help me please - I’ve spent hours trying to figure this out with no luck sad

Thanks in advance!]]>
https://forums.modx.com/thread/36152/headers-for-home-page-being-sent-as-404-when-page-displays-correctly#dis-post-203325 Tue, 31 Aug 2010 03:18:45 +0000 https://forums.modx.com/thread/36152/headers-for-home-page-being-sent-as-404-when-page-displays-correctly#dis-post-203325
<![CDATA[Install/update on this site was executed, please login again!]]> https://forums.modx.com/thread/36042/install-update-on-this-site-was-executed-please-login-again#dis-post-202761
I’ve run into a bit of a problem, where I receive the above error when trying to access the manager.

I found this thread http://modxcms.com/forums/index.php?topic=18563.0 which seems to be the same issue, however changing the code as described did nothing.

The install is running in xampp, on a usb key. I had it running at work today fine and am now receiving this error on my PC at home, the site is accessible, just not the manager. Presumably it is to do with session/cookie information as stated in the other thread, however I’m not sure what to look for or how I can clear/reset it.

My install directory was removed after the initial installation, which complete without any errors, so it can’t actually be running any install or upgrade.

Any pointers would be great. Apologies if I’m going over old ground, but searching only brought up that previous thread.

cheers,

Luke]]>
https://forums.modx.com/thread/36042/install-update-on-this-site-was-executed-please-login-again#dis-post-202761 Sun, 20 Jun 2010 08:53:55 +0000 https://forums.modx.com/thread/36042/install-update-on-this-site-was-executed-please-login-again#dis-post-202761
<![CDATA[Fatal error: Call to undefined function mb_strlen() in...]]> https://forums.modx.com/thread/36066/fatal-error-call-to-undefined-function-mb-strlen-in#dis-post-202908 Fatal error: Call to undefined function mb_strlen() in /home/account/public_html/cmsfolder1/assets/snippets/ajaxSearch/classes/ajaxSearch.class.inc.php on line 359. So I am wondering if someone could please tell me why I am getting this message, and how get I fix it?]]> https://forums.modx.com/thread/36066/fatal-error-call-to-undefined-function-mb-strlen-in#dis-post-202908 Thu, 17 Jun 2010 02:29:24 +0000 https://forums.modx.com/thread/36066/fatal-error-call-to-undefined-function-mb-strlen-in#dis-post-202908