Evo Development - MODX Community Forums https://forums.modx.com/board/?board=58 <![CDATA[Evo upgrade from 1.0.2 to 1.2.1 on PHP 5.4.45]]> https://forums.modx.com/thread/104570/evo-upgrade-from-1-0-2-to-1-2-1-on-php-5-4-45#dis-post-562446
Anyone any thoughts/experience on how well / badly a large site upgrade is going to go from Evo 1.0.2 to 1.2.1 when running on PHP 5.4.45?

Cheers,

dubbs.]]>
https://forums.modx.com/thread/104570/evo-upgrade-from-1-0-2-to-1-2-1-on-php-5-4-45#dis-post-562446 Wed, 31 Oct 2018 03:59:22 +0000 https://forums.modx.com/thread/104570/evo-upgrade-from-1-0-2-to-1-2-1-on-php-5-4-45#dis-post-562446
<![CDATA[Call to undefined function mysql_num_rows() - how to tell/ find which snippets are causing this error?]]> https://forums.modx.com/thread/102164/call-to-undefined-function-mysql-num-rows---how-to-tell-find-which-snippets-are-causing-this-error#dis-post-561967


Fatal error: Uncaught Error: Call to undefined function mysql_num_rows() in /var/www/html/evolution-1.2.1/manager/includes/document.parser.class.inc.php(1360) : eval()'d code:18 Stack trace: #0 /var/www/html/evolution-1.2.1/manager/includes/document.parser.class.inc.php(1360): eval() #1 /var/www/html/evolution-1.2.1/manager/includes/document.parser.class.inc.php(1466): DocumentParser->evalSnippet('include_once("a...', Array) #2 /var/www/html/evolution-1.2.1/manager/includes/document.parser.class.inc.php(1408): DocumentParser->_get_snip_result('category_listin...') #3 /var/www/html/evolution-1.2.1/manager/includes/document.parser.class.inc.php(2003): DocumentParser->evalSnippets('<!DOCTYPE html ...') #4 /var/www/html/evolution-1.2.1/manager/includes/document.parser.class.inc.php(668): DocumentParser->parseDocumentSource('<!DOCTYPE html ...') #5 /var/www/html/evolution-1.2.1/manager/includes/document.parser.class.inc.php(2234): DocumentParser->outputContent() #6 /var/www/html/evolution-1.2.1/manager/includes/document.parser in /var/www/html/evolution-1.2.1/manager/includes/document.parser.class.inc.php(1360) : eval()'d code on line 18


How can tell/ find which snippets are causing this error?
]]>
https://forums.modx.com/thread/102164/call-to-undefined-function-mysql-num-rows---how-to-tell-find-which-snippets-are-causing-this-error#dis-post-561967 Sat, 06 Oct 2018 05:43:27 +0000 https://forums.modx.com/thread/102164/call-to-undefined-function-mysql-num-rows---how-to-tell-find-which-snippets-are-causing-this-error#dis-post-561967
<![CDATA[evolution : usinf fpdf in a snippet]]> https://forums.modx.com/thread/103892/evolution-usinf-fpdf-in-a-snippet#dis-post-559340
I'm facing a problem that I can't solve using the class fpdf within a snippet in evolution cms.
When I'm using the fpdf class in a standalone file "mypdf.php" called with a redirect
$modx->sendRedirect($modx->config['site_url'].'assets/snippets/mysnippet/mypdf.php');

with this basic code in the php file :
<?php
include('fpdf.php');
$PDF=new fpdf('P','mm','A4');
$PDF->AddPage();
$PDF->SetFont('Arial','',10);
$PDF->Write(12, "mytext");
$PDF->Output();
?>

it works fine, but I can't use TVs, $_SESSION etc.

So I tried to use a snippet with the same code inside, called from a doc with a blank template and the following settings :
Ressource type : web page
Content type : application/pdf
content output : inline element

ressource content : [!Pdf!]

and the snippet :
<?php
include($modx->config['base_path'].'assets/snippets/mysnippet/'.fpdf.php');
$PDF=new fpdf('P','mm','A4');
$PDF->AddPage();
$PDF->SetFont('Arial','',10);
$PDF->Write(12, "mytext");
$PDF->Output();

and I get nothing but a blank file (if I set the doc content type as text/html, I get a blank page)
I guess this has something to do with item 2 in http://www.fpdf.org/?lang=en but i just can't find the solution within modx evolution.

I look at all posts that seemed to deal with this issue but did'nt find any solution.

Can anyone help ?

Thank's a lot !]]>
https://forums.modx.com/thread/103892/evolution-usinf-fpdf-in-a-snippet#dis-post-559340 Wed, 04 Jul 2018 02:06:44 +0000 https://forums.modx.com/thread/103892/evolution-usinf-fpdf-in-a-snippet#dis-post-559340
<![CDATA[Error by sending an email to a new user when i`ve trying to add it from the manager]]> https://forums.modx.com/thread/103720/error-by-sending-an-email-to-a-new-user-when-i-ve-trying-to-add-it-from-the-manager#dis-post-557930 Please help me to decide my little trouble with Evo.
When i`ve trying to add new user for my Evo 1.3 it`s crashes out with the error that i`ve attached to this post. And still the user is created even with an error. Sending email function is works fine i`ve checked it with PHP function.
Any ideas why the error is happens?
//sorry for my great english ^__^
]]>
https://forums.modx.com/thread/103720/error-by-sending-an-email-to-a-new-user-when-i-ve-trying-to-add-it-from-the-manager#dis-post-557930 Wed, 11 Apr 2018 09:23:01 +0000 https://forums.modx.com/thread/103720/error-by-sending-an-email-to-a-new-user-when-i-ve-trying-to-add-it-from-the-manager#dis-post-557930
<![CDATA[CodeMirror for MODX Evolution]]> https://forums.modx.com/thread/73753/codemirror-for-modx-evolution?page=4#dis-post-556831 some time ago I have done port CodeMirror 2 into MODX Evolution (originaly posted at http://www.modxcms.cz/forums/tema-codemirror-pro-modx-evolution-plugin-aktualizovano-29-1-2012).

GitHub repository: https://github.com/hansek/MODX-Evolution-CodeMirror

Install:
Just copy extracted two directories from archive into your MODX Evo root folder.
In second step go to URL of your modx slash install (etc. http://localhost/install/). This will install main plugin inside MODX manager.

Problems:
If you used plugin EditArea, then disable or delete it!

Changelog:



  • 2.25 (2012-06-05)
    - updated CodeMirror JS core to 2.25
    - added CodeMirror themes to settings
    - added new CodeMirror settings (thx dmit3yy)
    - improvment in path definition (thx yama)

  • 2.23 b (2012-04-15)
    - fixed bug with rendering of CM on document Content

  • 2.23 (2012-03-29)
    - updated CodeMirror JS core to 2.23
    - fixed problem with bad rendering of CodeMirror on inactive tab

  • 2.22 b (2012-03-20)
    - Minor fixies of path in plugin

  • 2.22 (2012-03-19)
    - update to CodeMirror 2.22
    - possibility to choose theme via Plugin properties
    - render CodeMirror for textarea TVs

  • 2.21 b (2012-01-29)
    - minor changes (cleanup in markup), ability to choice theme by variable $theme in codemirror.plugin.php
]]>
https://forums.modx.com/thread/73753/codemirror-for-modx-evolution?page=4#dis-post-556831 Tue, 13 Feb 2018 12:56:23 +0000 https://forums.modx.com/thread/73753/codemirror-for-modx-evolution?page=4#dis-post-556831
<![CDATA[CRM integration - CiviCrm]]> https://forums.modx.com/thread/33684/crm-integration---civicrm?page=3#dis-post-555884
I really like the idea of using CiviCRM, (and looking loosely at VTiger). Civi has easy integration set up already with Joomla and Drupal and although does provide very basic instructions on how to do it manually...looking through the modx forums there has been some discussion about CRM integration, and I do understand that Modx at somepoint soon will be expanding and growing beyond belief.

Just wondering has anyone already done it with Modx, if so - was it comparitvely easy? There’s only one post which wasn’t really answered on the CiviCRM website forums about MODx.

I would prefer not to go back to using Drupal for this forthcoming project although for ease on integration and database mangement by the end website users, may have to contemplate it. (also, once this site is done, other similar non-profits are already looking for me to do the same with them.) I want to promote Modx as a great CMF and not resort to reverting back to Drupal.

*** So if anyone has had any success already - can they let me know?

*** Are there other easy solutions available that others have used that have been successful? Or even a similar custom built tool that has worked very well, and can grow when necessary.
Its the back end database administration and querying and management side that I really need to get right for the end users, PHPmyadmin isn’t at all right for their level of IT!

In short, it’s only one on-line form to collect information at the moment, to record, and also to email/share data onto the individual partners but needs the back end CRM side for central contact management (and querying), email newsletters, mailmerge etc etc, by being an application which can develop the CRM facilities as time progresses and the partnership grows. (and has to be easy to use and manage for the end users!!!). I know that there are snippets that do the basics, but what I am talking about is something abit more.

Also, am happy to have a go myself, (and am already contracted for doing the main design and information management and transfer from their existing site) but more interestingly to others...(which may help develop Modx further...)

I have been given a (wee, we’re talking about a partnership of charities here) small budget for the whole database setup and intregration of forms to crm, onto the site I am about to design, if any MODX-type people are interested in taking this part on rather than just giving me advice.

(which potentially possibly can be then used as a model to help others which may be looking at this issue, thought this could be a great way to drive Modx further!)

(okay... its not alot of money - I have up to £500 all inclusive available for the set up and database integration, seperately to the web design side! ). If anyone is interested in this, it has to work, and preferably use a CRM that is easily used especially by non-profits/charities.
(like Civi). Timelines : mid-April I am hoping the new site will be coming up to being live. If interested please contact me directly. Ta!]]>
https://forums.modx.com/thread/33684/crm-integration---civicrm?page=3#dis-post-555884 Thu, 14 Dec 2017 09:03:57 +0000 https://forums.modx.com/thread/33684/crm-integration---civicrm?page=3#dis-post-555884
<![CDATA[$_GET for friendly URL SEO]]> https://forums.modx.com/thread/103212/get-for-friendly-url-seo#dis-post-555432
I have a page (my-page.html) where I have several content created by a personal database. So, I want to access to each content individually. The easy way is to put variable into the URL like this:
my-page.html?page=my-second-content
And I can get the variable with a simple $_GET
But it's not a friendly URL solution. I want this:
my-page/my-second-content.html
However, this URL display the homepage of course.
I think that the solution is to change the .htaccess file, but I'm not sure and, most important, I don't know how (properply). Or, maybe you have another way.

Someone can help me? Please.

Thanks.]]>
https://forums.modx.com/thread/103212/get-for-friendly-url-seo#dis-post-555432 Thu, 23 Nov 2017 09:43:32 +0000 https://forums.modx.com/thread/103212/get-for-friendly-url-seo#dis-post-555432
<![CDATA[modx_event_log - large data size and what is it for?]]> https://forums.modx.com/thread/102156/modx-event-log---large-data-size-and-what-is-it-for#dis-post-554807
What is causing the large data size?

Can I truncate the table?]]>
https://forums.modx.com/thread/102156/modx-event-log---large-data-size-and-what-is-it-for#dis-post-554807 Fri, 27 Oct 2017 12:20:49 +0000 https://forums.modx.com/thread/102156/modx-event-log---large-data-size-and-what-is-it-for#dis-post-554807
<![CDATA[Manage document and weblinks on Front End]]> https://forums.modx.com/thread/33969/manage-document-and-weblinks-on-front-end#dis-post-554209
I search a snippet which could manage on front end : document and weblinks like NewsPublisher or FDM. These snippets doesn’t manage weblink...

Someone have an idea ?

Thx]]>
https://forums.modx.com/thread/33969/manage-document-and-weblinks-on-front-end#dis-post-554209 Fri, 29 Sep 2017 06:39:55 +0000 https://forums.modx.com/thread/33969/manage-document-and-weblinks-on-front-end#dis-post-554209
<![CDATA[MODX EVO 1.2.1 upgraded to PHP7]]> https://forums.modx.com/thread/102870/modx-evo-1-2-1-upgraded-to-php7#dis-post-554015
any help would be appreciated. we switched a modx 1.2.1 from php5.6 to php7 to see if it would float and it didn't. the error log received:


----------------------------------------------------------------------------------------------
[20-Sep-2017 13:40:10 UTC] PHP Fatal error: Uncaught Error: Class 'mysqli' not found in /home/ggmservices/public_html/domain.com/manager/includes/extenders/dbapi.mysqli.class.inc.php:29
Stack trace:
#0 /home/ggmservices/public_html/domain.com/manager/includes/document.parser.class.inc.php(2028): DBAPI->connect()
#1 /home/ggmservices/public_html/domain.com/index.php(128): DocumentParser->executeParser()
#2 {main}
thrown in /home/ggmservices/public_html/domain.com/manager/includes/extenders/dbapi.mysqli.class.inc.php on line 29
-----------------------------------------------------------------------------------------------


We presumed that evo 1.2.1 was php7 friendly already and had the mysql1 classes etc, and that we wouldn't be missing classes. anyone come across errors like this when they moved to php7?

thanks

John

]]>
https://forums.modx.com/thread/102870/modx-evo-1-2-1-upgraded-to-php7#dis-post-554015 Wed, 20 Sep 2017 02:07:39 +0000 https://forums.modx.com/thread/102870/modx-evo-1-2-1-upgraded-to-php7#dis-post-554015
<![CDATA[EVO documentation website is down?]]> https://forums.modx.com/thread/102514/evo-documentation-website-is-down#dis-post-552341 I was looking for the YAMS documentation, but it looks like the Evo documentation website: http://www.evolution-docs.com/ is down.
Do you know of any other place where I can find the documentation?

Thanks a lot
Pietro]]>
https://forums.modx.com/thread/102514/evo-documentation-website-is-down#dis-post-552341 Fri, 07 Jul 2017 07:39:01 +0000 https://forums.modx.com/thread/102514/evo-documentation-website-is-down#dis-post-552341
<![CDATA[500 (Internal Server Error) on MODx Manager Configuration tab]]> https://forums.modx.com/thread/89834/500-internal-server-error-on-modx-manager-configuration-tab#dis-post-552068
I have upgraded the from 1.0.5 to 1.0.13 and have been going through the site front-end and MODx manager an d all seems well apart from one problem. I can access all sections in the Manager apart from the Site - Home tab and the Tools - Configuration tab. The pages tries to load and stops. I have checked the console log and am getting the error -

Failed to load resource: the server responded with a status of 500 (Internal Server Error) http://*****/manager/index.php?a=17
Refused to set unsafe header "Connection" index.php?a=1&f=menu:1
Refused to set unsafe header "Connection" mootools.js:2

I have also run this on a development server and all working well. Any ideas???

Windows NT WEBSERVER 5.2 build 3790 (Windows Server 2003 R2 Standard Edition Service Pack 2) i586
PHP - 5.3.6

I have now noticed the following error message appears but disappears when I click on the Configuartion and Home tab

MODx Array is currently editing these settings. Please wait until the other user has finished and try again

Also the Remove Locks option isn't working - No pop-up to indicate that it is locked either????

Regards,
Paraic]]>
https://forums.modx.com/thread/89834/500-internal-server-error-on-modx-manager-configuration-tab#dis-post-552068 Tue, 27 Jun 2017 06:42:49 +0000 https://forums.modx.com/thread/89834/500-internal-server-error-on-modx-manager-configuration-tab#dis-post-552068
<![CDATA[getchunk - snippets not executed]]> https://forums.modx.com/thread/35259/getchunk---snippets-not-executed#dis-post-550982
I have a problem: in a snippet I get the code of a chunk via the getchunk method. When I use echo to show it on the screen, snippets which are in the chunk are not executed. Is there a way to parse the chunk instead of just "echoeing" it, so that snippets are executed?

Many thanks,

Sebastian]]>
https://forums.modx.com/thread/35259/getchunk---snippets-not-executed#dis-post-550982 Sat, 20 May 2017 07:13:14 +0000 https://forums.modx.com/thread/35259/getchunk---snippets-not-executed#dis-post-550982
<![CDATA[Where to keep the global functions?]]> https://forums.modx.com/thread/102168/where-to-keep-the-global-functions#dis-post-550523 https://forums.modx.com/thread/102168/where-to-keep-the-global-functions#dis-post-550523 Sat, 06 May 2017 02:13:07 +0000 https://forums.modx.com/thread/102168/where-to-keep-the-global-functions#dis-post-550523 <![CDATA[Cache - what is it for?]]> https://forums.modx.com/thread/102169/cache---what-is-it-for#dis-post-550522

« MODX Parse Error »
Error : mkdir(): No such file or directory


Can I turn it off while developing the site?
]]>
https://forums.modx.com/thread/102169/cache---what-is-it-for#dis-post-550522 Sat, 06 May 2017 02:12:20 +0000 https://forums.modx.com/thread/102169/cache---what-is-it-for#dis-post-550522
<![CDATA[MODX 1.2.1 installation - 'New Installation' option?]]> https://forums.modx.com/thread/102161/modx-1-2-1-installation---new-installation-option#dis-post-550497
What have I missed?
]]>
https://forums.modx.com/thread/102161/modx-1-2-1-installation---new-installation-option#dis-post-550497 Fri, 05 May 2017 10:00:14 +0000 https://forums.modx.com/thread/102161/modx-1-2-1-installation---new-installation-option#dis-post-550497
<![CDATA[Upgrade to 1.2.1 does not work!]]> https://forums.modx.com/thread/102162/upgrade-to-1-2-1-does-not-work#dis-post-550494 http://127.0.1.1/evolution-1.2.1/

This is my config file:


<?php
/**
 * MODX Configuration file
 */
$database_type     = 'mysqli';
$database_server   = 'localhost';
$database_user     = 'root';
$database_password = 'xxx';
$database_connection_charset = 'latin1';
$database_connection_method = 'SET CHARACTER SET';
$dbase             = '`modx_mysite`';
$table_prefix      = 'modx_';

$lastInstallTime = 1494016583;

$https_port = '443';

if(!defined('MGR_DIR')) define('MGR_DIR', 'manager');

// automatically assign base_path and base_url
if(empty($base_path)||empty($base_url)||$_REQUEST['base_path']||$_REQUEST['base_url']) {
    $sapi= 'undefined';
    if (!strstr($_SERVER['PHP_SELF'], $_SERVER['SCRIPT_NAME']) && ($sapi= @ php_sapi_name()) == 'cgi') {
        $script_name= $_SERVER['PHP_SELF'];
    } else {
        $script_name= $_SERVER['SCRIPT_NAME'];
    }
    $script_name = str_replace('\\', '/', dirname($script_name));
    if(strpos($script_name,MGR_DIR)!==false)
        $separator = MGR_DIR;
    elseif(strpos($script_name,'/assets/')!==false)
        $separator = 'assets';
    else $separator = '';

    if($separator!=='') $a= explode('/'.$separator, $script_name);
    else $a = array($script_name);

    if (count($a) > 1)
        array_pop($a);
    $url= implode($separator, $a);
    reset($a);
    $a= explode(MGR_DIR, str_replace('\\', '/', dirname(__FILE__)));
    if (count($a) > 1)
        array_pop($a);
    $pth= implode(MGR_DIR, $a);
    unset ($a);
    $base_url= $url . (substr($url, -1) != '/' ? '/' : '');
    $base_path= $pth . (substr($pth, -1) != '/' && substr($pth, -1) != '\\' ? '/' : '');
}

// check for valid hostnames
$site_hostname = str_replace(':' . $_SERVER['SERVER_PORT'], '', $_SERVER['HTTP_HOST']);
if (!defined('MODX_SITE_HOSTNAMES')) {
	$site_hostnames_path = $base_path . 'assets/cache/siteHostnames.php';
	if (is_file($site_hostnames_path)) {
		include_once($site_hostnames_path);
	} else {
		define('MODX_SITE_HOSTNAMES', '');
	}
}
$site_hostnames = explode(',', MODX_SITE_HOSTNAMES);
if (!empty($site_hostnames[0]) && !in_array($site_hostname, $site_hostnames)) {
    $site_hostname = $site_hostnames[0];
}


// assign site_url
$site_url= ((isset ($_SERVER['HTTPS']) && strtolower($_SERVER['HTTPS']) == 'on') || $_SERVER['SERVER_PORT'] == $https_port) ? 'https://' : 'http://';
$site_url .= $site_hostname;
if ($_SERVER['SERVER_PORT'] != 80)
    $site_url= str_replace(':' . $_SERVER['SERVER_PORT'], '', $site_url); // remove port from HTTP_HOST  
$site_url .= ($_SERVER['SERVER_PORT'] == 80 || (isset ($_SERVER['HTTPS']) && strtolower($_SERVER['HTTPS']) == 'on') || $_SERVER['SERVER_PORT'] == $https_port) ? '' : ':' . $_SERVER['SERVER_PORT'];
$site_url .= $base_url;

if (!defined('MODX_BASE_PATH')) define('MODX_BASE_PATH', $base_path);
if (!defined('MODX_BASE_URL')) define('MODX_BASE_URL', $base_url);
if (!defined('MODX_SITE_URL')) define('MODX_SITE_URL', $site_url);
if (!defined('MODX_MANAGER_PATH')) define('MODX_MANAGER_PATH', $base_path.MGR_DIR.'/');
if (!defined('MODX_MANAGER_URL')) define('MODX_MANAGER_URL', $site_url.MGR_DIR.'/');

// start cms session
if(!function_exists('startCMSSession')) {
    
    global $site_sessionname;
    $_ = crc32(__FILE__);
    $_ = sprintf('%u', $_);
    $_ = base_convert($_,10,36);
    $site_sessionname = 'evo' . $_;
    
    function removeInvalidCmsSessionFromStorage(&$storage, $session_name) {
      if (isset($storage[$session_name]) && $storage[$session_name] === '')
      {
        unset($storage[$session_name]);
      }
    }
    function removeInvalidCmsSessionIds($session_name) {
        // session ids is invalid iff it is empty string
        // storage priorioty can see in PHP source ext/session/session.c
        removeInvalidCmsSessionFromStorage($_COOKIE, $session_name);
        removeInvalidCmsSessionFromStorage($_GET, $session_name);
        removeInvalidCmsSessionFromStorage($_POST, $session_name);
    }
    function startCMSSession(){
        
        global $site_sessionname, $https_port;
        
        session_name($site_sessionname);
        removeInvalidCmsSessionIds($site_sessionname);
        session_start();
        $cookieExpiration= 0;
        $secure = ((isset ($_SERVER['HTTPS']) && strtolower($_SERVER['HTTPS']) == 'on') || $_SERVER['SERVER_PORT'] == $https_port);
        
        if    (isset($_SESSION['mgrValidated'])) $context = 'mgr';
        elseif(isset($_SESSION['webValidated'])) $context = 'web';
        else {
            setcookie($site_sessionname, session_id(), $cookieExpiration, MODX_BASE_URL, null, $secure, true);
            return;
        }
        
        $key = "modx.{$context}.session.cookie.lifetime";
        if (isset($_SESSION[$key]) && is_numeric($_SESSION[$key])) {
            $cookieLifetime= intval($_SESSION[$key]);
            if($cookieLifetime) $cookieExpiration = $_SERVER['REQUEST_TIME']+$cookieLifetime;
        }
        if (!isset($_SESSION['modx.session.created.time'])) {
            $_SESSION['modx.session.created.time'] = $_SERVER['REQUEST_TIME'];
        }
        setcookie($site_sessionname, session_id(), $cookieExpiration, MODX_BASE_URL, null, $secure, true);
    }
}




What have I missed?]]>
https://forums.modx.com/thread/102162/upgrade-to-1-2-1-does-not-work#dis-post-550494 Fri, 05 May 2017 09:48:50 +0000 https://forums.modx.com/thread/102162/upgrade-to-1-2-1-does-not-work#dis-post-550494
<![CDATA[MODX legacy - Incorrect table definition; there can be only one auto column and it must be defined as a key]]> https://forums.modx.com/thread/102157/modx-legacy---incorrect-table-definition-there-can-be-only-one-auto-column-and-it-must-be-defined-as-a-key#dis-post-550486
Error in query (1075): Incorrect table definition; there can be only
one auto column and it must be defined as a key

For

 CREATE TABLE `modx_categories` (
      `id` int(11) NOT NULL auto_increment,
      `category` varchar(45) NOT NULL DEFAULT ''
    ) ENGINE=MyISAM DEFAULT CHARSET=latin1 COMMENT='Categories to be used snippets,tv,chunks, etc';



Any ideas how I can fix this table (and other tables that might have the same problem)?]]>
https://forums.modx.com/thread/102157/modx-legacy---incorrect-table-definition-there-can-be-only-one-auto-column-and-it-must-be-defined-as-a-key#dis-post-550486 Fri, 05 May 2017 09:17:42 +0000 https://forums.modx.com/thread/102157/modx-legacy---incorrect-table-definition-there-can-be-only-one-auto-column-and-it-must-be-defined-as-a-key#dis-post-550486
<![CDATA[Where is my local theme folder - templates, images, etc?]]> https://forums.modx.com/thread/102155/where-is-my-local-theme-folder---templates-images-etc#dis-post-550484
But how can I upgrade it? Where is my local theme folder: templates, images, etc that I need to back up and move them to 1.2.1?

In WordPress, we can find our local them in wp-content/, what about MODX?]]>
https://forums.modx.com/thread/102155/where-is-my-local-theme-folder---templates-images-etc#dis-post-550484 Fri, 05 May 2017 08:56:20 +0000 https://forums.modx.com/thread/102155/where-is-my-local-theme-folder---templates-images-etc#dis-post-550484
<![CDATA[How can I get the parsed content from a document in my snippet?]]> https://forums.modx.com/thread/34771/how-can-i-get-the-parsed-content-from-a-document-in-my-snippet#dis-post-550327
In the process of subscribing a new user, I need to send a few emails for confirmation, etc, so I’m using the excellent Swift Mailer library (http://swiftmailer.org/).

To make it easy for the church staff to edit the text of these emails, I’m creating a document (unpublished) for each one, all organized into a subscriptions folder in the site tree.

My question is, how can I get the parsed content of one of these documents in my snippet code so that I can pass it along to Swift Mailer to send the email? I will be setting some placeholders, so that’s the main reason I need to parse the content. Each email has the HTML message in the content field, but I also have a template variable that contains the plaintext version of the message, so it’d be great if I could get that parsed as well.

If that’s not doable, then I could probably write my own code to replace the placeholders with the correct data, but it just makes more sense to use the built-in functionality of MODx to do so.

Thanks!]]>
https://forums.modx.com/thread/34771/how-can-i-get-the-parsed-content-from-a-document-in-my-snippet#dis-post-550327 Fri, 28 Apr 2017 12:45:00 +0000 https://forums.modx.com/thread/34771/how-can-i-get-the-parsed-content-from-a-document-in-my-snippet#dis-post-550327