Evolution 1.0.5 and Prior - MODX Community Forums https://forums.modx.com/board/?board=49 <![CDATA[Did Upgrade Install - Welcome Screen Disappeared (MODX Evo 1.0.15)]]> https://forums.modx.com/thread/104970/did-upgrade-install---welcome-screen-disappeared-modx-evo-1-0-15#dis-post-564478
I also noticed that when I save any settings in the system configuration page, it updates, and then displays my site's 404 page. Something isn't right here. Thoughts?]]>
https://forums.modx.com/thread/104970/did-upgrade-install---welcome-screen-disappeared-modx-evo-1-0-15#dis-post-564478 Mon, 18 Mar 2019 04:33:29 +0000 https://forums.modx.com/thread/104970/did-upgrade-install---welcome-screen-disappeared-modx-evo-1-0-15#dis-post-564478
<![CDATA[ModX 1.0.15 Moved Host and Content Shows +] Errors]]> https://forums.modx.com/thread/104924/modx-1-0-15-moved-host-and-content-shows-errors#dis-post-564188
Half of my website shows content errors. It displays `+] and `:else=``+] all over the screen on some pages instead of the actual content, while other pages display normal.

In the admin section of those pages that show these symbols, I see the actual content. Yet on the front end, only these symbols show.

Please help anyone who may know how to fix this
]]>
https://forums.modx.com/thread/104924/modx-1-0-15-moved-host-and-content-shows-errors#dis-post-564188 Thu, 21 Feb 2019 10:02:30 +0000 https://forums.modx.com/thread/104924/modx-1-0-15-moved-host-and-content-shows-errors#dis-post-564188
<![CDATA[Help Needed! Manager View is not working]]> https://forums.modx.com/thread/104762/help-needed-manager-view-is-not-working#dis-post-563397 It is working fine till but I can't go to the manager view anymore.
I can login, with errors, but It doesn't go to a manager view, but gives me that strip at the top(see attached). If I click `Edit Resource` it gives a pop up with bunch of warnings.
Any help highly appreciated.
If somebody is willing to help I can offer some compensation (the data is very important to me).
Thanks!
]]>
https://forums.modx.com/thread/104762/help-needed-manager-view-is-not-working#dis-post-563397 Sun, 30 Dec 2018 09:04:29 +0000 https://forums.modx.com/thread/104762/help-needed-manager-view-is-not-working#dis-post-563397
<![CDATA[Only startpage / links broken?]]> https://forums.modx.com/thread/102810/only-startpage-links-broken#dis-post-553771
this is the site: dksb-do.eu. Suddenly only the start-page appears. If I try another link, the same page appears.
2 days ago everything was fine.
MODX 1.0.15
Any idea?]]>
https://forums.modx.com/thread/102810/only-startpage-links-broken#dis-post-553771 Fri, 08 Sep 2017 02:28:42 +0000 https://forums.modx.com/thread/102810/only-startpage-links-broken#dis-post-553771
<![CDATA[Is Evolution 1.04 and up compatible with php 5.3.x]]> https://forums.modx.com/thread/102788/is-evolution-1-04-and-up-compatible-with-php-5-3-x#dis-post-553679
Can anybody advise me on this subject?]]>
https://forums.modx.com/thread/102788/is-evolution-1-04-and-up-compatible-with-php-5-3-x#dis-post-553679 Wed, 06 Sep 2017 08:35:15 +0000 https://forums.modx.com/thread/102788/is-evolution-1-04-and-up-compatible-with-php-5-3-x#dis-post-553679
<![CDATA[How Can I Set the site_url setting?]]> https://forums.modx.com/thread/33107/how-can-i-set-the-site-url-setting#dis-post-553015
The actually file location relative to the root is something like /modx, but it is accessed in the browser at just the /

I’m using mod_rewrite to redirect everything in the root to the modx subfolder, but modx thinks the site_url includes the modx subfolder, and it shouldn’t.

I’m not sure if that was clear, but does anybody have any ideas?

Thanks!]]>
https://forums.modx.com/thread/33107/how-can-i-set-the-site-url-setting#dis-post-553015 Fri, 04 Aug 2017 05:26:39 +0000 https://forums.modx.com/thread/33107/how-can-i-set-the-site-url-setting#dis-post-553015
<![CDATA[On 0.9.6 - what version can I upgrade to safely?]]> https://forums.modx.com/thread/102373/on-0-9-6---what-version-can-i-upgrade-to-safely#dis-post-551658
I'm in charge of a site that was created (not by me) in 0.9.6 and never upgraded. We've been brought down by PHP upgrades by our host. I want to upgrade the site so this doesn't happen again. At least, in as much as I can control.

Thing is, I've found a post about upgrading to 1.0.6, but nothing much about upgrading further than that in one go. I understand the process, I'm a little intimidated by it, as I never did the wiring for the snippets or templates, though I understand roughly how that's working for us.

General gist: Backup, upload the new files (careful around the snippets folder, apparently), copy the old config file to the updated Manager folder, then run domain.com/install and select the upgrade option. Possibly uncheck snippets before it starts, then update them one by one. If all goes well, site pops back up. If all goes poorly, shenanigans. Referring to great guide here: http://www.evolution-docs.com/documentation/administration/upgrading and the post I mentioned above: https://forums.modx.com/thread/77856/help-currently-running-0-9-6-modx-and-need-to-upgrade-to-latest-version-soon.

Does anyone know how far I can upgrade to? Apparently I can go to 1.0.6, and I'm sure I could go up in another step from there, but could I conceivably go to Evolution 1.2 in one go, from 0.9.6? Is there anything I could do to review/prep the site beforehand to make the transition easier? I'll have a tech helping me out, but he's unfamiliar with modx - is there anything he should know about just in case?

Thanks for any help/expertise/advice,
Jen]]>
https://forums.modx.com/thread/102373/on-0-9-6---what-version-can-i-upgrade-to-safely#dis-post-551658 Mon, 12 Jun 2017 06:16:23 +0000 https://forums.modx.com/thread/102373/on-0-9-6---what-version-can-i-upgrade-to-safely#dis-post-551658
<![CDATA[I like Evo 1.2]]> https://forums.modx.com/thread/101612/i-like-evo-1-2#dis-post-548085
db   d8b   db  .d88b.  db   d8b   db 
88   I8I   88 .8P  Y8. 88   I8I   88 
88   I8I   88 88    88 88   I8I   88 
Y8   I8I   88 88    88 Y8   I8I   88 
`8b d8'8b d8' `8b  d8' `8b d8'8b d8' 
 `8b8' `8d8'   `Y88P'   `8b8' `8d8'  
                                                                   


what a nice manager in there !

Guys you did a wonderful job with Evolution ! It has the feeling of Revo with the speed and simplicity of Evo.. I notice a lot of improvement in settings and other details everywhere... it's soooo nice !!

Thank you!]]>
https://forums.modx.com/thread/101612/i-like-evo-1-2#dis-post-548085 Sun, 15 Jan 2017 09:51:29 +0000 https://forums.modx.com/thread/101612/i-like-evo-1-2#dis-post-548085
<![CDATA[A possible CSRF attempt was detected. No referer was provided by the server.]]> https://forums.modx.com/thread/33257/a-possible-csrf-attempt-was-detected-no-referer-was-provided-by-the-server#dis-post-547503
Getting this message when trying to login to my site manager in Firefox on Mac. Just updated to 1.0.1 today. Seems to be fine at the moment in Safari.

Anyone else experiencing this? What does it mean?]]>
https://forums.modx.com/thread/33257/a-possible-csrf-attempt-was-detected-no-referer-was-provided-by-the-server#dis-post-547503 Tue, 20 Dec 2016 02:26:40 +0000 https://forums.modx.com/thread/33257/a-possible-csrf-attempt-was-detected-no-referer-was-provided-by-the-server#dis-post-547503
<![CDATA[Links on Modx-powered website not working]]> https://forums.modx.com/thread/101352/links-on-modx-powered-website-not-working#dis-post-546856
My client's website was (apparently) hacked and a bunch of files renamed to .php.suspected and the links on the website are not working — the front page keeps reloading.

So I renamed all .suspected files back to original, but the links still don't work.

The website is — http://www.goingwild.org/index.html. When you click on links, no new pages open. Instead, the main page is reloaded.

I know this is a very outdated website, but I am moving to WordPress. I just need to see the content in the pages.

Thank you!]]>
https://forums.modx.com/thread/101352/links-on-modx-powered-website-not-working#dis-post-546856 Wed, 30 Nov 2016 06:31:14 +0000 https://forums.modx.com/thread/101352/links-on-modx-powered-website-not-working#dis-post-546856
<![CDATA[Error on line 145]]> https://forums.modx.com/thread/101239/error-on-line-145#dis-post-546367 I just found that I had my index file changed on my website. Any idea on how this could have happened? I am using MODx Build 1.02.]]> https://forums.modx.com/thread/101239/error-on-line-145#dis-post-546367 Mon, 14 Nov 2016 09:09:29 +0000 https://forums.modx.com/thread/101239/error-on-line-145#dis-post-546367 <![CDATA[@INCLUDE Broken for Custom input TVs?]]> https://forums.modx.com/thread/72690/include-broken-for-custom-input-tvs#dis-post-545254
I can't get any of the @bindings to process when creating a tv in evo 1.05. What is the simplest way to debug if they are working / processing or not? I have tried:
@EVAL return "boo"; 
both in the input options with no luck and also in the default value box. I created a text type TV, with
@EVAL return "boo"; 
in default value and when I go to edit the resource that has this tv tied to its template the output is[
@EVAL return "boo"; 
not "boo" as I would expect.

PLease give advice and council because I really want to set up a drag and drop sortable sidebar manager to release to the community and this is totally bumming out my week...

-Noah]]>
https://forums.modx.com/thread/72690/include-broken-for-custom-input-tvs#dis-post-545254 Fri, 23 Sep 2016 09:17:48 +0000 https://forums.modx.com/thread/72690/include-broken-for-custom-input-tvs#dis-post-545254
<![CDATA[WF + link_attributes ( [+wf.attributes+] ) in 1.05 ??]]> https://forums.modx.com/thread/32732/wf-link-attributes-wf-attributes-in-1-05#dis-post-543808
Is the doc link_attributes still working in Evo and remaining compatible with Wayfinder ?

Because doing an attept to add some accesskey into WF menu does not give anything.
<li class="[+wf.classnames+]"><a href="[+wf.link+]" [+wf.attributes+]  title="vers page [+wf.title+]">[+wf.linktext+]</a>[+wf.wrapper+]</li>

I setup some link_attributes for a few pages in their specific field (not a custom TV)

So I added a test output
<li class="[+wf.classnames+]"><a href="[+wf.link+]" [+wf.attributes+]  title="vers page [+wf.title+]">[+wf.linktext+]</a>[+wf.wrapper+] <span>[+link_attributes+]</span></li>


and the [+link_attributes+] is not here (nothing!)



any clues?

]]>
https://forums.modx.com/thread/32732/wf-link-attributes-wf-attributes-in-1-05#dis-post-543808 Wed, 03 Aug 2016 09:17:29 +0000 https://forums.modx.com/thread/32732/wf-link-attributes-wf-attributes-in-1-05#dis-post-543808
<![CDATA[Fatal error: Allowed memory size...]]> https://forums.modx.com/thread/33143/fatal-error-allowed-memory-size?page=3#dis-post-537268
I get this error:

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 49651 bytes) in /hsphere/local/home/lundsholm2/3manager.com/manager/processors/cache_sync.class.processor.php on line 44 


on all Saves (saving a resource, saving configuration, etc.). phpinfo() says my memory_limit is 128MB which should be plenty. I’m running the latest version from the SVN after getting the same error on the "official" 1.0.2.

Any help is greatly appreciated.

Regards
Jonas]]>
https://forums.modx.com/thread/33143/fatal-error-allowed-memory-size?page=3#dis-post-537268 Wed, 20 Jan 2016 05:57:20 +0000 https://forums.modx.com/thread/33143/fatal-error-allowed-memory-size?page=3#dis-post-537268
<![CDATA[Best Upgrade Path and Method?]]> https://forums.modx.com/thread/98119/best-upgrade-path-and-method#dis-post-530556
I have a client with a really old MODx Evo install. She was hacked. Apparently the Chinese are harassing her with their own sales catalog on her domain? Wierd. I am trying to figure out the best upgrade path.

Current Version: 1.0.4

I want to move her from the Evolution package to the Revolution release, but the Chinese have already gotten in and I just need to close that door.

From the posts, I gather that I should upgrade to 1.0.5 first, then to 1.0.14, and then to 1.0.15? Is that correct? Or maybe to play it safe I have to go one upgrade step at a time (v 1.0.4 to 1.0.5 to 1.0.6 to 1.0.7 to 1.0.8 to 1.0.9 to 1.0.10 to 1.0.12 to 1.0.13 to 1.0.14 to 1.0.15)?

Then, I will at least have the security issues resolved and can upgrade to Revolution after I update my Chunk codes with the right calls (@ to @@), I think?

Or is there a more in depth article, post I should refer to?


Thanks! -Doug]]>
https://forums.modx.com/thread/98119/best-upgrade-path-and-method#dis-post-530556 Wed, 26 Aug 2015 03:49:16 +0000 https://forums.modx.com/thread/98119/best-upgrade-path-and-method#dis-post-530556
<![CDATA[Editing Pages Not Showing]]> https://forums.modx.com/thread/97875/editing-pages-not-showing?page=2#dis-post-529511 https://forums.modx.com/thread/97875/editing-pages-not-showing?page=2#dis-post-529511 Wed, 05 Aug 2015 09:46:46 +0000 https://forums.modx.com/thread/97875/editing-pages-not-showing?page=2#dis-post-529511 <![CDATA[MODx Not Sending User's Passwords via Email]]> https://forums.modx.com/thread/33182/modx-not-sending-user-s-passwords-via-email#dis-post-524976
MODx (1.0.2) is not sending user’s password updates or new user’s passwords via email. Anyone else experience this issue or know how to fix it?

Thanks,
Jess]]>
https://forums.modx.com/thread/33182/modx-not-sending-user-s-passwords-via-email#dis-post-524976 Tue, 28 Apr 2015 02:24:23 +0000 https://forums.modx.com/thread/33182/modx-not-sending-user-s-passwords-via-email#dis-post-524976
<![CDATA[Modx Evolution 0.9.5 - Document content is blank though the page comes up in the preview section]]> https://forums.modx.com/thread/96585/modx-evolution-0-9-5---document-content-is-blank-though-the-page-comes-up-in-the-preview-section#dis-post-522908 https://forums.modx.com/thread/96585/modx-evolution-0-9-5---document-content-is-blank-though-the-page-comes-up-in-the-preview-section#dis-post-522908 Wed, 18 Mar 2015 08:28:19 +0000 https://forums.modx.com/thread/96585/modx-evolution-0-9-5---document-content-is-blank-though-the-page-comes-up-in-the-preview-section#dis-post-522908 <![CDATA[Manager blank page error in Evo 1.x - SOLUTION]]> https://forums.modx.com/thread/33088/manager-blank-page-error-in-evo-1-x---solution#dis-post-516549 I turned the error reporting in manager/index.php , and this is what it came up:


Warning: main() [function.main]: open_basedir restriction in effect. File(/quotes_stripper.inc.php) is not within the allowed path(s): (/var/www/vhosts/mydomain.com/httpdocs:/tmp) in /var/www/vhosts/mydomain.com/httpdocs/mdx12/manager/index.php on line 95

... and so on , many more warnings

I have not made any changes to the include_path on that server, and there is a modx 9.6. running just fine on the same domain.

PHP is Version 5.0.4, so it obviously uses ’set_include_path(get_include_path() . PATH_SEPARATOR . $incPath);

What could be causing such errors?]]>
https://forums.modx.com/thread/33088/manager-blank-page-error-in-evo-1-x---solution#dis-post-516549 Wed, 10 Dec 2014 02:00:18 +0000 https://forums.modx.com/thread/33088/manager-blank-page-error-in-evo-1-x---solution#dis-post-516549
<![CDATA[Problem with eForm]]> https://forums.modx.com/thread/95349/problem-with-eform#dis-post-516233
I have a web in which eForm is used as plugin. In web there are three form on same page. when user submit a form it validates and then submitted data and and after reloading other form display. Now i want that only two form should show form_2 and form_3 is beging merged. So form_2 and form_3 will save on second submit button, now issue is , after submission of form_2 , form_3 should not display and it redirect to thank you page.

My eForm call is given below:

[!plaintheme-signup-func!] [!eForm? &formid=`signup_form` &subject=`Cab Accounts Sign Up` &to=`[+recipient_email+]` &ccsender=`0` &tpl=`plaintheme-signup-form-1` &report=`plaintheme-signup-report` &vericode=`0` &eFormOnBeforeFormParse=`select_current_form` &eFormOnValidate=`select_next_form` &thankyou=`ThankYouNormal` !]

thnx]]>
https://forums.modx.com/thread/95349/problem-with-eform#dis-post-516233 Fri, 05 Dec 2014 05:39:19 +0000 https://forums.modx.com/thread/95349/problem-with-eform#dis-post-516233