Evo Discussions & Support - MODX Community Forums https://forums.modx.com/board/?board=48 <![CDATA[multiTV Pagination]]> https://forums.modx.com/thread/104900/multitv-pagination#dis-post-564067 For example, if I have a multiTV with 20 items, to paginate after 5 or 10.]]> https://forums.modx.com/thread/104900/multitv-pagination#dis-post-564067 Wed, 13 Feb 2019 11:09:13 +0000 https://forums.modx.com/thread/104900/multitv-pagination#dis-post-564067 <![CDATA[Flash all manager sessions in evo]]> https://forums.modx.com/thread/104893/flash-all-manager-sessions-in-evo#dis-post-564066 https://forums.modx.com/thread/104893/flash-all-manager-sessions-in-evo#dis-post-564066 Wed, 13 Feb 2019 11:05:29 +0000 https://forums.modx.com/thread/104893/flash-all-manager-sessions-in-evo#dis-post-564066 <![CDATA[Can see the document tree, but right side is blank when trying to edit.]]> https://forums.modx.com/thread/104627/can-see-the-document-tree-but-right-side-is-blank-when-trying-to-edit#dis-post-564064
Most of the Manager loads fine except for trying to edit pages. When clicking on a page in the document tree the right column where the editor would be is just a blank white page. No updates have been made to the site in quite a while. If I right click and try to view source it says "This software requires a browser with support for frames." However, the rest of the pages/frames load fine, chunks, templates, options, etc.

Viewing console I see:
Source map error: request failed with status 404 Resource URL: http://www.canfieldjoseph.com/assets/plugins/managermanager/js/jquery-1.9.1.min.js Source Map URL: jquery.min.map

Do you think Manager Manager needs to be updated?

Thanks,
Steve]]>
https://forums.modx.com/thread/104627/can-see-the-document-tree-but-right-side-is-blank-when-trying-to-edit#dis-post-564064 Wed, 13 Feb 2019 11:02:06 +0000 https://forums.modx.com/thread/104627/can-see-the-document-tree-but-right-side-is-blank-when-trying-to-edit#dis-post-564064
<![CDATA[Evo 1.2: introtext mce plugin not working any more]]> https://forums.modx.com/thread/101450/evo-1-2-introtext-mce-plugin-not-working-any-more?page=2#dis-post-564037
FYI, the code is as follows:

global $replace_richtexteditor;
$replace_richtexteditor[] = "introtext";

Thanks for any solutions]]>
https://forums.modx.com/thread/101450/evo-1-2-introtext-mce-plugin-not-working-any-more?page=2#dis-post-564037 Mon, 11 Feb 2019 12:24:27 +0000 https://forums.modx.com/thread/101450/evo-1-2-introtext-mce-plugin-not-working-any-more?page=2#dis-post-564037
<![CDATA[Evolution CMS on the way to a Russian system only?]]> https://forums.modx.com/thread/104836/evolution-cms-on-the-way-to-a-russian-system-only?page=2#dis-post-563950 For a long time and over many versions, Modx Evo was my favorite CMS. Now ModxEvo has been converted to Evolution CMS. The last versions up to the current 1.4.8 are running as expected and good.

Unfortunately, the information and presentation of Evolution CMS has changed a lot.
The site evo.im is not up to date! A documentation is no longer online!
The system is now maintained by Russian developers, almost all information can only be found in Russian! See: docs.evo.im

Even at "github.com/evolution-cms/evolution/issues" many topics are only answered in Russian - the English-speaking international users can no longer work with the system as before.

For me Evolutuion CMS is unfortunately on a bad way and I think Modx Revo remains as the best solution to continue to work with this wonderfully flexible system.

Unfortunately, there is no information from the development team whether the system will be completely international again...]]>
https://forums.modx.com/thread/104836/evolution-cms-on-the-way-to-a-russian-system-only?page=2#dis-post-563950 Mon, 04 Feb 2019 04:26:37 +0000 https://forums.modx.com/thread/104836/evolution-cms-on-the-way-to-a-russian-system-only?page=2#dis-post-563950
<![CDATA[Upgrading Evolution help]]> https://forums.modx.com/thread/104854/upgrading-evolution-help#dis-post-563810
I have an old clients site built in Evolution about 9 years ago. Last year (march) it was updated. I need to update it again but struggling to find a freelance programmer that knows about MODX Evoloution to upgrade it!

Does anyone know someone (in the UK) I can call to discuss updating it?

Thank you.

]]>
https://forums.modx.com/thread/104854/upgrading-evolution-help#dis-post-563810 Tue, 29 Jan 2019 09:59:08 +0000 https://forums.modx.com/thread/104854/upgrading-evolution-help#dis-post-563810
<![CDATA[My old Modx websites have been hacked and deemed unrecoverable by my hosting company]]> https://forums.modx.com/thread/104800/my-old-modx-websites-have-been-hacked-and-deemed-unrecoverable-by-my-hosting-company#dis-post-563807
I use to be a web designer 7 years ago. So I created MODX websites using the first CMS system - Is that Evolution? - I get confused which one came first?

I have been a full time Mum since then so not updated my MODX versions (I know!!) I now wish I had.

So now I have lost 2 websites through being hacked this weekend. They were built about 8/9 years ago. My hosting company say their backup files are corrupted! And say I need to re-build from scratch! I haven't done this for 7 years so that's not going to happen.

My question is: Years ago using Dreamweaver FTP I downloaded all my files (wwwroot folder) for both websites and I also went into MODX /manager online and clicked backup button to back up all my tables?? So if I have both the files via FTP and the old backup Modx files (from years ago so hopefully not hacked) can my websites be recovered?

Thanks in advance! I really hope so.]]>
https://forums.modx.com/thread/104800/my-old-modx-websites-have-been-hacked-and-deemed-unrecoverable-by-my-hosting-company#dis-post-563807 Tue, 29 Jan 2019 09:33:13 +0000 https://forums.modx.com/thread/104800/my-old-modx-websites-have-been-hacked-and-deemed-unrecoverable-by-my-hosting-company#dis-post-563807
<![CDATA[Doclister private filter]]> https://forums.modx.com/thread/104742/doclister-private-filter#dis-post-563322
I'm moving from Ditto to DocLister and I can't find the right syntax to the DocLister snippet private filter.
I'd like to list only the documents in the ressource group that a logged in user has access to.

For example :
user eric is in users group group1
group1 has access to ressource group res1

doc1 is in res1
doc2 is in res1
doc3 is in res2

I want to list only doc1 and doc2 for user eric and NOT doc3

With Ditto, it seems that this was a kind default output.
With DocLister, it seems that the &filters parameter needs to be used like &filters=`private:???:???:???` but I can't find documentation on private filter ...

Can someone help me ?

Thank you in advance

Eric]]>
https://forums.modx.com/thread/104742/doclister-private-filter#dis-post-563322 Wed, 19 Dec 2018 04:15:19 +0000 https://forums.modx.com/thread/104742/doclister-private-filter#dis-post-563322
<![CDATA[how to upgrade from 1.2.1 to current 1.4.6]]> https://forums.modx.com/thread/104607/how-to-upgrade-from-1-2-1-to-current-1-4-6#dis-post-562918
I think if we want to stay with modX Evo we should move on to Evolution CMS.
What is the "best practice" way to upgrade a 1.2.1 installation to 1.4.6?
Regards, Martin Lindenlauf]]>
https://forums.modx.com/thread/104607/how-to-upgrade-from-1-2-1-to-current-1-4-6#dis-post-562918 Sun, 25 Nov 2018 12:29:53 +0000 https://forums.modx.com/thread/104607/how-to-upgrade-from-1-2-1-to-current-1-4-6#dis-post-562918
<![CDATA[Evolution CMS and RESTFUL API]]> https://forums.modx.com/thread/104661/evolution-cms-and-restful-api#dis-post-562910
is there a way to use RESTFUL API with Evolution CMS to link my data with an external webapp ?

I searched in the forum but only found posts about MODX Revolution.

Can someone help me find some usefull documentation ?

Thank you in advance,

Eric]]>
https://forums.modx.com/thread/104661/evolution-cms-and-restful-api#dis-post-562910 Sat, 24 Nov 2018 02:56:17 +0000 https://forums.modx.com/thread/104661/evolution-cms-and-restful-api#dis-post-562910
<![CDATA[Cant login to manager following upgrade to 1.2.1]]> https://forums.modx.com/thread/104621/cant-login-to-manager-following-upgrade-to-1-2-1?page=2#dis-post-562743
<br />
<b>Fatal error</b>:  Call to a member function select() on a non-object in <b>/public_html/manager/includes/settings.inc.php</b> on line <b>8</b><br />


Upgrade was from 1.0.2 to 1.2.1

Is this a PHP version issue?

I am running 5.6, when i run 7.0 the error doesnt appear - but login doesnt work - just sits on manager page... huh

]]>
https://forums.modx.com/thread/104621/cant-login-to-manager-following-upgrade-to-1-2-1?page=2#dis-post-562743 Thu, 15 Nov 2018 10:19:55 +0000 https://forums.modx.com/thread/104621/cant-login-to-manager-following-upgrade-to-1-2-1?page=2#dis-post-562743
<![CDATA[Testing Area Within ModX Evo]]> https://forums.modx.com/thread/104624/testing-area-within-modx-evo#dis-post-562707
Cheers,
Jon]]>
https://forums.modx.com/thread/104624/testing-area-within-modx-evo#dis-post-562707 Wed, 14 Nov 2018 02:33:53 +0000 https://forums.modx.com/thread/104624/testing-area-within-modx-evo#dis-post-562707
<![CDATA[Testing Area Within ModX Evo]]> https://forums.modx.com/thread/104623/testing-area-within-modx-evo#dis-post-562706
Cheers,
Jon]]>
https://forums.modx.com/thread/104623/testing-area-within-modx-evo#dis-post-562706 Wed, 14 Nov 2018 02:32:50 +0000 https://forums.modx.com/thread/104623/testing-area-within-modx-evo#dis-post-562706
<![CDATA[Problem with file Manager in elements (menu)]]> https://forums.modx.com/thread/104620/problem-with-file-manager-in-elements-menu#dis-post-562703
This problem wasn't the day before yasturday.
I'nt changed settings.]]>
https://forums.modx.com/thread/104620/problem-with-file-manager-in-elements-menu#dis-post-562703 Wed, 14 Nov 2018 10:54:06 +0000 https://forums.modx.com/thread/104620/problem-with-file-manager-in-elements-menu#dis-post-562703
<![CDATA[ [SOLVED] change to https not working. base url always http in front end. manager always redirects to http]]> https://forums.modx.com/thread/102707/solved-change-to-https-not-working-base-url-always-http-in-front-end-manager-always-redirects-to-http?page=2#dis-post-562650
I am absolutely baffled and wondering if someone knows how to overcome this issue I am having.

I am wanting to change the server type to https for an existing http Evo 1.2.1 site but no matter what I do the base url (href="http://www.the-domain.com.au/") always shows as http in the front end source code - never https.

I have changed the setting to https in Tools > Configuration > Server type.

I have cleared the cache in Evo, and also manually via ftp by deleting the file at assets > cache > siteCache.idx.php. On checking the cache file it shows the https like so: $c['server_protocol']="https" - so that bit seems to have worked.

I have disabled cloudflare by putting the site into development mode.

I have uncommented the non www to www redirects in the htaccess file so basically all remains is the friendly url code.

I even ran the 1.2.1 install in case that had any bearing with caching http but that didn't help.

When I visit the manager login page at https I get the padlock and all looks good. But when I login from that page it redirects to the http non padlock. And when I preview the site from the Evo Manager, the site shows on http.

If I visit a https version of the site, the page is broken (because the base url in the source code shows as http - href="https://www.the-domain.com.au/").

If I visit a test page where I hardcoded the base url to https://www.the-domain.com.au/, it shows with the green padlock and works fine for that one page. Hardcoding is the not the solution for the site though - it also wouldn't have any bearing on the Evo manager which I also want in https.

Could there be something in cPanel that is caching the http or something?

Any ideas?

Thanks for any help.]]>
https://forums.modx.com/thread/102707/solved-change-to-https-not-working-base-url-always-http-in-front-end-manager-always-redirects-to-http?page=2#dis-post-562650 Sat, 10 Nov 2018 10:32:49 +0000 https://forums.modx.com/thread/102707/solved-change-to-https-not-working-base-url-always-http-in-front-end-manager-always-redirects-to-http?page=2#dis-post-562650
<![CDATA[error messaage "Check your internet connection" - but connection works, just annoying popup ...]]> https://forums.modx.com/thread/104031/error-messaage-check-your-internet-connection---but-connection-works-just-annoying-popup#dis-post-562554
I'm getting this annoying popup error messages in the Evo 1.4 backend every time I save changes on pages or in the settings:

Firefox says: "This page is asking you to confirm that you want to leave - data you have entered may not be saved."

Google Chrome shows a similar error message and in addition it shows a second message: "Server isn't available. Check your internet connection!"

The point is: there is no issue with the connection and when I click on "ok" in the error message box, everything is working and being saved.

Has everyone experienced that before? Or has an idea how I can get rid of this annoying error message(s)?

Thanks and kind regards,
Franz]]>
https://forums.modx.com/thread/104031/error-messaage-check-your-internet-connection---but-connection-works-just-annoying-popup#dis-post-562554 Tue, 06 Nov 2018 07:31:11 +0000 https://forums.modx.com/thread/104031/error-messaage-check-your-internet-connection---but-connection-works-just-annoying-popup#dis-post-562554
<![CDATA[does latest MODX Evo 1.2.1 support PHP 7.1/7.2? or should I upgrade to the latest Evolution CMS straight away?]]> https://forums.modx.com/thread/104553/does-latest-modx-evo-1-2-1-support-php-7-1-7-2-or-should-i-upgrade-to-the-latest-evolution-cms-straight-away#dis-post-562494
does latest MODX Evo 1.2.1 support PHP 7.1/7.2? or should I upgrade to the latest Evolution CMS straight away?

thanks a lot, cheers, j]]>
https://forums.modx.com/thread/104553/does-latest-modx-evo-1-2-1-support-php-7-1-7-2-or-should-i-upgrade-to-the-latest-evolution-cms-straight-away#dis-post-562494 Fri, 02 Nov 2018 10:25:16 +0000 https://forums.modx.com/thread/104553/does-latest-modx-evo-1-2-1-support-php-7-1-7-2-or-should-i-upgrade-to-the-latest-evolution-cms-straight-away#dis-post-562494
<![CDATA[Formlister Captcha Help]]> https://forums.modx.com/thread/104582/formlister-captcha-help#dis-post-562491
I have inherited a site on modx, ive managed to update it fully to the latest evolution version without issue but we have been recently inundated with spam.

I have tried to follow the instructions here: http://www.evolution-docs.com/tutorials/extras-how-to/formlister-tutorials/basic-contact-form-with-recaptcha

Without the captcha the form submits perfectly fine. When i enable the captcha i get the error A reCAPTCHA validation error occured from the call.

Can someone please assist in solving this issue?

my code is

  [!FormLister?
&formid=`contactform`
&rules=`
{
    "name":
    {
        "required": "Be sure to enter a name"
    },
    "email":
    {
        "required": "Be sure to enter email",
        "email": "Enter email correctly"
    },
	"message": {
		"required": "Please enter a message"
   
}`
&to=`email@email`
&fromName=`My Company`
&replyTo=`email@email`

&captcha=`reCaptcha`
&captchaParams=`{
    "siteKey":"xxxxxxx",
    "secretKey":"xxxxx",
    "errorCodeFailed":"A reCAPTCHA validation error occured",
    "theme":"light"
}`
&captchaField=`g-recaptcha-response`

&subject=`Contact form submission from [*pagetitle*]`
&reportTpl=`ContactCodeTpl`
&formTpl=`@CODE:
 <div class="half">
                        <h2>Contact Us</h2>
                        <form class="form-horizontal" method="post">
                            <input type="hidden" name="formid" value="contactform">
                            <ul>
                                <li class="[+name.errorClass+] [+name.requiredClass+]">
                                    <span class="lbl">Name:</span>
                                    <input type="text" id="name" placeholder="Name" name="name" value="[+name.value+]" autocomplete="none">
									 <div class="clear"></div>
                                </li>
							
								
                                <li class="[+company.errorClass+] [+company.requiredClass+]">
                                    <span class="lbl">Company:</span>
                                    <input type="text" id="company" name="company" value="[+company.value+]" autocomplete="none">
									 <div class="clear"></div>
                                </li>
                                <li class="[+email.errorClass+] [+email.requiredClass+]">
                                    <span class="lbl">Email:</span>
                                    <input type="text" id="email" placeholder="Email" name="email" value="[+email.value+]" autocomplete="none">
									 <div class="clear"></div>
                                </li>
                            </ul>
                    </div>
                    <div class="half">
                        <ul class="pad-down">
                            <li class="[+message.errorClass+] [+message.requiredClass+]">
                                <span class="lbl full">Message:</span>
                                <textarea id="message" placeholder="Your message" name="message"> </textarea>
                                    [+form.messages+]
								
								
                            </li>
							
							<!-- reCAPTCHA -->
[+captcha+]
							
                            <li>
                               <button type="submit">Send</button>
                            </li>
                        </ul>
                    </div>
            </form>
          `
&messagesTpl=`@CODE:<div class="form-group"><div class="col-sm-offset-2 col-sm-10">[+required+][+errors+][+messages+]</div></div>`
&messagesRequiredOuterTpl=`@CODE:<div class="panel panel-warning"><div class="panel-heading"><i class="glyphicon glyphicon-alert"></i>You did not fill in the required fields</div><div class="panel-body">[+messages+]</div></div>`
&messagesErrorOuterTpl=`@CODE:<div class="panel panel-danger"><div class="panel-heading"><i class="glyphicon glyphicon-alert"></i>Some fields are invalid </div><div class="panel-body">[+messages+]</div></div>`
&messagesOuterTpl=`@CODE:<div class="panel panel-default"><div class="panel-heading"></div><div class="panel-body">[+messages+]</div></div>`
&errorClass=` has-error`
&requiredClass=` has-warning`
&errorTpl=`@CODE:<span class="help-block">[+message+]</span>`
!]
]]>
https://forums.modx.com/thread/104582/formlister-captcha-help#dis-post-562491 Fri, 02 Nov 2018 08:27:36 +0000 https://forums.modx.com/thread/104582/formlister-captcha-help#dis-post-562491
<![CDATA[after update to Evo 1.4.5 Database charset is set to latin1 even though Database is set to UTF8]]> https://forums.modx.com/thread/104552/after-update-to-evo-1-4-5-database-charset-is-set-to-latin1-even-though-database-is-set-to-utf8#dis-post-562458
after the host updated the PHP version to 7.1/7.2 I was forced to update to Evolution 1.4.5, now I see, that under Info the DB Charset & Collation is set to latin1/latin1_german2_ci:


even though MySQL is set to UTF8:


and it only affects the first 3 rows of the database:


the site is working and as far as I can see it doesn't affect it, but I'd like to know how that could happen and how I can get it all back to UTF8 - anyone got an idea?

thanks a lot, cheers, j]]>
https://forums.modx.com/thread/104552/after-update-to-evo-1-4-5-database-charset-is-set-to-latin1-even-though-database-is-set-to-utf8#dis-post-562458 Thu, 01 Nov 2018 06:32:51 +0000 https://forums.modx.com/thread/104552/after-update-to-evo-1-4-5-database-charset-is-set-to-latin1-even-though-database-is-set-to-utf8#dis-post-562458
<![CDATA[Error on include]]> https://forums.modx.com/thread/104567/error-on-include#dis-post-562436

Warning: include_once(/homepages/16/d313340650/htdocs/medReach/manager/includes/extenders/maketable.class.php): failed to open stream: Permission denied in /homepages/16/d313340650/htdocs/medReach/manager/includes/extenders/ex_maketable.inc.php on line 8

Warning: include_once(): Failed opening '/homepages/16/d313340650/htdocs/medReach/manager/includes/extenders/maketable.class.php' for inclusion (include_path='.:/usr/lib/php5.6:/homepages/16/d313340650/htdocs/medReach/manager/includes/') in /homepages/16/d313340650/htdocs/medReach/manager/includes/extenders/ex_maketable.inc.php on line 8

Fatal error: Call to a member function handlePaging() on null in /homepages/16/d313340650/htdocs/medReach/manager/actions/document_data.static.php on line 80]]>
https://forums.modx.com/thread/104567/error-on-include#dis-post-562436 Wed, 31 Oct 2018 04:04:37 +0000 https://forums.modx.com/thread/104567/error-on-include#dis-post-562436