Revolution 2.0 - MODX Community Forums https://forums.modx.com/board/?board=42 <![CDATA[Links referring to anchors on the same page - How to?]]> https://forums.modx.com/thread/30297/links-referring-to-anchors-on-the-same-page---how-to#dis-post-563307
In our MODx-Revolution it works only by adding <a href="[[~page-id]]]#anchor">Anchor</a>

Our goal is to import a webpage including about 1.000 anchors with the syntax <a href="#anchor">. Because of this it would be great if we could keep this syntax.

Does anybody know how to make this work?

Gerdi smiley]]>
https://forums.modx.com/thread/30297/links-referring-to-anchors-on-the-same-page---how-to#dis-post-563307 Tue, 18 Dec 2018 07:35:05 +0000 https://forums.modx.com/thread/30297/links-referring-to-anchors-on-the-same-page---how-to#dis-post-563307
<![CDATA[mod_php vs fast-cgi]]> https://forums.modx.com/thread/104626/mod-php-vs-fast-cgi#dis-post-562731
my website is currently running in a shared hosting environment with php 7.0 (mod_php) without any problems. I can freely choose between mod_php 7 and various fast cgi/fpm variants. I asked my hoster but did not get some practical information about it, and even google does not help a lot here.

And thats why i'm here to ask: which is better in therms of performance and security? I compared them with help of my website and it seems the fast cgi implementation is slightly faster, but that can also be some sort of measuring inaccuracy. Are there any downsides with it?

Regards]]>
https://forums.modx.com/thread/104626/mod-php-vs-fast-cgi#dis-post-562731 Wed, 14 Nov 2018 07:36:33 +0000 https://forums.modx.com/thread/104626/mod-php-vs-fast-cgi#dis-post-562731
<![CDATA[Having problems with package installations]]> https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-562260
I’m having some issues with installing and updating any packages.
I’m using 2.0.8-pl on Linux server. I have other Revo sites running on this server without any problems. The only difference in this instance is the site is using a temporary url which is an ip.
I have checked in MySQL the path in the workspace_ table and it seems to be ok and the ’core’ directory is writable.
When i try to update a package i get the ’saving’ window and then ’package_download_err’ window.
When i try to install a package (in this instance Wayfinder)i get blank screen all the way to the final window which displays:

Could not install package with signature: wayfinder-2.3.0-rc2
Target directory is either not a directory or writable: home/myWebsites/public_html/core/packages/

Attempting to install package with signature: wayfinder-2.3.0-rc2
Could not transfer package wayfinder-2.3.0-rc2.transport.zip to home/myWebsite/public_html/core/packages/.
Package found...now preparing to install.


When i try to download a package, in this instance the simpleSearch i get:
Could not download package at: http://modx.com/extras/download/?id=4ddfa008f245545fbc000044

Could anyone suggest what might be the problem?

Thanks for any help

J]]>
https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-562260 Mon, 22 Oct 2018 12:31:04 +0000 https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-562260
<![CDATA[Firing action when new Resource is published]]> https://forums.modx.com/thread/104404/firing-action-when-new-resource-is-published#dis-post-561586 I am trying to do a POST call to my webhook when a new Resource is published.

I made my own plugin that does all the logic, I fire the plugin OnDocFormSave and OnDocPublished. Everythink works fine, but the plugin is not fired when a Publish date is set.

I read this topic:
https://forums.modx.com/thread/?thread=44201&i=1

But still I cannot make it work. The topic is also over 7 years old. Is there a new way to fire an event every time a new Resource is published (through administration or with the Publish date set)?]]>
https://forums.modx.com/thread/104404/firing-action-when-new-resource-is-published#dis-post-561586 Tue, 18 Sep 2018 04:19:07 +0000 https://forums.modx.com/thread/104404/firing-action-when-new-resource-is-published#dis-post-561586
<![CDATA[Package Manager - Warning! xxxx/ directory was not able to be created...]]> https://forums.modx.com/thread/98971/package-manager---warning-xxxx-directory-was-not-able-to-be-created#dis-post-560569
I am running into an issue with what appears to be folder permissions, which are preventing Package Manager from writing to them in order to do its work.

Warning!

Your assets/ directory was not able to be created at: /var/www/modx/assets/
You will need to create this directory and make it writable if you want to use Package Management or 3rd-Party Components.
,
Your assets/components/ directory was not able to be created at: /var/www/modx/assets/components/
You will need to create this directory and make it writable if you want to use Package Management or 3rd-Party Components.
,
Your core/components/ directory was not able to be created at: /var/www/modx/core/components/
You will need to create this directory and make it writable if you want to use Package Management or 3rd-Party Components.

I've checked this http://forums.modx.com/thread/29417/cannot-install-packages-through-the-package-manager but the advice didn't pan out for my situation.

All of the respective folders mentioned in the warning above have the following access -->
drwxrwxr-x 3 root root 4096 Dec  1 19:17 /var/www/modx/assets/ 


I've restarted my Apache server already and tried to clear the cache.

Anyone have any further trouble-shooting experience to share? Thank you.]]>
https://forums.modx.com/thread/98971/package-manager---warning-xxxx-directory-was-not-able-to-be-created#dis-post-560569 Thu, 09 Aug 2018 02:18:24 +0000 https://forums.modx.com/thread/98971/package-manager---warning-xxxx-directory-was-not-able-to-be-created#dis-post-560569
<![CDATA[UpgradeModx from version 'MODx Revolution 2.0.0-pl']]> https://forums.modx.com/thread/104148/upgrademodx-from-version-modx-revolution-2-0-0-pl#dis-post-560242
I've installed the UpgradeModx package but after installation the widget shows No 'UPDATES AVAILABLE' (attached as 'upgrademodx no updates.png')

My versions is 'MODx Revolution 2.0.0-pl'

Is there another upgrade process I can use? Captured the packages I have installed in case that alters the suggested approach ('installed packages.png')

Thanks in advance

Jon]]>
https://forums.modx.com/thread/104148/upgrademodx-from-version-modx-revolution-2-0-0-pl#dis-post-560242 Tue, 31 Jul 2018 03:11:27 +0000 https://forums.modx.com/thread/104148/upgrademodx-from-version-modx-revolution-2-0-0-pl#dis-post-560242
<![CDATA[Looking for 2.0.3pl]]> https://forums.modx.com/thread/104076/looking-for-2-0-3pl#dis-post-559774 Of course I'll be upgrading it asap after that ;-)

On the website it only goes back to 2.1 https://modx.com/download/other-downloads]]>
https://forums.modx.com/thread/104076/looking-for-2-0-3pl#dis-post-559774 Sat, 21 Jul 2018 03:09:52 +0000 https://forums.modx.com/thread/104076/looking-for-2-0-3pl#dis-post-559774
<![CDATA[Installation: failed to find install file Modx Revo 2.6.4]]> https://forums.modx.com/thread/103994/installation-failed-to-find-install-file-modx-revo-2-6-4?page=2#dis-post-559358 https://my-domain.com/www/modx Note that I bought a certificate, thus using https. Also my hosting co uses "www" in the dir structure instead of public_html or similar.

Under here I have the directories
connectors
core
manager
setup

& the files
---------------
config.core.php
ht.access
index.php
all with 755 permissions

I set my website to redirect www.my-domain.com => my-domain.com and I disabled the use of .htaccess files. I plan to do an advanced installation or at least one where I rename the core and manager and connectors directories. I made director listings viewable in my website control panel.

However going to the path for core simply shows a 404 error instead of loading some sort of setup routine to install.
Also I previously had Modx 2.5.7 working [poorly] on my site but I completely erased it. Hence I should meet the system requirements.]]>
https://forums.modx.com/thread/103994/installation-failed-to-find-install-file-modx-revo-2-6-4?page=2#dis-post-559358 Thu, 05 Jul 2018 05:16:46 +0000 https://forums.modx.com/thread/103994/installation-failed-to-find-install-file-modx-revo-2-6-4?page=2#dis-post-559358
<![CDATA[Switching Manager Language]]> https://forums.modx.com/thread/30614/switching-manager-language#dis-post-558636 and then switch it to another language? just the Manager?]]> https://forums.modx.com/thread/30614/switching-manager-language#dis-post-558636 Fri, 18 May 2018 03:00:50 +0000 https://forums.modx.com/thread/30614/switching-manager-language#dis-post-558636 <![CDATA[Upgrade from 2.0.8 to the latest version available]]> https://forums.modx.com/thread/103736/upgrade-from-2-0-8-to-the-latest-version-available#dis-post-558249 Since a lot of changes are made in 2.1 and 2.2, I presume it'll be the best to upgrade first to 2.1, then to 2.2 and after that, it should be safe for further upgrades, so I was doing a lot of upgrades from 2.2/2.3 to 2.5/2.6 without any issues.

I'm using UpgradeMODX extra and it was working great for the upgrades I had before (from 2.2/2.3 to 2.5/2.6), but since I'm doing 2.0.8 for the first time I want to know is it possible to use just this extra or it should be done manually?

]]>
https://forums.modx.com/thread/103736/upgrade-from-2-0-8-to-the-latest-version-available#dis-post-558249 Thu, 26 Apr 2018 07:40:06 +0000 https://forums.modx.com/thread/103736/upgrade-from-2-0-8-to-the-latest-version-available#dis-post-558249
<![CDATA[Installation problem: FATAL ERROR: ... You\'re using PHP version '.MODX_SETUP_PHP_VERSION.',]]> https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-re-using-php-version-modx-setup-php-version#dis-post-556336
FATAL ERROR: ... You\'re using PHP version '.MODX_SETUP_PHP_VERSION.',

when running c:/xampp/htdocs/modx-2.6.1-pl/setup/index.html. Seemingly the same was asked 4 years ago at

https://forums.modx.com/thread/82455/trouble-installing-modx-rev

but received no response. There, the full lengthy error message is quoted. It is the same as mine.

The error message itself seems corrupted as it recites a variable name rather than a variable value (a valid php version). Besides, the alleged error seems not to exist as I have php 7.2.0. XAMPP and MODX are new downloads on a new laptop. Running phpinfo() says php-version is 7.2.0, json support enabled. localhost/phpmyadmin says "Apache/2.4.29 (Win32) OpenSSL/1.1.0g PHP/7.2.0". Follwing the indications at

https://forums.modx.com/thread/?thread=99417

I set date.timezone=Europe/Berlin and restarted localhost. Same error.

Any idea what this is and what to do?

Thank you for your attention.

Best regards

Axel]]>
https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-re-using-php-version-modx-setup-php-version#dis-post-556336 Sat, 13 Jan 2018 11:06:28 +0000 https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-re-using-php-version-modx-setup-php-version#dis-post-556336
<![CDATA[Endless save/save loop - Need a solution defined]]> https://forums.modx.com/thread/77109/endless-save-save-loop---need-a-solution-defined?page=3#dis-post-555392
OK, so I'm trying to make sure all the keywords are in this thread because the search here is underwhelming at best.

This issue peeks up now and again, but it is NEVER resolved. I've searched and searched, and watched for solutions that work but it's always left unsolved in every thread. There are speculative discussions of compress_js/cs, tinyMCE, a key phrase in the content, container only, resources only, etc. but not any clear reason why it happens or what could fix it.

I think it's time to figure it out and put some real solutions in one thread so people can find it.

It seems to occur only in Chrome for me, and it's happening in Chrome for Dad too. Firefox does not have an issue on my end and apparently Dad isn't interested in Firefox enough to try it. (he's one of those IE lovers... it was hard enough to get him to install Chrome for MODX. big sigh...)

My Chrome is a fresh install with no add ons or plugins installed at all and I think Dad's Chrome is untouched by plugins as well. At least it's just dad's site, he forgives me at will so it's not the end of the world and he's not going to shop me because his site won't refresh after saving. But another client would complain much more, for sure.

It's occurred for me at some point in every installation from 2.0 up. I was using Chrome exclusively for MODX, but then I lost the ability to browse files when inserting images and I went back to Firefox. The new Chrome install (new win7 machine) does not seem to have this issue, but does have the save loop issue.

Refreshing the page works, the resource is saved. I've tried it on containers, non-containers, articles container, articles pages, and various elements. Elements (tv's, chunks, etc.) save fine.

Let's talk about this and find a real solution please?
]]>
https://forums.modx.com/thread/77109/endless-save-save-loop---need-a-solution-defined?page=3#dis-post-555392 Tue, 21 Nov 2017 09:51:20 +0000 https://forums.modx.com/thread/77109/endless-save-save-loop---need-a-solution-defined?page=3#dis-post-555392
<![CDATA[how to find if resource has children?]]> https://forums.modx.com/thread/29913/how-to-find-if-resource-has-children?page=2#dis-post-555003
I wondered if there is a way to simply check whether resource has children or not.

Regards,

Mike]]>
https://forums.modx.com/thread/29913/how-to-find-if-resource-has-children?page=2#dis-post-555003 Tue, 07 Nov 2017 11:26:28 +0000 https://forums.modx.com/thread/29913/how-to-find-if-resource-has-children?page=2#dis-post-555003
<![CDATA[Date TV - remove hour:minutes dropdown]]> https://forums.modx.com/thread/30815/date-tv---remove-hour-minutes-dropdown?page=2#dis-post-554724
Is it possible to remove the hour:minutes of the date from the a date TV?

See attached image. I want to remove the 7:44 box.

Thanks]]>
https://forums.modx.com/thread/30815/date-tv---remove-hour-minutes-dropdown?page=2#dis-post-554724 Mon, 23 Oct 2017 01:33:08 +0000 https://forums.modx.com/thread/30815/date-tv---remove-hour-minutes-dropdown?page=2#dis-post-554724
<![CDATA[Fatal error: Class 'Smarty_Internal_Compile_foreach' not found in Modx Install process]]> https://forums.modx.com/thread/102995/fatal-error-class-smarty-internal-compile-foreach-not-found-in-modx-install-process#dis-post-554563 Fatal error: Class 'Smarty_Internal_Compile_foreach' not found in /kunden/175516_65428/webseiten/dev/modx-2.5.8-pl/core/model/smarty/sysplugins/smarty_internal_templatecompilerbase.php on line 750

I get this each time I type in the Admin fields (Admin username, email, password) in the pre-install process. After that I get this error line and nothing happens.
Everything before worked. Connection to the db worked....

Didn't find anything in the net about this error line. I am trying to install modx 2.5.8 in a sub directory on my site to do a new design.

I hope that someone has a clue about this annoying error in the install process.]]>
https://forums.modx.com/thread/102995/fatal-error-class-smarty-internal-compile-foreach-not-found-in-modx-install-process#dis-post-554563 Mon, 16 Oct 2017 10:59:59 +0000 https://forums.modx.com/thread/102995/fatal-error-class-smarty-internal-compile-foreach-not-found-in-modx-install-process#dis-post-554563
<![CDATA[Revo 2.2.13 no longer connected to the database?]]> https://forums.modx.com/thread/102988/revo-2-2-13-no-longer-connected-to-the-database#dis-post-554519
Any ideas???]]>
https://forums.modx.com/thread/102988/revo-2-2-13-no-longer-connected-to-the-database#dis-post-554519 Sat, 14 Oct 2017 04:04:08 +0000 https://forums.modx.com/thread/102988/revo-2-2-13-no-longer-connected-to-the-database#dis-post-554519
<![CDATA[Dropped connection after log in]]> https://forums.modx.com/thread/102945/dropped-connection-after-log-in#dis-post-554455
Alas, I cannot consistently access Manager after submitting password, sometimes don't even get the log on screen.

This time, right after a supposedly successful install, I log in and Safari throws a "Failed to open page" error. The explanation given states that "the server unexpectedly dropped its connection. This sometimes occurs when the server is busy…" On other attempts to install ModX I've started out with a successful Manager log-on, got some work done, then found myself unable to log back on later. One time I got the "connection dropped" screen, but found myself in the Manager when I navigated back a page, but this was fluke behavior.

Troubleshooting efforts: Double checked PHP values and settings to assure compatibility with ModX's expressed requirements. Replaced MySQL with MariaDB. Upgraded my system to overwrite Apache config files and then rewrote the pertinent conf and virtual host files. Get the same result even after assigning all files and folders 777 privileges.

Tested out the index.php file in the Manager folder. Goes kablooey on the if clause at lines 57 through 59. Did a var_dump on the modx object and the settings it lists looks right.

Expected Outcome: Expected to see the Manager page.


  • MODX Version: 2.5.8
  • PHP Version: 7.1.0
  • Database (MySQL, SQL Server, etc) Version: MariaDB 10.2.8
  • Addit ional Server Info: Apache 2.4.27
  • Installed MODX Add-ons: None.
  • Error Log Contents:
  • Thu Oct 05 20:25:31.413700 2017] [autoindex:error] [pid 239] [client 127.0.0.1:49289] AH01276: Cannot serve directory /Library/WebServer/Documents/mysite.local/: No matching DirectoryIndex (index.html,index.html,index.php,index.html,index.php) found, and server-generated directory index forbidden by Options directive (attach as file if it’s too large)

Hmmm-mm. This sounds like I might need to edit htppd.conf again. Suggestions?

]]>
https://forums.modx.com/thread/102945/dropped-connection-after-log-in#dis-post-554455 Wed, 11 Oct 2017 11:11:32 +0000 https://forums.modx.com/thread/102945/dropped-connection-after-log-in#dis-post-554455
<![CDATA[$modx->user not available in other contexts?]]> https://forums.modx.com/thread/30509/modx--user-not-available-in-other-contexts?page=2#dis-post-554020
$authenticated = $modx->user->isAuthenticated($loginContext);


gettype($modx->user) is returning NULL.

Is there something I forgot to do in my context setup that is preventing it from being able to access $modx->user?

]]>
https://forums.modx.com/thread/30509/modx--user-not-available-in-other-contexts?page=2#dis-post-554020 Wed, 20 Sep 2017 08:55:29 +0000 https://forums.modx.com/thread/30509/modx--user-not-available-in-other-contexts?page=2#dis-post-554020
<![CDATA[Preview error: 404 on unpublished documents in new context]]> https://forums.modx.com/thread/31252/preview-error-404-on-unpublished-documents-in-new-context#dis-post-553042
When I log in at http://www.exampledomain.com/manager

and preview an unpublished document in context "secondcontext" at http://www.seconddomainexample.com

I get a 404, unless I publish the document, at which point preview works fine.

Is this a permissions issue? What have I missed / do I need to fix?

Thank you,

Jim

]]>
https://forums.modx.com/thread/31252/preview-error-404-on-unpublished-documents-in-new-context#dis-post-553042 Mon, 07 Aug 2017 08:12:10 +0000 https://forums.modx.com/thread/31252/preview-error-404-on-unpublished-documents-in-new-context#dis-post-553042
<![CDATA[Plugin Event OnUserSave retrieve context key]]> https://forums.modx.com/thread/102504/plugin-event-onusersave-retrieve-context-key#dis-post-552322 https://forums.modx.com/thread/102504/plugin-event-onusersave-retrieve-context-key#dis-post-552322 Thu, 06 Jul 2017 09:12:11 +0000 https://forums.modx.com/thread/102504/plugin-event-onusersave-retrieve-context-key#dis-post-552322