Revolution 2.1 - MODX Community Forums https://forums.modx.com/board/?board=41 <![CDATA[Manager login server 500 error]]> https://forums.modx.com/thread/104130/manager-login-server-500-error?page=2#dis-post-563402
Looking in core/cache/logs - I get this error > (ERROR @ /public_html/core/model/modx/modmanagerresponse.class.php : 114) PHP warning: Parameter 1 to modManagerController::getInstance() expected to be a reference, value given

Any ideas on a fix so I can get the manager back, and then upgrade to latest version?]]>
https://forums.modx.com/thread/104130/manager-login-server-500-error?page=2#dis-post-563402 Sun, 30 Dec 2018 06:36:56 +0000 https://forums.modx.com/thread/104130/manager-login-server-500-error?page=2#dis-post-563402
<![CDATA[TV Input Types - Resource List - Sort Sequence]]> https://forums.modx.com/thread/72122/tv-input-types---resource-list---sort-sequence#dis-post-563280
Current it's listing all resources, which is good, but the listing appears to be sorted by

Parents
then Children
then throw in a bit on randomness smiley

I'd probably prefer it all by pageTitle]]>
https://forums.modx.com/thread/72122/tv-input-types---resource-list---sort-sequence#dis-post-563280 Sun, 16 Dec 2018 11:14:00 +0000 https://forums.modx.com/thread/72122/tv-input-types---resource-list---sort-sequence#dis-post-563280
<![CDATA[Editing a particular resource returns a 500 HTTP error]]> https://forums.modx.com/thread/88492/editing-a-particular-resource-returns-a-500-http-error?page=2#dis-post-561223
HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

They were working fine, as far as I'm aware nothing changed on these pages, they display fine on the front end. They are complex, in that they use Wayfinder to concatenate the resource itself with HTML from its children resources (which are then displayed in animated Javascript panels). It might have started when I installed VersionX. I've tried deleting the contents of the core/cache directory. There is nothing in the MODx manager error log. All other resources edit fine.

Any idea how I can start to diagnose this?

Huge thanks
Chris]]>
https://forums.modx.com/thread/88492/editing-a-particular-resource-returns-a-500-http-error?page=2#dis-post-561223 Wed, 29 Aug 2018 04:22:28 +0000 https://forums.modx.com/thread/88492/editing-a-particular-resource-returns-a-500-http-error?page=2#dis-post-561223
<![CDATA[Manager Session Auto-Logout]]> https://forums.modx.com/thread/28717/manager-session-auto-logout#dis-post-553862
is there any option to turn off Auto-Logout in 2.1.1?

I can’t work the way i do (with multiple tabs open) and have to constantly re-login to manager. Somehow the session gets killed.
I asked in IRC and i’m not the only one having the issue.

running 2.1.1. in chrome.

is there a system pref i am missing?

thanks,
niklas]]>
https://forums.modx.com/thread/28717/manager-session-auto-logout#dis-post-553862 Wed, 13 Sep 2017 08:43:40 +0000 https://forums.modx.com/thread/28717/manager-session-auto-logout#dis-post-553862
<![CDATA[resetting password on database]]> https://forums.modx.com/thread/70058/resetting-password-on-database#dis-post-551277
I forgot my admin password on my local MODX Revolution 2.1.3-pl (traditional) installation.
I followed the different hints how to unblock / reset the login on the database (mainly by change the MD5 password with a new one in the table (prefix)_manager_users. But: this table does not exist.

Can anyone post a solution how to reset / unblock the admin account?

Thank you very much for your help.

f.]]>
https://forums.modx.com/thread/70058/resetting-password-on-database#dis-post-551277 Sun, 28 May 2017 04:11:18 +0000 https://forums.modx.com/thread/70058/resetting-password-on-database#dis-post-551277
<![CDATA[Configuration problem]]> https://forums.modx.com/thread/101748/configuration-problem#dis-post-548745
Trouble is, in the manager I a getting an issue.

The site map and the manager menus load fine but in the right hand panel, whatever I select in the menus I get this message;

Could not find action file at: /var/www/vhosts/mydomain/public_html/manager/controllers/default/welcome.php (or other file depending on context)

The bold bit is from the previous install.

My new path is /home/mynewdomain/public_html/manager/controllers/default/welcome.php. I have edited core/config.inc.php - and double checked it.

I have searched the database, apart for log entries I found one occurence in modx_workspaces, changed that.

Where else might this path be lurking?]]>
https://forums.modx.com/thread/101748/configuration-problem#dis-post-548745 Tue, 14 Feb 2017 12:19:29 +0000 https://forums.modx.com/thread/101748/configuration-problem#dis-post-548745
<![CDATA[After uploading the site to server i am unable to edit it. Resource not found occurs after login to CMS.]]> https://forums.modx.com/thread/100969/after-uploading-the-site-to-server-i-am-unable-to-edit-it-resource-not-found-occurs-after-login-to-cms#dis-post-546266 https://forums.modx.com/thread/100969/after-uploading-the-site-to-server-i-am-unable-to-edit-it-resource-not-found-occurs-after-login-to-cms#dis-post-546266 Tue, 08 Nov 2016 05:19:41 +0000 https://forums.modx.com/thread/100969/after-uploading-the-site-to-server-i-am-unable-to-edit-it-resource-not-found-occurs-after-login-to-cms#dis-post-546266 <![CDATA[Copy content section (Resources) from Old Site]]> https://forums.modx.com/thread/100800/copy-content-section-resources-from-old-site#dis-post-544518
I have a new site built in modx revolution and want to copy the latest news section from an old version of a modx site. Any ideas the best way to do this?]]>
https://forums.modx.com/thread/100800/copy-content-section-resources-from-old-site#dis-post-544518 Sat, 27 Aug 2016 08:17:28 +0000 https://forums.modx.com/thread/100800/copy-content-section-resources-from-old-site#dis-post-544518
<![CDATA[Manager slow to load Resources]]> https://forums.modx.com/thread/99816/manager-slow-to-load-resources#dis-post-539934 Environment

- Windows Server 2012
- PHP 5.3.29 with Wincache
- MySQL 5.6.26
- MODX Revolution 2.1.3-pl (I know)

Server has 8 2.2ghz cores and 12gb RAM. Typical use is 40-50% for both CPU and RAM.


Issue

The Manager typically takes 20 seconds to open Resources however occasionaly exceeds the max execution time of 30 seconds.

Other pages eg. Manage Users and Access Controls load in 1 second.


Background

The website was migrated to a new server with nearly identical configuration to the original. The website ran without issue before being moved.


Details that may help identify the issue

PHP error log for timeout contains a number of errors:

First
[23-Mar-2016 17:11:59 UTC] PHP Fatal error:  Maximum execution time of 30 seconds exceeded in C:\net\hosts\domain.co.uk\httpdocs\core\model\modx\modtemplatevar.class.php on line 492

#492 from modtemplatevar.class.php relates to render directories
if (!$file->isReadable() || !$file->isFile()) continue;


Second
[23-Mar-2016 17:11:59 UTC] PHP Fatal error:  Maximum execution time of 30 seconds exceeded in C:\net\hosts\domain.co.uk\httpdocs\core\xpdo\om\mysql\xpdoquery.class.php on line 57

#57 from xpdoquery.class.php is
$escape = !preg_match('/\bAS\b/i', $column) && !preg_match('/\./', $column) && !preg_match('/\(/', $column);

I don't think these help identify the issue though.

MySQL does not log any queries taking over 2 seconds to execute.

Does this indicate an issue on the PHP side?

Can anyone advise how to investigate further?]]>
https://forums.modx.com/thread/99816/manager-slow-to-load-resources#dis-post-539934 Fri, 25 Mar 2016 05:50:42 +0000 https://forums.modx.com/thread/99816/manager-slow-to-load-resources#dis-post-539934
<![CDATA[Incorrect TLD appearing in $base_url]]> https://forums.modx.com/thread/85230/incorrect-tld-appearing-in-base-url#dis-post-539732
This has happened twice now in as many weeks, and it occurred on a different set of pages than it did last time.

Now I'm not sure if this is related, but I was experiencing problems with localization of sidebar widgets - depending on what was cached first, the widget would always be in that language. When broken, my template invoked things this way:

[[$Head]]

[[Web_Contact_Map]]

And when I changed it to the below, things started working as expected:

[[!$Head?]]

[[!Web_Contact_Map?]]]]>
https://forums.modx.com/thread/85230/incorrect-tld-appearing-in-base-url#dis-post-539732 Thu, 17 Mar 2016 01:09:41 +0000 https://forums.modx.com/thread/85230/incorrect-tld-appearing-in-base-url#dis-post-539732
<![CDATA[How do i get access to an addon that I created on modx.com extras section?]]> https://forums.modx.com/thread/98493/how-do-i-get-access-to-an-addon-that-i-created-on-modx-com-extras-section#dis-post-532729 https://forums.modx.com/thread/98493/how-do-i-get-access-to-an-addon-that-i-created-on-modx-com-extras-section#dis-post-532729 Sat, 03 Oct 2015 11:31:21 +0000 https://forums.modx.com/thread/98493/how-do-i-get-access-to-an-addon-that-i-created-on-modx-com-extras-section#dis-post-532729 <![CDATA[Configuration Check Issue]]> https://forums.modx.com/thread/98494/configuration-check-issue#dis-post-532726 Core folder is accessible by web

in my .htaccess on my www root I have

# The Friendly URLs part
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

this obviously makes www.mysite.com/core redirect to index.php which makes the config think that its exposed..

I tried doing
#RewriteRule ^(?!core/)(.*)$ index.php?q=$1 [L,QSA]

and it still shows the error. Do you know of a way to work around this issue?

I am redirecting all URLS to index.php because I am doing a single page website (angularJS) and using modx as the CMS for angular but not using modx built in router.]]>
https://forums.modx.com/thread/98494/configuration-check-issue#dis-post-532726 Sat, 03 Oct 2015 08:25:12 +0000 https://forums.modx.com/thread/98494/configuration-check-issue#dis-post-532726
<![CDATA[Add some JS to a manager page]]> https://forums.modx.com/thread/85913/add-some-js-to-a-manager-page?page=2#dis-post-526976
I am just working my way through learning ModX and have created a custom input page in the manager using Form Customization. I would like to add a bit of javascript to hide/show some of the form fields depending what is set in some radio buttons.

regClientScript seems to be what is needed but I can't figure out where to add it.

Any suggestions gratefully received.

Thanks

Pete]]>
https://forums.modx.com/thread/85913/add-some-js-to-a-manager-page?page=2#dis-post-526976 Mon, 15 Jun 2015 01:13:29 +0000 https://forums.modx.com/thread/85913/add-some-js-to-a-manager-page?page=2#dis-post-526976
<![CDATA[Hiding sections from mobile viewing]]> https://forums.modx.com/thread/96735/hiding-sections-from-mobile-viewing?page=2#dis-post-523668 Can anyone tell me how you actually hide 2 sections on the homepage from being viewed on a mobile device?]]> https://forums.modx.com/thread/96735/hiding-sections-from-mobile-viewing?page=2#dis-post-523668 Mon, 30 Mar 2015 03:20:04 +0000 https://forums.modx.com/thread/96735/hiding-sections-from-mobile-viewing?page=2#dis-post-523668 <![CDATA[Recaptcha in Quip Not Working.]]> https://forums.modx.com/thread/96430/recaptcha-in-quip-not-working#dis-post-522501 I am trying to get recaptca to work with the Quip reply form. I have set Recaptcah to true. Added my security key, and pass phrase in settings but it's still not showing up.

Can someone please give me some direction on this?]]>
https://forums.modx.com/thread/96430/recaptcha-in-quip-not-working#dis-post-522501 Fri, 13 Mar 2015 02:46:54 +0000 https://forums.modx.com/thread/96430/recaptcha-in-quip-not-working#dis-post-522501
<![CDATA[Ordering a 2 level menu?]]> https://forums.modx.com/thread/95525/ordering-a-2-level-menu#dis-post-516980
is it possible to order a menu(im using wayfinder) with 2 levels? i mean, there is only a "placeholder" for all menus and submenus at the same time, i want to order my parent li with menuindex, and my inner li's with pagetitle, i think there is a problem with my DB, beacuse just my outer li's order when i put orderBy='pagetitle'

Order is not responding to the parameters i pass to wayfinder

 [[!Wayfinder?
                                 &startId=`[[!fatherOfparent?&parent=`[[*parent]]`]]`
                                 &level=`2`
                                 &outerTpl=`wfOuterInterna`
                                 &innerTpl=`wfInnerInterna`
                                 &parentRowHereTpl=`wfParentRowHereInterna`
                                 &parentRowTpl=`wfParentRowInterna`
                                 &activeParentRowTpl=`wfParentRowHereInterna`
                                 &ignoreHidden=`false`
                                 &sortBy=`pagetitle`
                           &excludeDocs=`21100`
                                 ]]




Thank you]]>
https://forums.modx.com/thread/95525/ordering-a-2-level-menu#dis-post-516980 Thu, 18 Dec 2014 06:14:06 +0000 https://forums.modx.com/thread/95525/ordering-a-2-level-menu#dis-post-516980
<![CDATA[setup fails in rc4 (advanced)]]> https://forums.modx.com/thread/28562/setup-fails-in-rc4-advanced#dis-post-516096 EDIT: Dont do what i suggest recomend here!!! See Post #3 and #4





Hello.

Im tired, so making it short:

Reason: case-sensitive filenames.

File: setup/includes/modinstallsmarty.class.php
Line: 26

replace

include_once strtr(realpath(MODX_CORE_PATH . 'model/smarty/Smarty.class.php'),'\\','/');


with

include_once strtr(realpath(MODX_CORE_PATH . 'model/smarty/smarty.class.php'),'\\','/');


But maybe its an allready known bug.

Thanx]]>
https://forums.modx.com/thread/28562/setup-fails-in-rc4-advanced#dis-post-516096 Wed, 03 Dec 2014 05:28:59 +0000 https://forums.modx.com/thread/28562/setup-fails-in-rc4-advanced#dis-post-516096
<![CDATA[ [SOLVED] Importing Evo to Revo Users]]> https://forums.modx.com/thread/71556/solved-importing-evo-to-revo-users#dis-post-515677
Hi,

I'm using phpMyAdmin to move 400+ users from Evo to Revo 2.1.3, along with their respective MD5 hash passwords.

First, I logged in and installed pbkdf2Convert. Very important! Without it, Evo Users will not be able to login. Yeah, they could use the forgot your password functionality, but there is no way I'm asking 400 users to do that. It would be the end of the site.

Note that the hashClass - thank you thank you thank you Opengeek for pbkdf2Convert! - is MD5. This allows Jason's pbkdf2Convert to do it's trick.

Second, I executed the SQL via phpMyadmin is:
INSERT INTO `revo_users` (`id`, `username`, `password`, `cachepwd`, `class_key`, `active`, `remote_key`, `remote_data`, `hash_class`, `salt`)
VALUES ('', 'Testing', 'ae2b1fca515949e5d54fb22b8ed95575', '', 'modUser', 1, NULL, NULL, '[b]hashing.modMD5[/b]', '');
--
INSERT INTO `revo_user_attributes` (`id`, `internalKey`, `fullname`, `email`, `phone`, `mobilephone`, `blocked`, `blockeduntil`, `blockedafter`, `logincount`, `lastlogin`, `thislogin`, `failedlogincount`, `sessionid`, `dob`, `gender`, `address`, `country`, `city`, `state`, `zip`, `fax`, `photo`, `comment`, `website`, `extended`) VALUES ('', '', 'Testing Evo2Revo', 'email@email.com', '', '', 0, 0, 0, 0, '', '', 0, '', '', '', '', '', '', '', '', '', '', '', '', '[]');
--
INSERT INTO `revo_member_groups` (`id`, `user_group`, `member`, `role`, `rank`) 
VALUES ('', 3, 14, 1, 0);


The last table has the # 14. I know this number from the increment associated from the previous 2 tables. It assigns the user to user group #3.

Here's where it gets funky, hairy and scary: after the import into those 3 tables, do this:
1) Clear Cache
2) Flush Permissions
3) Flush All Sessions

Log back in and test a Users login. It should work.

It took a lot of digging through each Revo table to find that Access Permissions that you see in the MGR is in fact "revo_member_groups".

It would be very helpful is someone with programming skills (that is sooooo not me!) could come up with a way to import users. Provisioner doesn't work on 2.1.3 (due to the pw hash method changed?). And I'm not sure modifying ImportX would work? Maybe it would since I've built my SQL file using Excel.

At any rate, I hope there would be a toolset that would allow for importing Evo to Revo.]]>
https://forums.modx.com/thread/71556/solved-importing-evo-to-revo-users#dis-post-515677 Tue, 25 Nov 2014 08:39:43 +0000 https://forums.modx.com/thread/71556/solved-importing-evo-to-revo-users#dis-post-515677
<![CDATA[Login Snippet has no output any more]]> https://forums.modx.com/thread/95238/login-snippet-has-no-output-any-more#dis-post-515672 I have a very strange problem and cannot solve it. My Login Snippte worked like a charm but does not produce any more output. I do not think that anything has changed on my server but unfortunately the snippet doesn't return anything any more...
Strange! I'm using Modx. 2.1.1 here and the login Snippet 1.9.0
The only thing i notice is that i get this in the error log:

[2014-11-25 16:03:34] (ERROR @ /index.php) Attempted to redirect to an empty URL.

I have no clue what might cause the problem. Has anyone seen this before? Thanks for helping me!

]]>
https://forums.modx.com/thread/95238/login-snippet-has-no-output-any-more#dis-post-515672 Tue, 25 Nov 2014 05:57:23 +0000 https://forums.modx.com/thread/95238/login-snippet-has-no-output-any-more#dis-post-515672
<![CDATA["Could not download package at" when downloading extras]]> https://forums.modx.com/thread/28714/could-not-download-package-at-when-downloading-extras#dis-post-513811
PHP ver: 5.2.13

Configuration command: ’./configure’ ’--enable-soap’ ’--prefix=/usr/local/php5’ ’--with-mysql=/usr’ ’--with-gd’ ’--with-zlib’ ’--with-kerberos’ ’--enable-ftp’ ’--enable-gd-native-ttf’ ’--with-freetype-dir=/usr’ ’--with-jpeg-dir=/usr’ ’--with-xpm-dir=/usr’ ’--with-png-dir=/usr’ ’--enable-bcmath’ ’--with-gettext’ ’--enable-mbstring’ ’--with-curl’ ’--with-imap’ ’--enable-calendar’ ’--with-mhash=/usr’ ’--with-openssl=/usr’ ’--enable-exif’ ’--with-mhash=/usr’ ’--with-mcrypt=/usr’ ’--with-imap-ssl’ ’--with-xsl=/usr’ ’--with-config-file-path=/home/sys/php5’ ’--with-pgsql=/usr’ ’--with-pdo-mysql’ ’--with-pdo-pgsql’ ’--with-mysqli’ ’--with-pear’ ’--with-iconv’ ’--enable-fastcgi’

curl info:

cURL support enabled
cURL Information libcurl/7.18.2 OpenSSL/0.9.8g zlib/1.2.3.3 libidn/1.8 libssh2/0.18

More related info:

allow_url_fopen: On

Yet... when I check the error logs on MODx:

[2011-06-27 06:58:35] (ERROR @ /connectors/workspace/packages-rest.php) Could not open file for reading: http://modx.com/extras/download/?id=4dd402c4f2455473fd000008&revolution_version=Revolution-2.1.1-pl
[2011-06-27 06:58:35] (ERROR @ /connectors/workspace/packages-rest.php) MODX could not download the file. You must enable allow_url_fopen, cURL or fsockopen to use remote transport packaging.
[2011-06-27 06:58:35] (ERROR @ /connectors/workspace/packages-rest.php) Could not download package at: http://modx.com/extras/download/?id=4dd402c4f2455473fd000008


What the?




]]>
https://forums.modx.com/thread/28714/could-not-download-package-at-when-downloading-extras#dis-post-513811 Fri, 31 Oct 2014 01:18:50 +0000 https://forums.modx.com/thread/28714/could-not-download-package-at-when-downloading-extras#dis-post-513811