Evolution 1.0.14 - MODX Community Forums https://forums.modx.com/board/?board=293 <![CDATA[We need to upgrade a client's website using Evolution 1.0.10 to be compatible with php 7.2.]]> https://forums.modx.com/thread/104768/we-need-to-upgrade-a-client-s-website-using-evolution-1-0-10-to-be-compatible-with-php-7-2#dis-post-563419
We are seeing deprecated remarks in the php_errors.log from our server.

It looks like we may be faced with an error with a function constructor for what we believe is the DB connection driver for modx.

Can anyone help us find the best upgrade path (but not by upgrading to Revolution)

Thank you!

Deb

php_errors.log:
[02-Jan-2019 12:57:44 America/Chicago] PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; DocumentParser has a deprecated constructor in /mnt/target04/367616/513298/staging.domainname.com/web/content/manager/includes/document.parser.class.inc.php on line 7
[02-Jan-2019 12:57:44 America/Chicago] PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; SystemEvent has a deprecated constructor in /mnt/target04/367616/513298/staging.domainname.com/web/content/manager/includes/document.parser.class.inc.php on line 3118
[02-Jan-2019 12:57:44 America/Chicago] PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; DBAPI has a deprecated constructor in /mnt/target04/367616/513298/staging.domainname.com/web/content/manager/includes/extenders/dbapi.mysql.class.inc.php on line 8
[02-Jan-2019 12:57:44 America/Chicago] PHP Fatal error:  Uncaught Error: Call to undefined function mysql_connect() in /mnt/target04/367616/513298/staging.domainname.com/web/content/manager/includes/extenders/dbapi.mysql.class.inc.php:89
Stack trace:
#0 /mnt/target04/367616/513298/staging.domainname.com/web/content/manager/includes/document.parser.class.inc.php(1215): DBAPI->connect()
#1 /mnt/target04/367616/513298/staging.domainname.com/web/content/index.php(137): DocumentParser->executeParser()
#2 {main}
  thrown in /mnt/target04/367616/513298/staging.domainname.com/web/content/manager/includes/extenders/dbapi.mysql.class.inc.php on line 89
]]>
https://forums.modx.com/thread/104768/we-need-to-upgrade-a-client-s-website-using-evolution-1-0-10-to-be-compatible-with-php-7-2#dis-post-563419 Thu, 03 Jan 2019 07:35:53 +0000 https://forums.modx.com/thread/104768/we-need-to-upgrade-a-client-s-website-using-evolution-1-0-10-to-be-compatible-with-php-7-2#dis-post-563419
<![CDATA[PHP version requirements]]> https://forums.modx.com/thread/102655/php-version-requirements#dis-post-553858
I know I'm due to an MODX upgrade, nonetheless I'd like to know up until which PHP version MODX Evo 1.0.14 is compatible

thanks a lot, cheers, j]]>
https://forums.modx.com/thread/102655/php-version-requirements#dis-post-553858 Wed, 13 Sep 2017 06:33:07 +0000 https://forums.modx.com/thread/102655/php-version-requirements#dis-post-553858
<![CDATA[1.0.14 hacked]]> https://forums.modx.com/thread/101356/1-0-14-hacked#dis-post-546875 Have deleted the files that are placed or changed by the hacker (sofar I could find out).
I have copied and upload the files from the security-update:
http://feedproxy.google.com/~r/modxsecurity/~3/wdP9yi22-cM/evo-security-patch-1-0-12-and-above
In the MODX Manager I see under Website - Start - Configuration a warning that one or more configuration options are false. And the warning that important systemfiles are changed.
I think that I have corrected the website; but can I check that? (aren't there any old version files??)
and how can I let disappeare the warning of the Configuration tab, so that I can see that the next time anything is changed.
Next question: what is the best MODX version to upgrade to (from my 1.0.14 site)
Thank you, if you will reply.
]]>
https://forums.modx.com/thread/101356/1-0-14-hacked#dis-post-546875 Thu, 01 Dec 2016 01:29:47 +0000 https://forums.modx.com/thread/101356/1-0-14-hacked#dis-post-546875
<![CDATA[MODX Parse Error - Failed to write session data (memcache).]]> https://forums.modx.com/thread/100738/modx-parse-error---failed-to-write-session-data-memcache#dis-post-544280
I'm running a MODX Evo 1.0.14 site which has been running happily for many years. A few days ago I started getting automated emails saying that there was a Parser Error:

Error : Unknown: Failed to write session data (memcache). Please verify that the current setting of session.save_path is correct...

Anybody know why these errors should suddenly be happening? Can they be ignored and if not, what can I do to stop them?

More Info
I have been investigating the site today, and have not triggered a single parser error. Looking through the Event Log there seem to be a number of sources which are triggering this error, e.g:


  • Bing - requesting an actual page on the site
  • Somebody (with a Russian IP) trying to hack my Wordpress theme files ;-)

Cheers,
Smooth Pixel


]]>
https://forums.modx.com/thread/100738/modx-parse-error---failed-to-write-session-data-memcache#dis-post-544280 Wed, 17 Aug 2016 12:18:47 +0000 https://forums.modx.com/thread/100738/modx-parse-error---failed-to-write-session-data-memcache#dis-post-544280
<![CDATA[MODX 1.014 website - not reachable anymore: parse error]]> https://forums.modx.com/thread/100408/modx-1-014-website---not-reachable-anymore-parse-error#dis-post-542838 A customer's MODx-Website is not reachable anymore. The following message appears:

« MODx Parse Error »

MODx encountered the following error while attempting to parse the requested resource:
« PHP Parse Error »

PHP error debug
Error: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead
Error type/ Nr.: - 8192
File: /home/httpd/vhosts/cp-laser.ch/httpdocs/manager/includes/extenders/dbapi.mysql.class.inc.php
Line: 89
Line 89 source: if (!$this->conn = ($persist ? mysql_pconnect($host, $uid, $pwd) : mysql_connect($host, $uid, $pwd, true))) {

Parser timing
MySQL: 0.0000 s (0 Requests)
PHP: 0.0144 s
Total: 0.0144 s

What happened?
Thanks for any help
Markus]]>
https://forums.modx.com/thread/100408/modx-1-014-website---not-reachable-anymore-parse-error#dis-post-542838 Sun, 26 Jun 2016 07:44:13 +0000 https://forums.modx.com/thread/100408/modx-1-014-website---not-reachable-anymore-parse-error#dis-post-542838
<![CDATA[KCFinder not passing image URL back to CKEditor]]> https://forums.modx.com/thread/93055/kcfinder-not-passing-image-url-back-to-ckeditor#dis-post-542553
I tried using the TinyMCE editor instead and that did get populated OK.

I note that KCFinder has this URL in it's window when called from CKEditor:
http://www.customersite.co.uk/manager/media/browser/mcpuk/browse.php?opener=tinymce3&type=images

...so presumably the fact that it thinks it is being called by tinymce is a big clue to as to why it does not populate CKEditor - but I have no idea where to change this.

I have got the CKEditor defined in the settings.

I don't remember exactly why I went for CKEditor over TinyMCE - I think it had something to do with less potential for self inflicted harm by the customer - but I do note now that the page displays reasonably accurately in CKEditor and not very accurately at all in TinyMCE - so I'm reluctant to change.

Any idea how I can get KCFinder to correctly populate the URL field in the CKEditor image properties dialog?

Or am I swimming against the flow and should I just switch to TinyMCE (with the attendant grief for the customer)?

Thanks for any suggestions...]]>
https://forums.modx.com/thread/93055/kcfinder-not-passing-image-url-back-to-ckeditor#dis-post-542553 Fri, 17 Jun 2016 10:36:47 +0000 https://forums.modx.com/thread/93055/kcfinder-not-passing-image-url-back-to-ckeditor#dis-post-542553
<![CDATA[Wrong URL]]> https://forums.modx.com/thread/100191/wrong-url#dis-post-541668
sergi/-avtorskie/sergi-polusfera

But it has to be like:
sergi-avtorskie/sergi-polusfera


In the template file it looks like:
<a href="[~[+id+]~]">...</a>


Where should I search to find the solution?]]>
https://forums.modx.com/thread/100191/wrong-url#dis-post-541668 Thu, 19 May 2016 02:42:58 +0000 https://forums.modx.com/thread/100191/wrong-url#dis-post-541668
<![CDATA[Pages does not appear on site after publishing through ManagerManager]]> https://forums.modx.com/thread/100070/pages-does-not-appear-on-site-after-publishing-through-managermanager#dis-post-541192 https://forums.modx.com/thread/100070/pages-does-not-appear-on-site-after-publishing-through-managermanager#dis-post-541192 Wed, 04 May 2016 06:37:40 +0000 https://forums.modx.com/thread/100070/pages-does-not-appear-on-site-after-publishing-through-managermanager#dis-post-541192 <![CDATA[How can I copy 1000 pages to another category]]> https://forums.modx.com/thread/100066/how-can-i-copy-1000-pages-to-another-category?page=2#dis-post-541160
What tables should I update to make new page appear on site? And also to make correct link to this page, because I already trided to make it, but link to my page is not '/new-page', but something like '/758' and it's even redirect me to 404.

I've updated dst_site_content, dst_products, dst_products_parents and dst_site_tmplvar_contentvalues, but still no progress.]]>
https://forums.modx.com/thread/100066/how-can-i-copy-1000-pages-to-another-category?page=2#dis-post-541160 Tue, 03 May 2016 08:39:06 +0000 https://forums.modx.com/thread/100066/how-can-i-copy-1000-pages-to-another-category?page=2#dis-post-541160
<![CDATA[Create New Web User Unable to load members only documents]]> https://forums.modx.com/thread/97628/create-new-web-user-unable-to-load-members-only-documents#dis-post-535445
Also when we set the hosting environment to use php5.3 we get a ton of errors in the events log like this eventually bogging down the server until we revert to php5.2 or clear the log.

We need php5.3 to support a quickbooks integration software from QBI.

Anyone got any ideas?


« MODX Parse Error »

MODX encountered the following error while attempting to parse the requested resource:
« PHP Parse Error »
PHP error debug
Error : Undefined index: virtual_dir
ErrorType[num] : NOTICE[8]
File : /hsphere/local/home/floral/floraldesigninstitute.com/manager/includes/document.parser.class.inc.php
Line : 2288
Source : $virtualDir= $this->config['virtual_dir'];
Basic info
REQUEST_URI : http://floraldesigninstitute.com/
Resource : [1]home
Current Snippet : WebLogin
Referer : http://floraldesigninstitute.com/page001.00.00.htm
User Agent : Mozilla/5.0 (Windows Phone 8.1; ARM; Trident/7.0; Touch; rv:11.0; IEMobile/11.0; NOKIA; Lumia 635) like Gecko
IP : 172.56.26.19
Benchmarks
MySQL : 0.4712 s (2 Requests)
PHP : 0.0502 s
Total : 0.5215 s
Memory : 7.426944732666 mb

Backtrace

1 DocumentParser->executeParser()
index.php on line 144
2 DocumentParser->prepareResponse()
manager/includes/document.parser.class.inc.php on line 1579
3 DocumentParser->outputContent()
manager/includes/document.parser.class.inc.php on line 1681
4 DocumentParser->parseDocumentSource()
manager/includes/document.parser.class.inc.php on line 596
5 DocumentParser->evalSnippets()
manager/includes/document.parser.class.inc.php on line 1461
6 DocumentParser->_get_snip_result()
manager/includes/document.parser.class.inc.php on line 1060
7 DocumentParser->evalSnippet()
manager/includes/document.parser.class.inc.php on line 1147
8 eval()
manager/includes/document.parser.class.inc.php on line 1009
9 include_once()
manager/includes/document.parser.class.inc.php(1009) : eval()'d code on line 86
10 preserveUrl()
assets/snippets/weblogin/weblogin.inc.php on line 85
11 DocumentParser->makeUrl()
assets/snippets/weblogin/weblogin.common.inc.php on line 91
]]>
https://forums.modx.com/thread/97628/create-new-web-user-unable-to-load-members-only-documents#dis-post-535445 Sun, 06 Dec 2015 02:47:48 +0000 https://forums.modx.com/thread/97628/create-new-web-user-unable-to-load-members-only-documents#dis-post-535445
<![CDATA[ [SOLVED] Cannot create images folder after update to 1.0.14]]> https://forums.modx.com/thread/92877/solved-cannot-create-images-folder-after-update-to-1-0-14#dis-post-533868
Any Ideas please help...]]>
https://forums.modx.com/thread/92877/solved-cannot-create-images-folder-after-update-to-1-0-14#dis-post-533868 Fri, 30 Oct 2015 07:28:05 +0000 https://forums.modx.com/thread/92877/solved-cannot-create-images-folder-after-update-to-1-0-14#dis-post-533868
<![CDATA[mxCalendar - update to Evo 1.0.14 - "Execution of a query to the database failed"]]> https://forums.modx.com/thread/92822/mxcalendar---update-to-evo-1-0-14---execution-of-a-query-to-the-database-failed#dis-post-531728 When I want to insert a new Event I get an "MODX Parse Error"

« MODX Parse Error »
MODX encountered the following error while attempting to parse the requested resource:
« Execution of a query to the database failed - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'repeat``, `lastrepeat`, `event_occurance`, `_occurance_wkly`, `event_occurance_r' at line 1 »
SQL > INSERT INTO `DB_Name`.`modx_mxcalendar_events` (`title`, `description`, `category`, `restrictedwebusergroup`, `link`, `linkrel`, `linktarget`, `location`, `displayGoogleMap`, `start`, `startdate`, `starttime`, `end`, `enddate`, `endtime`, ``repeat``, `lastrepeat`, `event_occurance`, `_occurance_wkly`, `event_occurance_rep`, `_occurance_properties`, `customFields`) VALUES('', '', '1', '', '', '', '', '', '0', '2014-08-24 11:43', '2014-08-24', '11:43:00', '2014-08-24 11:43', '2014-08-24', '11:43:00', '', '', '0', '', '1', '0', '{"detaillink":{"val":"Ja","name":"detaillink","type":"select","label":"Detaillink","options":"Ja,Nein","default":"Ja"},"veranstalter":{"val":"","name":"veranstalter","type":"text","label":"Veranstalter","options":"","default":""}}')
Basic info
REQUEST_URI : 	http://www.**.de/manager/index.php?a=112&id=3
Manager action : 	112 - Execute module
Referer : 	http://www.**.de/manager/index.php?a=112&id=3
User Agent : 	Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
IP : 	84.154.58.104
Benchmarks
MySQL : 	0,0065 s (7 Requests)
PHP : 	0,0432 s
Total : 	0,0497 s
Memory : 	1,5858421325684 mb

Backtrace
1	include_once()
manager/index.php on line 560
2	evalModule()
manager/processors/execute_module.processor.php on line 69
3	eval()
manager/processors/execute_module.processor.php on line 82
4	include_once()
manager/processors/execute_module.processor.php(82) : eval()'d code on line 34
5	mxCal_APP_CLASS->_mgrAddEdit()
assets/modules/mxCalendar/mxCalendar.tpl.php on line 101
6	mxCal_APP_CLASS->_saveEvent()
assets/modules/mxCalendar/mxCalendar.class.php on line 265
7	DBAPI->insert()
assets/modules/mxCalendar/mxCalendar.class.php on line 1255
8	DBAPI->query()
manager/includes/extenders/dbapi.mysql.class.inc.php on line 282  


- PHP-Version: 5.5.14
- SQL-Version: 5.6.19]]>
https://forums.modx.com/thread/92822/mxcalendar---update-to-evo-1-0-14---execution-of-a-query-to-the-database-failed#dis-post-531728 Fri, 18 Sep 2015 09:42:18 +0000 https://forums.modx.com/thread/92822/mxcalendar---update-to-evo-1-0-14---execution-of-a-query-to-the-database-failed#dis-post-531728
<![CDATA[Is FCKeditor able to work correctly in MODx 1.0.14 ?]]> https://forums.modx.com/thread/97654/is-fckeditor-able-to-work-correctly-in-modx-1-0-14#dis-post-528283
Does anyone have a fully working configuration of FCKeditor in MODX 1.0.14 ?

For me FCKeditor (mcpuk) is going wrong when called from TinyMCE to insert pictures in the newest MODx versions and it seems that I'm not alone to encounter this issue.

It is possible to upload pictures, to delete them, but when a thumbnail is double-clicked, nothing happens ; the path of the image is not returned to TinyMCE.

So, I compared the URL displayed in the address bar of FCKEditor in both MODX 1.0.14 and 1.0.3. (In 1.0.3, which FCKeditor is working perfectly).

http://www.version__1.0.3.ext/manager/media/browser/mcpuk/browser.php?Connector=/manager/media/browser/mcpuk/connectors/php/connector.php&ServerPath=/&editor=tinymce3&editorpath=/assets/plugins/tinymce&type=images
http://www.version_1.0.14.ext/manager/media/browser/mcpuk/browse.php?opener=tinymce3&type=images


We see that in MODx 1.0.14, FCKeditor is configured to call "browse.php",
whilst in MODx 1.0.3, FCKeditor is configured to call "browser.php" (notice the trailing "r"). I assume that this could explain why FCKeditor is mode "see-only" in MODx 1.0.14 and cannot return pictures.

We also see that no connector is specified in the call done from MODx 1.0.14.

Furthermore, the folder structure of in the mcpuk folder is very different for MODx 1.0.14 than for MODX 1.0.3.

I tried replacing the folder "manager/media/browser/mcpuk" with the one coming from a site running MODx 1.0.3.
After that, in MODx 1.0.14 the URL in the address bar of FCKeditor is similar to thus on the website running MODx 1.0.3, but FCKeditor doesn't link correctly the image folder.

The pathes in the config are similar for both sites and the web hosting is at the same company.]]>
https://forums.modx.com/thread/97654/is-fckeditor-able-to-work-correctly-in-modx-1-0-14#dis-post-528283 Tue, 14 Jul 2015 02:31:56 +0000 https://forums.modx.com/thread/97654/is-fckeditor-able-to-work-correctly-in-modx-1-0-14#dis-post-528283
<![CDATA[Quick Manager Front end menu: Create resource here loads a blank screen after uprgrade t0 1.0.14]]> https://forums.modx.com/thread/91829/quick-manager-front-end-menu-create-resource-here-loads-a-blank-screen-after-uprgrade-t0-1-0-14?page=3#dis-post-527284
Since upgrading to 1.0.14 both the "create resource here" and "edit resource" buttons load a blank screen. The manager and log out options still work.

The only problem I had with the upgrade was in FTP'ing the file assets/plugins/managermanager/js/jsquery-1.9.1.min.js Everything else went completely smoothly.

The webserver is Microsoft IIS 6.0 and PHP 5.3.5 MYSQL 5

Any help will be much appreciated.





]]>
https://forums.modx.com/thread/91829/quick-manager-front-end-menu-create-resource-here-loads-a-blank-screen-after-uprgrade-t0-1-0-14?page=3#dis-post-527284 Mon, 22 Jun 2015 10:05:31 +0000 https://forums.modx.com/thread/91829/quick-manager-front-end-menu-create-resource-here-loads-a-blank-screen-after-uprgrade-t0-1-0-14?page=3#dis-post-527284
<![CDATA[Problem with paths for images and links]]> https://forums.modx.com/thread/97430/problem-with-paths-for-images-and-links#dis-post-526910
I'm working on a site were we've added children pages for an event. I'm having an issue with image and link paths, where I think what's happening is that TinyMCE is rewriting all my paths so they are relative, even after I go into the HTML and make them absolute.

Does anyone know a way around this? Or is there a setting I may not know about that is causing this issue?

Thanks!]]>
https://forums.modx.com/thread/97430/problem-with-paths-for-images-and-links#dis-post-526910 Sat, 13 Jun 2015 10:01:06 +0000 https://forums.modx.com/thread/97430/problem-with-paths-for-images-and-links#dis-post-526910
<![CDATA[TV input-fields missing after upgrade]]> https://forums.modx.com/thread/96558/tv-input-fields-missing-after-upgrade#dis-post-522602
After the updates all TV-input-fields in my backend are missing. The content-field is right at it's place but everything beneath is gone.

When I downgrade the TinyMCE to 3.5.11 again all my input-fields are back, but
a) the new uploader doesn't work together with the old TinyMCE
b) of course I'd like to have the recent versions.

Any ideas?
Thanx
Christian]]>
https://forums.modx.com/thread/96558/tv-input-fields-missing-after-upgrade#dis-post-522602 Sun, 15 Mar 2015 11:06:03 +0000 https://forums.modx.com/thread/96558/tv-input-fields-missing-after-upgrade#dis-post-522602
<![CDATA[Manager automatically logs me out]]> https://forums.modx.com/thread/93175/manager-automatically-logs-me-out?page=3#dis-post-521221 ]]> https://forums.modx.com/thread/93175/manager-automatically-logs-me-out?page=3#dis-post-521221 Tue, 24 Feb 2015 05:39:53 +0000 https://forums.modx.com/thread/93175/manager-automatically-logs-me-out?page=3#dis-post-521221 <![CDATA[can't log in anymore]]> https://forums.modx.com/thread/95642/can-t-log-in-anymore#dis-post-517659
after getting an e-mail with the following text:
"Source: Parser - The details of the error could be seen in the MODX system events log.", I tried to log in, but couldn't.

resetting the password via phpMyAdmin failed, too (http://rtfm.modx.com/evolution/1.0/administration/manager-users/reset-your-password-unblock-your-user)
... looks like this solution is outdated anyway: http://forums.modx.com/thread/85754/evo-upgrade-issue

hmmm, weird, same here http://forums.modx.com/thread/85777/manager-lockout-after-evo-upgrade but with me this just happened out of the blue and not after an update

does anyone know how to solve this?

thanks a lot, cheers, j

p.s. resetting my password didn't work either, just sent me to the login screen]]>
https://forums.modx.com/thread/95642/can-t-log-in-anymore#dis-post-517659 Mon, 29 Dec 2014 04:38:54 +0000 https://forums.modx.com/thread/95642/can-t-log-in-anymore#dis-post-517659
<![CDATA[Evo 1.0.14 sending spam email (solved)]]> https://forums.modx.com/thread/94623/evo-1-0-14-sending-spam-email-solved?page=2#dis-post-516612
FYI:
Before i upgraded to 1.0.14 my older version (don't know which version it was 1.0.7!?) was hacked and was used for sending spam emails. unfortunately this upgrade did not solve the problem.

After to many hours searching the site and the internet i found out that the mails were send by the Tinymce rich text editor plugin.
Deleted it and replaced it by CKEditor

Until now (3 hours later) it seems that the problem is solved.

Kr
Michiel]]>
https://forums.modx.com/thread/94623/evo-1-0-14-sending-spam-email-solved?page=2#dis-post-516612 Thu, 11 Dec 2014 01:47:54 +0000 https://forums.modx.com/thread/94623/evo-1-0-14-sending-spam-email-solved?page=2#dis-post-516612
<![CDATA[Some of my modx 1.0.14 are hacked]]> https://forums.modx.com/thread/93126/some-of-my-modx-1-0-14-are-hacked?page=9#dis-post-516296
Today i noticed that some .js files from some sites with the latest modx evolution 1.0.14 are infected with the script (see attachment).

My question is how could this can happen and how can i prevent this?





]]>
https://forums.modx.com/thread/93126/some-of-my-modx-1-0-14-are-hacked?page=9#dis-post-516296 Sun, 07 Dec 2014 04:30:55 +0000 https://forums.modx.com/thread/93126/some-of-my-modx-1-0-14-are-hacked?page=9#dis-post-516296