Evolution 1.0.12 - MODX Community Forums https://forums.modx.com/board/?board=290 <![CDATA[Resolved - Cannot modify header information - headers already sent]]> https://forums.modx.com/thread/88656/resolved---cannot-modify-header-information---headers-already-sent#dis-post-556186
I have been getting the familiar old "Cannot modify header information - headers already sent" error message and it is driving me crazy.
No white space before or after, Utf-8 with NO BOM - tried pretty much everything I could find online - PLEASE HELP.
*******
The full error message is - Warning: Cannot modify header information - headers already sent by (output started at /home/rsacours/public_html/assets/modules/coursemanager/process.cm.php:11) in /home/rsacours/public_html/manager/includes/document.parser.class.inc.php on line 3595
Error
(Note: The line number referenced here - process.cm.php:11 is the one following this line
<div id="padbox">
below)
*******
I have a (Course Manager) module that manages some custom tables. One of the functions is to update/edit course numbers which works fine for the first row (red box in attached image) but for all subsequent rows the above error is generated.


Two files are involved here - 1.process.cm.php which is called to process the POSTED data and 2.index.cm.php which is the GUI for the Course Manager Module.
If anyone can spot the issue in the offending file below I would be eternally grateful.
1. process.cm.php
<html>
<head>
</head>
<body>
<div id="padbox">
<?php
// include the modx config and parser -- Modified by WSG - 10/01/2014 added places
require_once('../../../manager/includes/config.inc.php');
require_once('../../../manager/includes/document.parser.class.inc.php');
$modx = new DocumentParser;

// ******** NEW SESSION **********
if($_POST['add_new']==1){
$c=$_POST['course'];
$d=$_POST['date'];
$t=$_POST['time'];
$v=$_POST['venue'];
$p=$_POST['places'];

// ****** ADD NEW SESSION ********** WSG
$sql = "INSERT INTO xtra_session VALUES(NULL,$c,$v,'$d','$t',$p)";
$add = $modx->db->query($sql);
$msg = ($add? "new session has been added" : "error: ".mysql_error());	
}

// ******** REMOVE SESSION **********
if($_POST['remove']==1){
$id=$_POST['sid'];
$sql = "DELETE FROM xtra_session WHERE xtra_session.id=$id";
$add = $modx->db->query($sql);
$msg = ($add? "session has been deleted" : "error: ".mysql_error());	
}

// ******** EDIT SESSION PLACES ********** WSG
if($_POST['edit']==1){
$id=$_POST['sid'];
$z=$_POST['edit_places'];
$sql = "UPDATE xtra_session SET places=$z WHERE xtra_session.id=$id";
$add = $modx->db->query($sql);
$msg = ($add? "The available places have been updated" : "error: ".mysql_error());
}
else {
echo "Please enter a number of places to change";
}
}
echo $msg;
?>
<form><input type="button" value="Back to admin page" onclick="history.go(-1); return true;" /></form>
<noscript style="color:#c00">oh dear... looks like you have no javascript and the button is broken, click Course Manager from top menu to continue</noscript>
</div>
</body>
</html>


and 2. index.cm.php
<html>
<head>
<link rel="stylesheet" type="text/css" href="media/style/<?php echo $modx->config['manager_theme']; ?>/style.css" />
<link rel="stylesheet" type="text/css" href="../assets/modules/coursemanager/cm_style.css" />
<script type="text/javascript" src="../assets/modules/coursemanager/calendarDateInput.js"></script>
<script type="text/javascript" src="../assets/modules/coursemanager/input.js"></script>
</head>
<body>
<noscript style="color:#c00">oh dear... it looks like you have no javascript, continue at your own risk! This module recommends you turn your javascript on.</noscript>
<div id="padbox">

<h1>Course Manager</h1>

<!-- add session -->
<!-- this block of code has been removed for brevity -->
<!-- ******************************************************************************* -->

<!-- list all sessions with edit places and removal option WSG 11/01/2014-->
<h2 class="section">Currently available sessions</h2>
<table cellspacing="0" cellpadding="5">
	<tr><th>ID</th><th>Course</th><th>yyyy-mm-dd</th><th>Venue</th><th>Time</th><th>Places</th><th>New #</th><th> </th></tr>
<?php
$q2="SELECT xtra_session.id AS id,xtra_courses.code AS code,xtra_session.date AS date,xtra_session.time AS time, xtra_session.places AS places, xtra_venues.name AS venue FROM xtra_session,xtra_courses,xtra_venues WHERE xtra_session.date >= CURDATE() AND xtra_session.course_id=xtra_courses.id AND xtra_session.venue_id=xtra_venues.id ORDER BY xtra_session.course_id, xtra_session.date";
$r2= mysql_query($q2);

while($details = mysql_fetch_array($r2)){
$sid = $details['id'];
$code = $details['code'];
$date = $details['date'];
$venue = $details['venue'];
$time = $details['time'];
$places = $details['places'];

echo '<tr'.(($c = !$c)?' class="o"':' class="e"').">";
echo"<td>".$sid."</td>";
echo"<td>".$code."</td>";
echo"<td>".$date."</td>";
echo"<td>".$venue."</td>";
echo"<td>".$time."</td>";
echo"<td>".$places."</td>";

<!-- The block below is the code that works for the first row only then produces the ERROR -->

echo"<td><form name=\"edit_session\" id=\"edit_session\" method=\"post\" action=\"../assets/modules/coursemanager/process.cm.php\"><input type=\"hidden\" name=\"edit\" value=\"1\" /><input type=\"text\" size=\"3\" name=\"edit_places\" value=\" \" /><input type=\"hidden\" name=\"sid\" value=\"".$sid."\" /><input type=\"button\" name=\"Submit\" value=\"edit places\" onclick=\"return resetForm();\"/></form></td>";

echo"<td><form name=\"remove_session".$sid."\" method=\"post\" action=\"../assets/modules/coursemanager/process.cm.php\" onsubmit=\"return check_del();\"><input type=\"hidden\" name=\"remove\" value=\"1\" /><input type=\"hidden\" name=\"sid\" value=\"".$sid."\" /><input type=\"submit\" name=\"Submit\" value=\"delete session\" /></form></td>\n\n";
echo"</tr>";
}
?>
</table>
<p> </p>
<!-- list all sessions with removal option -->
<!-- this block of code has been removed for brevity -->
<!-- ******************************************************************************* -->

<!-- list all courses -->
<!-- this block of code has been removed for brevity -->
<!-- ******************************************************************************* -->

<!-- list all venues -->
<!-- this block of code has been removed for brevity -->
<!-- ******************************************************************************* -->

</div>
<script language="javascript">
function resetForm()
{
    document.forms["edit_session"].submit(); //first submit the form values
    document.forms["edit_session"].reset(); //then reset the form values
  }
</script>
</body>
</html>
]]>
https://forums.modx.com/thread/88656/resolved---cannot-modify-header-information---headers-already-sent#dis-post-556186 Fri, 05 Jan 2018 10:57:26 +0000 https://forums.modx.com/thread/88656/resolved---cannot-modify-header-information---headers-already-sent#dis-post-556186
<![CDATA[KCFinder not loading/uploading/working]]> https://forums.modx.com/thread/88659/kcfinder-not-loading-uploading-working?page=4#dis-post-545371
I checked permissions, directories, and error logs. I've exhausted everything I can think of to do. Any ideas?

Thanks!]]>
https://forums.modx.com/thread/88659/kcfinder-not-loading-uploading-working?page=4#dis-post-545371 Fri, 30 Sep 2016 08:44:54 +0000 https://forums.modx.com/thread/88659/kcfinder-not-loading-uploading-working?page=4#dis-post-545371
<![CDATA[When I click save show me the home page]]> https://forums.modx.com/thread/99009/when-i-click-save-show-me-the-home-page#dis-post-535692
When I click save a modification made into a chunk show me the home page.

Like the image attached

Other questions:

how can I set up the debug mode?
If this a problem of a plugin how can I deactivate?

Thanks for reply.]]>
https://forums.modx.com/thread/99009/when-i-click-save-show-me-the-home-page#dis-post-535692 Thu, 10 Dec 2015 03:51:48 +0000 https://forums.modx.com/thread/99009/when-i-click-save-show-me-the-home-page#dis-post-535692
<![CDATA[Table modx_event_log full]]> https://forums.modx.com/thread/99038/table-modx-event-log-full#dis-post-535551
Table modx_event_log consume the total space of my BD what can I do?

This is a error of modx, I work with 1.0.12 version.

Thanks for reply.
]]>
https://forums.modx.com/thread/99038/table-modx-event-log-full#dis-post-535551 Tue, 08 Dec 2015 02:19:38 +0000 https://forums.modx.com/thread/99038/table-modx-event-log-full#dis-post-535551
<![CDATA[PHP safe mode problem with KCFinder]]> https://forums.modx.com/thread/87868/php-safe-mode-problem-with-kcfinder#dis-post-518800
The "safe_mode" PHP ini setting is turned on! You cannot run KCFinder in safe mode.

I asked the hosting support to turn the safe mode off, but they say they cannot because of site safety.
What can I do? Never had that kind of problem before.]]>
https://forums.modx.com/thread/87868/php-safe-mode-problem-with-kcfinder#dis-post-518800 Tue, 20 Jan 2015 03:29:08 +0000 https://forums.modx.com/thread/87868/php-safe-mode-problem-with-kcfinder#dis-post-518800
<![CDATA[Configuration warning: 'Important System Files have been modified.']]> https://forums.modx.com/thread/92127/configuration-warning-important-system-files-have-been-modified#dis-post-518798 I run a Modx that has been compromised. Hosting support says so. I noticed, also, odd files added to /manager directory and sub directories.
It is an old site that I have been upgrading and have a lot of snippets (some of them custom). The site is OK, and not code was added to my pages.
MODX version is 1.0.12
PHP Version 5.3.20
What I should do next? Could you help me with an advice about how to save this site please?

Thank you in advance.]]>
https://forums.modx.com/thread/92127/configuration-warning-important-system-files-have-been-modified#dis-post-518798 Tue, 20 Jan 2015 03:25:21 +0000 https://forums.modx.com/thread/92127/configuration-warning-important-system-files-have-been-modified#dis-post-518798
<![CDATA[KCFinder - Can't upload files]]> https://forums.modx.com/thread/88017/kcfinder---can-t-upload-files#dis-post-515745
Anybody have any ideas?]]>
https://forums.modx.com/thread/88017/kcfinder---can-t-upload-files#dis-post-515745 Thu, 27 Nov 2014 06:02:26 +0000 https://forums.modx.com/thread/88017/kcfinder---can-t-upload-files#dis-post-515745
<![CDATA[Wayfinder IncludeDocs parameter is breaking the snippet?]]> https://forums.modx.com/thread/94763/wayfinder-includedocs-parameter-is-breaking-the-snippet#dis-post-515730
To do this, I have used the includeDocs parameter.

[[Wayfinder? &startId=`0` &includeDocs=`17,18,19,20`]]

When I do this, I get no output at all. Remove includeDocs and I get the standard nav (expected). Use the param and the output is completely empty.

No idea what I'm doing wrong or what (if any) other setting must be defined in order to make this work.]]>
https://forums.modx.com/thread/94763/wayfinder-includedocs-parameter-is-breaking-the-snippet#dis-post-515730 Wed, 26 Nov 2014 10:21:11 +0000 https://forums.modx.com/thread/94763/wayfinder-includedocs-parameter-is-breaking-the-snippet#dis-post-515730
<![CDATA[Not correct translation strtotime:date - always 01.01.1970]]> https://forums.modx.com/thread/94679/not-correct-translation-strtotime-date---always-01-01-1970#dis-post-512799 MODX Evo 1.0.12

I want to display pub. date in human-readable format.
What i do:

[+pub_date:strtotime:date=`%e %B %Y`+]


Result: 1 Jan 1970.
For all posts.

But [+pub_date+] display right date in unix time (if i convert it) and all post has right pub dates (in unix time).
Can someone help me with it?

Thanks and sorry for my English.]]>
https://forums.modx.com/thread/94679/not-correct-translation-strtotime-date---always-01-01-1970#dis-post-512799 Thu, 16 Oct 2014 11:07:17 +0000 https://forums.modx.com/thread/94679/not-correct-translation-strtotime-date---always-01-01-1970#dis-post-512799
<![CDATA[Friendly URL's only partialy working]]> https://forums.modx.com/thread/92752/friendly-url-s-only-partialy-working#dis-post-506830 I have a strange problem with friendly URL's. I have set them to ON but they don't show.
(I am pretty sure) the .htaccess is configured correctly. There is only one .htaccess in the root directory.
I have cleared the cache and tried viewing the site in different browsers while being logged out.
All pages have an URL alias set.

However, by default, the URL's are showing the /index.php?id=1 and not the URL alias.
Oddly, when the URL alias is entered into the browser it works and the friendly URL shows.
When any link is selected, it reverts back to the unfriendly /index.php?id=1 type URL.

The site is http://www.rsacoursemelbourne.com/
]]>
https://forums.modx.com/thread/92752/friendly-url-s-only-partialy-working#dis-post-506830 Tue, 19 Aug 2014 04:27:57 +0000 https://forums.modx.com/thread/92752/friendly-url-s-only-partialy-working#dis-post-506830
<![CDATA[New phpthumb snippet can't create thumbnails in assets/cache/images]]> https://forums.modx.com/thread/89129/new-phpthumb-snippet-can-t-create-thumbnails-in-assets-cache-images#dis-post-506707
I'm running MODx Evo 1.0.12 on PHP 5.3.28 (also tried on 5.5.7) and thumbnails don't want to create in assets/cache/images

I tried to CHMOD assets/cache/images 755 and 777.

I guess snippet may work well as
[[phpthumb? &input=`[+vignette+]` &options=`w=200,h=200,zc=1`]]
calls assets/cache/images/200x200-yeux_bleu.785.jpg but the thumbnails is not created in assets/cache/images.
When I try to view the image in Firefox, I get a 403 error.

In phpThumb.config.php, I have :
$PHPTHUMB_CONFIG['cache_directory'] = dirname(__FILE__).'/../../cache/images/';  

Is that right ?

Where else can I search for a potentiel error ?

Thank you !]]>
https://forums.modx.com/thread/89129/new-phpthumb-snippet-can-t-create-thumbnails-in-assets-cache-images#dis-post-506707 Sun, 17 Aug 2014 07:36:30 +0000 https://forums.modx.com/thread/89129/new-phpthumb-snippet-can-t-create-thumbnails-in-assets-cache-images#dis-post-506707
<![CDATA[Issues with Mod X manager after moving website to another server]]> https://forums.modx.com/thread/91625/issues-with-mod-x-manager-after-moving-website-to-another-server#dis-post-500857 Hi All,

I moved my site to another sever and frontend is working fine but manager is giving a popup with the complete manager url when after entering username and password http://207.210.202.165/manager/ and I have to refresh after the popup to see manager options.

Also, When I am saving anything then the right side of the manager gets blank and I see only left menu tree and top navigation but the settings get saved and again when I refresh I see everything.

Please see attached screenshots and help me find out the cuase.

Thanks
Pranav]]>
https://forums.modx.com/thread/91625/issues-with-mod-x-manager-after-moving-website-to-another-server#dis-post-500857 Thu, 19 Jun 2014 03:24:44 +0000 https://forums.modx.com/thread/91625/issues-with-mod-x-manager-after-moving-website-to-another-server#dis-post-500857
<![CDATA[Open download windows in IE...]]> https://forums.modx.com/thread/90113/open-download-windows-in-ie?page=2#dis-post-498912 I have a acad file on the server *.dwg and the download window does not open in Internet Explorer all version, but works well on other file types as .doc .pdf etc... In Mozilla, Opera etc so it works perfectly.

Any idea?

/Kjelle

]]>
https://forums.modx.com/thread/90113/open-download-windows-in-ie?page=2#dis-post-498912 Thu, 29 May 2014 08:48:07 +0000 https://forums.modx.com/thread/90113/open-download-windows-in-ie?page=2#dis-post-498912
<![CDATA[connect() cannot select database]]> https://forums.modx.com/thread/90818/connect-cannot-select-database#dis-post-497684
luckily I learned long ago never to update MODx on a livesite.. so I'm testing 1.0.12 @home ;-)

I used to connect to a 2nd database with db->connect(HOST,DBASE,USER,PASSWORD,PERSISTENT).
Sometimes I have to do a db->disconnect() before this and sometimes a db->connect() afterwards, to get me away from (or back to) the modx database. AFAIK that worked from 0.9.x upto 1.0.9

With this 1.0.12 update I keep getting "cannot select database" when trying to connect to this 2nd database. The database does exist and the login is right. I know this because I tried it with mysql_connect and mysql_select_db. AFAIK one can't do these mysql statements first to connect and then switch to existing db_select() methods, right?

So.. am I missing something? What changed? Anyone have a clue or suggestion?

TIA,
IngMA
Amsterdam
]]>
https://forums.modx.com/thread/90818/connect-cannot-select-database#dis-post-497684 Mon, 12 May 2014 01:30:42 +0000 https://forums.modx.com/thread/90818/connect-cannot-select-database#dis-post-497684
<![CDATA[After update from 1.0.10 to .12: Execution of a query to the database failed - Unknown column 'alias_visible' in 'field list']]> https://forums.modx.com/thread/87453/after-update-from-1-0-10-to-12-execution-of-a-query-to-the-database-failed---unknown-column-alias-visible-in-field-list?page=2#dis-post-493619
I upgraded a 1.0.10-installation to 1.0.12. I did the following:

• download the 1.0.12 ZIP file to target host
• unzip
• copy over all files overwriting the 1.0.10 installation
• run /install
• fix some minor permission issues until everything was “ok”
• “Install“
• rm -r install

When I now access hostname.example.com/manager I get:

-------
« MODX Parse Error »

MODX encountered the following error while attempting to parse the requested resource:
« Execution of a query to the database failed - Unknown column 'alias_visible' in 'field list' »
SQL > SELECT id, IF(alias='', id, alias) AS alias, parent, alias_visible FROM `knubbelmac`.`modx_site_content`
Basic info
REQUEST_URI : /
Referer :
User Agent : Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9) AppleWebKit/537.71 (KHTML, like Gecko) Version/7.0 Safari/537.71
Benchmarks
MySQL : 0.0060 s (2 Requests)
PHP : 0.0069 s
Total : 0.0129 s
Memory : 0.77809906005859 mb

Backtrace

1 DocumentParser->executeParser()
index.php on line 140
2 DocumentParser->getSettings()
manager/includes/document.parser.class.inc.php on line 1495
3 synccache->buildCache()
manager/includes/document.parser.class.inc.php on line 269
4 synccache->getParents()
manager/processors/cache_sync.class.processor.php on line 208
5 DBAPI->query()
manager/processors/cache_sync.class.processor.php on line 39
-------

Host: Debian Linux 7
nginx/1.2.1 + php_fpm PHP Version 5.4.4-14+deb7u5 + xcache
]]>
https://forums.modx.com/thread/87453/after-update-from-1-0-10-to-12-execution-of-a-query-to-the-database-failed---unknown-column-alias-visible-in-field-list?page=2#dis-post-493619 Wed, 26 Mar 2014 10:00:29 +0000 https://forums.modx.com/thread/87453/after-update-from-1-0-10-to-12-execution-of-a-query-to-the-database-failed---unknown-column-alias-visible-in-field-list?page=2#dis-post-493619
<![CDATA[301 redirect htaccess help]]> https://forums.modx.com/thread/89562/301-redirect-htaccess-help#dis-post-493415
I'm trying to permanently 301 redirect an old page to a newer version with the following in my .htaccess:

Redirect 301 /web-design.html http://www.mydomain-name.co.uk/new-web-design.html

which at first I thought was working but it's also redirecting:

/anotherpage-web-design.html to http://www.mydomain-name.co.uk/new-web-design.html

If anyone can post the correct markup I'd be thankful!?]]>
https://forums.modx.com/thread/89562/301-redirect-htaccess-help#dis-post-493415 Sun, 23 Mar 2014 06:14:06 +0000 https://forums.modx.com/thread/89562/301-redirect-htaccess-help#dis-post-493415
<![CDATA[www.domain.com/DOCID]]> https://forums.modx.com/thread/88918/www-domain-com-docid?page=3#dis-post-493131
i just update http://www.avanspeldehoveniers.nl/ form 1.0.10 to 1.0.12

in earlier versions of MODx my client used links like:

http://www.avanspeldehoveniers.nl/2

But now in 10.0.12 these links doesn't work anymore, what should i do?]]>
https://forums.modx.com/thread/88918/www-domain-com-docid?page=3#dis-post-493131 Thu, 20 Mar 2014 05:57:09 +0000 https://forums.modx.com/thread/88918/www-domain-com-docid?page=3#dis-post-493131
<![CDATA[Maxigallery crashing site after upgrade]]> https://forums.modx.com/thread/89482/maxigallery-crashing-site-after-upgrade#dis-post-492030
I updated Maxigallery to the very latest version as well.

But we get the following errors when you load the home page of this site for example. If we remove the call to Maxigallery Snippet, the site loads fine.

www.vermontstone.com

« MODX Parse Error »
MODX encountered the following error while attempting to parse the requested resource:
« Execution of a query to the database failed - Unknown storage engine 'InnoDB' »
SQL > CREATE TABLE `vermonts_MODx`.vermonts_maxigallery ( `id` int(10) unsigned NOT NULL auto_increment, `gal_id` int(10) unsigned NOT NULL, `filename` tinytext NOT NULL, `title` text NOT NULL, `date` datetime NOT NULL, `descr` text default NULL, `pos` int(10) default NULL, `own_id` int(10) default NULL, `hide` int(1) default 0, PRIMARY KEY (`id`) ) ENGINE=MyISAM AUTO_INCREMENT=1 ;
Basic info
REQUEST_URI : /
Resource : [1]Home
Current Snippet : MaxiGallery
Current Plugin : PHx(OnParseDocument)
Referer : http://vermontstone.com/walls.html
User Agent : Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.146 Safari/537.36
IP : 68.112.101.185
Benchmarks
MySQL : 0.0035 s (4 Requests)
PHP : 0.0170 s
Total : 0.0204 s
Memory : 0.90210723877 mb

Backtrace

1 DocumentParser->executeParser()
index.php on line 140
2 DocumentParser->prepareResponse()
manager/includes/document.parser.class.inc.php on line 1568
3 DocumentParser->outputContent()
manager/includes/document.parser.class.inc.php on line 1673
4 DocumentParser->parseDocumentSource()
manager/includes/document.parser.class.inc.php on line 582
5 DocumentParser->invokeEvent()
manager/includes/document.parser.class.inc.php on line 1434
6 DocumentParser->evalPlugin()
manager/includes/document.parser.class.inc.php on line 3334
7 eval()
manager/includes/document.parser.class.inc.php on line 969
8 PHxParser->OnParseDocument()
manager/includes/document.parser.class.inc.php(969) : eval()'d code on line 26
9 PHxParser->Parse()
assets/plugins/phx/phx.parser.class.inc.php on line 49
10 PHxParser->ParseValues()
assets/plugins/phx/phx.parser.class.inc.php on line 64
11 DocumentParser->evalSnippets()
assets/plugins/phx/phx.parser.class.inc.php on line 131
12 DocumentParser->_get_snip_result()
manager/includes/document.parser.class.inc.php on line 1061
13 DocumentParser->evalSnippet()
manager/includes/document.parser.class.inc.php on line 1147
14 eval()
manager/includes/document.parser.class.inc.php on line 1005
15 include()
manager/includes/document.parser.class.inc.php(1005) : eval()'d code on line 76
16 maxiGallery->createTable()
assets/snippets/maxigallery/maxigallery.php on line 243
17 DBAPI->query()
assets/snippets/maxigallery/maxigallery.class.inc.php on line 55
]]>
https://forums.modx.com/thread/89482/maxigallery-crashing-site-after-upgrade#dis-post-492030 Fri, 07 Mar 2014 12:42:26 +0000 https://forums.modx.com/thread/89482/maxigallery-crashing-site-after-upgrade#dis-post-492030
<![CDATA[Site configuration changes not saved]]> https://forums.modx.com/thread/89367/site-configuration-changes-not-saved#dis-post-491457
Has anyone else had this?]]>
https://forums.modx.com/thread/89367/site-configuration-changes-not-saved#dis-post-491457 Fri, 28 Feb 2014 11:08:35 +0000 https://forums.modx.com/thread/89367/site-configuration-changes-not-saved#dis-post-491457
<![CDATA[Weird Ditto template problem]]> https://forums.modx.com/thread/88939/weird-ditto-template-problem#dis-post-490812
It's as if the Ditto template is cached--I make changes to the template, and they are not reflected in the output whatsoever. If I duplicate the template and point ditto towards the new one, it gives me the error "&tpl either does not contain any placeholders or is an invalid chunk name, code block, or filename. Please check it." Despite the fact that it is identical to the old template!

Of course I've tried emptying the cache, to no avail.

I am at a loss as to what's going on. Can anyone point me in the right direction? Thank you!]]>
https://forums.modx.com/thread/88939/weird-ditto-template-problem#dis-post-490812 Fri, 21 Feb 2014 11:30:13 +0000 https://forums.modx.com/thread/88939/weird-ditto-template-problem#dis-post-490812