modxcms.com Discussions and Suggestions - MODX Community Forums https://forums.modx.com/board/?board=29 <![CDATA[Package Manager not working on local install]]> https://forums.modx.com/thread/24515/package-manager-not-working-on-local-install?page=2#dis-post-546336 https://forums.modx.com/thread/24515/package-manager-not-working-on-local-install?page=2#dis-post-546336 Fri, 11 Nov 2016 10:29:04 +0000 https://forums.modx.com/thread/24515/package-manager-not-working-on-local-install?page=2#dis-post-546336 <![CDATA[modx Lite anyone?]]> https://forums.modx.com/thread/24351/modx-lite-anyone#dis-post-545919 Nut sometimes I wish I could have lite version that doesn’t require a database.

I really like the way the chunks, snippets, and templates work in modx, but for smaller sites a database can be overkill. How about a modX lite?

does anyone know of any alternatives that do this?
lightneasy seems ok, but I gots myself hooked on the good stuff.]]>
https://forums.modx.com/thread/24351/modx-lite-anyone#dis-post-545919 Sun, 23 Oct 2016 05:18:16 +0000 https://forums.modx.com/thread/24351/modx-lite-anyone#dis-post-545919
<![CDATA[Change Usernames]]> https://forums.modx.com/thread/24501/change-usernames#dis-post-545422 https://forums.modx.com/thread/24501/change-usernames#dis-post-545422 Sun, 02 Oct 2016 02:22:23 +0000 https://forums.modx.com/thread/24501/change-usernames#dis-post-545422 <![CDATA[Showcase rejection]]> https://forums.modx.com/thread/24445/showcase-rejection#dis-post-532767
Today I received an email from the MODxcms.com Showcase telling me that one of my sites had been rejected. Strange thing is, it was looking for the wrong URL!

The site has actually been on there for two years I think, which makes this message kind of strange. Is there some kind of vulnerability in the showcase system that could have allowed the URL of my site (of ID 14) to be changed?]]>
https://forums.modx.com/thread/24445/showcase-rejection#dis-post-532767 Mon, 05 Oct 2015 06:14:20 +0000 https://forums.modx.com/thread/24445/showcase-rejection#dis-post-532767
<![CDATA[Snippet return for directory contents]]> https://forums.modx.com/thread/24276/snippet-return-for-directory-contents#dis-post-465544
It seems this would create a gallery within Modx that the CMS user could manage by simply uploading to/deleting from a specified directory. Has anyone done anything like this?]]>
https://forums.modx.com/thread/24276/snippet-return-for-directory-contents#dis-post-465544 Tue, 07 May 2013 12:41:03 +0000 https://forums.modx.com/thread/24276/snippet-return-for-directory-contents#dis-post-465544
<![CDATA[Bug Report Bucket--can we have a simple way to report bugs?]]> https://forums.modx.com/thread/24499/bug-report-bucket--can-we-have-a-simple-way-to-report-bugs#dis-post-395882
I suggest we put together a "Bug Report Bucket" where we can just fill out a form with a couple fields, no login required, and no need to search to see if others have reported the bug already, and "environment" as an optional field. The whole process could be done in 60 seconds.

The "preferred" way to submit bugs would not change. The "bucket" would just be a second option for all of us who don’t want to spend 20 minutes figuring out how to report a minor bug.

My second suggestion is to have the "Bugs and Requests" link on the MODx homepage link to a page that lists the official locations to file bugs for all MODx projects, subprojects, AND addons--plus a link to the one stop Bug Report Bucket. Naturally most developers would give less priority to bugs reported via the bucket, but it would be a good way to be alerted about bugs that would otherwise be unreported.

Background:
Yesterday I found two bugs that I figured I really should report. So I went modx.com and clicked on "Bugs and Requests" in the Revolution menu. That brought me to
http://bugs.modx.com/projects/revo/

It looks like we’re using Redmine now instead of JIRA. That’s cool. I use Redmine for my own project tracking sometimes, so it should be pretty easy for me to use. So I poked around looking for a button to submit a bug, but I couldn’t find one. I didn’t see any text that said I had to log in to submit a bug, but I eventually noticed that I wasn’t logged in. So I logged in. Usually that would stop me from filling a bug, but I already have an account and I happen to know my password, so I got past that step.

I did like I should and did a few searches to see if anyone else had filled the same bug, and then I created a new report. But there was no appropriate category to file bugs for these particular addons (in spite of the fact that both addons are maintained by core devs). For the second bug I searched around the forums, github, etc. to find another place to file the bug but could not find any.

So after spending all that time and effort yesterday, today I see that both bugs were rejected as invalid. The responses were thoughtful and helpful--one I have to file at github, and the other I can try reporting in the forums (the issue was reported 6 months back on the forums and the precise problem identified, so I don’t know how much luck I’ll have with reporting it again).

Hopefully I’ll find the time to report the bugs the proper way...]]>
https://forums.modx.com/thread/24499/bug-report-bucket--can-we-have-a-simple-way-to-report-bugs#dis-post-395882 Tue, 04 Oct 2011 12:20:39 +0000 https://forums.modx.com/thread/24499/bug-report-bucket--can-we-have-a-simple-way-to-report-bugs#dis-post-395882
<![CDATA[Context based plugins]]> https://forums.modx.com/thread/24504/context-based-plugins#dis-post-394979
Think, that this would help everyone who is managing multi-site based on contexts...

-- sorry I posted it to bad forum and I can’t delete it :-/]]>
https://forums.modx.com/thread/24504/context-based-plugins#dis-post-394979 Wed, 28 Sep 2011 02:40:00 +0000 https://forums.modx.com/thread/24504/context-based-plugins#dis-post-394979
<![CDATA[ [SOLVED] Where are the Child Boards RSS feeds or are they missing?]]> https://forums.modx.com/thread/24379/solved-where-are-the-child-boards-rss-feeds-or-are-they-missing#dis-post-393392 https://forums.modx.com/thread/24379/solved-where-are-the-child-boards-rss-feeds-or-are-they-missing#dis-post-393392 Wed, 14 Sep 2011 05:29:59 +0000 https://forums.modx.com/thread/24379/solved-where-are-the-child-boards-rss-feeds-or-are-they-missing#dis-post-393392 <![CDATA[MODx new extra section: a great resource of the free add ons]]> https://forums.modx.com/thread/24485/modx-new-extra-section-a-great-resource-of-the-free-add-ons?page=4#dis-post-392717 Thanks for so much work on providing this.
The search task looks awesome!
The badge/tag is also very useful.

Anyway,
What is the yellow background?
And how can we get that ’solid’ tag, as audited and approved?
Just got your tweet about other tags:

Deprecated, approved, status (inactive/active), featured. You can "report" bad Extras as well
It’s great then.

Reporting a bug:
When I select an extra item, the desc tabs seems redirect to the [[++site_url]] only + #tab_name.]]>
https://forums.modx.com/thread/24485/modx-new-extra-section-a-great-resource-of-the-free-add-ons?page=4#dis-post-392717 Thu, 08 Sep 2011 06:13:35 +0000 https://forums.modx.com/thread/24485/modx-new-extra-section-a-great-resource-of-the-free-add-ons?page=4#dis-post-392717
<![CDATA[MODX website - Site gallery buggy?]]> https://forums.modx.com/thread/24516/modx-website---site-gallery-buggy#dis-post-125044 http://modx.com/learn/gallery

The first page load always works fine, if I scrolll down I see a bunch of different websites. Default it loads with evo and revo sites. After unchecking evo the gallery reloads. Here is where the weird behavior starts. It does show some revo websites but the same websites are repeated every other 6 rows. If I scroll down, row 7-12 and 13-18 is exactly the same as row 1-6. When checking evo again it doesn’t restore to the default situation, it’s still repeating. This behavior is the same with unchecking revo.

I use Ubuntu 11.4 and experienced this behavior in Chromium 12.0.742.112 and Firefox 5.0

Ciao kiss]]>
https://forums.modx.com/thread/24516/modx-website---site-gallery-buggy#dis-post-125044 Mon, 15 Aug 2011 01:16:59 +0000 https://forums.modx.com/thread/24516/modx-website---site-gallery-buggy#dis-post-125044
<![CDATA[Bug with site showcase]]> https://forums.modx.com/thread/24514/bug-with-site-showcase#dis-post-125038
http://modx.com/learn/gallery/?product[]=revolution&mode=mostrecent
]]>
https://forums.modx.com/thread/24514/bug-with-site-showcase#dis-post-125038 Thu, 11 Aug 2011 04:04:45 +0000 https://forums.modx.com/thread/24514/bug-with-site-showcase#dis-post-125038
<![CDATA[Is wiki.modxcms.com down?]]> https://forums.modx.com/thread/24512/is-wiki-modxcms-com-down#dis-post-125034
I hope this is only temporary since I would miss it greatly. It contains useful snippet documentations and howtos. Also some of the Evolution api was documented only there afaik.]]>
https://forums.modx.com/thread/24512/is-wiki-modxcms-com-down#dis-post-125034 Mon, 11 Jul 2011 06:26:28 +0000 https://forums.modx.com/thread/24512/is-wiki-modxcms-com-down#dis-post-125034
<![CDATA[What happened to modx wiki]]> https://forums.modx.com/thread/24513/what-happened-to-modx-wiki#dis-post-125037 http://wiki.modxcms.com/. What happened here?]]> https://forums.modx.com/thread/24513/what-happened-to-modx-wiki#dis-post-125037 Fri, 08 Jul 2011 06:57:36 +0000 https://forums.modx.com/thread/24513/what-happened-to-modx-wiki#dis-post-125037 <![CDATA[login problem]]> https://forums.modx.com/thread/24511/login-problem#dis-post-125025 I hope my problem is different.

Once I had an account on the old modxcms.com, I was able to use it, but now I can’t get in.
My username is vhollo, email is vhollo [at] gmail [dot] com, and I guess a bunch of possible passwords.
When trying to reset the password, no email is sent - nor upon username, nor on giving my email.
When trying to register a new account with this username, the system says it’s already taken. Hmmm... vhollo is me. I suppose I did take it, not anyone else. However, I can’t have it.

Could someone help me?]]>
https://forums.modx.com/thread/24511/login-problem#dis-post-125025 Mon, 06 Jun 2011 04:17:04 +0000 https://forums.modx.com/thread/24511/login-problem#dis-post-125025
<![CDATA[modxcms.com infected with malware?]]> https://forums.modx.com/thread/24472/modxcms-com-infected-with-malware?page=2#dis-post-124797
My pc was infected two times with malware (fake virus scanner and trojan) by visiting modxcms.com !
I guess the modx page is infected. I’m can’t say it 100% but I believe so.
I reformated my pc and opened firefox to visit modxcms.com and I was infected immediately again.

Then I was searching the web and I’m not alone:
http://webcache.googleusercontent.com/search?q=cache:8OTyr3N8gM8J:forums.malwarebytes.org/index.php%3Fshowtopic%3D71392+modxcms.com+malware&cd=3&hl=de&ct=clnk&gl=de&source=www.google.de

Please check this!
Thanks!]]>
https://forums.modx.com/thread/24472/modxcms-com-infected-with-malware?page=2#dis-post-124797 Fri, 27 May 2011 12:17:28 +0000 https://forums.modx.com/thread/24472/modxcms-com-infected-with-malware?page=2#dis-post-124797
<![CDATA[Typos]]> https://forums.modx.com/thread/24510/typos#dis-post-125022 http://modx.com/partners/program/compare-partner-levels/

MODX Partner Listing
The MODX Solution Partner Directory provides organizations looking for help with MODX the jumping off point for sourcing premiere MDOX developers.

and possibly a word missing here?
MODX partners tend to grow fast and need great hires. If you need to bring additional talent on board to keep up with your growth ...

Don’t mean to be nit-picky, but many hands make light work and all wink
]]>
https://forums.modx.com/thread/24510/typos#dis-post-125022 Sat, 21 May 2011 08:14:01 +0000 https://forums.modx.com/thread/24510/typos#dis-post-125022
<![CDATA[Wikispam?]]> https://forums.modx.com/thread/24503/wikispam#dis-post-124991

http://wiki.modxcms.com/index.php/Main_Page]]>
https://forums.modx.com/thread/24503/wikispam#dis-post-124991 Fri, 06 May 2011 02:27:04 +0000 https://forums.modx.com/thread/24503/wikispam#dis-post-124991
<![CDATA[Finding posts on Forum]]> https://forums.modx.com/thread/24508/finding-posts-on-forum#dis-post-125018 https://forums.modx.com/thread/24508/finding-posts-on-forum#dis-post-125018 Wed, 04 May 2011 02:21:00 +0000 https://forums.modx.com/thread/24508/finding-posts-on-forum#dis-post-125018 <![CDATA[modx.com registration form silently fails]]> https://forums.modx.com/thread/24506/modx-com-registration-form-silently-fails#dis-post-125006
I’ve been told I have to report this on the forums as well, so here goes.

1) Your registration form SILENTLY fails when you register a new account. No error, no confirmation, no message that something is wrong in your backend, nothing. Did I tell you I think this is awful? First people tell me to stop venting on twitter and start submitting bugreports, then they tell me to go to the forum to tell you guys that I can’t file bugreports because the ’register an account’ form is broken, woohoo lucky me that registering an account on the forum works smiley

I had Jay Gilmore on skype yesterday, who told me it has been fixed, however I still get a silent fail every time I try to register.

2) If you enter an ’incorrect username / password’ today (after it has been ’fixed’) you don’t get a message that the user/pass is incorrect, you’ll get an HTTP 500 Internal Server Error.

So please:
1) Fix the 500 internal server error on incorrect username / password.
2) Fix any scenarios where your login form could silently fail. (You should NEVER silently fail, it’s by far the worst / most frustrating experience you can give a new user like me.)
3) Test if you can now properly register a new account (don’t just test that, test all scenarios and verify that you’ll get the proper response / error message and no silent failures).

Here’s what I tried:
- Register in Chrome 10
- Register in Chrome 11 (today)
- Register in Firefox 4
- Tried all of the above in ’Incognito mode’ so no cookies are used
- Tried clearing my flash cookies (because I’m not sure what these do in incognito mode)

Oh, and I’m on Windows 7.]]>
https://forums.modx.com/thread/24506/modx-com-registration-form-silently-fails#dis-post-125006 Thu, 28 Apr 2011 09:25:25 +0000 https://forums.modx.com/thread/24506/modx-com-registration-form-silently-fails#dis-post-125006
<![CDATA[MODX.com broken links]]> https://forums.modx.com/thread/24505/modx-com-broken-links#dis-post-125001 http://modx.com/services/request-a-quote/ the link to the help wanted board (/shop/) gives a 404.

You may also want to check the children of a reusable container to see if they’re published, seeing some funny things here after a random search..

Seen more 404’s, but forgot to put them somewhere sad Will let you guys know when I find more. tongue]]>
https://forums.modx.com/thread/24505/modx-com-broken-links#dis-post-125001 Wed, 20 Apr 2011 06:52:13 +0000 https://forums.modx.com/thread/24505/modx-com-broken-links#dis-post-125001