mxFormBuilder - MODX Community Forums https://forums.modx.com/board/?board=275 <![CDATA[Is it worth saving?]]> https://forums.modx.com/thread/104603/is-it-worth-saving#dis-post-562610
Cheers]]>
https://forums.modx.com/thread/104603/is-it-worth-saving#dis-post-562610 Thu, 08 Nov 2018 11:14:31 +0000 https://forums.modx.com/thread/104603/is-it-worth-saving#dis-post-562610
<![CDATA[mxFormBuilder does not display on page; help?]]> https://forums.modx.com/thread/99918/mxformbuilder-does-not-display-on-page-help#dis-post-540628
I apologize in advance for posting in an old forum (I see most of the posts here are from a few years ago!) but I thought I would reach out in case we still have any active mxForm users. I'm a ModX newbie so perhaps this is an easy fix!

I am attempting to implement an mxFormBuilder form into a page, but I am unable to get the form to display. Here's a little more info:

Test page in question: http://www.ridgecrestvillage.org/index.php?id=130
Version of ModX I am using: MODX Revolution 2.2.12-pl (traditional)
I am inserting the TV directly into the page content, and have tried using both the cached and non-cached (!) version:
[[!mxfb?&formid=`1`]]



A few things about the form:
* I am using a success message
* None of my fields require basic spam validation



Where am I going wrong?

P.S. I had a few errors pop up when installing the plugin, but thus far haven't had any issues with creating forms. Example part of the log:
PHP warning: preg_match(): Compilation failed: invalid range in character class at offset 38

PHP notice: Array to string conversion

chunk_err_createArray

Error saving vehicle object of class modChunk; criteria: Array
(
    [name] => emailUserTpl
)


Full error output is attached.

Any help is very appreciated! smiley]]>
https://forums.modx.com/thread/99918/mxformbuilder-does-not-display-on-page-help#dis-post-540628 Mon, 18 Apr 2016 02:00:01 +0000 https://forums.modx.com/thread/99918/mxformbuilder-does-not-display-on-page-help#dis-post-540628
<![CDATA[mxFormBuilder...not working...stumped]]> https://forums.modx.com/thread/88258/mxformbuilder-not-working-stumped?page=2#dis-post-534182
I'm a bit stumped here.

I have mxFormBuilder installed and set up. Everything is working (creating forms, adding fields, putting them on pages with the TVs...etc) with one exception.

The forms don't do anything.

I have a variety of forms setup. I've added a few fields, added the submit button and when you click "submit" the form just resets. Nothing is submitted.

I made sure that the only button I have is a "submit" button. But no matter what, nothing submits. It just resets the form.

I'm completely stumped.

Is there a setting somewhere that I've missed to enable the actual processing of forms? Is there something else I need to configure (manually) after the Package installs?

I'm happy to provide code samples if that would help.

Really like the package and the ease of building and applying forms, but I can't get it to actually send/submit a form.

Thanks!

-Justin]]>
https://forums.modx.com/thread/88258/mxformbuilder-not-working-stumped?page=2#dis-post-534182 Mon, 09 Nov 2015 10:39:34 +0000 https://forums.modx.com/thread/88258/mxformbuilder-not-working-stumped?page=2#dis-post-534182
<![CDATA[mxFormBuilder window opens briefly then blank]]> https://forums.modx.com/thread/92724/mxformbuilder-window-opens-briefly-then-blank?page=2#dis-post-520863
However upon invoking it from Extras -> mxFormBuider it initially loads ok, but on completion of loading the browser window goes completely blank. That is, there are no menus, logos or page elements of any kind (although the page source looks ok). The only way to get back into MODX is to hit the back button on the browser. Tried it in Firefox and Chrome, same result.

Does anyone know what's up with that?

MODX Revolution 2.3.1 (traditional)
PHP 5.2.17
MySQL 5.0.77]]>
https://forums.modx.com/thread/92724/mxformbuilder-window-opens-briefly-then-blank?page=2#dis-post-520863 Wed, 18 Feb 2015 12:56:27 +0000 https://forums.modx.com/thread/92724/mxformbuilder-window-opens-briefly-then-blank?page=2#dis-post-520863
<![CDATA[mxfb - Success Message RTE saving error]]> https://forums.modx.com/thread/95636/mxfb---success-message-rte-saving-error#dis-post-517637
If any html tags are inserted (<strong>, <em>, etc), the following error occurs on save:

Uncaught SyntaxError: Invalid regular expression: missing /

This is the bit that is malformed:
({"success":true,"message":"","total":0,"data":[],"object":{"form_id":1,"name":"sss","enablepages":false,"active":false,"owners":"","emailrecipients":"","opendate":0,"closedate":0,"maxnumbersubmissions":0,"successmessage":"dsf<b>sdfds<\/b>","successtargetdocid":0,"successredirectenable":false,"maxreachedmessage":"","context":"All","createdon":1419825711,"createdby":1,"editedon":1419826190,"editedby":1,"action":"mgr\/forms\/update"}}</b>)


in the successmessage parameter, it is not encoding/escaping the first <b> tag, but it is the closing tag, and that is wigging out the JSON string

Is there something that I can add to the update.class.php to clean this up?

]]>
https://forums.modx.com/thread/95636/mxfb---success-message-rte-saving-error#dis-post-517637 Mon, 29 Dec 2014 10:40:08 +0000 https://forums.modx.com/thread/95636/mxfb---success-message-rte-saving-error#dis-post-517637
<![CDATA[mxfb & MODX 2.3.x - quick fix for Users and Contexts superboxselect]]> https://forums.modx.com/thread/95635/mxfb-modx-2-3-x---quick-fix-for-users-and-contexts-superboxselect#dis-post-517606
Anywhere you find
url: MODx.config.connector_url+'folder/some_connector.php',
baseParams: { action: 'getlist'},


you will need to change to
    	,url: MODx.config.connector_url
        ,baseParams: {
            action: 'folder/some_connector/getlist'
        }


This is due to the way 2.3 handles connectors from what I have gathered on the forums.

Another thing that has to change for the SuperBoxSelect to show up properly in mxfb is the class.

        ,clearBtnCls: 'x-form-trigger'
        ,expandBtnCls: 'x-form-trigger'

needs to be added (and any other old tagClass needs to be removed) so that the select box renders properly in 2.3.

Here is my refactored code to get the Users superselectbox working in 2.3:
MODx.combo.Users = function (config, getStore) {
    config = config || {};
    Ext.applyIf(config, {
        name: 'fake_users'
        ,hiddenName: 'fake_users'
        ,valueField: "id"
        ,displayField: "username"
        ,mode: 'remote'
        ,triggerAction: 'all'
        ,typeAhead: true
        ,editable: true
        ,forceSelection: false
        ,clearBtnCls: 'x-form-trigger'
        ,expandBtnCls: 'x-form-trigger'
    	,xtype:'superboxselect'
    	,url: MODx.config.connector_url
        ,baseParams: {
            action: 'security/user/getlist'
        }
        ,fields: ['username', 'id']
    });
    Ext.applyIf(config,{
        
	store: new Ext.data.JsonStore({
	    url: config.url
            ,root: 'results'
            ,fields: config.fields
            ,errorReader: MODx.util.JSONReader
            ,baseParams: config.baseParams || {}
            ,remoteSort: config.remoteSort || false
            ,autoDestroy: true
	,listeners: {
                    'load': {fn:function(store, records, options ) {
                    }}
                    ,scope : this
                }
	})
        ,listeners: {
            'beforeselect': {fn:function(combo, record, index ) {
                if (record.data.is_parent == '1'){
                    return false;
                }
            }}
            ,scope : this
        }  
    });
    if (getStore === true) {
        config.store.load();
        return config.store;
    }
    MODx.combo.Users.superclass.constructor.call(this, config);
    this.config = config;
    return this;
};
Ext.extend(MODx.combo.Users, Ext.ux.form.SuperBoxSelect);
Ext.reg('modx-superbox-user', MODx.combo.Users);
]]>
https://forums.modx.com/thread/95635/mxfb-modx-2-3-x---quick-fix-for-users-and-contexts-superboxselect#dis-post-517606 Sun, 28 Dec 2014 09:55:45 +0000 https://forums.modx.com/thread/95635/mxfb-modx-2-3-x---quick-fix-for-users-and-contexts-superboxselect#dis-post-517606
<![CDATA[Success Redirect : not loading resources in the list]]> https://forums.modx.com/thread/95487/success-redirect-not-loading-resources-in-the-list#dis-post-516995
When creating a new form, Enable Redirect is checked but the Success Redirect list tries to load the resources without success.

]]>
https://forums.modx.com/thread/95487/success-redirect-not-loading-resources-in-the-list#dis-post-516995 Thu, 18 Dec 2014 09:37:54 +0000 https://forums.modx.com/thread/95487/success-redirect-not-loading-resources-in-the-list#dis-post-516995
<![CDATA[How to create arbitrary form + send mail]]> https://forums.modx.com/thread/92210/how-to-create-arbitrary-form-send-mail#dis-post-506684
How to create a custom form template output as Formit + Send to mail]]>
https://forums.modx.com/thread/92210/how-to-create-arbitrary-form-send-mail#dis-post-506684 Sun, 17 Aug 2014 12:31:22 +0000 https://forums.modx.com/thread/92210/how-to-create-arbitrary-form-send-mail#dis-post-506684
<![CDATA[Request for revise to mxformbuilder.class.php]]> https://forums.modx.com/thread/92299/request-for-revise-to-mxformbuilder-class-php#dis-post-506683
on line 738 of mxformbuilder.class.php, can you either change the line to be
$this->modx->regClientScript($this->config['assetsUrl']."js/web/jquery.validate.min.js");


or give a setting option to allow for the validate link to be put at the bottom? Issue is that in my jQuery doesn't load until the end of the doc, and currently mxFormBuilder loads the validate script in the head (and thus it can't find jquery)

Thanks
Jason]]>
https://forums.modx.com/thread/92299/request-for-revise-to-mxformbuilder-class-php#dis-post-506683 Sun, 17 Aug 2014 12:26:59 +0000 https://forums.modx.com/thread/92299/request-for-revise-to-mxformbuilder-class-php#dis-post-506683
<![CDATA[Make submissions UTF8 encoded?]]> https://forums.modx.com/thread/91842/make-submissions-utf8-encoded#dis-post-504090 Is there a way to modify this plugin or if there is a setting I have missed to get special characters working?

I've tried to use mxFormBuilder with a page made in german, but all special characters are changed to html encoded characters. So characters like åäö are converted to öäåö.
Any suggestions on how I can fix this?

This is a great plugin by the way! Good work!]]>
https://forums.modx.com/thread/91842/make-submissions-utf8-encoded#dis-post-504090 Tue, 22 Jul 2014 07:51:51 +0000 https://forums.modx.com/thread/91842/make-submissions-utf8-encoded#dis-post-504090
<![CDATA[Change field chunks]]> https://forums.modx.com/thread/91259/change-field-chunks#dis-post-500615 I have tried to modify core/components/mxformbuilder/elements/chunks/field.text.chunk.tpl but nothing at all happens to the form. Nothing that I add changes anything. Are the chunks located in a different place?

Thanks.
André]]>
https://forums.modx.com/thread/91259/change-field-chunks#dis-post-500615 Mon, 16 Jun 2014 11:38:05 +0000 https://forums.modx.com/thread/91259/change-field-chunks#dis-post-500615
<![CDATA[Feedback & General Conversation]]> https://forums.modx.com/thread/81911/feedback-general-conversation?page=3#dis-post-497521
Cheers]]>
https://forums.modx.com/thread/81911/feedback-general-conversation?page=3#dis-post-497521 Fri, 09 May 2014 10:13:41 +0000 https://forums.modx.com/thread/81911/feedback-general-conversation?page=3#dis-post-497521
<![CDATA[mxFormBuilder hook: best way to add email addresses to owners]]> https://forums.modx.com/thread/90116/mxformbuilder-hook-best-way-to-add-email-addresses-to-owners#dis-post-495352
I have the Country<->Contact info set up in a simple MIGX TV.

Once I match the $fields['fldxx']['fld_country_value'] to an entry in the TV, and have the additional email address, how do I add it to the email send that mxfb is getting ready to do?

It looks like its owner property is an id number (these extra email addresses are not in the modx system). Is there a way to append it with a string email address?]]>
https://forums.modx.com/thread/90116/mxformbuilder-hook-best-way-to-add-email-addresses-to-owners#dis-post-495352 Fri, 18 Apr 2014 11:59:17 +0000 https://forums.modx.com/thread/90116/mxformbuilder-hook-best-way-to-add-email-addresses-to-owners#dis-post-495352
<![CDATA[Enhancement Request - Submit a requested feature here]]> https://forums.modx.com/thread/87289/enhancement-request---submit-a-requested-feature-here#dis-post-495244
Cheers]]>
https://forums.modx.com/thread/87289/enhancement-request---submit-a-requested-feature-here#dis-post-495244 Wed, 16 Apr 2014 11:02:51 +0000 https://forums.modx.com/thread/87289/enhancement-request---submit-a-requested-feature-here#dis-post-495244
<![CDATA[Closed Beta: All conversations regarding the beta test group]]> https://forums.modx.com/thread/81912/closed-beta-all-conversations-regarding-the-beta-test-group?page=3#dis-post-474660
Open to general public viewing as well.

Cheers]]>
https://forums.modx.com/thread/81912/closed-beta-all-conversations-regarding-the-beta-test-group?page=3#dis-post-474660 Mon, 12 Aug 2013 06:20:04 +0000 https://forums.modx.com/thread/81912/closed-beta-all-conversations-regarding-the-beta-test-group?page=3#dis-post-474660