Evolution 1.0.6 - MODX Community Forums https://forums.modx.com/board/?board=273 <![CDATA[Not showing thumbnails image on sitepages]]> https://forums.modx.com/thread/101408/not-showing-thumbnails-image-on-sitepages#dis-post-547077 Clean the site, after virus attack (https://forums.modx.com/thread/101390/evolution-1-1-and-prior-remote-execution), but there was a nuisance - stopped working thumbnails of pictures:

Error message in the debug console chrome:
http://www.domain.ru/image.php?src=assets/images/pic_271_170/2014-11-06-05-image.jpg&wp=271&hp=170&q95&hash=86ede1d226ee748f87d3e13b259004d4
Failed to load resource: the server responded with a status of 404 (Not Found)

Tell me, please, what could be, what to improve?
It is not updated to 1.2, plan the weekend, is now 1.0.6]]>
https://forums.modx.com/thread/101408/not-showing-thumbnails-image-on-sitepages#dis-post-547077 Fri, 09 Dec 2016 07:30:25 +0000 https://forums.modx.com/thread/101408/not-showing-thumbnails-image-on-sitepages#dis-post-547077
<![CDATA[Stopped to work with PHP 5.5 after update from PHP 5.3]]> https://forums.modx.com/thread/99142/stopped-to-work-with-php-5-5-after-update-from-php-5-3#dis-post-536178
My site stopped to work with PHP 5.5 after update from PHP 5.3

The error is
PHP error debug
Error: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead
Error type/ Nr.: - 8192
File: /home/4/u/ulsrud/www/manager/includes/extenders/dbapi.mysql.class.inc.php

I need to updagrade, but now sure what version I should upgrade to?

Can I upgrade right to 1.0.15?
Or I should take every version from 1.0.6 to 1.0.15 version to version?

I don't want to take an unnecessary risk.
]]>
https://forums.modx.com/thread/99142/stopped-to-work-with-php-5-5-after-update-from-php-5-3#dis-post-536178 Sun, 20 Dec 2015 04:52:46 +0000 https://forums.modx.com/thread/99142/stopped-to-work-with-php-5-5-after-update-from-php-5-3#dis-post-536178
<![CDATA[Friеndly URLs, resource with cyrillic alias within a container with latin alias - issue]]> https://forums.modx.com/thread/98536/fri-ndly-urls-resource-with-cyrillic-alias-within-a-container-with-latin-alias---issue#dis-post-532914
I was assigned the task of moving an old ModX 1.06 instance to a new server. First of all I want to point out that it was a horrible experience so far smiley Putting that aside, I can't figure out this last (I hope) issue, so please help me smiley

The issue is that some of the friendly urls aren't working and I cannot tell why
This is the resource structure:
* My Home
    - BG - container
        > Начало - content
        > За нас - content
        > Проекти - container
            * Project 1 - content
            * Project 2 - content
    - EN - container
        > Home - content
        > About us - content
        > Projects - container
            * Project 1 - content
            * Project 2 - content
    - RU - container
        > Начало - content
        > Для нас - content
        > Проекты - container
            * Project 1 - content
            * Project 2 - content


Aliases are using the resource name, so the alias for the BG container is 'bg', for the content 'Начало' in 'BG' it is - 'за-нас'. The friendly url for it should be http://example.com/bg/за-нас but trying to access it loads the home page. Which seems to be the way ModX handles 404 errors when there is no resource id set to handle them.

If I try to access http://example.com/en/about-us it loads the content that it should. But it seems that when the alias is written in cyrillic it doesn't work.

I tried disabling the friendly urls and everything works perfect. Also enabled direct access to the resource so http://example.com/за-нас would work and it does.

MySQL tables collation is utf8_general_ci
$database_connection_charset = 'utf8';
mysqldump on the old server was performed with --default-character-set=utf8
Import via phpMyAdmin was done with the utf8 connection option enabled.

.htaccess rewrite rules:
# For Friendly URLs
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

MODX_SITE_URL is http://example.com
MODX_BASE_URL is / (modx is in the public_html directory)
MODX_BASE_PATH is /home/example.com/public_html/

I added <base href="[(site_url)]"> to the header because it was missing, but it didn't change anything.

Apache/2.2.29, PHP/5.4.39

curl -I http://example.com/bg/за-нас gives Content-Type: text/html; charset=UTF-8

So it seems i am out of options that I can think of. Please help smiley

p.s. I have no previous experience with ModX, so don't rule out the obvious smiley
]]>
https://forums.modx.com/thread/98536/fri-ndly-urls-resource-with-cyrillic-alias-within-a-container-with-latin-alias---issue#dis-post-532914 Thu, 08 Oct 2015 10:05:57 +0000 https://forums.modx.com/thread/98536/fri-ndly-urls-resource-with-cyrillic-alias-within-a-container-with-latin-alias---issue#dis-post-532914
<![CDATA[Re: Horrible system!!! Two days can not run.]]> https://forums.modx.com/thread/98028/re-horrible-system-two-days-can-not-run#dis-post-530187 Maybe in the index.php is the debugging active?

// Debugging mode:
$modx->stopOnNotice = false;
]]>
https://forums.modx.com/thread/98028/re-horrible-system-two-days-can-not-run#dis-post-530187 Tue, 18 Aug 2015 10:20:40 +0000 https://forums.modx.com/thread/98028/re-horrible-system-two-days-can-not-run#dis-post-530187
<![CDATA[Site Hacked. AD inserted at bottom of page]]> https://forums.modx.com/thread/84064/site-hacked-ad-inserted-at-bottom-of-page?page=2#dis-post-529609
<p><map name="Map">
  <area shape="rect" coords="75,1,109,24" href="[~4~]" alt="Contact Us">
  <area shape="rect" coords="37,1,71,24" href="[~7~]" alt="Site Map">
  <area shape="rect" coords="-1,1,33,24" href="[(base_url)]" alt="Home Page">
</map></p>

</body>
</html>

The ads div has absolute positioning that pushes it off the top-left of the page. I downloaded a fresh copy of 1.0.6 from the MODX site and took a dump of the database. I uploaded these along with my template files to a different shared hosting account but the ad still appears.

I am really at a loss as to how to track this down and remove it. Any suggestions would be greatly appreciated!]]>
https://forums.modx.com/thread/84064/site-hacked-ad-inserted-at-bottom-of-page?page=2#dis-post-529609 Thu, 06 Aug 2015 05:40:02 +0000 https://forums.modx.com/thread/84064/site-hacked-ad-inserted-at-bottom-of-page?page=2#dis-post-529609
<![CDATA[Layout problems in versions of IE]]> https://forums.modx.com/thread/90973/layout-problems-in-versions-of-ie#dis-post-498415
Currently experiencing issues with the layout of our site in Internet explorer (no surprise there!). The website is working fine in every other browser. When you click on the navigation bars on the left such as Full time courses and Part time/Love2Learn courses, none of the listings are appearing, I've added a screenshot here: http://imgur.com/ML3BYRk

The website also changes regarding the font size, colour and a few elements are out of place such as the slider at the top of the page. The website address is www.citybathcoll.ac.uk if you want to see it first hand. Any help would be seriously appreciated, Thanks.]]>
https://forums.modx.com/thread/90973/layout-problems-in-versions-of-ie#dis-post-498415 Thu, 22 May 2014 03:10:25 +0000 https://forums.modx.com/thread/90973/layout-problems-in-versions-of-ie#dis-post-498415
<![CDATA[Character escaping problems in JavaScript code in TemplateVariable value]]> https://forums.modx.com/thread/89665/character-escaping-problems-in-javascript-code-in-templatevariable-value#dis-post-493524
I have tried using "@CHUNK chunkname" as the value, and also pasting the full code into the Template Variable creation form, but neither seems to work.

Both the data-in-field and @CHUNK method seem to end up with the TV data being embedded in the page editor form (view source) when I edit a page which uses this TV.

I suspect that the problem is caused by the JavaScript code containing the MODx TV value separator ("||"), as follows:

var _paq = _paq || [];


as when I look in the page editor form source it closes the 'value' string after the _paq text and then proceeds with

id="tv_0" name="tv15[]"  onchange="documentDirty=true;" /><label for="tv_0">


at which point my text gets inserted (starting from the beginning again) with the label above closing after _paq (again, getting caught by the TV value separator) and then the rest of my text getting mashed into a checkbox input value with the HTML special characters escaped.

This then gets tangled up with the "Settings" tab in the MODx editor and it all goes wrong from there..

Is there any way that I can safely insert this code into a TV?

I have attached the intended code and the faulty page source as it is probably a bit hard to explain otherwise!

]]>
https://forums.modx.com/thread/89665/character-escaping-problems-in-javascript-code-in-templatevariable-value#dis-post-493524 Tue, 25 Mar 2014 07:49:31 +0000 https://forums.modx.com/thread/89665/character-escaping-problems-in-javascript-code-in-templatevariable-value#dis-post-493524
<![CDATA[Error due to a PHP upgrade]]> https://forums.modx.com/thread/77904/error-due-to-a-php-upgrade?page=2#dis-post-485550
Due to a PHP upgrade (5.3 to 5.4) , the following error has occured:
« MODx Parse Error »
MODx encountered the following error while attempting to parse the requested resource:
« PHP Parse Error »

PHP error debug
Error: Non-static method ditto::buildURL() should not be called statically, assuming $this from incompatible context
Error type/ Nr.: - 2048
File: /srv/data/web/vhosts/www.soluprest.com/htdocs/assets/snippets/ditto/extenders/tagging.extender.inc.php
Line: 319
Line 319 source: $url = ditto::buildURL("tags=$tag&start=0",$tagDocID);

PHP Version 5.4.4-2
MODx Evolution 1.0.6

Thanks a lot for help.
Loic]]>
https://forums.modx.com/thread/77904/error-due-to-a-php-upgrade?page=2#dis-post-485550 Wed, 18 Dec 2013 03:48:23 +0000 https://forums.modx.com/thread/77904/error-due-to-a-php-upgrade?page=2#dis-post-485550
<![CDATA[AjaxSearch with custom input criteria of &tplInput not work when 2 instances and ajax mode =1]]> https://forums.modx.com/thread/88013/ajaxsearch-with-custom-input-criteria-of-tplinput-not-work-when-2-instances-and-ajax-mode-1#dis-post-484538
I have a need to run 2 instances of AjaxSearch: 1 snippet call per one Tab (See attached preview).

The problem is that there are a several troubles:

1. it alerts "AjaxSearch version obsolete. Empty your browser cache and check the version of AjaxSearch-jQuery.js file" on page load. I have read the forum post about fixing it with cleaning up the cache,etc, inc comparing and making sure that JS is of the same version as php.. but it does not help .. so I just skipped this problem and click OK to let the page load.

2. when page ready and tabs shown, user can click to tab HOUSE or CONDO. HOUSE tab have a hidden input field for TV property = house, and tab CONDO has nearly the same snippet call but hidden input field for TV property = condo. There are more select boxes like price, or number of rooms but at least it needs to search per selected tab and input string input type = text name = search. The thing is that despite the above js alert the AJAX request works per both tabs but it does not run in advanced mode. I mean it does not react to the value of hidden input called property. I have noted that it actually loads the custom config but seems does not use the function inside of it.

Here are more details:

2 snippets calls:

 [!AjaxSearch?
&ajaxSearch=`2`
&asId=`asc` 
&addJscript=`0`
&jscript=`jquery`
&parents=`1,40,1068`
&tplInput=`realEstate1InputCnd`
&config=`realEstate`
&withTvs=`+:property,bedrooms1,location,condorentprice,condosaleprice` 
&tvPhx=`property,bedrooms1,location,condorentprice,condosaleprice` 
&tplResult=`realEstate1Result1`
&debug=`3`
&whereSearch=`content|tv` 
&minChars=`0` &showPagingAlways=`1`
 !]


&config=`realEstate` is
<?php
/* -----------------------------------------------------------------------------
* Input 4, 5 & 6 Form configuration
* ------------------------------------------------------------------------------
* @author       Coroico <coroico@wangba.fr>
* Purpose:
 
*/

if(!function_exists('asfConfig')) {
    function asfConfig($form, & $get){
        global $modx;
        $where_array = array();
        $where = '';

        global $modx;
        switch ($form) { 
            case "restate":
                unset($ctg, $tag, $loc);
		//tv property
                if ((isset($_POST['property']) && $_POST['property']!='') || (isset($_GET['property']) && $_GET['property']!='')){
                    $ctg = isset($_POST['property']) ? strip_tags($_POST['property']) : strip_tags($_GET['property']);
                    $get['property'] = $ctg;
                    $where_array[] = 'FIND_IN_SET(\'' . $ctg .'\',property)';
                }
		//tv bedrooms1
                if ((isset($_POST['bedrooms1']) && ($_POST['bedrooms1'])!='') || (isset($_GET['bedrooms1']) && ($_GET['bedrooms1']!=''))){
                    $tag = isset($_POST['bedrooms1']) ? strip_tags($_POST['bedrooms1']) : strip_tags($_GET['bedrooms1']);
                    $get['bedrooms1'] = $tag;
                    $where_array[] = 'FIND_IN_SET(\'' . $tag .'\',bedrooms1)';
                }

                // Location
                if ((isset($_POST['location'])  && ($_POST['location']!='')) || (isset($_GET['location'])  && ($_POST['location']!=''))){
                    $loc = isset($_POST['location']) ? strip_tags($_POST['location']) : strip_tags($_GET['location']);
                    $get['location'] = $loc;
                    $where_array[] = 'FIND_IN_SET(\'' . $loc .'\',location)';
                }

                // condorentprice
                if ((isset($_POST['condorentprice'])  && ($_POST['condorentprice']!='')) || (isset($_GET['condorentprice'])  && ($_POST['condorentprice']!=''))){
                    $pr1 = isset($_POST['condorentprice']) ? strip_tags($_POST['condorentprice']) : strip_tags($_GET['condorentprice']);
                    $get['condorentprice'] = $pr1;
                    $where_array[] = 'FIND_IN_SET(\'' . $pr1 .'\',condorentprice)';
                }
		//condosaleprice
                if ((isset($_POST['condosaleprice'])  && ($_POST['condosaleprice']!='')) || (isset($_GET['condosaleprice'])  && ($_POST['condosaleprice']!=''))){
                    $pr2 = isset($_POST['condosaleprice']) ? strip_tags($_POST['condosaleprice']) : strip_tags($_GET['condosaleprice']);
                    $get['condosaleprice'] = $pr2;
                    $where_array[] = 'FIND_IN_SET(\'' . $pr2 .'\',condosaleprice)';
                }

 
                $where = implode(' AND ',$where_array); 
                break;
        }
	 
	 
        return $where;
    }
}

?>


in non-ajax mode the sql "FIND_IN_SET" is there and it works but in ajax-mode enabled it looks like there is no sql "FIND_IN_SET" in SQL criteria. Please see log: http://pastebin.com/HJHJk7YU

The input realEstate1InputCnd tpl is
[+as.showInputForm:is=`1`:then=`
<div class="restateInput">
<form action="[+as.formAction+]" method="post"  id="[+as.formId+]" >
    <fieldset class="inputAS2">
   [+as.showAsId:is=`1`:then=`<input type="hidden" name="[+as.asName+]" value="[+as.asId+]" />`+]
     <input type="hidden" name="asf" value="restate" />
    <div>    
              <input type="hidden" name="property" value="Condo" />
    </div> 
   <div>
          <label>Number of Bedrooms:</label> [[AsSelectTv? &name=`bedrooms1`  &tvName=`bedrooms1`  &filter=`bedrooms1` &tplName=`New Condo for Sale` &first=``]]
    </div><br />
   <div>
          <label>Location:</label> [[AsSelectTv? &name=`location`  &tvName=`location`  &filter=`location` &tplName=`New Condo for Sale` &first=``]]
    </div><br />

   <div>
          <label>Size:</label> <!-- [[AsSelectTv? &name=`location`  &tvName=`location`  &filter=`location` &tplName=`New Condo for Sale` &first=``]] -->
    </div><br />

   <div>
          <label>Price:</label> rent [[AsSelectTv? &name=`condorentprice`  &tvName=`condorentprice`  &filter=`condorentprice` &tplName=`New Condo for Rent` &first=``]] 
                                                sale [[AsSelectTv? &name=`condosaleprice`  &tvName=`condosaleprice`  &filter=`condosaleprice` &tplName=`New Condo for Sale` &first=``]] 
    </div><br />
     <div>
          <label>ref Number:</label><input id="[+as.inputId+]" class="cleardefault" type="text" name="search" value="" />
    </div><br />   
    <br /><br />
    <input id="[+as.submitId+]" type="submit" name="sub" value="Property Search" />
    </fieldset>
</form>
</div>
<br />
`+]


The second tab for HOUSE has snippet call:
 [!AjaxSearch?
&ajaxSearch=`2`
&asId=`ash` 
&jscript=`jquery`
&addJscript=`0`
&parents=`1,40,1068`
&tplInput=`realEstate1InputHouse`
&config=`realEstate`
&withTvs=`+:property,bedrooms1,location,houserentprice,housesaleprice` 
&tvPhx=`property,bedrooms1,location,houserentprice,housesaleprice` 
&tplResult=`realEstate1Result1`
&debug=`3`
&whereSearch=`content|tv` 
&minChars=`0` &showPagingAlways=`1`
 !]
and it's input tpl is
[+as.showInputForm:is=`1`:then=`
<div class="restateInput">
<form action="[+as.formAction+]" method="post"  id="[+as.formId+]" >
    <fieldset class="restate">
     <input type="hidden" name="asf" value="restate" />
    <div>
           <input type="hidden" name="property" value="House" />
    </div><br />
   <div>
          <label>Number of Bedrooms:</label> [[AsSelectTv? &name=`bedrooms1`  &tvName=`bedrooms1`  &filter=`bedrooms1` &tplName=`New House for Sale` &first=``]]
    </div><br />
   <div>
          <label>Location:</label> [[AsSelectTv? &name=`location`  &tvName=`location`  &filter=`location` &tplName=`New House for Sale` &first=``]]
    </div><br />

   <!--div>
          <label>Size:</label--> <!-- [[AsSelectTv? &name=`location`  &tvName=`location`  &filter=`size` &tplName=`New House for Sale` &first=``]] -->
    <!--/div><br /-->

   <div>
          <label>Price:</label>rent [[AsSelectTv? &name=`condorentprice`  &tvName=`houserentprice`  &filter=`houserentprice` &tplName=`New House for Rent` &first=``]] 
                                                sale [[AsSelectTv? &name=`condosaleprice`  &tvName=`housesaleprice`  &filter=`housesaleprice` &tplName=`New House for Sale` &first=``]] 
                                                      
    </div><br />
     <div>
          <label>ref Number:</label><input id="[+as.inputId+]" class="cleardefault" type="text" name="search" value="" />
    </div><br />   
    <br /><br />
    <input id="[+as.submitId+]" type="submit" name="sub" value="Property Search" />
    </fieldset>
</form>
</div>
<br />
`+]


I have run through all js libs included and they seem to be loaded fine, nothing of 404 smiley

There are a few example of good use ajax mode but not of 2 instances with advanced type with custom input on http://www.evo.wangba.fr, http://www.evo.wangba.fr/index.php?id=188

There are also good examples of non ajax mode but with advanced mode http://www.evo.wangba.fr/index.php?id=239

Looks like either snippet calls are wrong or config wrong. Any idea?
]]>
https://forums.modx.com/thread/88013/ajaxsearch-with-custom-input-criteria-of-tplinput-not-work-when-2-instances-and-ajax-mode-1#dis-post-484538 Tue, 03 Dec 2013 06:37:19 +0000 https://forums.modx.com/thread/88013/ajaxsearch-with-custom-input-criteria-of-tplinput-not-work-when-2-instances-and-ajax-mode-1#dis-post-484538
<![CDATA[Request a look at my modx website which has freaked out]]> https://forums.modx.com/thread/87241/request-a-look-at-my-modx-website-which-has-freaked-out#dis-post-480633
I have a modx website at auctionbandits.com and until yesterday, all was fine. But yesterday afternoon I visited my site, to find that every page I went to would open for a moment, then shrinks to a tiny window in the corner. It did this on all of the several computers I've tried to access it on. What's weird is that the little box is a Wordpress login, and I don't even have Wordpress installed on my server. I also have not modified my site in months. I think I'm running 1.0.5 or 1.0.6 so I know I should upgrade, but I was wondering if anyone has seen anything like this before. Any insight to this weirdness is greatly appreciated!

- Cris]]>
https://forums.modx.com/thread/87241/request-a-look-at-my-modx-website-which-has-freaked-out#dis-post-480633 Sat, 19 Oct 2013 11:19:38 +0000 https://forums.modx.com/thread/87241/request-a-look-at-my-modx-website-which-has-freaked-out#dis-post-480633
<![CDATA[TinyMCE 3.3.9.2 stopped displaying Link list. Link list disappeared]]> https://forums.modx.com/thread/86768/tinymce-3-3-9-2-stopped-displaying-link-list-link-list-disappeared#dis-post-478239
It is now also gone when logged in as administrator. I've verified in the config settings of the plugin that Link list is enabled.

I seem to recall this happening once before but couldn't find anything in the forums. Would love some help on this.

Thanks!]]>
https://forums.modx.com/thread/86768/tinymce-3-3-9-2-stopped-displaying-link-list-link-list-disappeared#dis-post-478239 Thu, 19 Sep 2013 05:46:17 +0000 https://forums.modx.com/thread/86768/tinymce-3-3-9-2-stopped-displaying-link-list-link-list-disappeared#dis-post-478239
<![CDATA[Problems with \ and "]]> https://forums.modx.com/thread/85769/problems-with-and#dis-post-472804
when i change something in my templates

<div class="container">
<div class="header"><div class="jezici">
[[YAMS? &get=`repeat` &beforetpl=`@CODE:<ul>` &repeattpl=`otherFlagItemTpl` &currenttpl=`currentFlagItemTpl` &aftertpl=`@CODE:</ul>`]]
</div></div>

and save and close i get this. and my site is broken.

<div class=\"container\">
<div class=\"header\"><div class=\"jezici\">
[[YAMS? &get=`repeat` &beforetpl=`@CODE:<ul>` &repeattpl=`otherFlagItemTpl` &currenttpl=`currentFlagItemTpl` &aftertpl=`@CODE:</ul>`]]
</div></div>

why the system includes this \ before quoting marks.

maybe is the problem by Transalias plugin or by DB setting. on my plesk is the DB on utf8 and since we moved the site to another location DB has Swedish latin encoding. why? we imported the DB like UTF8!

every help will be appreciated.]]>
https://forums.modx.com/thread/85769/problems-with-and#dis-post-472804 Wed, 24 Jul 2013 12:43:57 +0000 https://forums.modx.com/thread/85769/problems-with-and#dis-post-472804
<![CDATA[Can't insert image with file browser]]> https://forums.modx.com/thread/81354/can-t-insert-image-with-file-browser#dis-post-471878
I can manually add the image by typing "assets/images/[filename]" in the add image dialogue box, so it doesn't seem like a permission issue that I can think of.

I don't see any error in the logs either.

I did upgrade to TinyMCE 3.2.4 to try and fix it but no change.

Evolution 1.06
UNIX, Apache,PHP 5.3.4
Thanks for any ideas why I can't insert images.
]]>
https://forums.modx.com/thread/81354/can-t-insert-image-with-file-browser#dis-post-471878 Mon, 15 Jul 2013 09:26:10 +0000 https://forums.modx.com/thread/81354/can-t-insert-image-with-file-browser#dis-post-471878
<![CDATA[mailCould not instantiate mail function, eform snippet not working]]> https://forums.modx.com/thread/85226/mailcould-not-instantiate-mail-function-eform-snippet-not-working#dis-post-470065
Main mail: Mailer was unable to send mailCould not instantiate mail function.

Am using

[!eForm? &formid=`ContactForm` &subject=`[+subject+]` &to=`[(emailsender)]` &ccsender=`1` &tpl=`ContactForm` &report=`ContactFormReport` &invalidClass=`invalidValue` &requiredClass=`requiredValue` &cssStyle=`ContactStyles` &gotoid=`46` !]

The site hosted on UK2 dedicated server on Linux Server

Any help would be most appreciated, thanks Stewart]]>
https://forums.modx.com/thread/85226/mailcould-not-instantiate-mail-function-eform-snippet-not-working#dis-post-470065 Wed, 26 Jun 2013 11:00:22 +0000 https://forums.modx.com/thread/85226/mailcould-not-instantiate-mail-function-eform-snippet-not-working#dis-post-470065
<![CDATA[Can not see images]]> https://forums.modx.com/thread/84817/can-not-see-images#dis-post-467729 https://forums.modx.com/thread/84817/can-not-see-images#dis-post-467729 Fri, 31 May 2013 07:43:06 +0000 https://forums.modx.com/thread/84817/can-not-see-images#dis-post-467729 <![CDATA[Evo Module Permissions - Unauthorized access]]> https://forums.modx.com/thread/84070/evo-module-permissions---unauthorized-access#dis-post-465048
Unauthorized access

You're not allowed to access file folder


this is a result of migrating to Bluehost's Pro package and the website moving servers. Permissions on the images directory are set to 755.

Any other thoughts on how to get this working again?

Thanks!]]>
https://forums.modx.com/thread/84070/evo-module-permissions---unauthorized-access#dis-post-465048 Wed, 01 May 2013 03:48:05 +0000 https://forums.modx.com/thread/84070/evo-module-permissions---unauthorized-access#dis-post-465048
<![CDATA[Resource Not Saving]]> https://forums.modx.com/thread/84093/resource-not-saving?page=2#dis-post-464920
I haven't ran into this problem in the past; therefore, I can't track down what is going on. I sat on this for three days and still can't figure out the issue. Have anyone ran into similar situation? Perhaps some permission issues?

I am running MODX Evo 1.0.6.

Thanks for your help.]]>
https://forums.modx.com/thread/84093/resource-not-saving?page=2#dis-post-464920 Wed, 01 May 2013 12:28:27 +0000 https://forums.modx.com/thread/84093/resource-not-saving?page=2#dis-post-464920
<![CDATA[DittoCal and restricted pages]]> https://forums.modx.com/thread/81923/dittocal-and-restricted-pages#dis-post-452418 Initial Data from Json
{
"title":"blog json output",
"link":"http://mysite.ru/blog-json-output",
"description":"",
"language":"ru",
"copyright":"GLT GROUP 2009",
"ttl":"120",
"entries":[

]
}

Data after JSON decoding
stdClass Object
(
[title] => blog json output
[link] => http://mysite.ru/blog-json-output
[description] =>
[language] => ru
[copyright] => Site
[ttl] => 120
[entries] => Array
(
)

)


Filter Settings

Filter Month: 1
Filter Year: 2013

Day Array for output
Array
(
)

All pages that I want to get restricted by access rights. And that is the cause of problem. But how can I resolve it?]]>
https://forums.modx.com/thread/81923/dittocal-and-restricted-pages#dis-post-452418 Mon, 28 Jan 2013 09:20:23 +0000 https://forums.modx.com/thread/81923/dittocal-and-restricted-pages#dis-post-452418
<![CDATA[File Browser in frontend doesn`t show any files or folders]]> https://forums.modx.com/thread/81880/file-browser-in-frontend-doesn-t-show-any-files-or-folders#dis-post-452415
I`ve tried to add TinyMCE and Resource manager to frontend. I added Resourse Editor snippet, TinyMCE to it and then turn on Resource Browser feature in TinyMCE. But when I click on Resource browser button blank window opens. I`ve attached the screenshot. Also if I try to add any images or create folder my browser reports about javascript error in fckxml.js:
TypeError: this.DOMDocument is null
var xPathResult = this.DOMDocument.evaluate( xpath, this.DOMDocument - line 108
But as I understand this is consequence and not the cause.
When I use resource manage in site backend all works perfectly.
I`ve already tried so much solutions and really don`t know what to do now. Any suggestions would be appreciated. My last hope is community:).
MODx Evo 1.0.6]]>
https://forums.modx.com/thread/81880/file-browser-in-frontend-doesn-t-show-any-files-or-folders#dis-post-452415 Mon, 28 Jan 2013 09:18:03 +0000 https://forums.modx.com/thread/81880/file-browser-in-frontend-doesn-t-show-any-files-or-folders#dis-post-452415
<![CDATA[Comment spam in the demo Mini-Blog HOWTO article]]> https://forums.modx.com/thread/81517/comment-spam-in-the-demo-mini-blog-howto-article#dis-post-449718
I had left the demo pages in place on my site in case they contained any code that I might find useful later, but it seems that this was perhaps not a wise strategy.

To prevent the problem from occurring again, I think I will delete the demo pages from my live site (but leave them on my test site, which has very strict access permissions).

I haven't knowingly used any of the demo pages other than "404 - Document Not Found" and "Search Results". Are the other pages needed for any part of MODx functionality, or is it safe to remove them? ("RSS Feed" (actually, I might want to make use of that), "MODx Features" (and children), "[*loginName*]" ×2 (URIs: login and blog-login), "Thank You", "Contact Us", "Blog" (and children), "Request an Account"). The site doesn't have any web users, only manager users.

To get rid of the spam comments themselves, can I just delete all of the records in the modx_jot_* tables, or are there any records that "need" to be in there? I don't actually use Jot, although I suppose that there is always the possibility that I might do so in future.

I'm also somewhat worried as to how the comment spam found its way there in the first place. I haven't really investigated the demo blog in very much detail, but I am surprised that it somehow seems to have allowed spam to be posted without alerting a manager user first!

Given the "Forgot manager login" bug, I have checked that there are no unexpected user accounts on the site, and have now disabled the "Forgot manager login" plugin. I will upgrade my installation to 1.0.7 when I get time. I don't know whether this is a related issue or not.

Just another reminder of the need to be ever-careful, I suppose!
]]>
https://forums.modx.com/thread/81517/comment-spam-in-the-demo-mini-blog-howto-article#dis-post-449718 Tue, 08 Jan 2013 04:50:02 +0000 https://forums.modx.com/thread/81517/comment-spam-in-the-demo-mini-blog-howto-article#dis-post-449718