MIGX - MODX Community Forums https://forums.modx.com/board/?board=271 <![CDATA[MIGXdb Validation Rules Don't Run Properly When Using Inline Editor]]> https://forums.modx.com/thread/104977/migxdb-validation-rules-don-t-run-properly-when-using-inline-editor#dis-post-564471 number data type, is required, and has a config of:
{"allowDecimals":"No","allowNegative":"No","minValue":"250","maxValue":"5000"}

Note that the column config for the field has the Cell Editor set to this.textEditor.

The validation works as expected when editing a record the typical way. But when entering an invalid value directly into the column in a grid, the value ends up being "0". I suspect what's happening is that the validation gets called but, in the case of inline editing, you don't an error message (in the form or by modal) and a chance to correct the value and the save process does not get interrupted; subsequently the value written to the db in empty.

Is this a known issue?]]>
https://forums.modx.com/thread/104977/migxdb-validation-rules-don-t-run-properly-when-using-inline-editor#dis-post-564471 Sat, 16 Mar 2019 07:13:03 +0000 https://forums.modx.com/thread/104977/migxdb-validation-rules-don-t-run-properly-when-using-inline-editor#dis-post-564471
<![CDATA[Errors in MIGX tv, cannot save an item]]> https://forums.modx.com/thread/104863/errors-in-migx-tv-cannot-save-an-item#dis-post-563861
I'm completely stuck with using MIGX, as I cannot save a simple test variable.

My MIGX version 2.12.0-pl
MODX Revolution 2.7.0-pl

I've installed MIGX extra, than I've created a tv with the following params:

name: testmigx
input:mogx

FormTabs:

[
{"caption":"Info", "fields": [
    {"field":"title","caption":"Title"}
]}
]


Grid Columns:

[
{"header": "Title", "width": "160", "sortable": "true", "dataIndex": "title"}
]


And when I try to add a text variable I see the following window:


When I click "Done", I see that there are some errors, but there is no way to understand what's wrong:



I'm not able to save resource as I receive "Please correct the errors in your form before submitting." on clicking save button.

Any ideas? Maybe I forgot something?]]>
https://forums.modx.com/thread/104863/errors-in-migx-tv-cannot-save-an-item#dis-post-563861 Thu, 31 Jan 2019 02:07:25 +0000 https://forums.modx.com/thread/104863/errors-in-migx-tv-cannot-save-an-item#dis-post-563861
<![CDATA[MIGXdb Grid - Sort by Arbitrary Column?]]> https://forums.modx.com/thread/104845/migxdb-grid---sort-by-arbitrary-column#dis-post-563763 https://forums.modx.com/thread/104845/migxdb-grid---sort-by-arbitrary-column#dis-post-563763 Fri, 25 Jan 2019 04:33:47 +0000 https://forums.modx.com/thread/104845/migxdb-grid---sort-by-arbitrary-column#dis-post-563763 <![CDATA[Add Item works, but can't delete or edit entry -> TypeError: rec is undefined]]> https://forums.modx.com/thread/104830/add-item-works-but-can-t-delete-or-edit-entry---typeerror-rec-is-undefined#dis-post-563728 I recovered a version of a page with "VersionX". Frontend and backend are looking correct. But after the recoveery I wasn't able to edit or delete entries of the template variables migx list anymore. The debugger says "TypeError: rec is undefined". I hope somebody can help me. I tried to delete the database field with the entries, but without result.
Attached is the error message and the code lines with the error. Here is the configuration:

{
  "formtabs":[
    {
      "MIGX_id":4,
      "caption":"Programm-Elemente",
      "print_before_tabs":"0",
      "fields":[
        {
          "MIGX_id":10,
          "field":"programm_title",
          "caption":"Titel",
          "description":"",
          "description_is_code":"0",
          "inputTV":"programm_title",
          "inputTVtype":"text",
          "validation":"",
          "configs":"",
          "restrictive_condition":"",
          "display":"",
          "sourceFrom":"config",
          "sources":"",
          "inputOptionValues":"",
          "default":"",
          "useDefaultIfEmpty":"0",
          "pos":1
        },
        {
          "MIGX_id":11,
          "field":"programm_text",
          "caption":"Aussage",
          "description":"",
          "description_is_code":"0",
          "inputTV":"programm_text",
          "inputTVtype":"text",
          "validation":"",
          "configs":"",
          "restrictive_condition":"",
          "display":"",
          "sourceFrom":"config",
          "sources":"",
          "inputOptionValues":"",
          "default":"",
          "useDefaultIfEmpty":"0",
          "pos":2
        }
      ],
      "pos":1
    }
  ],
  "contextmenus":"update||remove",
  "actionbuttons":"",
  "columnbuttons":"update||remove",
  "filters":"",
  "extended":{
    "migx_add":"Programmpunkt hinzuf\u00fcgen",
    "disable_add_item":"",
    "add_items_directly":1,
    "formcaption":"",
    "update_win_title":"",
    "win_id":"programm_items",
    "maxRecords":"",
    "addNewItemAt":"bottom",
    "media_source_id":"",
    "multiple_formtabs":"",
    "multiple_formtabs_label":"",
    "multiple_formtabs_field":"",
    "multiple_formtabs_optionstext":"",
    "multiple_formtabs_optionsvalue":"",
    "actionbuttonsperrow":4,
    "winbuttonslist":"",
    "extrahandlers":"",
    "filtersperrow":4,
    "packageName":"",
    "classname":"",
    "task":"",
    "getlistsort":"",
    "getlistsortdir":"",
    "sortconfig":"",
    "gridpagesize":"",
    "use_custom_prefix":"0",
    "prefix":"",
    "grid":"",
    "gridload_mode":1,
    "check_resid":1,
    "check_resid_TV":"",
    "join_alias":"",
    "has_jointable":"yes",
    "getlistwhere":"",
    "joins":"",
    "hooksnippets":"",
    "cmpmaincaption":"",
    "cmptabcaption":"",
    "cmptabdescription":"",
    "cmptabcontroller":"",
    "winbuttons":"",
    "onsubmitsuccess":"",
    "submitparams":""
  },
  "columns":[
    {
      "MIGX_id":3,
      "header":"Id",
      "dataIndex":"MIGX_id",
      "width":10,
      "sortable":"false",
      "show_in_grid":1,
      "customrenderer":"",
      "renderer":"",
      "clickaction":"",
      "selectorconfig":"",
      "renderchunktpl":"",
      "renderoptions":"",
      "editor":""
    },
    {
      "MIGX_id":1,
      "header":"Programmpunkt",
      "dataIndex":"programm_title",
      "width":50,
      "sortable":"false",
      "show_in_grid":1,
      "customrenderer":"",
      "renderer":"",
      "clickaction":"",
      "selectorconfig":"",
      "renderchunktpl":"",
      "renderoptions":"",
      "editor":""
    },
    {
      "MIGX_id":2,
      "header":"Aussage",
      "dataIndex":"programm_text",
      "width":"",
      "sortable":"false",
      "show_in_grid":1,
      "customrenderer":"",
      "renderer":"",
      "clickaction":"",
      "selectorconfig":"",
      "renderchunktpl":"",
      "renderoptions":"",
      "editor":""
    }
  ],
  "category":""
}
]]>
https://forums.modx.com/thread/104830/add-item-works-but-can-t-delete-or-edit-entry---typeerror-rec-is-undefined#dis-post-563728 Wed, 23 Jan 2019 06:00:05 +0000 https://forums.modx.com/thread/104830/add-item-works-but-can-t-delete-or-edit-entry---typeerror-rec-is-undefined#dis-post-563728
<![CDATA[MIGXCalendar For Front End Only Fed From Existing MIGXdb, Possible?]]> https://forums.modx.com/thread/104808/migxcalendar-for-front-end-only-fed-from-existing-migxdb-possible#dis-post-563613 I was looking to implement an external events calendar into an existing MIGXdb that is currently fully functional with its own CMP.

Then it dawned on me that I had over looked MIGX Calendar, however I read this line on it's MODX extras page:

"Its currently not meant to be used in production"

from this page:

https://modx.com/extras/package/migxcalendars

This made me cautious so I not try to install yet.

However, I know how fantastic MIGXdb is so it got me thinking that if it can work it would be a great fit with an existing MIGXdb

So I have a couple of questions:

1. Is MIGXCalendar still compatible with the latest version of MIGX?

If yes....

2. Can I just use MIGXCalendar for front end displaying data from an existing MIGXdb?

My use case would be as follows:


  • Load data into existing MIGXdb CMP
  • Feed data into MIGXCalendar from existing data base (use MIGXLoopCollection)

I'd be really interested to know if I can use MIGXCalendar as I have set out above

I'm not really interested in the front end editing functions of MIGXCalendar, I just want to display start date and end date ranges on a number of events that range from 1 day up to 2 or 3 weeks that have been read from the data base
]]>
https://forums.modx.com/thread/104808/migxcalendar-for-front-end-only-fed-from-existing-migxdb-possible#dis-post-563613 Wed, 16 Jan 2019 04:31:46 +0000 https://forums.modx.com/thread/104808/migxcalendar-for-front-end-only-fed-from-existing-migxdb-possible#dis-post-563613
<![CDATA[Help: How to Make MigxLoopCollection to Json Function?]]> https://forums.modx.com/thread/104770/help-how-to-make-migxloopcollection-to-json-function#dis-post-563431
MODX Revolution 2.7.0-pl
MIGX 2.12.0-pl

Objective

To replace (a manually updated) json file with a migxloopcollection to json output

Why?

I want the json to dynamically change every time the MIGXdb CMP is updated, currently I have to update the json every time an update is done to the CMP, so I'm trying to introduce a method to dynamically replace the manual update

What I Have Done That Is Working

I have set up a MIGXdb CMP where I can load and update data to the MySql database

MIGXdb Schema
<?xml version="1.0" encoding="UTF-8"?>
<model package="towersite" baseClass="xPDOObject" platform="mysql" defaultEngine="MyISAM" version="1.1">
    <object class="TowerSite" table="towersite" extends="xPDOSimpleObject">
	  	<field key="siteid" dbtype="varchar" precision="255" phptype="string" null="false" default=""/>
		<field key="state" dbtype="varchar" precision="255" phptype="string" null="false" default=""/>
    	<field key="township" dbtype="varchar" precision="255" phptype="string" null="false" default=""/>        
		<field key="address" dbtype="varchar" precision="255" phptype="string" null="false" default=""/>
		<field key="lat" dbtype="varchar" precision="255" phptype="string" null="false" default=""/>
        <field key="lng" dbtype="varchar" precision="255" phptype="string" null="false" default=""/>			
		<field key="towertype" dbtype="varchar" precision="255" phptype="string" null="false" default=""/>
		<field key="pos" dbtype="int" precision="10" phptype="integer" null="false" default="0"/>
		<field key="createdon" dbtype="datetime" phptype="datetime" null="true"/>
    <field key="createdby" dbtype="int" precision="10" attributes="unsigned" phptype="integer" null="false" default="0" />
    <field key="editedon" dbtype="datetime" phptype="datetime" null="true"/>
    <field key="editedby" dbtype="int" precision="10" attributes="unsigned" phptype="integer" null="false" default="0" />
		<field key="deleted" dbtype="tinyint" precision="1" attributes="unsigned" phptype="integer" null="false" default="0" />
		<field key="deletedon" dbtype="datetime" phptype="datetime" null="false" />
		<field key="deletedby" dbtype="int" precision="10" phptype="integer" null="false" default="0" />
    <field key="published" dbtype="tinyint" precision="1" attributes="unsigned" phptype="integer" null="false" default="0" />  
		<field key="publishedon" dbtype="datetime" phptype="datetime" null="false" />
		<field key="publishedby" dbtype="int" precision="10" phptype="integer" null="false" default="0" />
    <aggregate alias="CreatedBy" class="modUser" local="createdby" foreign="id" cardinality="one" owner="foreign"/>
    <aggregate alias="EditedBy" class="modUser" local="editedby" foreign="id" cardinality="one" owner="foreign"/>
    </object>
</model>


migxloopcollection code (this is the part I think I need help with)
[[!migxLoopCollection?
&packageName=`towersite`
&classname=`TowerSite`
&selectfields=`id,siteid,state,township,address,towertype,lat,lng`
&toJsonPlaceholder=`markers` 
]]
[[+markers]]


json code (the original - this can work independently & it is what I am trying to replace)
markers = [
   {
     "siteid": "BNK1001",
     "state": "Bangkok Metropolitan Area",
	 "township": "Thonburi",
	 "address": "21 de laetya street",
	 "towertype": "Rooftop",
	 "lat": 16.829394,
     "lng": 96.155004
   },
   {
     "siteid": "BNK1002",
     "state": "Bangkok Metropolitan Area",
	 "township": "Phra Khanong",
	 "address": "Block 5, 12 Old Khanong Road",
	 "towertype": "Rooftop",
	 "lat": 16.827123,
     "lng": 96.164543
   },
];


I delete the 'markers json' file so I can test the migxloopcollection method, but when I load the web page it does not display the map markers and in the page source code I can see the migxloopcollection is collecting the data but the console is saying "Uncaught ReferenceError: markers is not defined". (There is a 'leaflet js' file looking for the 'markers json')

Does anyone know what I'm doing wrong here and can advise corrective action?
]]>
https://forums.modx.com/thread/104770/help-how-to-make-migxloopcollection-to-json-function#dis-post-563431 Fri, 04 Jan 2019 03:35:43 +0000 https://forums.modx.com/thread/104770/help-how-to-make-migxloopcollection-to-json-function#dis-post-563431
<![CDATA[Error in BlOX core with PHP 7.1]]> https://forums.modx.com/thread/102690/error-in-blox-core-with-php-7-1#dis-post-563420
After upgrading my Modx site form 2.3.5 to the latest version and pimping my server from php 5.6 to php 7.1 I get this error :

Backend fatal error: PHP Fatal error:  'break' not in the 'loop' or 'switch' context in xxx/public_html/core/components/blox/inc/adodb-time.inc.php on line 1009\n, referer: https:xxxx.com/


How can I fix this please ?

The page that uses Migx Calendar with BLOX is a White Screen Of Death Now ...

I commented out that function on line 1009, and the page loads again, but I don't know if this will impair the good functioning of the Migx Calendar.
Now I get another (not WSOD) PHP ERROR:

Backend log: PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; xettcal has a deprecated constructor in xxx/public_html/core/components/blox/inc/xettcal.class.inc.php on line 2\n, referer: https:xxxx.com/



thanks]]>
https://forums.modx.com/thread/102690/error-in-blox-core-with-php-7-1#dis-post-563420 Thu, 03 Jan 2019 01:54:12 +0000 https://forums.modx.com/thread/102690/error-in-blox-core-with-php-7-1#dis-post-563420
<![CDATA[Nested migx tv with new media source, have some troubles]]> https://forums.modx.com/thread/104695/nested-migx-tv-with-new-media-source-have-some-troubles#dis-post-563131 Sorry for my bad English)))

I have tv, which have migx type with this markup inside:
[{"caption":"Салон", "fields": [
    {"field":"kids","caption":"Kids?","inputTVtype":"checkbox","inputOptionValues":"Yes==Yes"},
    {"field":"name","caption":"Name"},
    {"field":"adress","caption":"Adress"},
    {"field":"phone","caption":"Phone"},
    {"field":"slider","caption":"Slider image","inputTV":"contactSliderforMigx"}
  ]
}]

And contactSliderforMigx tv have this markup:
[{"caption":"Image", "fields": [ 
{"field":"image","caption":"Image","inputTV":"migxImage","sourceFrom":"migx"}
]
}]

At front i output this data like two nested calling of getImageList,and tv migxImage have custom media source with custom file path.
And when i have second nested call of getImageList with image output, url of images doenst have right url.There is a file path like "/myImage.png", but i need a path like "mymediasourcepath/myImage.png"


]]>
https://forums.modx.com/thread/104695/nested-migx-tv-with-new-media-source-have-some-troubles#dis-post-563131 Thu, 06 Dec 2018 10:58:42 +0000 https://forums.modx.com/thread/104695/nested-migx-tv-with-new-media-source-have-some-troubles#dis-post-563131
<![CDATA[Nested MigxDB - Child MigxDB field title]]> https://forums.modx.com/thread/104648/nested-migxdb---child-migxdb-field-title#dis-post-562853
I leave fieldname empty, and use migxdb as Input TV Type with it's config under Configs.

Every time I add object, i get an error

xPDOObject - Called set() with an invalid field name:

How can I fix it? And what can I use fore field name, to avoid this error?]]>
https://forums.modx.com/thread/104648/nested-migxdb---child-migxdb-field-title#dis-post-562853 Wed, 21 Nov 2018 02:21:19 +0000 https://forums.modx.com/thread/104648/nested-migxdb---child-migxdb-field-title#dis-post-562853
<![CDATA[MigxDB inside MigxDB - get current parent id?]]> https://forums.modx.com/thread/104647/migxdb-inside-migxdb---get-current-parent-id#dis-post-562852
Eg I have a classes Brands and Brandcategories.

I've got a config for each brand. And brandcategories config is nested as migxdb tv inside Brand formtabs. I need to get id of the Brand, i'm currently editing, as I add a brand categorie.

Thanks]]>
https://forums.modx.com/thread/104647/migxdb-inside-migxdb---get-current-parent-id#dis-post-562852 Wed, 21 Nov 2018 12:12:48 +0000 https://forums.modx.com/thread/104647/migxdb-inside-migxdb---get-current-parent-id#dis-post-562852
<![CDATA[Deleting/removing multiple MIGXdb entries in CMP]]> https://forums.modx.com/thread/98179/deleting-removing-multiple-migxdb-entries-in-cmp#dis-post-562844
I've set up a custom MIGXdb model and I'm using a CMP for adding, editing and deleting entries. I'm struggling to work out how I can delete multiple entries at once without having to use the trash functionality. Is this possible?

Thanks in advance for your help!]]>
https://forums.modx.com/thread/98179/deleting-removing-multiple-migxdb-entries-in-cmp#dis-post-562844 Tue, 20 Nov 2018 01:13:18 +0000 https://forums.modx.com/thread/98179/deleting-removing-multiple-migxdb-entries-in-cmp#dis-post-562844
<![CDATA[500 Error. Blank overlay. Fresh install 2.6.5]]> https://forums.modx.com/thread/104477/500-error-blank-overlay-fresh-install-2-6-5#dis-post-561963
I've tried PHP 5.6 and 7

Any help gratefully received.


/assets/components/migx/connector.php:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
modx.jsgrps-min.js:4 Uncaught TypeError: this.mask.addClass is not a function
at S.onShow (modx.jsgrps-min.js:4)
at S.afterShow (ext-all.js:21)
at S.show (ext-all.js:21)
at Object.show (ext-all.js:21)
at MODx.onAjaxException (modx.js?v=f7e90b99:122)
at h.Event.fire (ext-all.js:21)
at Ext.data.Connection.fireEvent (ext-all.js:21)
at Ext.data.Connection.handleFailure (ext-all.js:21)
at f (ext-base.js:21)
at m (ext-base.js:21)
/assets/components/migx/connector.php:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
modx.jsgrps-min.js:4 Uncaught TypeError: Cannot read property 'removeClass' of undefined
at S.onHide (modx.jsgrps-min.js:4)
at S.afterHide (ext-all.js:21)
at S.hide (ext-all.js:21)
at Object.hide (ext-all.js:21)
at Object.show (ext-all.js:21)
at MODx.onAjaxException (modx.js?v=f7e90b99:122)
at h.Event.fire (ext-all.js:21)
at Ext.data.Connection.fireEvent (ext-all.js:21)
at Ext.data.Connection.handleFailure (ext-all.js:21)
at f (ext-base.js:21)]]>
https://forums.modx.com/thread/104477/500-error-blank-overlay-fresh-install-2-6-5#dis-post-561963 Sat, 06 Oct 2018 04:42:12 +0000 https://forums.modx.com/thread/104477/500-error-blank-overlay-fresh-install-2-6-5#dis-post-561963
<![CDATA[How to control Bulk (actionbuttons)?]]> https://forums.modx.com/thread/104467/how-to-control-bulk-actionbuttons#dis-post-561937
I would like to control which actions appear in the [Bulk] selectmenu (top of of the grid). Does anyone know of a config file that will allow me to do this, as I can't see anywhere in the UI to manage this?

Thank you

Jim]]>
https://forums.modx.com/thread/104467/how-to-control-bulk-actionbuttons#dis-post-561937 Fri, 05 Oct 2018 01:55:10 +0000 https://forums.modx.com/thread/104467/how-to-control-bulk-actionbuttons#dis-post-561937
<![CDATA[How to use Activate / Deactivate (contextmenus, columnbuttons)]]> https://forums.modx.com/thread/104466/how-to-use-activate-deactivate-contextmenus-columnbuttons#dis-post-561936
By default, publish/unpublish work fine. However, I cannot get active/inactive to work, even with a corresponding 'active' field (boolean) in my database. I can't find any documentation on this. Has anyone else got this working?

My database table and schema are working as expected in all other respects.

Thank you

Jim]]>
https://forums.modx.com/thread/104466/how-to-use-activate-deactivate-contextmenus-columnbuttons#dis-post-561936 Fri, 05 Oct 2018 01:54:43 +0000 https://forums.modx.com/thread/104466/how-to-use-activate-deactivate-contextmenus-columnbuttons#dis-post-561936
<![CDATA[Display 'error' message in dialog]]> https://forums.modx.com/thread/104472/display-error-message-in-dialog#dis-post-561935
Has anyone managed to pass an error message back to JS successfully (in the context of MIGXdb)?

Thanks]]>
https://forums.modx.com/thread/104472/display-error-message-in-dialog#dis-post-561935 Fri, 05 Oct 2018 01:54:13 +0000 https://forums.modx.com/thread/104472/display-error-message-in-dialog#dis-post-561935
<![CDATA[Nested MIGXdb. MIGXdb inside MIGXdb.]]> https://forums.modx.com/thread/79667/nested-migxdb-migxdb-inside-migxdb?page=8#dis-post-561910
I'm trying to make a "media list" with MIGXdb.
Every media item can have an other list. A list of images (for a gallery).

So my thought is this:

MIGXdb 1: mediaList
Fields:
- title
- description
- media <-- this one shoud be connected to an other MIGXdb
- buttonText
- buttonURL

MIGXdb 2: media
Fields:
title
image

Thats the basic idea. Of course there should (?) be more fields like id, published on, and so on...

Is this possible? Using "aggregate" in the schema? Or maybe "joins" in the configuration? How would I do this?

Thank you.

/E]]>
https://forums.modx.com/thread/79667/nested-migxdb-migxdb-inside-migxdb?page=8#dis-post-561910 Thu, 04 Oct 2018 12:52:52 +0000 https://forums.modx.com/thread/79667/nested-migxdb-migxdb-inside-migxdb?page=8#dis-post-561910
<![CDATA[Errors with migxResourceMediaPath and MODX 2.6.1]]> https://forums.modx.com/thread/103472/errors-with-migxresourcemediapath-and-modx-2-6-1#dis-post-561772
The call for basePath and baseURL have been unchanged are as follows:

[[migxResourceMediaPath? &pathTpl=`assets/foldername/resourceimages/{id}/`]]

Whilst this did list images under the media source there the following error would appear in the logs;

/paas/site/www/core/cache/includes/elements/modsnippet/13.include.cache.php : 69) [migxResourceMediaPath]: docid could not be determined.

However there is a new error appearing:

/paas/site/www/core/model/modx/sources/modfilemediasource.class.php : 53) PHP warning: is_dir(): open_basedir restriction in effect. File(/) is not within the allowed path(s): (/paas/site)

Plus the images are now no longer listed under the Media Source although the folder still exists.

The site is hosted on MODX Cloud and was using PHP 7.1 but have reverted to PHP 5.6 but this hasn't resolved that issue... had another issue relating to AJAX Upload which seemed to be linked to a compatability isssue with PHP 7.1 which was almost resolved with rolling back to 5.6. Can use AJAX multi upload but not individual upload as I think there is an issue with the media source...

Any suggestions / solutions to this problem. I have also posted it to github... https://github.com/Bruno17/MIGX/issues/304]]>
https://forums.modx.com/thread/103472/errors-with-migxresourcemediapath-and-modx-2-6-1#dis-post-561772 Thu, 27 Sep 2018 07:54:16 +0000 https://forums.modx.com/thread/103472/errors-with-migxresourcemediapath-and-modx-2-6-1#dis-post-561772
<![CDATA[MIGX Restrictive Condition]]> https://forums.modx.com/thread/104399/migx-restrictive-condition#dis-post-561541
Example:
- section_source can be section_text or section_image
- If section_source == section_image I want to show an image field

I've successfully used restrictive conditions before with snippets, but I can't figure out how to pass 'section_source' as a parameter. I guess it's not a placeholder in this context.

John]]>
https://forums.modx.com/thread/104399/migx-restrictive-condition#dis-post-561541 Fri, 14 Sep 2018 12:16:06 +0000 https://forums.modx.com/thread/104399/migx-restrictive-condition#dis-post-561541
<![CDATA[MIGX hanging on "Add Item"]]> https://forums.modx.com/thread/104369/migx-hanging-on-add-item#dis-post-561529
I have a new 2.6.5 site that is up and running fine. I have now added MIGX to make a gallery easier to manage. However, although the MIGX grid appears as it should in the Template Variables tab, when I click on "Add Item" the window pops up and hangs (see attached image).

There are no errors on either server error log or the MODX error log to give a clue. I have cleared the MODX cache manually and the browser cache. I have also re-installed MIGX.

I have used MIGX before on several sites (earlier versions) and not had this issue, so I was wondering if there a bug with this latest version or can anyone suggest a fix for this?

Many thanks - Mark.

MIGX 2.12.0-pl
MODX 2.6.5
PHP 5.6.37
MySql 5.6.39
Apache 2.4.34


]]>
https://forums.modx.com/thread/104369/migx-hanging-on-add-item#dis-post-561529 Thu, 13 Sep 2018 06:17:56 +0000 https://forums.modx.com/thread/104369/migx-hanging-on-add-item#dis-post-561529
<![CDATA[Ajax Upload Box Not Working on SSL Site]]> https://forums.modx.com/thread/101243/ajax-upload-box-not-working-on-ssl-site#dis-post-560284
So I recently transferred a website from one domain to another, and everything is working fine other than the multi-upload. The folder is correctly created for each resource with the proper permissions, but when I open the multi-upload box there is no "upload files" button and I can't drag images into it (screenshot attached along with the console error).

Any ideas would be much appreciated!]]>
https://forums.modx.com/thread/101243/ajax-upload-box-not-working-on-ssl-site#dis-post-560284 Tue, 31 Jul 2018 09:29:39 +0000 https://forums.modx.com/thread/101243/ajax-upload-box-not-working-on-ssl-site#dis-post-560284