Modu&#322;y, pluginy, snipety i kod - MODX Community Forums https://forums.modx.com/board/?board=218 <![CDATA[Modx - problem z logowaniem (tylko SUDO)]]> https://forums.modx.com/thread/84255/modx---problem-z-logowaniem-tylko-sudo#dis-post-465094
mam dziwny problem. Dość głęboko zaszyłem się w realia kodowania w ModX Revolution, jednak tworzenie uprawnień dla nowego uzytkownika wydaje mi się skomplikowanym procesem.

Otóż stworzyłem użytkownika, nadałem mu uprzednio stworzoną grupę z odpowiednimi uprawnieniami, nadałem Resources i co się dzieje? Nie mogę się zalogować na wyżej wymienionego użytkownika. Nie dostaje podczas logowania zadnego komunikatu walidacyjnego - co jest oznaką, że login i hasło są poprawne.

Gdy zmienię uprawnienia wybranego usera na SUDO to automatycznie bez problemu loguję się pod podanym loginem i haslem.

Pytanie brzmi - w czym tkwi problem i jak go rozwiązać?

Proszę o poradę HOW TO, badz krótką instrukcję poczawszy od tworzenia uzytkownika, poprzez nadawanie uprawnien , koncząć na poprawnym zalogowaniu sie !!]]>
https://forums.modx.com/thread/84255/modx---problem-z-logowaniem-tylko-sudo#dis-post-465094 Thu, 02 May 2013 05:43:57 +0000 https://forums.modx.com/thread/84255/modx---problem-z-logowaniem-tylko-sudo#dis-post-465094
<![CDATA[Baner promocyjny z użyciem lightbox]]> https://forums.modx.com/thread/84268/baner-promocyjny-z-u-yciem-lightbox#dis-post-465092
Czy jest jakieś rozszerzenie umożliwiające dodawanie przez klienta końcowego takich banerów. Powiedzmy stałych wymiarów. np. reklama jakiegoś eventu. Wchodzę na stronę i automatycznie na środek ekranu wyskakuje zdjęcie reklamujące dany event z możliwością kliknięcia z przekierowaniem na podstronę danej promocji, oraz określeniem daty rozpoczęcia/wygaśnięcia oferty/baneru. Przeszukałem wszystko i w zasadzie najbardziej pasujący plugin to SlideshowManager. Jednak wyświetla się on nawet pusty jak niema żadnego slajdu, oraz nie korzysta z żadnego skryptu typu lightbox. Może dało by się go jakoś przerobić aby działał tak jak chcę? Dopiero zaczynam przygodę z modx'em i jest to moja pierwsza strona z jego użyciem dlatego proszę o podpowiedzi.]]>
https://forums.modx.com/thread/84268/baner-promocyjny-z-u-yciem-lightbox#dis-post-465092 Thu, 02 May 2013 05:14:36 +0000 https://forums.modx.com/thread/84268/baner-promocyjny-z-u-yciem-lightbox#dis-post-465092
<![CDATA[MODx - problem z modułem galerii.]]> https://forums.modx.com/thread/78351/modx---problem-z-modu-em-galerii#dis-post-431932 Chciałem Was bardzo prosić o pomoc w rozwiązaniu problemu z którym nie mogę sobie od wczoraj poradzić. Chodzi o moduł galerii w systemie zarządzania treścią MODx który był przenoszony wraz ze stroną z jednego serwera na drugi. Strona działa już prawidłowo. Problem zaczyna się podczas tworzenie galerii. Gdy próbuję dodać nową galerią otrzymują takie oto komunikaty błędów:

Undefined variable: sql (/home/users/gminaleszno/public_html/manager/includes/extenders/dbapi.mysql.class.inc.php#228)

#0 __lambda_func(8, Undefined variable: sql, /home/users/gminaleszno/public_html/manager/includes/extenders/dbapi.mysql.class.inc.php, 228, Array ([fields] => Array ([title] => rtrt,[miniW] => 75,[miniH] => 50,[normalW] => 200,[normalH] => 150,[galleryTemplate] => snippet.phtml,[imageTemplate] => image.phtml,[pages] => ,[hacks] => ),[intotable] => modx_gallery,[fromfields] => *,[fromtable] => ,[where] => ,[limit] => ,[flds] => (title,miniW,miniH,normalW,normalH,galleryTemplate,imageTemplate,pages,hacks) VALUES('rtrt','75','50','200','150','snippet.phtml','image.phtml','',''),[keys] => Array ([0] => title,[1] => miniW,[2] => miniH,[3] => normalW,[4] => normalH,[5] => galleryTemplate,[6] => imageTemplate,[7] => pages,[8] => hacks),[values] => Array ([0] => rtrt,[1] => 75,[2] => 50,[3] => 200,[4] => 150,[5] => snippet.phtml,[6] => image.phtml,[7] => ,[8] => ))) called at [/home/users/gminaleszno/public_html/manager/includes/extenders/dbapi.mysql.class.inc.php:228]

#1 DBAPI->insert(Array ([title] => rtrt,[miniW] => 75,[miniH] => 50,[normalW] => 200,[normalH] => 150,[galleryTemplate] => snippet.phtml,[imageTemplate] => image.phtml,[pages] => ,[hacks] => ), modx_gallery) called at [/home/users/gminaleszno/public_html/assets/modules/moduleframework/MEG_Model.php:99]

#2 MEG_Model::insert(gallery, Array ([title] => rtrt,[miniW] => 75,[miniH] => 50,[normalW] => 200,[normalH] => 150,[galleryTemplate] => snippet.phtml,[imageTemplate] => image.phtml,[pages] => ,[hacks] => )) called at [/home/users/gminaleszno/public_html/assets/modules/gallery/MEG_Model_Gallery.php:52]

#3 MEG_Model_Gallery::create(rtrt) called at [/home/users/gminaleszno/public_html/assets/modules/gallery/MEG_Module_Gallery.php:34]

#4 MEG_Module_Gallery->addAction(rtrt)

#5 ReflectionMethod->invokeArgs(MEG_Module_Gallery Object ([] => layout-manager.phtml,[availableTranslations] => Array (),[language] => en,[] => Array ([0] => /home/users/gminaleszno/public_html/assets/modules/gallery,[1] => /home/users/gminaleszno/public_html/assets/modules/moduleframework)), Array ([0] => rtrt)) called at [/home/users/gminaleszno/public_html/assets/modules/moduleframework/MEG_Module.php:138]

#6 MEG_Module->dispatch(addAction, Array ([action] => add,[a] => 112,[id] => 3,[title] => rtrt)) called at [/home/users/gminaleszno/public_html/assets/modules/moduleframework/MEG_Module.php:103]

#7 MEG_Module->dispatchAction() called at [/home/users/gminaleszno/public_html/manager/processors/execute_module.processor.php(114) : eval()'d code:3]

#8 eval() called at [/home/users/gminaleszno/public_html/manager/processors/execute_module.processor.php:114]

#9 evalModule(require_once MODX_BASE_PATH.'assets/modules/gallery/MEG_Module_Gallery.php';
$module=new MEG_Module_Gallery();
$module->dispatchAction();, Array ()) called at [/home/users/gminaleszno/public_html/manager/processors/execute_module.processor.php:101]

#10 include_once(/home/users/gminaleszno/public_html/manager/processors/execute_module.processor.php) called at [/home/users/gminaleszno/public_html/manager/index.php:548]

Bardzo Was proszę o pomoc wink.]]>
https://forums.modx.com/thread/78351/modx---problem-z-modu-em-galerii#dis-post-431932 Wed, 01 Aug 2012 01:47:23 +0000 https://forums.modx.com/thread/78351/modx---problem-z-modu-em-galerii#dis-post-431932
<![CDATA[Backend Upload i "fakepath"]]> https://forums.modx.com/thread/74728/backend-upload-i-fakepath#dis-post-414402 Czy któryś z szanownych kolegów, koleżanek wie jak uporać się z problemem uploadu w BE
Chodzi o ścieżkę C:\fakepath\obrazek.jpg - jak ją naprawić ?

Używam:
MODX Revolution 2.2.0-pl2 (traditional)]]>
https://forums.modx.com/thread/74728/backend-upload-i-fakepath#dis-post-414402 Fri, 02 Mar 2012 05:17:35 +0000 https://forums.modx.com/thread/74728/backend-upload-i-fakepath#dis-post-414402
<![CDATA[Odpalanie snippeta]]> https://forums.modx.com/thread/56952/odpalanie-snippeta#dis-post-334180 mam taką zagwozdkę, chciałbym móc uruchamiać snippet (albo plik php) po przeładowaniu strony z edycją dokumentu czyli po kliknięciu zapisz. Próbowałem z TV i @EVAL $modx->runSnippet(’nazwa’); ale w tak uruchamianym snippecie działa tylko zainicjowanie i zwracanie zmiennej, a np. operacji na plikach już się nie da wykonać. Poza tym nic mi do głowy nie przychodzi jak to ugryźć. Wersja Modx: Evolution 1.0.5.]]> https://forums.modx.com/thread/56952/odpalanie-snippeta#dis-post-334180 Tue, 26 Jul 2011 07:09:45 +0000 https://forums.modx.com/thread/56952/odpalanie-snippeta#dis-post-334180 <![CDATA[Brak rozwijanego menu styli W TinyMCE]]> https://forums.modx.com/thread/56951/brak-rozwijanego-menu-styli-w-tinymce#dis-post-334179 Zainstalowałem sobie najnowszą wersję Evo 1.0.5 i w edytorze TinMCE brakuje tego rozwijanego menu ze stylami CSS, wie ktoś jak to wstawić?
Pozdrawiam

Edit: Już znalazłem rozwiązanie;) Trzeba wejść w narzędzia > konfiguracja systemu > ustawienia interfejsu i edytora i z rozwijanej listy Theme wybrać Advanced.]]>
https://forums.modx.com/thread/56951/brak-rozwijanego-menu-styli-w-tinymce#dis-post-334179 Tue, 29 Mar 2011 07:30:34 +0000 https://forums.modx.com/thread/56951/brak-rozwijanego-menu-styli-w-tinymce#dis-post-334179
<![CDATA[Problem z javascript]]> https://forums.modx.com/thread/56950/problem-z-javascript#dis-post-334178
Próbuję opanować powiązanie modx revo z posiadanym szablonem i javascript zdecydowanie odmawia współpracy.

Tak wygląda funkcjonujący szablon strony:

http://www.spades.pl/dev00/index.html

Wszystkie niezbędne funkcje (slider, menu, powiększanie obrazków, prosta galeria, itp.) działają bez problemu.
Dla testów użyłem tylko strony głównej.

Zainstalowałem modx revo 2.0.6, dodałem spolszczenie i nowy template z takim kodem:

<!DOCTYPE html>
<html lang="pl">
<head>
<title>[[*pagetitle]]</title>
<meta charset="utf-8">
<meta name="description" content="[[*description]]">
<meta name="keywords" content="[[*keywords]]">
<meta name="author" content="[[*author]]">
<link rel="stylesheet" href="assets/templates/Spades/css/reset.css" type="text/css" media="all">
<link rel="stylesheet" href="assets/templates/Spades/css/grid.css" type="text/css" media="all">
<link rel="stylesheet" href="assets/templates/Spades/css/style.css" type="text/css" media="all">
<!-- styles for prettyPhoto -->
<link rel="stylesheet" href="assets/templates/Spades/css/prettyPhoto.css" type="text/css" media="all">
<script type="text/javascript" src="assets/templates/Spades/js/jquery-1.3.2.min.js"></script>
<script type="text/javascript" src="assets/templates/Spades/js/script.js"></script>
<script type="text/javascript" src="assets/templates/Spades/js/date.js"></script>
<!--[if lt IE 7]>
   <script type="text/javascript" src="assets/templates/Spades/js/ie6_script_other.js"></script>
 <![endif]-->
<!--[if lt IE 9]>
  	<script type="text/javascript" src="assets/templates/Spades/js/js/html5.js"></script>
  <![endif]-->
</head>
<body onLoad="myclock();">

[[*content]] 


</body>
</html>



oraz

stronę Home z takim kodem:


<div class="tail-top">
   <div class="tail-bottom">
      <div id="main">
         <!-- header -->
         <header>
            <!-- .logo -->

            <div class="logo"> <a href="index.html">Communication<span>Providing best connection</span></a> </div>
            <!-- /.logo -->
           <form id="ClockForm" action="">
               <fieldset>
               <input type="text" id="clock" />
               </fieldset>
            </form>

            <ul class="contacts">
               <li class="phone">Freephone:  +1 800 559 6580</li>
               <li class="email"><a href="#">communicationcompany@demolink.org</a></li>
            </ul>
            <nav>
              <ul class="sf-menu">
                  <li><a href="index.html" class="current">Main</a></li>

                  <li><a href="index-1.html">About</a>
                     <ul>
                        <li><a href="more.html">Lorem ipsum dolor sit</a></li>
                        <li><a href="more.html">Nulla quis metus</a></li>
                        <li><a href="more.html">Vestibulum in velit justo</a></li>
                        <li><a href="more.html">Vivamus nisi massa</a></li>

                        <li><a href="more.html">Nullam commodo</a></li>
                     </ul>
                  </li>
                  <li><a href="index-2.html">Services</a></li>
                  <li><a href="index-3.html">Projects</a></li>
                  <li><a href="index-4.html">FAQs</a></li>
                  <li><a href="index-5.html">Solutions</a></li>

                  <li><a href="index-6.html">contacts</a></li>
               </ul>
            </nav>
            <form action="" id="search-form">
               <fieldset>
               <input type="text" class="text" value="Search..." onFocus="if(this.value=='Search...'){this.value=''}" onBlur="if(this.value==''){this.value='Search...'}">
               <a href="#" onClick="document.getElementById('search-form').submit()"><img src="assets/templates/Spades/images/button-search.gif"></a>
               </fieldset>

            </form>
         </header>
         <!-- content -->
         <section id="content">
            <div id="coin-slider"> <a href="#"><img src="assets/templates/Spades/images/slide-img1.jpg"></a> <a href="#"><img src="assets/templates/Spades/images/slide-img2.jpg"></a> <a href="#"><img src="assets/templates/Spades/images/slide-img3.jpg"></a></div>
		  <h2 class="extra1">Fresh ideas<br>
                  for growing<br>

                  your business</h2>
            <div class="cont-box">
               <div class="inner">
                  <div class="wrapper container_16">
                     <article class="grid_4">
                        <h2>Remote</h2>
                        <p>Praesent vestibulum molesti acuan nonumm eurissellus portusus.</p>

                        <ul class="list">
                           <li><a href="#">Praesent vestibulum molesti </a></li>
                           <li><a href="#">Acuan nonumm euriss</a></li>
                           <li><a href="#">Fusce suscipit vim</a></li>
                           <li><a href="#">Nascetur ridiculus mus</a></li>
                           <li><a href="#">Fsce feugiat malesuada odi</a></li>

                        </ul>
                     </article>
                     <article class="grid_4">
                        <h2>IP Phone</h2>
                        <p class="p2">Praesent vestibulum molesti acuan nonumm eurissellus portusu ociis natoque pe et mis parturie ntontes nascetur ridiculus ma dui.</p>
                        <p class="p2">Fsce feugiat malesuada odio. Morbi nunc odiovida atcursus nec uctus a lorem. Maecenas tristiq.</p>
                        <ul class="list">

                           <li><a href="#">Fusce suscipit vim</a></li>
                           <li><a href="#">Nascetur ridiculus mus</a></li>
                        </ul>
                     </article>
                     <article class="grid_4">
                        <h2>Hardware</h2>
                        <p>Mim sociis natoque petibus et mis parturie ntontes nascetur ridic.</p>

                        <ul class="list">
                           <li><a href="#">Praesent vestibulum molesti </a></li>
                           <li><a href="#">Acuan nonumm euriss</a></li>
                           <li><a href="#">Fusce suscipit vim</a></li>
                           <li><a href="#">Nascetur ridiculus mus</a></li>
                           <li><a href="#">Fsce feugiat malesuada odi</a></li>

                        </ul>
                     </article>
                     <article class="grid_4">
                        <h2>Internet</h2>
                        <p class="p2">Praesent vestibulm molesi acuan nonumm eurissellus portususipit varMim sociis natoque peibus et mis parturie ntontes nasctur ulus musNulla dui. Fsce feugiat suada odio. Morbi nunc odiov.</p>
                        <p>Rida atcursus nec uctus a lornas tristique orci ac sem. Duis ultrcies pharetra magna. Donec accusan malesuda orciec sit  eros. Lorem ipsum dolor sit am.</p>
                     </article>

                  </div>
                  <div class="wrapper container_16">
                     <article class="grid_4"> <a href="more.html" class="button">Read More</a> </article>
                     <article class="grid_4"> <a href="more.html" class="button">Read More</a> </article>
                     <article class="grid_4"> <a href="more.html" class="button">Read More</a> </article>

                     <article class="grid_4"> <a href="more.html" class="button">Read More</a> </article>
                  </div>
               </div>
            </div>
         </section>
         <!-- aside -->
         <aside class="bottom">

            <div class="inside">
               <div class="wrapper container_16">
                  <article class="grid_8">
                     <h2>The world of opportunities</h2>
                     <div class="img-box">
                        <figure><a href="assets/templates/Spades/images/tfile_gall_1_1.jpg" class="lightbox-image" rel="prettyphoto" title="Example 1"><img src="assets/templates/Spades/images/1page-img.jpg" alt=""></a></figure>
                        <h5 class="extra">Praesent vestibulum molesti acuanumm eurissellus portuenas tristiquesuipit var</h5>
                        <p>Mim sociis natoque p musNulla dui. Fsc muda odio. Morbi nunc odiovida ursus nec uca lorem. Maecenaristique orci ac sem. Duis u pharetra magnaccumsan malest am.</p>

                        et consectetuer adipiscing elit. Mauris fermen tum dictum magna. Sed oreet aliquam leo. Ut tellus dolor dapibus eget elementum vel curus eleife elit. </div>
                     <a href="more.html" class="button">Read More</a> </article>
                  <article class="grid_8">
                     <h2>Features</h2>
                     <dl>
                        <dt class="color1"><span>1</span>Professional researches</dt>

                        <dd>Mim sociis natoque p musNulla dui. Fsc muada odio. Morbi nunc odiovida ursus nec uca lorem. Maecenaristiq.</dd>
                        <dt class="color2"><span>2</span>Dynamic development</dt>
                        <dd>Mim sociis natoque p musNulla dui. Fsc muada odio. Morbi nunc odiovida ursus nec uca lorem. Maecenaristiq.</dd>
                        <dt class="color3"><span>3</span>Individual customer support</dt>
                        <dd>Mim sociis natoque p musNulla dui. Fsc muada odio. Morbi nunc odiovida ursus nec uca lorem. Maecenaristiq.</dd>

                     </dl>
                  </article>
               </div>
            </div>
         </aside>
         <!-- footer -->
         <footer>
            <div class="inside">Communication © 2010 • <a href="index-7.html">Privacy Policy</a>

               <ul class="social-services">
                  <li><a href="#" title="Reddit" class="normaltip"><img src="assets/templates/Spades/images/icon-reddit.gif"></a></li>
                  <li><a href="#" title="Flickr" class="normaltip"><img src="assets/templates/Spades/images/icon-flickr.gif"></a></li>
                  <li><a href="#" title="Twitter" class="normaltip"><img src="assets/templates/Spades/images/icon-twitter.gif"></a></li>
                  <li><a href="#" title="Rss" class="normaltip"><img src="assets/templates/Spades/images/icon-rss.gif"></a></li>
                  <li><a href="#" title="Digg" class="normaltip"><img src="assets/templates/Spades/images/icon-digg.gif"></a></li>
               </ul>
            </div>
         </footer>

      </div>
   </div>
</div>




efekt jest taki:

http://spades.pl/dev01/

czyli nie do końca zgodny z oczekiwaniami - nie działa slider, menu rozwijane kuleje, powiększanie obrazków również nie działa.

W zakresie slidera próbowałem per analogiae zastosować metodę opisaną tutaj:

http://designfromwithin.com/integrating-coda-slider-2-0-in-modx-revolution/

zrobiłem odpowiedniego chunka i stosowne TV, niestety efekt jest identyczny jak bez chunka i TV.


Jakiś pomysł? Co robię źle?

Pozdrawiam]]>
https://forums.modx.com/thread/56950/problem-z-javascript#dis-post-334178 Sun, 16 Jan 2011 06:44:56 +0000 https://forums.modx.com/thread/56950/problem-z-javascript#dis-post-334178
<![CDATA[losowe zdjęcie z albumu]]> https://forums.modx.com/thread/56949/losowe-zdj-cie-z-albumu#dis-post-334175
ma ktoś pomysł, jak wyciągnąć losowe zdjęcie z konkretnego albumu? Używam pluginu Gallery do Revolution 2.0.

Z góry dzięki za pomoc.]]>
https://forums.modx.com/thread/56949/losowe-zdj-cie-z-albumu#dis-post-334175 Wed, 25 Aug 2010 08:35:09 +0000 https://forums.modx.com/thread/56949/losowe-zdj-cie-z-albumu#dis-post-334175
<![CDATA[Galeria na stronę opartą o MODx]]> https://forums.modx.com/thread/56948/galeria-na-stron-opart-o-modx#dis-post-334174 Tworzę pewną stronę opartą o MODx. Zainstalowałem MODx 1.0.2 na WAMP’ie. Chciałbym stworzyć prostą galerię z kategoriami, lightboxem oraz łatwym uploadem zdjęć ale niestety nie mogę znaleźć odpowiedniej proszę o pomoc. MODx poznaję od 2 dni. MaxiGallery nie potrafię ogarnąć. Proszę o pomoc.
Pozdrawiam.]]>
https://forums.modx.com/thread/56948/galeria-na-stron-opart-o-modx#dis-post-334174 Mon, 11 Jan 2010 07:11:12 +0000 https://forums.modx.com/thread/56948/galeria-na-stron-opart-o-modx#dis-post-334174
<![CDATA[Jak stworzyć za pomocą ditto wyszukiwarke dokumentów]]> https://forums.modx.com/thread/56947/jak-stworzy-za-pomoc-ditto-wyszukiwarke-dokument-w#dis-post-334172 Pozdrawiam]]> https://forums.modx.com/thread/56947/jak-stworzy-za-pomoc-ditto-wyszukiwarke-dokument-w#dis-post-334172 Thu, 27 Aug 2009 06:04:49 +0000 https://forums.modx.com/thread/56947/jak-stworzy-za-pomoc-ditto-wyszukiwarke-dokument-w#dis-post-334172 <![CDATA[Polskie znaczki w tagach a Ditto]]> https://forums.modx.com/thread/56946/polskie-znaczki-w-tagach-a-ditto#dis-post-334171 Mam problem z linkami tagów. Nie wyglądają tak jak powinny.

jest: http://mysite.com/49.html?tags=%C5%82adny+link
zamiast: http://mysite.com/49.html?tags=ladny+link

Problem występuje ze wszystkimi snippetami do wyświetlania tagów: TvTagCloud, Cumulus, tagLinks.

Wygląda na to, że problem jest związany z Ditto. Problem na razie rozwiązałem zmieniając
kawałek kodu w TvTagCloud i stosując dodatkowe TV dla Ditto.

Oto mój post w innym miejscu forum: http://modxcms.com/forums/index.php/topic,5814.msg231451.html#msg231451

Przeszukując forum niczego na ten temat nie znalazłem.

Może komuś udało się rozwiązać ten problem w inny sposób?]]>
https://forums.modx.com/thread/56946/polskie-znaczki-w-tagach-a-ditto#dis-post-334171 Fri, 21 Aug 2009 01:19:13 +0000 https://forums.modx.com/thread/56946/polskie-znaczki-w-tagach-a-ditto#dis-post-334171
<![CDATA[MaxiGallery polskie znaki]]> https://forums.modx.com/thread/56945/maxigallery-polskie-znaki#dis-post-334170 https://forums.modx.com/thread/56945/maxigallery-polskie-znaki#dis-post-334170 Wed, 11 Mar 2009 03:14:11 +0000 https://forums.modx.com/thread/56945/maxigallery-polskie-znaki#dis-post-334170 <![CDATA[Jak zrobic Forum na MODx-ie ??]]> https://forums.modx.com/thread/56943/jak-zrobic-forum-na-modx-ie#dis-post-334155
mam wielka prośbę do was
Podpowiedzcie mi jak stworzyć forum na MODx ? Ewentualnie wskażcie gdzie szukać smiley

Z gory wielkie dzięki za pomoc smiley]]>
https://forums.modx.com/thread/56943/jak-zrobic-forum-na-modx-ie#dis-post-334155 Tue, 20 Jan 2009 02:35:22 +0000 https://forums.modx.com/thread/56943/jak-zrobic-forum-na-modx-ie#dis-post-334155
<![CDATA[Kłopoty z Bindings @EVAL]]> https://forums.modx.com/thread/56944/k-opoty-z-bindings-eval#dis-post-334162
@EVAL return "The time stamp is now ".time();

Wyświetla mi sie na ekranie dokładnie taki komunikat - tak jakby parser nie przetwarzał tego.

Czy ktoś może mi to wyjaśnić? Może trzeba cos uruchomić albo inaczej osadzić?
]]>
https://forums.modx.com/thread/56944/k-opoty-z-bindings-eval#dis-post-334162 Thu, 18 Dec 2008 07:49:18 +0000 https://forums.modx.com/thread/56944/k-opoty-z-bindings-eval#dis-post-334162
<![CDATA[Ditto problemy.]]> https://forums.modx.com/thread/56942/ditto-problemy#dis-post-334150 Zatem witam wszystkich zrzeszonych i przechodzę do rzeczy.

Mam problem z instalacja jakiego kolwiek modułu.
Zacząłem instalować Ditto i zgodnie z instrukcją i tym co pisali na forum zrobiłe wszystko jak nalerzy.

Ale dalej nie widać tego w manager, i sam nie wiem czy ma być jakaś kolejna zakładka czy jak to sie tu odbywa. nie mam pojęcia może ktoś mnie oświeci.

Postąpiłem następująco:
Ściągnąłem ditto, rozpakowałem, wgrałem na serwer pliki do katalogu assets/snippets/ditto i w manager dodałem strzępka o nazwie Ditto i skopiowałem z pliku snippet.ditto.php cod i wkleiłem. dałem zapisz i wykonaj i nic.

co jeszcze?
]]>
https://forums.modx.com/thread/56942/ditto-problemy#dis-post-334150 Sat, 20 Sep 2008 06:33:43 +0000 https://forums.modx.com/thread/56942/ditto-problemy#dis-post-334150
<![CDATA[MaxiGallery - prośba o pomoc]]> https://forums.modx.com/thread/56926/maxigallery---pro-ba-o-pomoc#dis-post-334121 czy może mi ktoś wytłumaczyć w jaki sposób wywołac na stronie i jak kozystac z maxigallery? zainstalowałem sobie wg wskazówek, ale nie bardzo wiem co dalej zrobic.
dzieki za pomoc]]>
https://forums.modx.com/thread/56926/maxigallery---pro-ba-o-pomoc#dis-post-334121 Sun, 24 Aug 2008 03:16:01 +0000 https://forums.modx.com/thread/56926/maxigallery---pro-ba-o-pomoc#dis-post-334121
<![CDATA[Modx i forum SMF]]> https://forums.modx.com/thread/56941/modx-i-forum-smf#dis-post-334148 Jakie macie doświadczenia. Czy dobrze działa?
może są jakieś przykłady?
Chciałbym zaproponować takie rozwiązanie klientowi, ale wolałbym mieć wcześniej trochę opinii użytkowników.
Z góry dziękuję,
lx]]>
https://forums.modx.com/thread/56941/modx-i-forum-smf#dis-post-334148 Tue, 01 Jul 2008 03:01:37 +0000 https://forums.modx.com/thread/56941/modx-i-forum-smf#dis-post-334148
<![CDATA[Problem z uprawnieniami]]> https://forums.modx.com/thread/56940/problem-z-uprawnieniami#dis-post-334147 2. Rolę tę przypisałem do usera "usuwacz"
3. "Usuwacza" przypisałem do grupy "usuwacze"
4. "Usuwaczy" powiązałem z jedną jedyną grupą dokumentów "do usunięcia"
5. Do grupy "do usunięcia" włożyłem jeden maleńki dokumencik.

Więc dlaczego do cholery mam pełne prawa tworzenia/usuwania/edycji na całym drzewie dokumentów gdy zaloguje się do systemu jako "usuwacz"? Co robię nie tak?]]>
https://forums.modx.com/thread/56940/problem-z-uprawnieniami#dis-post-334147 Mon, 05 May 2008 05:43:04 +0000 https://forums.modx.com/thread/56940/problem-z-uprawnieniami#dis-post-334147
<![CDATA[Wyszukiwarka, sesje itp]]> https://forums.modx.com/thread/56938/wyszukiwarka-sesje-itp#dis-post-334145
<form NAME="demo" method="POST" action="index.php?id=7">
<input type="hidden" name="change" value="1">


Typ transakcji

<select name="typ_trans" type="list">
<option value="s" selected>Sprzedaż</option>
<option value="w">Wynajem</option>
</select>



Typ nieruchomości

<select name="typ_nier" type="list">
<option value="MIESZKANIE">Mieszkanie</option>
<option value="DOM">Dom (wszystkie)</option>
<option value="DZIALKA">Dzia3ka (wszystkie)</option>
</select>



Lokalizacja

<select class="form" name="lokal">
<option value="" selected>WSZYSTKIE </option>
<option value="GDAŃSK">GDAŃSK</option>
<option value="GDYNIA">GDYNIA</option>
</select>



<p align="center">
<input type="submit" value="Wyszukaj">
<input type="reset" value="Wyczyść"></p>
</form>

w podstronie o id=7 mam strzępka który pobiera z bazy pasujące wyniki.

Jest jednak problem, bo po wybraniu za pierwszym razem parametrow jest ok ale po cofnieciu sie do formularza i wybraniu innych parametrow nie zmianiaja sie one. Pamietane sa pewnie w sesji ale nie moge ich podmienic na nowe parametry. Czy ktos wiej jak to zrobic?]]>
https://forums.modx.com/thread/56938/wyszukiwarka-sesje-itp#dis-post-334145 Sat, 12 Apr 2008 01:10:16 +0000 https://forums.modx.com/thread/56938/wyszukiwarka-sesje-itp#dis-post-334145
<![CDATA[Problem z CSS Star Rating i szablonem AqueousLightX]]> https://forums.modx.com/thread/56939/problem-z-css-star-rating-i-szablonem-aqueouslightx#dis-post-334146
Mam problem z prawidłowym wyświetlaniem ocen w postaci gwiazdek w szablonie AqueousLightX. Wygląda to tak, jakby gwiazdki były rozjechane (załączam screenshota). Gdzie mogę szukać błędu?

Mój plik css:

http://forum.programypc.pl/files/1.css]]>
https://forums.modx.com/thread/56939/problem-z-css-star-rating-i-szablonem-aqueouslightx#dis-post-334146 Sat, 12 Apr 2008 11:18:41 +0000 https://forums.modx.com/thread/56939/problem-z-css-star-rating-i-szablonem-aqueouslightx#dis-post-334146