Hosting Experiences - MODX Community Forums https://forums.modx.com/board/?board=13 <![CDATA[Anyone having problems at SkyToaster?]]> https://forums.modx.com/thread/103422/anyone-having-problems-at-skytoaster#dis-post-562551
So I'm wondering whether other people here using Skytoaster have been having issues. I really don't want to have to switch hosts once again. Why is it that after a fews years of great hosting, companies get sold and the quality goes down?? Site5 was originally a great host, then got bought by EIG and went down the tubes. That's when I switched to Skytoaster. It makes recommending a host to my clients a tricky proposition.]]>
https://forums.modx.com/thread/103422/anyone-having-problems-at-skytoaster#dis-post-562551 Mon, 05 Nov 2018 09:34:55 +0000 https://forums.modx.com/thread/103422/anyone-having-problems-at-skytoaster#dis-post-562551
<![CDATA[Simple if statment in code snippet won't work]]> https://forums.modx.com/thread/104460/simple-if-statment-in-code-snippet-won-t-work#dis-post-561957
I have some code, which works on a normal php page. The code snippet created will find the $_GET['retval2'] but no if statements work in the snippet, it defaults to the else.

myurl.com?retval2=survey

<?php
if($_GET['retval2'] == 'survey') { 
    $url = './BLOBSurveyVerify.php';
} else { 
   $url = './BLOBFSBMemberVerification.php';
}

echo $url;


using snippet

[[quoteSurvey]]
]]>
https://forums.modx.com/thread/104460/simple-if-statment-in-code-snippet-won-t-work#dis-post-561957 Sat, 06 Oct 2018 10:57:12 +0000 https://forums.modx.com/thread/104460/simple-if-statment-in-code-snippet-won-t-work#dis-post-561957
<![CDATA[Recommended web hosting for a short duration (1 month) ?]]> https://forums.modx.com/thread/100754/recommended-web-hosting-for-a-short-duration-1-month#dis-post-558613
Do you know serious webhosting company, preferably in Europe, offering short duration plans?
Typically for 1 month?

It would be for simple PHP/MySQL MODx websites, so that I have a temporary solution whilst testing a VPS.

I'm looking for some plan in the 4$/month - 10$/month price range.

I'm aware that some companies offer a few trial free months but I prefer paying something and have some simple but reliable hosting.

Thanks.






]]>
https://forums.modx.com/thread/100754/recommended-web-hosting-for-a-short-duration-1-month#dis-post-558613 Thu, 17 May 2018 01:14:40 +0000 https://forums.modx.com/thread/100754/recommended-web-hosting-for-a-short-duration-1-month#dis-post-558613
<![CDATA[Migration Recommendations: Rackspace/AWS to Something Else]]> https://forums.modx.com/thread/103234/migration-recommendations-rackspace-aws-to-something-else#dis-post-558612
Questions:
What would be the first steps in initiating that migration? (Difficulties or "gotchas" I should look out for)
Will I need to package up all the files in S3?
What services would be comparable (MODX Cloud up to the task?)
Would this be a standard "Moving MODX to a new Server" situation]]>
https://forums.modx.com/thread/103234/migration-recommendations-rackspace-aws-to-something-else#dis-post-558612 Thu, 17 May 2018 01:06:06 +0000 https://forums.modx.com/thread/103234/migration-recommendations-rackspace-aws-to-something-else#dis-post-558612
<![CDATA[Where is the documentation for running MODX on Windows Server, with IIS?]]> https://forums.modx.com/thread/103040/where-is-the-documentation-for-running-modx-on-windows-server-with-iis#dis-post-554733 mysql 5.0.95 on a separate server accessed remotely, no known issues
New web server: (The DESTINATION)
php 7.1.7, no known issues
Windows Server 2016 IIS 8.5
old server (THE SOURCE):
centos 6; php 5.3 modx 2.5.1.

BUT, I am currently focused on an installation on DESTINATION and done as a fresh install of 2.5.8.

1. What to put in web.config for "friendly URLs"? I got something out of IIS's URL rewrite and Import.
2. What is the right mitigation for the configuration check... if it matters, the site is using running using a Active Directory domain user and its own application pool with this user set on it.

1. Your site is vulnerable to hackers who could do a lot of damage to the site. Please make your config file read only! It is located at D:\<site directory>\www/core/config/config.inc.php

MITIGATION: Added "Deny" on Write to core/config/config.inc.php. Windows would not let me deny modify without also including the read&execute and list.
This satisfied the MODX check.

Installer still present but led to this:
1b: Core folder is accessible by web
MODX detected that your core folder is (partially) accessible to the public. This is not recommended and a security risk. If your MODX installation is running on a Apache webserver you should at least set up the .htaccess file inside the core folder D:\<site directory>\www/core/. This can be easily done by renaming the existing ht.access example file there to .htaccess.
MITIGATION: Want to get a 403 error for this: https://<site directory>/core/docs/changelog.txt
MITIGATION: I tried to deny read access to core via deny read permissions. Stopped the entire manager from working. Thus I removed it.
MITIGATION: I still have to drill through the hardening guide, but am having difficulty understanding it.

If you setup everything correctly, browsing e.g. to the Changelog should give you a 403 (permission denied) or better a 404 (not found). If you can see the changelog there in the browser, something is still wrong and you need to reconfigure or call an expert to solve this.
]]>
https://forums.modx.com/thread/103040/where-is-the-documentation-for-running-modx-on-windows-server-with-iis#dis-post-554733 Mon, 23 Oct 2017 07:38:26 +0000 https://forums.modx.com/thread/103040/where-is-the-documentation-for-running-modx-on-windows-server-with-iis#dis-post-554733
<![CDATA[How much time consuming is hosting websites on a VPS like Vultr or DigitalOcean ?]]> https://forums.modx.com/thread/100752/how-much-time-consuming-is-hosting-websites-on-a-vps-like-vultr-or-digitalocean#dis-post-554437
I have several MODx domains on shared hostings.
I'm looking in the direction of a small VPS like those from Vultr and DigitalOcean as this would allow lower web hosting costs, more freedom with packages that I want to use and possibly better speeds as the websites would not be hosted together with ressource hungry ones.

However, I wonder how much time is required by the system admin tasks.
I'm a regular user of Linux and I'm not scared about the console line.
I also have some experience from Apache administration.
However, I remember that operating a web server like Apache is not that easy when not done on an almost daily basis.

The learning curve to install things like Apache, PHP, MySQL and RoundCube doesn't scare me too much as there are tutorials and taking time is worth if things were installed "once and for all".

But what about maintenance and security?
As there are regular upgrades of PHP and many softwares, how time consuming are these tasks?
Do simple commands like "apt-get upgrade" suffice or will I need to fully reinstall/migrate the server when new versions of Apache / PHP / MySQL / PostgreSQL are published?

Another fear I have is how can it be stressful when things go wrong.
Should I use a low cost rescue web hosting together with a failover service?

Has someone on the forum any experience with such VPS hosting and could he tell approximately how long does the first setup last and how much time per week or month is required for maintenance?

Thank you very much.]]>
https://forums.modx.com/thread/100752/how-much-time-consuming-is-hosting-websites-on-a-vps-like-vultr-or-digitalocean#dis-post-554437 Tue, 10 Oct 2017 09:21:34 +0000 https://forums.modx.com/thread/100752/how-much-time-consuming-is-hosting-websites-on-a-vps-like-vultr-or-digitalocean#dis-post-554437
<![CDATA[Strange Behavior When Using MSSQL 2012 And MODX 2.2.4 (PHP 5.4.6)]]> https://forums.modx.com/thread/79162/strange-behavior-when-using-mssql-2012-and-modx-2-2-4-php-5-4-6#dis-post-554375
we have problems using the MS SQL Server with MODX.

Enviroment:
- Windows Server 2008 R2 Standard (64bit)
- IIS 7.5
- PHP 5.4.6 (as FastCGI)
- Microsoft SQL Server Native Client 2012
- Microsoft SQL Server 2012 (on database server)
- Modx 2.2.4 traditional
- enabled PDO via "extension=php_pdo_sqlsrv_54_nts.dll" in php.ini

We have configured the IIS and PHP properly, like described in "Introducing the Microsoft Drivers for PHP for SQL Server". The System is running and the installation process completes successfully (seemingly).
But MODX has several bugs or rather shows strange behavior.

1.) There is no package provider declared.

The logs say: "Could not find the main provider for some reason with a name of "modx.com". Did you delete it?" --> of course not!
Beside, it is not possible to create a new provider and point it to "http://rest.modx.com/extras/". Error: [2012-09-07 17:07:43] (DEBUG @ /connectors/workspace/packages-rest.php) Language string not found: "provider_err_nf"

2.) Manager logs shows no information (is completly emtpy)

3.) During the installation process, when choosing collation and connection charset only Latin1 is available. Is that normal? Is it not possible to choose UTF-8 when using MSSQL?

4.) Configuration Check shows: "Configuration warning: Config file still writable!" and "Configuration warning: Installer still present". Even though it should be readonly and deleted!


We have no idea what goes wrong nor how to solve the problem. Is it possible to log the entire installation process somehow? Any suggestions how to enclose the malefactor?

Best regards,
Kersten

]]>
https://forums.modx.com/thread/79162/strange-behavior-when-using-mssql-2012-and-modx-2-2-4-php-5-4-6#dis-post-554375 Sun, 08 Oct 2017 09:26:13 +0000 https://forums.modx.com/thread/79162/strange-behavior-when-using-mssql-2012-and-modx-2-2-4-php-5-4-6#dis-post-554375
<![CDATA[Nexcess Hosting]]> https://forums.modx.com/thread/102349/nexcess-hosting#dis-post-551537 https://forums.modx.com/thread/102349/nexcess-hosting#dis-post-551537 Tue, 06 Jun 2017 09:30:27 +0000 https://forums.modx.com/thread/102349/nexcess-hosting#dis-post-551537 <![CDATA[Execution of a query to the database failed]]> https://forums.modx.com/thread/101790/execution-of-a-query-to-the-database-failed#dis-post-548999
I have one task/ problem and need help

« MODX Parse Error »
MODX encountered the following error while attempting to parse the requested resource:
« Execution of a query to the database failed - Unknown column 'alias_visible' in 'field list' »

How to solve this problem?]]>
https://forums.modx.com/thread/101790/execution-of-a-query-to-the-database-failed#dis-post-548999 Mon, 27 Feb 2017 07:46:48 +0000 https://forums.modx.com/thread/101790/execution-of-a-query-to-the-database-failed#dis-post-548999
<![CDATA[Best MODx Hosting Companies (legitimate list from MODx users)]]> https://forums.modx.com/thread/17101/best-modx-hosting-companies-legitimate-list-from-modx-users?page=4#dis-post-548868
I recently bought hosting with Fatcow.com because of some links i found online listing Fatcow as one of the hosting companies ’Best MODx Hosting’. (This is one of the links: http://www.webhostingsecretrevealed.com/modx-hosting/ ). I was really happy with Fatcow’s service and the control panel, etc., but when i went to see if MODx was listed in their ’InstallCentral’ (a list of various apps that you can install from within the control panel instead of downloading MODx, for example, and doing it manually), MODx was not listed. So I thought, no big deal, I’ll probably just have to install it manually...but I’m sure it is supported by Fatcow because I read it on numerous sites (like the previous link) saying they support it.

I then decided to see if I could chat with someone at Fatcow to see if I could get it added to ’InstallCentral’. I discovered through the chat that Fatcow does not support MODx at all and has no plans to do so because their platform does not support the InnoDB storage engine, along with PDO, specifically pdo_mysql (for xPDO) which is also not supported. So, now I had to cancel my fatcow hosting account and find another hosting company that does support MODx. I am really disappointed with fatcow because of this, not to mention the hassle and loss of cash through this process.

I switched to SiteGround.com hosting last night because they advertise MODx hosting directly on their site ( http://www.siteground.com/modx-hosting.htm ) and I saw that they are also listed on the MODx hosting partners ( http://modxcms.com/community/partners/hosting.html ). I would have went with bluehost.com but for some reason their site wasn’t loading on my home computer last night and I didn’t have the patience to figure out why.

Anyways, I just wanted to give some people who are searching for hosting that supports MODx a heads up and thought that by posting a thread about this we can start a legitimate list of the ’Best MODx hosting companies’, maybe rate them, the pros-cons, stories, etc. Then others can use this when shopping around for a MODx hosting company.

I will post back in this thread later about Siteground.com once I get this transfer headache worked out and get MODx running.

For now and according to Fatcow: Fatcow.com does not support MODx and have no plans to in the future.

]]>
https://forums.modx.com/thread/17101/best-modx-hosting-companies-legitimate-list-from-modx-users?page=4#dis-post-548868 Tue, 21 Feb 2017 01:55:17 +0000 https://forums.modx.com/thread/17101/best-modx-hosting-companies-legitimate-list-from-modx-users?page=4#dis-post-548868
<![CDATA[Google Cloud]]> https://forums.modx.com/thread/101244/google-cloud#dis-post-546420 https://forums.modx.com/thread/101244/google-cloud#dis-post-546420 Tue, 15 Nov 2016 05:32:00 +0000 https://forums.modx.com/thread/101244/google-cloud#dis-post-546420 <![CDATA[ISPAZE for MODX ?]]> https://forums.modx.com/thread/101060/ispaze-for-modx#dis-post-545653 CMS Hosting Package from https://www.ispaze.com Will it be fine or I should go for a entry level Vps server?]]> https://forums.modx.com/thread/101060/ispaze-for-modx#dis-post-545653 Wed, 12 Oct 2016 09:41:43 +0000 https://forums.modx.com/thread/101060/ispaze-for-modx#dis-post-545653 <![CDATA[500 error on some scripts]]> https://forums.modx.com/thread/77020/500-error-on-some-scripts#dis-post-544038 Firebug shows that these scripts cause 500 error:

  • /connectors/lang.js.php?ctx=mgr&topic=topmenu,file,resource,workspace,namespace&action=69
  • /manager/min/index.php?f=/dekor/manager/assets/modext/widgets/modx.treedrop.js,/dekor/manager/assets/modext/widgets/windows.js,/dekor/manager/assets/modext/widgets/resource/modx.tree.resource.js,/dekor/manager/assets/modext/widgets/element/modx.tree.element.js,/dekor/manager/assets/modext/widgets/system/modx.tree.directory.js,/dekor/manager/assets/modext/core/modx.view.js,/dekor/manager/assets/modext/core/modx.layout.js
  • /connectors/lang.js.php?ctx=mgr&topic=topmenu,file,resource,workspace,namespace&action=69
  • /connectors/layout/modx.config.js.php?action=69&wctx=mgr
  • /connectors/system/registry/register.php
  • /connectors/resource/index.php?action=getNodes&id=root

What should I do with this?]]>
https://forums.modx.com/thread/77020/500-error-on-some-scripts#dis-post-544038 Thu, 11 Aug 2016 09:19:32 +0000 https://forums.modx.com/thread/77020/500-error-on-some-scripts#dis-post-544038
<![CDATA[CanSpace Solutions as a MODx host]]> https://forums.modx.com/thread/99165/canspace-solutions-as-a-modx-host#dis-post-536309 http://www.canspace.ca/) as a MODx host? I would be pleased to hear your experience good and bad.

Thanks
Jim]]>
https://forums.modx.com/thread/99165/canspace-solutions-as-a-modx-host#dis-post-536309 Thu, 24 Dec 2015 10:24:01 +0000 https://forums.modx.com/thread/99165/canspace-solutions-as-a-modx-host#dis-post-536309
<![CDATA[Getting a Parse Error in Manager]]> https://forums.modx.com/thread/97253/getting-a-parse-error-in-manager#dis-post-526037
Warning: Cannot modify header information - headers already sent by (output started at /home/saintmon/public_html/manager/includes/header.inc.php:12) in /home/saintmon/public_html/manager/includes/document.parser.class.inc.php on line 3647
« MODX Parse Error »
MODX encountered the following error while attempting to parse the requested resource:
« PHP Parse Error »
PHP error debug
Error : include_once() [function.include]: Failed opening '/home/saintmon/public_html/assets/plugins/managermanager/widgets/mm_renamefield/mm_renamefield.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/saintmon/public_html/manager/includes/')

Warning: include_once(/home/saintmon/public_html/assets/plugins/managermanager/widgets/mm_renamefield/mm_renamefield.php) [function.include-once]: failed to open stream: Permission denied in /home/saintmon/public_html/assets/plugins/managermanager/mm.inc.php on line 61

Warning: include_once() [function.include]: Failed opening '/home/saintmon/public_html/assets/plugins/managermanager/widgets/mm_renamefield/mm_renamefield.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/saintmon/public_html/manager/includes/') in /home/saintmon/public_html/assets/plugins/managermanager/mm.inc.php on line 61
ErrorType[num] : WARNING[2]
File : /home/saintmon/public_html/assets/plugins/managermanager/mm.inc.php
Line : 61
Source : Plugin
Basic info
REQUEST_URI : http://www.saintmonicaconverse.net/manager/index.php?a=27&id=1
Manager action : 27 - Editing resource
Current Plugin : ManagerManager(OnDocFormPrerender)
Referer : http://www.saintmonicaconverse.net/manager/index.php?a=1&f=tree
User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
IP : 173.174.230.17
Benchmarks
MySQL : 0.0031 s (6 Requests)
PHP : 0.0223 s
Total : 0.0254 s
Memory : 1.14972686768 mb

Backtrace
1 include_once()
manager/index.php on line 288
2 DocumentParser->invokeEvent()
manager/actions/mutate_content.dynamic.php on line 492
3 DocumentParser->evalPlugin()
manager/includes/document.parser.class.inc.php on line 3379

This just started today. The install has been working fine for more than a year.]]>
https://forums.modx.com/thread/97253/getting-a-parse-error-in-manager#dis-post-526037 Tue, 26 May 2015 11:51:20 +0000 https://forums.modx.com/thread/97253/getting-a-parse-error-in-manager#dis-post-526037
<![CDATA[Best hosting companies that also offer Windows hosting?]]> https://forums.modx.com/thread/96708/best-hosting-companies-that-also-offer-windows-hosting#dis-post-523365
I did get a test account with Arvixe some time ago to see how MODX runs there, and it was a very positive experience. They also offer Windows hosting, so this is one company I'm considering, but they're on the West Coast and I'd like to find an East Coast provider, or at least someone closer to us.]]>
https://forums.modx.com/thread/96708/best-hosting-companies-that-also-offer-windows-hosting#dis-post-523365 Wed, 25 Mar 2015 12:18:49 +0000 https://forums.modx.com/thread/96708/best-hosting-companies-that-also-offer-windows-hosting#dis-post-523365
<![CDATA[Are the rights 644 for the config.inc.php really insecure?]]> https://forums.modx.com/thread/96587/are-the-rights-644-for-the-config-inc-php-really-insecure#dis-post-522897
my Configuration Check reports that we should change the config.inc.php file permissions after upgrading our Modx installation. Here the message:

One or more configuration details didn’t check out OK:
Configuration warning: Config file still writable!

I don’t understand this because the config file on the server in core/config/config.inc.php has exactly the same rights than in my localhost: 644, and here we don’t receive any message from the Configuration Check.

The server is a window machine, the localhost is unix (using www.mamp.info).

Why are we receiving this message? are the rights 644 really insecure?

I will appreciate any help.]]>
https://forums.modx.com/thread/96587/are-the-rights-644-for-the-config-inc-php-really-insecure#dis-post-522897 Wed, 18 Mar 2015 06:54:03 +0000 https://forums.modx.com/thread/96587/are-the-rights-644-for-the-config-inc-php-really-insecure#dis-post-522897
<![CDATA[Setting register_globals to OFF]]> https://forums.modx.com/thread/71530/setting-register-globals-to-off#dis-post-519931
First, is there somewhere that I can download a php.ini file for Modx 2.0.06-pl2 with all of the correct settings already setup? If not, what do I need to do in my default php.ini file?

Thanks!]]>
https://forums.modx.com/thread/71530/setting-register-globals-to-off#dis-post-519931 Wed, 04 Feb 2015 08:52:14 +0000 https://forums.modx.com/thread/71530/setting-register-globals-to-off#dis-post-519931
<![CDATA[Excessive resource usage?]]> https://forums.modx.com/thread/95845/excessive-resource-usage?page=2#dis-post-518952
I have multiple modx websites running on a VPS with csf/lfd plugin installed and i'm getting these error mails regularly.
It happens to different sites, on different times and it allways refers to public_html/index.php
Is this a normal amount of memory a modx Revo site uses? Or nothing to worry about.
Any ideas how to lower the memory size?
Could it be that a plugin is causing the problem?
The sites doesnt have that many visitors and are basic small company websites, with basic plugins installed, such as wayfinder, getresources, redactor, .....

Thanks for any help!

Time: Mon Jan 19 21:41:37 2015 +0100
Account: ****
Resource: Virtual Memory Size
Exceeded: 320 > 200 (MB)
Executable: /opt/php52/bin/php-cgi
Command Line: /opt/php52/bin/php-cgi /home/***/public_html/index.php
PID: 26410 (Parent PID:26330)
Killed: No]]>
https://forums.modx.com/thread/95845/excessive-resource-usage?page=2#dis-post-518952 Wed, 21 Jan 2015 08:53:24 +0000 https://forums.modx.com/thread/95845/excessive-resource-usage?page=2#dis-post-518952
<![CDATA[Godaddy hosting?]]> https://forums.modx.com/thread/95287/godaddy-hosting#dis-post-518007
Thanks
Mike]]>
https://forums.modx.com/thread/95287/godaddy-hosting#dis-post-518007 Wed, 07 Jan 2015 12:44:02 +0000 https://forums.modx.com/thread/95287/godaddy-hosting#dis-post-518007