Subscribe: RSS
  • So, I am using Evo and the newest ManagerManager version. Everything seems to be working fine with one exception. When I attempt to hide a content field it still displays.

    mm_hideFields(’content’, ’2’, ’8’);

    All the other fields are working fine, but the content field still displays. Is there some change I am unaware of? Is there a different way to hide the content field?

    Any help would be greatly appreciated.
    • I was having the same problem. The Hide Editor plug-in works:

      http://modxcms.com/extras/package/200

      • Thanks so much.

        I’m hoping this is not the only option. I really hate to have to load another plugin just to hide the content area in the manager. Is no one else having this problem that has a fix?
        • Hi

          Yes, I can confirm your issues.

          Having Evo 1.0.0 with MM_3.4 the *content*-area was hidden (with MM_3.5 it wasn’t).
          I just upgraded to Evo 1.0.1. Unfortunately the content-area is being shown again ALSO with MM_3.5 (I just tested). undecided

          Any clues?

          QT
          • OK here’s a solution until the next release:

            1) Open the file assets/plugins/managermanager/functions/fields.inc.php

            2) Find the content case near line 115.

            3) Change the code from:
            					$output .= '$j("#sectionContentHeader, #sectionContentBody").hide();';

            to:
            					$output .= '$j("#ta").parent("div").parent("div").hide().prev("div").hide();';


            The reality is that there really should be a single wrapper div with an ID around the content section to make it easier to get both pieces at once, but jQuery sure does make this nice and simple!

            Someone please file a report for this in JIRA; currently down for maintenance and I don’t want to overlook this issue.

            This is a 1.0.1 specific bug, so moving there.
              Ryan Thrash, MODX Co-Founder
              Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
            • Thanks so much for the fix.
              • Yes this fix worked great! Thanks.
                  Jeremy Foster
                • Yep.
                  Fix works great!

                  Thank you!

                  QT
                  • Quote from: rthrash at Oct 23, 2009, 11:04 PM

                    Someone please file a report for this in JIRA; currently down for maintenance and I don’t want to overlook this issue.
                    I’ve added the fix to the SVN (commit 5973) and to my work in progress 0.3.6 release.
                      Author: ManagerManager plugin - customise your ModX manager interface

                      Rckt - web development, Sheffield, UK
                    • I’m also having problems moving menuindex from the General tab. Is this just me?